+ Reply to Thread
Results 1 to 12 of 12

Thread: OSPF Question

  1. Member
    Join Date
    Oct 2013
    Location
    San Antonio
    Posts
    40
    #1

    Default OSPF Question

    So I put 3 routers in a triangle and setup some ip helpers to dhcp on a remote router. I tried setting area 0 to the inner ring of the 3 routers, with the 3 router outer interfaces on other areas like 1,2, and 3. I just left the serials linking the 3 routers on HDLC and the routing table shows all remote networks so I guess it converged but when I do SH IP OSPF NEIGHBOR it shows FULL adjacency but I don't see BD or BDR. Can someone help me figure out why? Here are the 3 configs of R1,R2, and R3:

    R1

    interface Loopback0
    ip address 209.165.200.1 255.255.255.252
    !
    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/0.2
    encapsulation dot1Q 20
    ip address 172.16.100.129 255.255.255.248
    ip helper-address 172.16.100.1
    !
    interface GigabitEthernet0/0.30
    encapsulation dot1Q 30
    ip address 172.16.100.137 255.255.255.248
    ip helper-address 172.16.100.1
    !
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface GigabitEthernet0/2
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/0/0
    ip address 10.0.0.2 255.255.255.252
    !
    interface Serial0/0/1
    ip address 10.0.0.5 255.255.255.252
    clock rate 2000000
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router ospf 1
    log-adjacency-changes
    passive-interface GigabitEthernet0/0
    network 172.16.100.128 0.0.0.7 area 1
    network 172.16.100.136 0.0.0.7 area 1
    network 10.0.0.0 0.0.0.255 area 0

    R2

    interface GigabitEthernet0/0
    ip address 192.168.100.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface GigabitEthernet0/2
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/0/0
    ip address 10.0.0.1 255.255.255.252
    clock rate 2000000
    !
    interface Serial0/0/1
    ip address 10.0.0.9 255.255.255.252
    clock rate 2000000
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router ospf 1
    log-adjacency-changes
    passive-interface GigabitEthernet0/0
    passive-interface GigabitEthernet0/1
    network 192.168.100.0 0.0.0.255 area 3
    network 10.0.0.0 0.0.0.255 area 0

    R3

    ip dhcp pool 172.16.100.128-136
    network 172.16.100.128 255.255.255.248
    default-router 172.16.100.129
    ip dhcp pool 172.16.100.0-127
    network 172.16.100.0 255.255.255.128
    default-router 172.16.100.1
    ip dhcp pool 172.16.100.136-143
    network 172.16.100.136 255.255.255.248
    default-router 172.16.100.137
    !
    no ip cef
    no ipv6 cef
    !
    !
    !
    !
    license udi pid CISCO2911/K9 sn FTX15240GNL
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    spanning-tree mode pvst
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/0.10
    encapsulation dot1Q 10
    ip address 172.16.100.1 255.255.255.128
    !
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface GigabitEthernet0/2
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/0/0
    ip address 10.0.0.10 255.255.255.252
    !
    interface Serial0/0/1
    ip address 10.0.0.6 255.255.255.252
    !
    interface Vlan1
    no ip address
    shutdown
    !
    router ospf 1
    log-adjacency-changes
    passive-interface GigabitEthernet0/0
    network 172.16.100.0 0.0.0.127 area 2
    network 10.0.0.0 0.0.0.255 area 0

    R3 ROUTE TABLE

    Gateway of last resort is not set


    10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
    O 10.0.0.0/30 [110/128] via 10.0.0.9, 00:18:01, Serial0/0/0
    [110/128] via 10.0.0.5, 00:18:01, Serial0/0/1
    C 10.0.0.4/30 is directly connected, Serial0/0/1
    L 10.0.0.6/32 is directly connected, Serial0/0/1
    C 10.0.0.8/30 is directly connected, Serial0/0/0
    L 10.0.0.10/32 is directly connected, Serial0/0/0
    172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
    C 172.16.100.0/25 is directly connected, GigabitEthernet0/0.10
    L 172.16.100.1/32 is directly connected, GigabitEthernet0/0.10
    O IA 172.16.100.128/29 [110/65] via 10.0.0.5, 00:32:52, Serial0/0/1
    O IA 172.16.100.136/29 [110/65] via 10.0.0.5, 00:32:10, Serial0/0/1
    O IA 192.168.100.0/24 [110/65] via 10.0.0.9, 00:18:01, Serial0/0/0

    I'm pretty out of practice and I'm sure I'm gonna kick myself after someone helps me see my error. Oh and here's the OSPF Neighbor table:


    Neighbor ID Pri State Dead Time Address Interface
    192.168.100.1 0 FULL/ - 00:00:32 10.0.0.9 Serial0/0/0
    209.165.200.1 0 FULL/ - 00:00:33 10.0.0.5 Serial0/0/1
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member _Gonzalo_'s Avatar
    Join Date
    Nov 2014
    Location
    Spain
    Posts
    107

    Certifications
    CCNP R&S
    #2
    There are not DR/BDR elections on every case. For instance, when using a serial connection (this is true as far as CCNA content takes you )

    You should be concerned with full adjacency. If your neighbors are there and you see that the state is FULL, it´s working. Then you should be checking your routing tables for all routes.
    Last edited by _Gonzalo_; 12-24-2014 at 01:11 PM.
    Reply With Quote Quote  

  4. Network Engineer Dieg0M's Avatar
    Join Date
    Jun 2013
    Location
    Montreal
    Posts
    853

    Certifications
    CCIE #48240, CCDP
    #3
    P2P and P2M wont elect DR/BDR. Serial is P2P by default.
    Follow my CCDE journey at www.routingnull0.com
    Reply With Quote Quote  

  5. Senior Member jamesp1983's Avatar
    Join Date
    Sep 2007
    Location
    PA
    Posts
    2,465

    Certifications
    A+,Net+,S+,MCSA:S & MCSE:S 2k3,MCITP:SA/EA, CCNA:Security/RS/DC,CCNP DC, CCIE RS 51060
    #4
    Reply With Quote Quote  

  6. Senior Member _Gonzalo_'s Avatar
    Join Date
    Nov 2014
    Location
    Spain
    Posts
    107

    Certifications
    CCNP R&S
    #5
    Come on guys, this is CCNA forum... OSPF network types is something he has not studied. Remember that CCNA only deals with OSPF area 0 implementations.
    Reply With Quote Quote  

  7. Senior Member
    Join Date
    Dec 2009
    Location
    Illinois
    Posts
    482

    Certifications
    A+, CCNA:S, CCNP
    #6
    And his question was answered...what is your issue with that?
    Reply With Quote Quote  

  8. Member
    Join Date
    Oct 2013
    Location
    San Antonio
    Posts
    40
    #7
    Great, those Packetlife articles are always to the point! So as it mentions, a FR could allow for DR's and in my case which is without FR, it's just a Point-to-Multipoint and so multicast are not forwarded unless I add a non-broadcast parameter to force Multicasts to forward thru as unicast.
    I appreciate you guys not wanting to give me too much information for the sake of keeping the mind uncluttered for the sake of taking the CCNA but I'm not worried about that. I'm just intrigued by it all and want know anyway. So I'm thinking, there would never be an OSPF config on 3 routers forming a junction as in this case because each of the other areas would have their own efficient setup complete with DR's within their own neighborhood. And since this tiangle arrangement of routers would probably exist to act more of a junction, it would not be an area 0 by any means. Is it possible that each of the 3 OSPF areas say, (area 2,3 and 4) might already have an area 0 of their own and what would be involved for them be joined in this triangle router junction such as this one?
    I'm just saying... even if it were just two companies merging and each already had their own area 0? How would you go about joining those two if they already have their own area 0's?

    Btw, this new 200-120 CCNAX does show multi-area configurations, however they are always configured with a switch joining the routers much as this example: (triple W).danscourses.com/CCNA-2/ospf-drbdr-pt-lab.html
    And since I thought both this example and my lab both use point-to-multipoint, I expected to see DR's being elected. But I can see now that in this website example, it is an ethernet multipoint and so allows the multicast addresses to form as opposed to my point-to-multipoint. (that's just what I gathered)MyLab.JPGOSPF-Multicast.jpg
    Last edited by danyzuko; 12-24-2014 at 06:51 PM.
    Reply With Quote Quote  

  9. Senior Member _Gonzalo_'s Avatar
    Join Date
    Nov 2014
    Location
    Spain
    Posts
    107

    Certifications
    CCNP R&S
    #8
    Quote Originally Posted by Heero View Post
    And his question was answered...what is your issue with that?


    Well, it´s not that I have an issue.

    When answering here, I try to stick to CCNA topics, as I consider that it´ll be easier to understand.

    Also, when I took my CCNA cert exam, I was already on a CCNP course. I only were unable to answer one thing, the EIGRP lab, a topic that I had already started studying on CCNP. The result is that I spent a lot of time checking and doublechecking metric values and passive interface configs when there was no need. I was so confident on passing that I gave up on the lab, but maybe if that hadn´t been the case, I would have spent too much time on it and failed... But that might be just my experience.
    Reply With Quote Quote  

  10. Senior Member _Gonzalo_'s Avatar
    Join Date
    Nov 2014
    Location
    Spain
    Posts
    107

    Certifications
    CCNP R&S
    #9
    Quote Originally Posted by danyzuko View Post
    Is it possible that each of the 3 OSPF areas say, (area 2,3 and 4) might already have an area 0 of their own and what would be involved for them be joined in this triangle router junction such as this one?
    I'm just saying... even if it were just two companies merging and each already had their own area 0? How would you go about joining those two if they already have their own area 0's?
    It´s good to know that you want to know things beyond CCNA. Actually, I believe that CCNA is just a collection of half truths! If as you say, configuration of different areas is shown in CCNA, I do not remember

    About your question, there can only be one area 0, and all areas (CCNA wise) must be connected to it. There can be areas not connected to area 0, and virtual links are what's used for that. To put it simply, you use (let´s say) area 1 as a virtual link to connect area 2 and area 0.

    In your example of two merging companies, you would most likely need to restructure your areas. Every case is different, but at least you´ll have to reconfigure one of the two area 0´s you have. If you have a real topology to work with, it might clarify things even further.
    Reply With Quote Quote  

  11. DCD
    DCD is offline
    Senior Member DCD's Avatar
    Join Date
    Jan 2013
    Location
    San Francisco , Ca
    Posts
    437

    Certifications
    CCNA
    #10
    Quote Originally Posted by _Gonzalo_ View Post
    It´s good to know that you want to know things beyond CCNA. Actually, I believe that CCNA is just a collection of half truths! If as you say, configuration of different areas is shown in CCNA, I do not remember

    The new exam lightly goes over multi-area OSPF network now.

    4.7 Configure and verify OSPF

    • 4.7.a Benefit of single area
    • 4.7.b Configure OSPv2
    • 4.7.c Configure OSPv3
    • 4.7.d Router ID
    • 4.7.e Passive Interface
    • 4.7.f Discuss multi-area OSPF
    • 4.7.g Understand LSA types and purpose
    Reply With Quote Quote  

  12. Member
    Join Date
    Oct 2013
    Location
    San Antonio
    Posts
    40
    #11
    which brings up another question. I live in San Antonio, TX where having an CCNA Security would be valuable to the government institutions nearby. I'm curious about CCNP though. Is there more of a market in that direction? And I'm tempted to pursue Ethical Hacking as well. I would like to end up in Nevada or as close to southern California or even northward like Sacramento. I'm just not sure what direction to go.
    Reply With Quote Quote  

  13. Senior Member
    Join Date
    Dec 2009
    Location
    Illinois
    Posts
    482

    Certifications
    A+, CCNA:S, CCNP
    #12
    My personal opinion is that it is better to dive deeper into the core of networking before branching out. How can you secure what you don't understand?

    I ended up getting my CCNA Security after my CCNP just as resume fodder since the word "security" looks good, but I can honestly tell you that I didn't learn much more than the basics I learned in my 3 credit hour security course I took 6 years ago in college. But now I'm certified!
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks