+ Reply to Thread
Results 1 to 3 of 3
  1. Junior Member Registered Member
    Join Date
    Feb 2016
    Posts
    2
    #1

    Default VLAN Routing Question

    I'm trying to figure out if I need any other configuration necessary for this scenario. I have two Cisco 2960CG switches connected by Fiber with two VLANs. VLAN 2 is internal and VLAN 70 is Public. The fiber connection is the trunk. Both VLANs connect to separate layer 3 switches. The internal VLAN 2 has the default gateway set on this switch. Will the correct data still be able to reach the router on VLAN 70? Can I configure a separate Gateway for both VLANs? I haven't setup a IP or subnet for VLAN 70 yet. I'm also not sure if this is the correct location to post this thread.


    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname Fiber Connection
    !
    boot-start-marker
    boot-end-marker
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    !
    vlan internal allocation policy ascending
    !
    !
    !
    interface GigabitEthernet0/1
    !
    interface GigabitEthernet0/2
    description Fiber Uplink Internal Network
    switchport access vlan 2
    !
    interface GigabitEthernet0/3
    description Fiber Uplink Public Network
    switchport access vlan 70
    !
    interface GigabitEthernet0/4
    !
    interface GigabitEthernet0/5
    !
    interface GigabitEthernet0/6
    !
    interface GigabitEthernet0/7
    !
    interface GigabitEthernet0/8
    !
    interface GigabitEthernet0/9
    !
    interface GigabitEthernet0/10
    description FIBER Connection
    switchport mode trunk
    !
    interface Vlan1
    ip address 192.168.70.250 255.255.255.0
    !
    interface Vlan2
    ip address 192.168.2.250 255.255.255.248
    !
    ip default-gateway 192.168.2.254
    ip http server
    ip http secure-server
    !
    !
    end
    Reply With Quote Quote  

  2. SS -->
  3. Junior Member
    Join Date
    Feb 2016
    Location
    Columbia, SC
    Posts
    12

    Certifications
    CCNA R&S/Wireless/Security, Security+, BS in CS, MPA in Computer & Network Security
    #2
    Assuming I'm reading this right and your topology is pc1 <-> 2960 <-> L3_Switch <-> 2960 <-> PC2, and you have PC1 on g0/2 with the layer 3 switch on the other side of the g0/10 trunk as the gateway. In that case, the vlan interfaces on this 2960 are just for management. Your client will arp for the gateway address then communicate with the L3 switch over the trunk at layer 2. The ability to reach vlan 70 is then based on the config of the L3 switch.
    Reply With Quote Quote  

  4. Junior Member Registered Member
    Join Date
    Feb 2016
    Posts
    2
    #3
    Yeah essentially except both VLANs connect to separate routers with separate internet connections after leaving the 2960. Basically the public connection is completely separate from the internal connection. So its more like this. Thanks for the input.

    Internal Network <-> l3 Switch <-> 2960 VLAN 2 Port 2|2960 VLAN 70 Port 3<->l3 switch<->Public Network
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks