+ Reply to Thread
Results 1 to 14 of 14
  1. Senior Member Talic's Avatar
    Join Date
    Feb 2008
    Location
    SiN City USA
    Posts
    423

    Certifications
    A+ Network+
    #1

    Default Routing question

    Maybe explaining my situation would be best:
    I have about 6 WAN serial links set up with a address of 192.168.1.XX/30 and the routing protocols found the various network WAN links fine. I have 5 routers hooked into those interfaces and each router hooked into a LAN with computer behind it. When I configured the LAN networks I used a address 192.168.N.XX/24. Wheres the N is the LAN different networks from 2 to 6

    My question is, do I need to type in each different LAN network number to get the routing protocols to up date their routing table with the LAN networks? I did get RIP2 working on the WAN links but I'm not sure how to input the LAN behind each router.
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member
    Join Date
    Oct 2005
    Posts
    1,030

    Certifications
    CCNP (R&S/Voice), CCDP, CCIP, VCP, NCDA, MCSE, CCNA Security
    #2
    I'm not sure I exactly understand how you have your network setup, but for RIP you have to do a "network 192.168.X.0" for each network you want to advertise and each network you want to send out advertisements on

    -Kale.
    Reply With Quote Quote  

  4. Senior Member Talic's Avatar
    Join Date
    Feb 2008
    Location
    SiN City USA
    Posts
    423

    Certifications
    A+ Network+
    #3
    I typed in network 192.168.0.0 and I was going to let RIP find the subnets.

    Todd used a example that if you had subnets of 172.16.10.0 and 172.16.20.0 along with 172.16.30.0 with the classful subnet mask of /24, you could just type in network 172.16.0.0 and it'll work. Shouldn't 192.168.0.0 work with class c address or would you need to specify the 3rd octet?

    I would think it wouldn't do any classful stuff with rip2 and eigrp but it seems like it wants to do the classful crap.

    Gotta change all my ip address to 10.0.0.0 or 172.16.0.0 I guess
    Reply With Quote Quote  

  5. Senior Member
    Join Date
    Oct 2005
    Posts
    1,030

    Certifications
    CCNP (R&S/Voice), CCDP, CCIP, VCP, NCDA, MCSE, CCNA Security
    #4
    It looks like you have to enter the classful address of the network, if that network were subnetted it would find all the networks under it. When you entered 192.168.0.0 it was trying to add the network 192.168.0.0/24. So, as you said, you would have to move them to a class A or B network (or subnet the class C you were using).

    -Kale
    Reply With Quote Quote  

  6. Lost in the box...
    Join Date
    Oct 2007
    Location
    OK
    Posts
    561

    Certifications
    CCIE R&S and DC, CCIP, CCNP, CCNA, CCENT, Network+, A+, MCDST, MCP, )
    #5
    172.16.x.x is a class B address, so in a classful network, even if you are using it with a class c mask (255.255.255.0 or /24), simply typing 172.16.0.0 into your RIP config will work. However, with a classful class c address such as 192.168.1.x, you will have to type in each one (ie 192.168.2.x....3.x.....4.x. Which version of RIP are you using?
    Reply With Quote Quote  

  7. Senior Member Talic's Avatar
    Join Date
    Feb 2008
    Location
    SiN City USA
    Posts
    423

    Certifications
    A+ Network+
    #6
    Quote Originally Posted by jason_lunde
    172.16.x.x is a class B address, so in a classful network, even if you are using it with a class c mask (255.255.255.0 or /24), simply typing 172.16.0.0 into your RIP config will work. However, with a classful class c address such as 192.168.1.x, you will have to type in each one (ie 192.168.2.x....3.x.....4.x. Which version of RIP are you using?
    Yeah, it clicked after I tried doing it, hehe. I was thinking about the range of network addresses reserved for private use, which were 192.168.1.0 up to 192.168.255.0 I believe.

    I redid the addresses using RIP 2 and the private 10.0.0.0 address block with 10.1.1.0 block used for WAN connections and 10.1.X.0 used for the LAN with a computer behind it. I did under router config: network 10.0.0.0 and rip doesn't seem to be advertising the LAN networks behind the routers but isn't supposed to find them? I added them statically two days ago and it worked but with using rip it doesn't seem to. All the LAN's networks are showing up on show ip route.

    The static routes are gone now since I've been using rip.
    Reply With Quote Quote  

  8. Senior Member Talic's Avatar
    Join Date
    Feb 2008
    Location
    SiN City USA
    Posts
    423

    Certifications
    A+ Network+
    #7
    I don't want to make another thread but I wanted to ask another quick question: I looked at the objectives for CCENT and it only says to configure RIP on it, would it bee a good idea to hold off on EIGRP and OSPF for ICND2? EIGRP and OSPF are a lot to chew on right now.
    Reply With Quote Quote  

  9. Senior Member Netwurk's Avatar
    Join Date
    May 2005
    Location
    Philadelphia, PA
    Posts
    1,156

    Certifications
    CCNA, Network+, A+ (CCNP Progress: 1/3)
    #8
    RIP v2 should do what you want if you turn off autosummary. The command is "no auto-summary"
    Reply With Quote Quote  

  10. Senior Member phantasm's Avatar
    Join Date
    Jan 2008
    Location
    West by God
    Posts
    990

    Certifications
    CCNP:R&S, CCDA
    #9
    Quote Originally Posted by Talic
    I don't want to make another thread but I wanted to ask another quick question: I looked at the objectives for CCENT and it only says to configure RIP on it, would it bee a good idea to hold off on EIGRP and OSPF for ICND2? EIGRP and OSPF are a lot to chew on right now.
    Yes. The info on Cisco's site says that OSPF and EIGRP are on the ICND2 exam. No need to sweat it for the ICND1.
    Reply With Quote Quote  

  11. Senior Member bighornsheep's Avatar
    Join Date
    Jul 2006
    Location
    Toronto, Ontario, Canada
    Posts
    1,527

    Certifications
    CCDP, CCNP, CCDA, CCNA, ITIL Foundation, MCSA, MCDST, MCP, A+, Network+
    #10
    Even if you're using RIPv2 with no auto-summary command,
    Code:
    network 10.10.1.0
    for example will still turn into
    Code:
    network 10.0.0.0
    when you do a show run.

    RIP in its nature is a classful protocol, V2 simply uses the previously unused bits in the message to pass the subnet mask information.
    Reply With Quote Quote  

  12. Senior Member Netwurk's Avatar
    Join Date
    May 2005
    Location
    Philadelphia, PA
    Posts
    1,156

    Certifications
    CCNA, Network+, A+ (CCNP Progress: 1/3)
    #11
    The "no auto-summary" should work for him.

    Here's a config straight from a ciscopress book:

    !
    interface Ethernet0
    ip address 128.200.1.1 255.255.255.0
    !
    interface Ethernet1
    ip address 128.200.2.1 255.255.255.0
    !
    router rip
    version 2
    network 128.200.0.0
    no auto-summary


    If you had auto-summary on, RIP would see both interfaces as being in the same network.
    Reply With Quote Quote  

  13. Senior Member Talic's Avatar
    Join Date
    Feb 2008
    Location
    SiN City USA
    Posts
    423

    Certifications
    A+ Network+
    #12
    Cool, thanks guys
    Reply With Quote Quote  

  14. Senior Member Talic's Avatar
    Join Date
    Feb 2008
    Location
    SiN City USA
    Posts
    423

    Certifications
    A+ Network+
    #13
    Another question, when modifying RIP do you need to enter version 2 every time? Is just turning on RIP 2 once enough?


    Maybe I should of named this thread "Talic's question thread"
    Reply With Quote Quote  

  15. Senior Member Netwurk's Avatar
    Join Date
    May 2005
    Location
    Philadelphia, PA
    Posts
    1,156

    Certifications
    CCNA, Network+, A+ (CCNP Progress: 1/3)
    #14
    Quote Originally Posted by Talic
    Another question, when modifying RIP do you need to enter version 2 every time? Is just turning on RIP 2 once enough?


    Maybe I should of named this thread "Talic's question thread"
    Once you set RIP as version 2, it should stay that way unless you do a "no router rip" and start over.

    Do a show run command and look at the RIP config if you're not sure which version you set.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks