+ Reply to Thread
Page 1 of 2 1 2 Last
Results 1 to 25 of 29

Thread: RIPv2 problems

  1. Senior Member SdotLow's Avatar
    Join Date
    May 2011
    Location
    Maryland, D.C. Metro Area
    Posts
    235

    Certifications
    A+, Network+, CCENT
    #1

    Default RIPv2 problems

    Can't get any of my routers to even recognize each other with RIPv2. I've done everything per Odom's config chapter.

    I went and through the cisco learning network RIP2 tutorial. They had an "IP Host <Name> <IP Address>" config I didn't see in the book.

    This seems suspect to me...

    interface Serial0/0
    ip address 172.16.0.2 255.255.255.0
    no fair-queue
    !
    router rip
    version 2
    network 172.16.0.0
    !
    ip classless
    no ip http server
    !
    !
    The "no fair-queue" is out of place obviously. I can't see what I'm doing wrong, but I'm obviously doing something wrong.

    R1 Config :

    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R1
    !
    boot-start-marker
    boot system flash:c2600-advsecurityk9-mz.124-9.t1.bin
    boot-end-marker
    !
    enable secret 5 $1$iMgL$WKcjBDNJSgmzXP6kLbfCY.
    !
    no aaa new-model
    !
    resource policy
    !
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !
    !
    !
    ip host R2 172.16.0.2 172.16.1.2
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.1.150 255.255.255.0
    speed 100
    full-duplex
    !
    interface Serial0/0
    no ip address
    shutdown
    no fair-queue
    !
    interface Serial1/0
    ip address 172.16.0.1 255.255.255.0
    clock rate 56000
    !
    interface Serial1/1
    ip address 172.16.1.1 255.255.255.0
    clock rate 56000
    !
    interface Serial1/2
    no ip address
    shutdown
    !
    interface Serial1/3
    no ip address
    shutdown
    !
    router rip
    version 2
    network 172.16.0.0
    !
    !
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    control-plane
    R2 Config :

    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    ip host R1 172.16.0.1
    !
    --More--
    Aug 20 10:14:24.007: %SYS-5-CONFIG_I: Configured from console by console
    ip cef
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    speed auto
    !
    interface Serial0/0
    ip address 172.16.0.2 255.255.255.0
    no fair-queue
    !
    router rip
    version 2
    network 172.16.0.0
    !
    ip classless
    no ip http server
    !
    !
    Router 3:

    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R3
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    ip subnet-zero
    !
    !
    !
    ip cef
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    speed auto
    !
    interface Serial0/0
    ip address 172.16.1.2 255.255.255.0
    no fair-queue
    !
    router rip
    version 2
    network 172.16.0.0
    !
    ip classless
    no ip http server
    Last edited by SdotLow; 08-06-2011 at 11:35 PM.
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member cyberguypr's Avatar
    Join Date
    May 2007
    Location
    Chicago, IL
    Posts
    5,772

    Certifications
    GCFE, GCED, GCIH, CISSP, CCSP, and others that should never be mentioned
    #2
    What is this: ip address 172.16.0.2 255.255.255.252 ?

    S0/0 on R2 seems to have that IP but different mask. Which one is correct?
    Reply With Quote Quote  

  4. Senior Member
    Join Date
    Oct 2010
    Location
    United States
    Posts
    1,099

    Certifications
    CCNA, CCNA:Sec CCNA:Voice, A+, Project+, Sec+, Linux+, MCTS, ITIL v3, VCP-DCV
    #3
    Which interface on R1 is connected to what interface on R2?
    Reply With Quote Quote  

  5. Senior Member SdotLow's Avatar
    Join Date
    May 2011
    Location
    Maryland, D.C. Metro Area
    Posts
    235

    Certifications
    A+, Network+, CCENT
    #4
    Maybe the way I have it set up won't allow RIP to work?

    R1 has both DCE cables going out to R2 and R3 which both have DTE ends.

    R1 Serial 1/0 going to R2.
    R1 Serial 1/1 going to R3.
    Reply With Quote Quote  

  6. Senior Member SdotLow's Avatar
    Join Date
    May 2011
    Location
    Maryland, D.C. Metro Area
    Posts
    235

    Certifications
    A+, Network+, CCENT
    #5
    Quote Originally Posted by cyberguypr View Post
    What is this: ip address 172.16.0.2 255.255.255.252 ?

    S0/0 on R2 seems to have that IP but different mask. Which one is correct?
    I changed that first quote. I thought I might have been doing some bad subnetting so I made them all /24 instead of /30 to see if that fixed, which it didn't. Everything up there is accurate as of right now.
    Reply With Quote Quote  

  7. Senior Member alan2308's Avatar
    Join Date
    Apr 2010
    Location
    Ann Arbor, MI
    Posts
    1,807

    Certifications
    CCNA, CCNA Sec, MCSA 2008, MCSA 2012, CISSP
    #6
    The first thing that I see is that you will probably want to add "no auto-summarization" to the rip process on all three routers. without that, RIP will auto-summarize and advertise the entire 172.16.0.0/16 network rather than the two /24 networks that you're using. I would also add network 192.168.1.0 on R1 so you can see that advertised around the rest of the network as well.

    That being said, none of that should stop RIP from working in this small network. I just put this config as-is into Packet Tracer (just the interface names changed) and it worked just fine. For example, on R2 I see:

    Code:
         172.16.0.0/24 is subnetted, 2 subnets
    C       172.16.0.0 is directly connected, Serial0/0
    R       172.16.1.0 [120/1] via 172.16.0.1, 00:00:23, Serial0/0
    R    192.168.1.0/24 [120/1] via 172.16.0.1, 00:00:23, Serial0/0
    Reply With Quote Quote  

  8. Senior Member SdotLow's Avatar
    Join Date
    May 2011
    Location
    Maryland, D.C. Metro Area
    Posts
    235

    Certifications
    A+, Network+, CCENT
    #7
    so then my cables might be bad? or maybe the WIC-1T cards?

    Does that "No Fair-Queue" imply something bad on the card?

    Edit: Just switched the cable with 2 others I have laying around, didn't do anything.
    Last edited by SdotLow; 08-07-2011 at 01:02 AM.
    Reply With Quote Quote  

  9. Senior Member Chris_'s Avatar
    Join Date
    Feb 2011
    Location
    UK
    Posts
    325

    Certifications
    CCNP, CCNA, CCNA Security, CCNA Voice, JNCIA-JUNOS
    #8
    Ip host has nothing at all to do with RIP - it is is just a mapping of ip address to hostname - think dns or client hosts file.

    i take it your serial links are up and you can ping between them.....
    Reply With Quote Quote  

  10. Senior Member alan2308's Avatar
    Join Date
    Apr 2010
    Location
    Ann Arbor, MI
    Posts
    1,807

    Certifications
    CCNA, CCNA Sec, MCSA 2008, MCSA 2012, CISSP
    #9
    Quote Originally Posted by SdotLow View Post
    so then my cables might be bad? :X
    It's possible. It's also possible that the two cables on R1 are swapped or something isn't plugged in all the way or even a bad WIC or WIC slot in the router.
    Reply With Quote Quote  

  11. Senior Member SdotLow's Avatar
    Join Date
    May 2011
    Location
    Maryland, D.C. Metro Area
    Posts
    235

    Certifications
    A+, Network+, CCENT
    #10
    Quote Originally Posted by Chris_ View Post
    Ip host has nothing at all to do with RIP - it is is just a mapping of ip address to hostname - think dns or client hosts file.

    i take it your serial links are up and you can ping between them.....
    Can't ping between the serial links.

    R2#show ip int brie
    Interface IP-Address OK? Method Status Protocol
    FastEthernet0/0 unassigned YES NVRAM administratively down down
    Serial0/0 172.16.0.2 YES NVRAM down down
    Serial interfaces for R1 on both 1/0 and 1/1 are down/down, as is R3 serial.

    Everything is plugged in snug. WIC cards are in snug.
    Reply With Quote Quote  

  12. Senior Member SdotLow's Avatar
    Join Date
    May 2011
    Location
    Maryland, D.C. Metro Area
    Posts
    235

    Certifications
    A+, Network+, CCENT
    #11
    Quote Originally Posted by alan2308 View Post
    It's possible. It's also possible that the two cables on R1 are swapped or something isn't plugged in all the way or even a bad WIC or WIC slot in the router.
    I have a one year warranty on the cards and the routers so, if they're bad I can have them replaced.

    Best idea to confirm these are bad? I can slap one in my 2620xm if there's a way to test through that. Connect my NM4A/S to a WIC slot on the same router? lol

    Edit: Forgot I have 2 WIC-1T's coming Tuesday afternoon. If the above isn't possible I'll just have to wait until then. /sigh
    Last edited by SdotLow; 08-07-2011 at 01:13 AM.
    Reply With Quote Quote  

  13. Senior Member Chris_'s Avatar
    Join Date
    Feb 2011
    Location
    UK
    Posts
    325

    Certifications
    CCNP, CCNA, CCNA Security, CCNA Voice, JNCIA-JUNOS
    #12
    Quote Originally Posted by SdotLow View Post
    Can't ping between the serial links.



    Serial interfaces for R1 on both 1/0 and 1/1 are down/down, as is R3 serial.

    Everything is plugged in snug. WIC cards are in snug.
    Okay, just best to make sure your connectivity is good before looking at your RIP config!!
    Reply With Quote Quote  

  14. Senior Member
    Join Date
    Jul 2011
    Location
    Sydney,Australia
    Posts
    753
    #13
    Didn't do my stuff up of the other week and have the cables the wrong way around ?

    What are the cables like ? are the link/connected lights coming on ?
    Do you have a multimeter or cable checker to test the cables ?

    can you ping across the connections ?

    what does sh diag give you , are all the cards/interfaces showing up?


    do you need no shutdown on the interfaces you are using ?

    This is what my 3640 gives me for
    sh diag

    R7>sh diag
    Slot 1:
    Fast-ethernet Port adapter, 1 port
    Port adapter is analyzed
    Port adapter insertion time 01:17:33 ago
    EEPROM contents at hardware discovery:
    Hardware revision 1.0 Board revision D0
    Serial number 15165099 Part number 800-03490-02
    FRU Part Number NM-1FE-TX=
    Test history 0x0 RMA number 00-00-00
    EEPROM format version 1
    EEPROM contents (hex):
    0x00: 01 44 01 00 00 E7 66 AB 50 0D A2 02 00 00 00 00
    0x10: 68 00 00 00 99 07 31 00 FF FF FF FF FF FF FF FF
    0x20: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    0x30: FF FF FF FF FF FF FF FF FF FF FF FF

    Slot 2:
    Combo 2E, 2W Port adapter, 4 ports
    Port adapter is analyzed
    Port adapter insertion time 01:17:32 ago
    EEPROM contents at hardware discovery:
    Hardware revision 1.2 Board revision C0
    Serial number 16246859 Part number 800-01171-05
    FRU Part Number NM-2E2W=
    Test history 0x0 RMA number 00-00-00
    EEPROM format version 1
    EEPROM contents (hex):
    0x00: 01 1E 01 02 00 F7 E8 4B 50 04 93 05 00 00 00 00
    0x10: 60 00 00 00 99 10 25 17 FF FF FF FF FF FF FF FF
    0x20: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    0x30: FF FF FF FF FF FF FF FF FF FF FF FF

    WIC Slot 0:
    Serial 1T WAN daughter card
    Hardware revision 1.0 Board revision M0
    Serial number 6933385 Part number 800-01514-02
    FRU Part Number WIC-1T=
    Test history 0x0 RMA number 00-00-00
    Connector type Wan Module
    EEPROM format version 1
    EEPROM contents (hex):
    0x20: 01 02 01 00 00 69 CB 89 50 05 EA 02 00 00 00 00
    0x30: B0 00 00 00 97 11 20 01 FF FF FF FF FF FF FF FF

    WIC Slot 1:
    Serial 1T WAN daughter card
    Hardware revision 1.0 Board revision B0
    Serial number 32328483 Part number 800-01514-02
    FRU Part Number WIC-1T=
    Test history 0x0 RMA number 00-00-00
    Connector type Wan Module
    EEPROM format version 1
    EEPROM contents (hex):
    0x20: 01 02 01 00 01 ED 4B 23 50 05 EA 02 00 00 00 00
    0x30: 58 00 00 00 04 04 25 01 FF FF FF FF FF FF FF FF

    Slot 3:
    NM-2FE2W Port adapter, 2 ports
    Port adapter is analyzed
    Port adapter insertion time 01:17:34 ago
    EEPROM contents at hardware discovery:
    Hardware Revision : 1.0
    Top Assy. Part Number : 800-04797-01
    Board Revision : E0
    Deviation Number : 0-0
    Fab Version : 04
    PCB Serial Number : JAB04330384
    RMA Test History : 00
    RMA Number : 0-0-0-0
    RMA History : 00
    Product (FRU) Number : NM-2FE2W=
    EEPROM format version 4
    EEPROM contents (hex):
    0x00: 04 FF 40 00 D8 41 01 00 C0 46 03 20 00 12 BD 01
    0x10: 42 45 30 80 00 00 00 00 02 04 C1 8B 4A 41 42 30
    0x20: 34 33 33 30 33 38 34 03 00 81 00 00 00 00 04 00
    0x30: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

    WIC Slot 0:
    Serial 1T WAN daughter card
    Hardware revision 1.0 Board revision B0
    Serial number 34194727 Part number 800-01514-02
    FRU Part Number WIC-1T=
    Test history 0x0 RMA number 00-00-00
    Connector type Wan Module
    EEPROM format version 1
    EEPROM contents (hex):
    0x20: 01 02 01 00 02 09 C5 27 50 05 EA 02 00 00 00 00
    0x30: 58 00 00 00 05 11 25 01 FF FF FF FF FF FF FF FF

    R7>
    Last edited by alxx; 08-07-2011 at 01:47 AM.
    Reply With Quote Quote  

  15. Senior Member
    Join Date
    Jul 2011
    Location
    Sydney,Australia
    Posts
    753
    #14
    One thing that I was told thats a handy tip is don't forget to add a description
    for each interface

    e.g
    description serial 1/1 connection to router R22 for CB01.23(building 1 level 23)

    try these and see what they give you

    show ip interface brief
    show interfaces
    show ip protocols
    show ip route
    show ip arp
    debug ip rip
    Last edited by alxx; 08-07-2011 at 02:05 AM.
    Reply With Quote Quote  

  16. Senior Member SdotLow's Avatar
    Join Date
    May 2011
    Location
    Maryland, D.C. Metro Area
    Posts
    235

    Certifications
    A+, Network+, CCENT
    #15
    Didn't do my stuff up of the other week and have the cables the wrong way around ?

    What are the cables like ? are the link/connected lights coming on ?
    Do you have a multimeter or cable checker to test the cables ?

    can you ping across the connections ?

    what does sh diag give you , are all the cards/interfaces showing up?


    do you need no shutdown on the interfaces you are using ?
    Cables are correct. DCE is on router 1 with clock rate set.

    Link lights are on and showing "ok". I switched the slot of the WIC-1T on my R2 and I have gotten rid of the "No Fair-Queue" under the interface in the show run, but not able to ping it still. I've tried 3 different cables that I've gotten from 3 different places. I don't think it's a cable problem.

    Nope, can not ping.

    This is really frustrating me. I have no idea how to confirm what is broken/bad. /sigh

    R1 Diag:

    R1#sh diag
    Slot 0:
    C2621XM 1FE Mainboard Port adapter, 1 port
    Port adapter is analyzed
    Port adapter insertion time unknown
    EEPROM contents at hardware discovery:
    Hardware Revision : 1.0
    PCB Serial Number : FFFF
    Part Number : 73-7753-02
    RMA History : 00
    RMA Number : 0-0-0-0
    Board Revision : B0
    Deviation Number : 0-0
    Product (FRU) Number : C2620XM-1FE
    EEPROM format version 4
    EEPROM contents (hex):
    0x00: 04 FF 40 03 6C 41 01 00 C1 0B FF FF FF FF 46 46
    0x10: 46 46 FF FF FF 82 49 1E 49 02 04 00 81 00 00 00
    0x20: 00 42 42 30 80 00 00 00 00 FF FF FF FF FF FF FF
    0x30: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

    Slot 1:
    Sync/Async Port adapter, 4 ports
    Port adapter is analyzed
    Port adapter insertion time unknown
    EEPROM contents at hardware discovery:
    Hardware revision 1.0 Board revision E0
    Serial number 13846193 Part number 800-01224-02
    FRU Part Number NM-4A/S=
    Test history 0x0 RMA number 00-00-00
    EEPROM format version 1
    EEPROM contents (hex):
    0x00: 01 24 01 00 00 D3 46 B1 50 04 C8 02 00 00 00 00
    0x10: 70 00 00 00 99 04 14 17 FF FF FF FF FF FF FF FF
    0x20: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    0x30: FF FF FF FF FF FF FF FF FF FF FF FF
    R2 Diag:

    R2#sh diag
    Slot 0:
    C1760 1FE VE 4SLOT DV Mainboard Port adapter, 2 ports
    Port adapter is analyzed
    Port adapter insertion time unknown
    EEPROM contents at hardware discovery:
    Hardware Revision : 2.0
    PCB Serial Number : FOC065108QS
    Part Number : 73-7167-02
    Board Revision : C0
    Deviation Number : 0-47975
    Fab Version : 04
    Product (FRU) Number : CISCO1760
    EEPROM format version 4
    EEPROM contents (hex):
    0x00: 04 FF 40 03 16 41 02 00 C1 8B 46 4F 43 30 36 35
    0x10: 31 30 38 51 53 82 49 1B FF 02 42 43 30 80 00 00
    0x20: BB 67 02 04 FF FF FF FF FF FF FF FF FF FF FF FF
    0x30: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
    0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

    WIC/VIC Slot 1:
    Serial 1T
    Hardware revision 1.1 Board revision E0
    Serial number 0009938889 Part number 73-1775-02
    FRU Part Number WIC-1T=

    Test history 0x00 RMA number 00-00-00
    Connector type WAN Module
    EEPROM format version 1
    EEPROM contents (hex):
    0x20: 01 02 01 01 00 97 A7 C9 49 06 EF 02 00 00 00 00
    0x30: 70 00 00 00 98 08 20 01 FF
    Reply With Quote Quote  

  17. Senior Member
    Join Date
    Jul 2011
    Location
    Sydney,Australia
    Posts
    753
    #16
    what is this for ?

    no network-clock-participate slot 1
    no network-clock-participate wic 0

    Don't worry just looked it. Cisco IOS Voice Command Reference - Commands: N [Cisco IOS Software Releases 12.2 T] - Cisco Systems

    no network clock uses its own clock/time signal .
    network-clock-participate , To allow the ports on a specified network module or voice/WAN interface
    card (VWIC) to use the network clock for timing, use the network-clock-participate command in global configuration mode. To restrict the device to use only its own clock signals, use the no form of this command.

    Is this the one you are doing ?
    Configuration Example: RIP-2 Routing
    Last edited by alxx; 08-07-2011 at 02:20 AM.
    Reply With Quote Quote  

  18. Senior Member SdotLow's Avatar
    Join Date
    May 2011
    Location
    Maryland, D.C. Metro Area
    Posts
    235

    Certifications
    A+, Network+, CCENT
    #17
    Quote Originally Posted by alxx View Post
    what is this for ?

    no network-clock-participate slot 1
    no network-clock-participate wic 0
    I was wondering that as well, I have no idea.

    I'm in the process of write erasing my routers to JUST run router configs.
    Reply With Quote Quote  

  19. Senior Member
    Join Date
    Jul 2011
    Location
    Sydney,Australia
    Posts
    753
    #18
    Quote Originally Posted by SdotLow View Post
    I was wondering that as well, I have no idea.

    I'm in the process of write erasing my routers to JUST run router configs.

    what does show controllers give ?
    Last edited by alxx; 08-07-2011 at 02:30 AM.
    Reply With Quote Quote  

  20. Senior Member SdotLow's Avatar
    Join Date
    May 2011
    Location
    Maryland, D.C. Metro Area
    Posts
    235

    Certifications
    A+, Network+, CCENT
    #19
    R1 Show Control:

    R1#show controllers
    Interface FastEthernet0/0
    Hardware is AMD Am79c977
    ADDR: 83472688, FASTSEND: 8014E7A0, MCI_INDEX: 0
    DIST ROUTE ENABLED: 0
    Route Cache Flag: 11
    LADRF=0x0000 0x0100 0x0000 0x0000
    CSR0 =0x00000004, CSR3 =0x00000004, CSR4 =0x00000804, CSR15 =0x00000000
    CSR80 =0x00001800, CSR114=0x00000000, CRDA =0x00000000, CXDA =0x00000000
    BCR9 =0x00000000
    CSR5 =0x00000000, CSR7 =0x00008008, CSR100=0x00000000, CSR125=0x00005C3C
    BCR2 =0x00001000, BCR9 =0x00000000, BCR18 =0x00001880, BCR22 =0x00001818
    BCR25 =0x00000200, BCR26 =0x00000100, BCR27 =0x00000000, BCR32 =0x00004D80
    HW filtering information:
    Promiscuous Mode Disabled, PHY Addr Enabled, Broadcast Addr Enabled
    PHY Addr=000C.CEA2.6320, Multicast Filter=0x0000 0x0100 0x0000 0x0000
    amdp2_instance=0x83473770, registers=0x40000000, ib=0x7DAB760
    rx ring entries=64, tx ring entries=128
    rxring=0x7DAB7C0, rxr shadow=0x834739FC, rx_head=0, rx_tail=0
    txring=0x7DABC00, txr shadow=0x83473B30, tx_head=25, tx_tail=25, tx_count=0
    Software MAC address filter(hash:length/addr/mask/hits):
    need_af_check = 0
    0x00: 0 ffff.ffff.ffff 0000.0000.0000 0
    0xC0: 0 0100.0ccc.cccc 0000.0000.0000 0
    spurious_idon=0, throttled=0, enabled=0, disabled=0
    rx_framing_err=0, rx_overflow_err=0, rx_buffer_err=0
    rx_bpe_err=0, rx_soft_overflow_err=0, rx_no_enp=0, rx_discard=0
    tx_one_col_err=0, tx_more_col_err=0, tx_no_enp=0, tx_deferred_err=0
    tx_underrun_err=0, tx_late_collision_err=0, tx_loss_carrier_err=25
    tx_exc_collision_err=0, tx_buff_err=0, fatal_tx_err=0
    hsrp_conf=0, need_af_check=0
    tx_limited=0(64)
    PHY registers:
    Register 0x00: 1C00 7809 0013 78E2 01E1 0000 0004 2001
    Register 0x08: 0000 FFFF FFFF FFFF FFFF FFFF FFFF FFFF
    Register 0x10: 2104 0100 0000 0014 0000 0000 0000
    Register 0x18: 0000 0000 0048 0000 FFFF

    CD2430 Slot 1, Port 0, Controller 0, Channel 0, Revision 19
    Channel mode is synchronous serial
    idb 0x83478A54, buffer size 1524, No cable, clockrate 56000

    Global registers
    rpilr 0x2, rir 0x0, risr 0x0, rfoc 0x0, rdr 0x0
    tpilr 0x1, tir 0x3, tisr 0x68, tftc 0x0, tdr 0x0
    mpilr 0x3, mir 0x3, misr 0x40
    bercnt 0xFF, stk 0x0
    Per-channel registers for channel 0
    Option registers
    0x02 0x00 0x42 0x67 0x60 0x00 0x00
    Command and status registers
    cmr 0xC0, ccr 0x00, csr 0x88, msvr-rts 0x10, msvr-dtr 0x10
    Clock option registers
    rcor 0x86, rbpr 0x01, tcor 0xC0, tbpr 0x08
    Interrupt registers
    ier 0x89, livr 0x00, licr 0x00
    DMA buffer status 0x00
    DMA receive registers
    arbaddr 0x7DFA4C4, arbcnt 1548, arbsts 0x1
    brbaddr 0x7DFAB44, brbcnt 1548, brbsts 0x1
    rcbaddr 0x0
    DMA transmit registers
    atbaddr 0x0, atbcnt 0, atbsts 0x0
    btbaddr 0x0, btbcnt 0, btbsts 0x0
    tcbaddr 0x0
    Special character registers
    schr1 0x00, schr2 0x00, schr3 0x00, schr4 0x00
    scrl 0x0, scrh 0x0, lnxt 0x10
    Driver context information
    Context structure 0x8347ADA0, Register table 0x40800400
    Serial Interface Control 5:1 Register (0x40800802) is 0x80
    Adaptor Flags 0x0
    Serial Modem Control Register (0x40800804) is 0x34
    Receive static buffer 0x8347C070
    Receive particle buffers 0x8347B400, 0x8347B440
    Transmit DMA buffers 0x0, 0x0, 0x0, 0x0
    Transmit packet with particles 0x0, first word is 0x0
    Interrupt rates (per second) transmit 0, receive 0, modem 0
    True fast-switched packets 0
    Semi fast-switched packets 0
    Transmitter hang count 0
    Residual indication count 0
    Bus error count 0
    Aborted short frames count 0
    CRC short frames count 0
    Tx DMA low threshold count 0
    Error counters
    CTS deassertion failures 0
    Nested interrupt errors transmit 0, receive 0, modem 0


    CD2430 Slot 1, Port 1, Controller 0, Channel 1, Revision 19
    Channel mode is synchronous serial
    idb 0x8347E378, buffer size 1524, No cable

    Global registers
    rpilr 0x2, rir 0x0, risr 0x0, rfoc 0x0, rdr 0x0
    tpilr 0x1, tir 0x3, tisr 0x68, tftc 0x0, tdr 0x0
    mpilr 0x3, mir 0x3, misr 0x40
    bercnt 0xFF, stk 0x0
    Per-channel registers for channel 1
    Option registers
    0x02 0x00 0x42 0x67 0x60 0x00 0x00
    Command and status registers
    cmr 0xC0, ccr 0x00, csr 0x04, msvr-rts 0x00, msvr-dtr 0x00
    Clock option registers
    rcor 0x80, rbpr 0x81, tcor 0x00, tbpr 0x81
    Interrupt registers
    ier 0x00, livr 0x04, licr 0x04
    DMA buffer status 0x00
    DMA receive registers
    arbaddr 0x7DFF304, arbcnt 1548, arbsts 0x1
    brbaddr 0x7DFF984, brbcnt 1548, brbsts 0x1
    rcbaddr 0x0
    DMA transmit registers
    atbaddr 0x0, atbcnt 0, atbsts 0x0
    btbaddr 0x0, btbcnt 0, btbsts 0x0
    tcbaddr 0x0
    Special character registers
    schr1 0x00, schr2 0x00, schr3 0x00, schr4 0x00
    scrl 0x0, scrh 0x0, lnxt 0x0
    Driver context information
    Context structure 0x834806C4, Register table 0x40800400
    Serial Interface Control 5:1 Register (0x40800806) is 0x80
    Adaptor Flags 0x0
    Serial Modem Control Register (0x4080080 is 0x14
    Receive static buffer 0x833AF6E8
    Receive particle buffers 0x83480D00, 0x83480D40
    Transmit DMA buffers 0x0, 0x0, 0x0, 0x0
    Transmit packet with particles 0x0, first word is 0x0
    Interrupt rates (per second) transmit 0, receive 0, modem 0
    True fast-switched packets 0
    Semi fast-switched packets 0
    Transmitter hang count 0
    Residual indication count 0
    Bus error count 0
    Aborted short frames count 0
    CRC short frames count 0
    Tx DMA low threshold count 0
    Error counters
    CTS deassertion failures 0
    Nested interrupt errors transmit 0, receive 0, modem 0


    CD2430 Slot 1, Port 2, Controller 0, Channel 2, Revision 19
    Channel mode is synchronous serial
    idb 0x83481264, buffer size 1524, No cable

    Global registers
    rpilr 0x2, rir 0x0, risr 0x0, rfoc 0x0, rdr 0x0
    tpilr 0x1, tir 0x3, tisr 0x68, tftc 0x0, tdr 0x0
    mpilr 0x3, mir 0x3, misr 0x40
    bercnt 0xFF, stk 0x0
    Per-channel registers for channel 2
    Option registers
    0x02 0x00 0x42 0x67 0x60 0x00 0x00
    Command and status registers
    cmr 0xC0, ccr 0x00, csr 0x04, msvr-rts 0x00, msvr-dtr 0x00
    Clock option registers
    rcor 0x80, rbpr 0x81, tcor 0x00, tbpr 0x81
    Interrupt registers
    ier 0x00, livr 0x08, licr 0x08
    DMA buffer status 0x00
    DMA receive registers
    arbaddr 0x7E04144, arbcnt 1548, arbsts 0x1
    brbaddr 0x7E047C4, brbcnt 1548, brbsts 0x1
    rcbaddr 0x0
    DMA transmit registers
    atbaddr 0x0, atbcnt 0, atbsts 0x0
    btbaddr 0x0, btbcnt 0, btbsts 0x0
    tcbaddr 0x0
    Special character registers
    schr1 0x00, schr2 0x00, schr3 0x00, schr4 0x00
    scrl 0x0, scrh 0x0, lnxt 0x0
    Driver context information
    Context structure 0x834835B0, Register table 0x40800400
    Serial Interface Control 5:1 Register (0x4080080A) is 0x80
    Adaptor Flags 0x0
    Serial Modem Control Register (0x4080080C) is 0x14
    Receive static buffer 0x833AFA94
    Receive particle buffers 0x83483C40, 0x83483C80
    Transmit DMA buffers 0x0, 0x0, 0x0, 0x0
    Transmit packet with particles 0x0, first word is 0x0
    Interrupt rates (per second) transmit 0, receive 0, modem 0
    True fast-switched packets 0
    Semi fast-switched packets 0
    Transmitter hang count 0
    Residual indication count 0
    Bus error count 0
    Aborted short frames count 0
    CRC short frames count 0
    Tx DMA low threshold count 0
    Error counters
    CTS deassertion failures 0
    Nested interrupt errors transmit 0, receive 0, modem 0


    CD2430 Slot 1, Port 3, Controller 0, Channel 3, Revision 19
    Channel mode is synchronous serial
    idb 0x83484158, buffer size 1524, V.35 DCE cable

    Global registers
    rpilr 0x2, rir 0x0, risr 0x0, rfoc 0x0, rdr 0x1A
    tpilr 0x1, tir 0x3, tisr 0x68, tftc 0x0, tdr 0x10
    mpilr 0x3, mir 0x3, misr 0x40
    bercnt 0xFF, stk 0x0
    Per-channel registers for channel 3
    Option registers
    0x02 0x00 0x42 0x67 0x60 0x00 0x00
    Command and status registers
    cmr 0xC0, ccr 0x00, csr 0x04, msvr-rts 0xE0, msvr-dtr 0xE0
    Clock option registers
    rcor 0x80, rbpr 0x81, tcor 0x00, tbpr 0x81
    Interrupt registers
    ier 0x00, livr 0x0C, licr 0x0C
    DMA buffer status 0x00
    DMA receive registers
    arbaddr 0x7E08F84, arbcnt 1548, arbsts 0x1
    brbaddr 0x7E09604, brbcnt 1548, brbsts 0x1
    rcbaddr 0x0
    DMA transmit registers
    atbaddr 0x7C8A114, atbcnt 24, atbsts 0x0
    btbaddr 0x7C8A394, btbcnt 24, btbsts 0x0
    tcbaddr 0x7C8A3AC
    Special character registers
    schr1 0x00, schr2 0x00, schr3 0x00, schr4 0x00
    scrl 0x0, scrh 0x0, lnxt 0x0
    Driver context information
    Context structure 0x834864A4, Register table 0x40800400
    Serial Interface Control 5:1 Register (0x4080080E) is 0x80
    Adaptor Flags 0x0
    Serial Modem Control Register (0x40800810) is 0x14
    Receive static buffer 0x834877B0
    Receive particle buffers 0x83486B40, 0x83486B80
    Transmit DMA buffers 0x0, 0x0, 0x0, 0x0
    Transmit packet with particles 0x0, first word is 0x0
    Interrupt rates (per second) transmit 0, receive 0, modem 0
    True fast-switched packets 0
    Semi fast-switched packets 0
    Transmitter hang count 0
    Residual indication count 0
    Bus error count 0
    Aborted short frames count 0
    CRC short frames count 0
    Tx DMA low threshold count 0
    Error counters
    CTS deassertion failures 0
    Nested interrupt errors transmit 0, receive 0, modem 0
    R2 Show Control:

    R2#show control
    Interface FastEthernet0/0
    Hardware is PQUICC MPC860P ADDR: 811AE080, FASTSEND: 8003A8F0
    DIST ROUTE ENABLED: 0
    Route Cache Flag: 11
    ADDR_LOW =0x000AF43B, ADDR_HIGH =0x0000466A, HASH_HIGH =0x00000000, HASH_LOW =0x00000000
    R_DES_ST =0x03663D40, X_DES_ST =0x03663E80, R_BUFF_SIZ=0x00000600, ECNTRL =0xF0000000
    IEVENT =0x00000000, IMASK =0x0A000000, IVEC =0xC0000000, R_DES_ACT=0x00000000
    X_DES_ACT=0x00000000, MII_DATA =0x60460100, MII_SPEED =0x00000014, R_BOUND =0x00000600
    R_FSTART =0x00000500, X_FSTART =0x00000440, FUN_CODE =0x7F000000, R_CNTRL =0x00000006
    R_HASH =0xAD0005F2
    X_CNTRL =0x00000000
    HW filtering information:
    Promiscuous Mode Disabled
    Software MAC address filter(hash:length/addr/mask/hits):
    pquicc_fec_instance=0x811B04A0
    rx ring entries=32, tx ring entries=32
    rxring=0x3663D40, rxr shadow=0x811B06E0, rx_head=0, rx_tail=0
    txring=0x3663E80, txr shadow=0x8127DE08, tx_head=9, tx_tail=9, tx_count=0

    RX_RING_ENTRIES
    status 8000, len 0, buf_ptr 358E980
    status 8000, len 0, buf_ptr 358E300
    status 8000, len 0, buf_ptr 358DC80
    status 8000, len 0, buf_ptr 358D600
    status 8000, len 0, buf_ptr 358CF80
    status 8000, len 0, buf_ptr 358C900
    status 8000, len 0, buf_ptr 358C280
    status 8000, len 0, buf_ptr 358BC00
    status 8000, len 0, buf_ptr 358B580
    status 8000, len 0, buf_ptr 358AF00
    status 8000, len 0, buf_ptr 358A880
    status 8000, len 0, buf_ptr 358A200
    status 8000, len 0, buf_ptr 3589B80
    status 8000, len 0, buf_ptr 3589500
    status 8000, len 0, buf_ptr 3588E80
    status 8000, len 0, buf_ptr 3588800
    status 8000, len 0, buf_ptr 3588180
    status 8000, len 0, buf_ptr 3587B00
    status 8000, len 0, buf_ptr 3587480
    status 8000, len 0, buf_ptr 3586E00
    status 8000, len 0, buf_ptr 3586780
    status 8000, len 0, buf_ptr 3586100
    status 8000, len 0, buf_ptr 3585A80
    status 8000, len 0, buf_ptr 3585400
    status 8000, len 0, buf_ptr 3584D80
    status 8000, len 0, buf_ptr 3584700
    status 8000, len 0, buf_ptr 3584080
    status 8000, len 0, buf_ptr 3583A00
    status 8000, len 0, buf_ptr 35A3140
    status 8000, len 0, buf_ptr 35A2AC0
    status 8000, len 0, buf_ptr 35A2440
    status A000, len 0, buf_ptr 35A1DC0

    TX_RING_ENTRIES
    status 0, len 3C, buf_ptr 354CA0A
    status 0, len 26A, buf_ptr 3551DCA
    status 0, len 3C, buf_ptr 354CC8A
    status 0, len 26A, buf_ptr 3552B8A
    status 0, len 3C, buf_ptr 354CF0A
    status 0, len 3C, buf_ptr 354D18A
    status 0, len 3C, buf_ptr 354D40A
    status 0, len 3C, buf_ptr 354D68A
    status 0, len 3C, buf_ptr 354D90A
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 0, len 0, buf_ptr 0
    status 2000, len 0, buf_ptr 0
    throttled=0, enabled=0, disabled=0
    rx_framing_err=0, rx_overflow_err=0, rx_buffer_err=0
    rx_no_enp=0, rx_discard=0
    tx_one_col_err=0, tx_more_col_err=0, tx_no_enp=0, tx_deferred_err=0
    tx_underrun_err=0, tx_late_collision_err=0, tx_loss_carrier_err=9
    tx_exc_collision_err=0, tx_buff_err=0, fatal_tx_err=0
    PHY registers:
    Register 00 1800
    Register 01 7809
    Register 02 0013
    Register 03 78E2
    Register 04 01E1
    Register 05 0000
    Register 06 0004
    Register 16 0184
    Register 17 0100
    Register 18 0062
    Register 19 0014
    Register 20 4732


    Interface Serial1/0
    Hardware is PowerQUICC MPC860
    DTE V.35 clocks stopped.
    idb at 0x812A64F4, driver data structure at 0x812AE09C
    SCC Registers:
    General [GSMR]=0x2:0x00000030, Protocol-specific [PSMR]=0x8
    Events [SCCE]=0x0000, Mask [SCCM]=0x001F, Status [SCCS]=0x00
    Transmit on Demand [TODR]=0x0, Data Sync [DSR]=0x7E7E
    Interrupt Registers:
    Config [CICR]=0x00365F80, Pending [CIPR]=0x00000002
    Mask [CIMR]=0x20200400, In-srv [CISR]=0x00000000
    Command register [CR]=0x640
    Port A [PADIR]=0x0000, [PAPAR]=0x060C
    [PAODR]=0x0000, [PADAT]=0xFFFB
    Port B [PBDIR]=0x0200F, [PBPAR]=0x0D00E
    [PBODR]=0x00000, [PBDAT]=0x30FFC
    Port C [PCDIR]=0x008, [PCPAR]=0x000
    [PCSO]=0x080, [PCDAT]=0xFF4, [PCINT]=0x000
    Receive Ring
    rmd(FF002530): status 9000 length 60C address 35A1744
    rmd(FF00253: status 9000 length 60C address 35A10C4
    rmd(FF002540): status 9000 length 60C address 35A0A44
    rmd(FF00254: status 9000 length 60C address 35A03C4
    rmd(FF002550): status 9000 length 60C address 359FD44
    rmd(FF00255: status 9000 length 60C address 359F6C4
    rmd(FF002560): status 9000 length 60C address 359F044
    rmd(FF00256: status 9000 length 60C address 359E9C4
    rmd(FF002570): status 9000 length 60C address 359E344
    rmd(FF00257: status 9000 length 60C address 359DCC4
    rmd(FF002580): status 9000 length 60C address 359D644
    rmd(FF00258: status 9000 length 60C address 359CFC4
    rmd(FF002590): status 9000 length 60C address 359C944
    rmd(FF00259: status 9000 length 60C address 359C2C4
    rmd(FF0025A0): status 9000 length 60C address 359BC44
    rmd(FF0025A: status B000 length 60C address 359B5C4
    Transmit Ring
    tmd(FF0025B0): status 0 length 0 address 0
    tmd(FF0025B: status 0 length 0 address 0
    tmd(FF0025C0): status 0 length 0 address 0
    tmd(FF0025C: status 0 length 0 address 0
    tmd(FF0025D0): status 0 length 0 address 0
    tmd(FF0025D: status 0 length 0 address 0
    tmd(FF0025E0): status 0 length 0 address 0
    tmd(FF0025E: status 0 length 0 address 0
    tmd(FF0025F0): status 0 length 0 address 0
    tmd(FF0025F: status 0 length 0 address 0
    tmd(FF002600): status 0 length 0 address 0
    tmd(FF00260: status 0 length 0 address 0
    tmd(FF002610): status 0 length 0 address 0
    tmd(FF00261: status 0 length 0 address 0
    tmd(FF002620): status 0 length 0 address 0
    tmd(FF00262: status 2000 length 0 address 0

    tx_limited=1(2)

    SCC GENERAL PARAMETER RAM (at 0xFF003D00)
    Rx BD Base [RBASE]=0x2530, Fn Code [RFCR]=0x18
    Tx BD Base [TBASE]=0x25B0, Fn Code [TFCR]=0x18
    Max Rx Buff Len [MRBLR]=1548
    Rx State [RSTATE]=0x0, BD Ptr [RBPTR]=0x2530
    Tx State [TSTATE]=0x0, BD Ptr [TBPTR]=0x25B0

    SCC HDLC PARAMETER RAM (at 0xFF003D3
    CRC Preset [C_PRES]=0xFFFF, Mask [C_MASK]=0xF0B8
    Errors: CRC [CRCEC]=0, Aborts [ABTSC]=0, Discards [DISFC]=0
    Nonmatch Addr Cntr [NMARC]=0
    Retry Count [RETRC]=0
    Max Frame Length [MFLR]=1608
    Rx Int Threshold [RFTHR]=0, Frame Cnt [RFCNT]=0
    User-defined Address 0000/0000/0000/0000
    User-defined Address Mask 0x0000


    buffer size 1524

    PowerQUICC SCC specific errors:
    0 input aborts on receiving flag sequence
    0 throttles, 0 enables
    0 overruns
    0 transmitter underruns
    0 transmitter CTS losts
    Reply With Quote Quote  

  21. Senior Member
    Join Date
    Jul 2011
    Location
    Sydney,Australia
    Posts
    753
    #20
    Quote Originally Posted by SdotLow View Post
    R1 Show Control:

    R2 Show Control:
    cables still plugged in ?

    one cable backwards ?

    R1 s0
    CD2430 Slot 1, Port 0, Controller 0, Channel 0, Revision 19
    Channel mode is synchronous serial
    idb 0x83478A54, buffer size 1524, No cable, clockrate 56000

    R1
    CD2430 Slot 1, Port 1, Controller 0, Channel 1, Revision 19
    Channel mode is synchronous serial
    idb 0x8347E378, buffer size 1524, No cable

    R1
    CD2430 Slot 1, Port 2, Controller 0, Channel 2, Revision 19
    Channel mode is synchronous serial
    idb 0x83481264, buffer size 1524, No cable

    R1
    CD2430 Slot 1, Port 3, Controller 0, Channel 3, Revision 19
    Channel mode is synchronous serial
    idb 0x83484158, buffer size 1524, V.35 DCE cable


    R2
    Interface Serial1/0
    DTE V.35 clocks stopped.
    Reply With Quote Quote  

  22. Senior Member SdotLow's Avatar
    Join Date
    May 2011
    Location
    Maryland, D.C. Metro Area
    Posts
    235

    Certifications
    A+, Network+, CCENT
    #21
    Alxx I love you. I assumed (and we all know what they say about assuming) that serial ports on the NM4A/S would be left to right. That would be a false assumption.

    Wow. Just wow.
    Reply With Quote Quote  

  23. Senior Member
    Join Date
    Jul 2011
    Location
    Sydney,Australia
    Posts
    753
    #22
    Is this what you have setup ?
    http://www.alexthegeek.com/rip2.jpg

    excuse the crappy symbols using omni graffle on mac as don't have visio setup on windows yet.
    Reply With Quote Quote  

  24. Senior Member alan2308's Avatar
    Join Date
    Apr 2010
    Location
    Ann Arbor, MI
    Posts
    1,807

    Certifications
    CCNA, CCNA Sec, MCSA 2008, MCSA 2012, CISSP
    #23
    Quote Originally Posted by SdotLow View Post
    Alxx I love you. I assumed (and we all know what they say about assuming) that serial ports on the NM4A/S would be left to right. That would be a false assumption.

    Wow. Just wow.
    You're not the first, and you wont be the last to make this mistake.
    Reply With Quote Quote  

  25. Senior Member SdotLow's Avatar
    Join Date
    May 2011
    Location
    Maryland, D.C. Metro Area
    Posts
    235

    Certifications
    A+, Network+, CCENT
    #24
    Quote Originally Posted by alxx View Post
    Is this what you have setup ?
    http://www.alexthegeek.com/rip2.jpg

    excuse the crappy symbols using omni graffle on mac as don't have visio setup on windows yet.
    Yeah it was. I set them up in a line to assist in my trouble shooting.

    Right now its R3 --------> R1 ---------> R2. I'll be switching it back to your picture in a few minutes.
    Reply With Quote Quote  

  26. Senior Member SdotLow's Avatar
    Join Date
    May 2011
    Location
    Maryland, D.C. Metro Area
    Posts
    235

    Certifications
    A+, Network+, CCENT
    #25
    Quote Originally Posted by alan2308 View Post
    You're not the first, and you wont be the last to make this mistake.
    Maybe it's just me, but it seems pretty counter intuitive to be put in that formation.

    But I learned a lot from the experience. Things I won't forget in a long time lol.
    Reply With Quote Quote  

+ Reply to Thread
Page 1 of 2 1 2 Last

Social Networking & Bookmarks