Hi All,

I hope you guys that have a bit more experience with Nexus kit can help me out.

1 of our clients are running 2x Nexus 5k's in a vdc with fex's and access switches dual homed combined with EIGRP. On both nexus a L3 interface was configured that was connected to a 4948 that is no longer used and I wanted to decommission these links.

Config on both nexus

router eigrp 2008
autonomous-system 2008
redistribute static route-map static-routes

interface Ethernet1/36 (Nexus 1)
description L3 LINK -> E2-DC-FWIN-01 [G1/45]
no switchport
speed 1000
ip address 172.21.255.193/30
ip router eigrp 2008

interface Ethernet1/36 (Nexus 2)
description L3 LINK -> E2-DC-FWIN-01 [G1/46]
no switchport
speed 1000
ip address 172.21.255.197/30
ip router eigrp 2008


On nexus 1 I shut the interface and than removed the eigrp config from the interface(not on global level) by running no ip router eigrp 2008 which was fine however when I did this on the 2nd nexus I lost partial from the access switches. As far as I know if you run no ip router eigrp 2008 on an interface level it will only stop eigrp from advertising the route. When I checked show ip eigrp neighbours on n nexus 2 it showed that the process is not running. In the event log I saw the following log message:

2015 May 28 14:58:45.418 E2-DC-CSW-02 %ETHPORT-5-IF_DOWN_CFG_CHANGE: Interface Ethernet1/36 is down(Config change)
2015 May 28 14:58:45.616 E2-DC-CSW-02 %EIGRP-5-NBRCHANGE_DUAL: eigrp-2008 [3350] (default-base) IP-EIGRP(0) 2008: Neighbor 172.21.25
5.198 (Ethernet1/36) is down: interface status down
2015 May 28 14:58:45.619 E2-DC-CSW-02 %ETHPORT-5-IF_DOWN_CFG_CHANGE: Interface Ethernet1/36 is down(Config change)
2015 May 28 14:58:45.734 E2-DC-CSW-02 %ETHPORT-5-IF_DOWN_ADMIN_DOWN: Interface Ethernet1/36 is down (Administratively down)
2015 May 28 15:00:28.817 E2-DC-CSW-02 %EIGRP-5-SHUTDOWN: eigrp-2008 [3350] Shutting down EIGRP process - due to deconfiguration

I'm trying to figure out if I forked up or if this is a software bug.