+ Reply to Thread
Results 1 to 3 of 3
  1. Junior Member Registered Member
    Join Date
    May 2014
    Posts
    1
    #1

    Unhappy I'm unable to register any Cisco Phones with my Cisco 3845 CCME V8.6 router

    First let me state I am not much of a voice expert by no means. I have managed to get the soft phones to register both X-Lite and Zoiper with no problem. However I am unable to get any Cisco Hard phones to register. I have the following phones.


    Cisco 7941 SIP
    2 Cisco 7942 SCCP I would like to eventually convert these to SIP
    2 Cisco 7960 SCCP


    Is my understanding correct in that ephone-dn is for SCCP while voice register is SIP??


    The SCCP phones boot up but do not look as though they contact the call manager as they have a 2000 extension and as you can see from my config everything is 4xxx. The SIP phone 7941 Boots up requests the term41.default.loads. And I believe its getting it. I did a packet capture as well. Which is attached.


    Any help would be greatly appreciated. This is for a lab enviroment

    Code:
    cme8.6>
    cme8.6>enable
    cme8.6#sh run
    Building configuration...
    
    
    
    
    Current configuration : 9727 bytes
    !
    ! Last configuration change at 12:30:05 MDT Thu May 1 2014
    ! NVRAM config last updated at 12:06:40 MDT Thu May 1 2014
    ! NVRAM config last updated at 12:06:40 MDT Thu May 1 2014
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname cme8.6
    !
    boot-start-marker
    boot system flash c3845-adventerprisek9-mz.151-4.M5.bin
    boot-end-marker
    !
    !
    !
    aaa new-model
    !
    !
    !
    !
    !
    !
    !
    aaa session-id common
    !
    clock timezone MST -7 0
    clock summer-time MDT recurring
    !
    dot11 syslog
    ip source-route
    !
    ip cef
    !
    !
    !
    ip dhcp pool VoIP_Test_Pool
     network 10.250.0.0 255.255.254.0
     option 150 ip 10.250.0.57
     default-router 10.250.0.57
    !
    !
    no ip domain lookup
    ip domain name fnetlab.private
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    voice-card 0
    !
    !
    !
    voice service voip
     allow-connections h323 to sip
     allow-connections sip to h323
     allow-connections sip to sip
     supplementary-service h450.12
     sip
      registrar server
    !
    voice class codec 1
     codec preference 1 g729r8
     codec preference 2 g711ulaw
    !
    !
    voice register global
     mode cme
     source-address 10.250.0.57 port 5060
     max-dn 720
     max-pool 262
     load 7942 SIP42.9-2-1S
     load 7941 SIP41.9-2-1S
     authenticate register
     authenticate realm cisco
     tftp-path flash:
     file text
     create profile sync 000845224589399A
     video
    !
    voice register dn  1
     number 4001
     name 4001
     no-reg
     label Kris A
    !
    voice register dn  2
     number 4002
     name 4002
     no-reg
     label Kris A 2
    !
    voice register dn  10
     number 4010
     name 40010
     no-reg
     label Gordon Dell Laptop
    !
    voice register dn  20
     number 4020
     name 4020
     no-reg
     label Gordon VMWare 1
    !
    voice register dn  30
     number 4030
     name 4030
     no-reg
     label Gordon VMWare 2
    !
    voice register dn  40
     number 4040
     name 4040
     no-reg
     label Gordon HW Probe 1
    !
    voice register dn  50
     number 4050
     name 4050
     no-reg
     label Kevin Dell T3500
    !
    voice register dn  60
     number 4060
     name 4060
     no-reg
     label Kevin Dell E6410
    !
    voice register dn  70
     number 4070
     name 4070
     no-reg
     label Kevin Dell M6300
    !
    voice register dn  205
     number 4205
     name 4205
     no-reg
     label Gordon B C7942 SIP
    !
    voice register dn  210
     number 4210
     name 4210
     label Kevin L 7942 SIP
    !
    voice register dn  215
     number 4215
     name 4215
     label Kris A 7941 SIP
    !
    voice register pool  1
     id mac 685B.359A.CDB0
     number 1 dn 1
     voice-class codec 1
     username 4001 password 4001
    !
    voice register pool  2
     id mac 000C.29DF.9F70
     number 1 dn 2
     voice-class codec 1
     username 4002 password 4002
    !
    voice register pool  10
     id mac F01F.AF25.2908
     number 1 dn 10
     voice-class codec 1
     username 4010 password 4010
    !
    voice register pool  20
     id mac 0050.56C0.0001
     number 1 dn 20
     voice-class codec 1
     username 4020 password 4020
    !
    voice register pool  30
     id mac 0050.56C0.0008
     number 1 dn 30
     voice-class codec 1
     username 4030 password 4030
    !
    voice register pool  40
     id mac 00C0.1701.0206
     number 1 dn 40
     voice-class codec 1
     username 4040 password 4040
    !
    voice register pool  50
     id mac B8AC.6F95.51A3
     number 1 dn 50
     voice-class codec 1
     username 4050 password 4050
    !
    voice register pool  60
     id mac 5C26.0A1F.B7BB
     number 1 dn 60
     voice-class codec 1
     username 4060 password 4060
    !
    voice register pool  70
     id mac 001C.232F.9236
     number 1 dn 70
     voice-class codec 1
     username 4070 password 4070
    !
    voice register pool  205
     id mac 0025.8416.BEE9
     type 7942
     number 1 dn 205
     voice-class codec 1
     username 4205 password 4205
    !
    voice register pool  210
     id mac 0023.5E18.9B3F
     type 7942
     number 1 dn 210
     voice-class codec 1
     username 4210 password 4210
    !
    voice register pool  215
     id mac 001E.138C.A191
     type 7941
     number 1 dn 215
     voice-class codec 1
     no vad
    !
    !
    !
    !
    crypto pki token default removal timeout 0
    !
    crypto pki trustpoint TP-self-signed-1612486836
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-1612486836
     revocation-check none
     rsakeypair TP-self-signed-1612486836
    !
    !
    crypto pki certificate chain TP-self-signed-1612486836
     certificate self-signed 01
      3082024E 308201B7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31363132 34383638 3336301E 170D3134 30343235 31393036
      33355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 36313234
      38363833 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100C28D 74A783B5 DEE733FB 456811F9 7A019F0E E0EE8580 EB840C7D 15410DF8
      24841943 EF7A1844 B28D6B71 C68833D3 C577325E 6BC1F1BC 1B503575 BEA82E5A
      21F52DEE CC3EE31C A57F1B91 DAEAAC5B A7AA8229 3FBD5816 8DB47686 CE431AE3
      0B4EB211 93AD93C0 D7685AB7 E24141E0 0FBF5DC0 35C8F314 70DF0700 E79C9713
      51110203 010001A3 76307430 0F060355 1D130101 FF040530 030101FF 30210603
      551D1104 1A301882 16636D65 382E362E 666E6574 6C61622E 70726976 61746530
      1F060355 1D230418 30168014 B3333567 4C464AA8 1694AF90 AFD0F49F 7945D97B
      301D0603 551D0E04 160414B3 3335674C 464AA816 94AF90AF D0F49F79 45D97B30
      0D06092A 864886F7 0D010104 05000381 81006EC6 C9B6D557 461926AF F038149A
      52AE4084 26FB5281 B6A6111D CE5C6101 E0A06D7B 943D8CAD FAB2BEE4 F5E96AE8
      5FC5FDC1 72F9AB6C 9211544F F7018B2B A16B2BB5 9247FB69 A78DC31B BCAF01C4
      06A5AE2B AA078BAB 86C1DF31 1F85FE8D B2036B85 CCE966DF 3C9B622D 077ED840
      A80CBE85 C48682C2 B6E646F2 1AF14388 1A9A
            quit
    !
    !
    license udi pid CISCO3845-MB sn FOC15210MMY
    username Admin privilege 15 password 0 fnet150
    username Cisco privilege 15 password 0 Cisco
    !
    redundancy
    !
    !
    ip ssh version 2
    !
    !
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
     ip address 10.250.0.57 255.255.254.0
     duplex auto
     speed auto
     media-type rj45
    !
    interface GigabitEthernet0/1
     ip address dhcp
     shutdown
     duplex auto
     speed auto
     media-type rj45
    !
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip http path flash:/cme-gui-8.6.0
    !
    !
    !
    !
    !
    !
    !
    !
    tftp-server flash:/Phones/P0030801SR02.sbn alias P0030801SR02.sbn
    tftp-server flash:/Phones/P0030801SR02.txt alias P0030801SR02.txt
    tftp-server flash:/Phones/P0030801SR02.bin alias P0030801SR02.bin
    tftp-server flash:/Phones/P0030801SR02.loads alias P0030801SR02.loads
    tftp-server flash:/Phones/P0030801SR02.sb2 alias P0030801SR02.sb2
    tftp-server flash:/Phones/P003-8-12-00.sbn alias P003-8-12-00.sbn
    tftp-server flash:/Phones/OS79XX.TXT alias OS79XX.TXT
    tftp-server flash:/Phones/P0S3-8-12-00.loads alias P0S3-8-12-00.loads
    tftp-server flash:/Phones/P0S3-8-12-00.sb2 alias P0S3-8-12-00.sb2
    tftp-server flash:/Phones/P003-8-12-00.bin alias P003-8-12-00.bin
    tftp-server flash:/Phones/cnu41.9-2-1TH1-13.sbn alias cnu41.9-2-1TH1-13.sbn
    tftp-server flash:/Phones/cvm41sip.9-2-1TH1-13.sbn alias cvm41sip.9-2-1TH1-13.sbn
    tftp-server flash:/Phones/dsp41.9-2-1TH1-13.sbn alias dsp41.9-2-1TH1-13.sbn
    tftp-server flash:/Phones/jar41sip.9-2-1TH1-13.sbn alias jar41sip.9-2-1TH1-13.sbn
    tftp-server flash:/Phones/SIP41.9-2-1S.loads alias SIP41.9-2-1S.loads
    tftp-server flash:/Phones/term41.default.loads alias term41.default.loads
    tftp-server flash:/Phones/term61.default.loads alias term61.default.loads
    tftp-server flash:/Phones/apps41.9-2-1TH1-13.sbn alias apps41.9-2-1TH1-13.sbn
    tftp-server flash:/Phones/cvm41sccp.9-2-1TH1-13.sbn alias cvm41sccp.9-2-1TH1-13.sbn
    tftp-server flash:/Phones/jar41sccp.9-2-1TH1-13.sbn alias jar41sccp.9-2-1TH1-13.sbn
    tftp-server flash:/Phones/SCCP41.9-2-1S.loads alias SCCP41.9-2-1S.loads
    tftp-server flash:/Phones/cnu42.9-2-1TH1-13.sbn alias cnu42.9-2-1TH1-13.sbn
    tftp-server flash:/Phones/cvm42sccp.9-2-1TH1-13.sbn alias cvm42sccp.9-2-1TH1-13.sbn
    tftp-server flash:/Phones/dsp42.9-2-1TH1-13.sbn alias dsp42.9-2-1TH1-13.sbn
    tftp-server flash:/Phones/jar42sccp.9-2-1TH1-13.sbn alias jar42sccp.9-2-1TH1-13.sbn
    tftp-server flash:/Phones/SCCP42.9-2-1S.loads alias SCCP42.9-2-1S.loads
    tftp-server flash:/Phones/term42.default.loads alias term42.default.loads
    tftp-server flash:/Phones/term62.default.loads alias term62.default.loads
    tftp-server flash:/Phones/apps42.9-2-1TH1-13.sbn alias apps42.9-2-1TH1-13.sbn
    tftp-server flash:/Phones/jar42sip.9-2-1TH1-13.sbn alias jar42sip.9-2-1TH1-13.sbn
    tftp-server flash:/Phones/SIP42.9-2-1S.loads alias SIP42.9-2-1S.loads
    tftp-server flash:/Phones/cvm42sip.9-2-1TH1-13.sbn alias cvm42sip.9-2-1TH1-13.sbn
    !
    !
    !
    control-plane
    !
    !
    !
    !
    mgcp profile default
    !
    !
    !
    sip-ua
    !
    !
    !
    telephony-service
     max-ephones 262
     max-dn 720
     ip source-address 10.250.0.249 port 5080
     system message Cisco VoIP CCMEV8.6
     load 7942 SCCP42.9-2-1S
     time-format 24
     max-conferences 12 gain -6
     dn-webedit
     time-webedit
     transfer-system full-consult
     create cnf-files version-stamp 7960 May 01 2014 10:58:20
    !
    !
    ephone-dn  150
     number 4150
     label 4150
     name 4150
     allow watch
     hold-alert 30 originator
    !
    !
    ephone-dn  155
     number 4155
     label 4155
     name 4155
     allow watch
    !
    !
    ephone-dn  160
     number 4160
     label 4160
     name 4160
     allow watch
    !
    !
    ephone-dn  165
     number 4165
     label 4165
     name 4165
     allow watch
    !
    !
    ephone-dn  170
     number 4170
     label 4170
     name 4170
     allow watch
    !
    !
    ephone-dn  175
     number 4175
     label 4175
     name 4175
     allow watch
    !
    !
    ephone-dn  180
     number 4180
     label 4180
     name 4180
     allow watch
    !
    !
    ephone-dn  185
     number 4185
     label 4185
     name 4185
     allow watch
    !
    !
    ephone-dn  190
     number 4190
     label 4190
     name 4190
     allow watch
    !
    !
    ephone-dn  195
     number 4195
     label 4195
     name 4195
     allow watch
    !
    !
    ephone  150
     device-security-mode none
     mac-address 0025.8416.BEE9
     type 7942
    !
    !
    !
    ephone  155
     device-security-mode none
     mac-address 0023.5E18.9B3F
     type 7942
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     privilege level 15
     logging synchronous
     transport input ssh
    !
    scheduler allocate 20000 1000
    ntp master
    ntp server 128.138.140.44
    end
    debug tftp
    debug ccsip messages

    May 1 18:08:56.347: TFTP: Looking for CTLSEP00258416BEE9.tlv
    May 1 18:08:56.419: TFTP: Looking for ITLSEP00258416BEE9.tlv
    May 1 18:08:56.487: TFTP: Looking for ITLFile.tlv
    May 1 18:08:56.727: TFTP: Looking for SEP00258416BEE9.cnf.xml.sgn
    May 1 18:08:56.851: TFTP: Looking for XMLDefault.cnf.xml.sgn
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member
    Join Date
    Jul 2010
    Location
    Chicago, Illinois
    Posts
    149

    Certifications
    MCSE:2003 / CCNA/A+
    #2

    Default What Call Manager TFTPserver address is phones looking for?

    The phones are configured with a TFTP server so it will look for a specified TFTP server.
    It should be the address of your CME service. [from your config. source-address 10.250.0.57]

    While I like DHCP to hand out service options, I like to manually config the phone addresses and resources
    Reply With Quote Quote  

  4. Senior Member
    Join Date
    Dec 2012
    Location
    UK
    Posts
    225

    Certifications
    CCNP:R&S, CCNA:Voice, MSc Networking Technologies
    #3
    Is your firmware right for the 7960? I have:

    P00308000400.bin
    P00308000400.loads
    P00308000400.sb2
    P00308000400.sbn

    You have a tlot of options there, I would start from scratch with the basics and work your way up, focus on getting them registered before adding all the other stuff.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks