+ Reply to Thread
Results 1 to 15 of 15
  1. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #1

    Default Cucm + 3550 + physical phones

    I've been playing around with CME running on a couple 2911 routers and 3550pwr switches and a few 7940/7960 and all has been good, made a couple "branch sites" and dial peers and all.

    I then decided to bring CUCM into the mix, so what I've done is stood up cucm 8.6 demo in esxi first.
    I then connected this cucm 8.6 to vswitch and spun up another vm running windows OS and installed IP communicator.
    I got the CUCM to register ip communicator and made some test calls between two ip communicator phones on two vm's.

    I decided to then connect the Cucm to a physical 3550 switch with 2 physical 7940/7960 phones. Cucm is running tftp and dhcp server. From the 3550 switch I can ping the cucm server by it's ip 192.168.1.86 and via sh cdp neighbor command I do see cucm and the physical phones. I am using vlan1 for voice and data just for this simple test, to not complicate things further.

    Under vlan 1 I've also added ip helper-address for the cucm ip 192.168.1.86.

    I must be missing something, as I can't get the phones to pull their ip from the cucm server?

    Keep in mind, when the same CUCM is not being used with 3550 switch, but instead I use it with Cisco IP communicator phones in Windows, I can get the phones registered if I point them to the 192.168.1.86 ip address.

    Do I have to bring a physical router into this mix to get this to work, or should it be possible to get CUCM-3550-7940/7960 combo to work by itself?

    I tried adding a router into the mix, set it as 192.168.1.1 and set the ip-helper address of cucm. Didn't make a difference.
    interface FastEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    ip helper-address 192.168.1.86
    duplex auto
    speed auto

    3550 Switch has
    ip dhcp relay information option
    interface Vlan1
    ip address 192.168.1.55 255.255.255.0
    ip helper-address 192.168.1.86
    !
    ip default-gateway 192.168.1.1

    I can ping every ip from every ip, but phones are stuck on broadcasting for tftp server 255.255.255.255
    Tried resetting the phones as well, no difference.

    Thanks.

    ------------------------------Layout-------------------------

    CUCM = ip 192.168.1.86 (dhcp server 192.168.1.86, primary tftp option 150 192.168.1.86, domain name 192.168.186, option 66 tftp server name 192.168.1.86)
    dhcp subnet 192.168.1.0 / start ip 192.168.1.130 / end ip 192.168.1.199

    windows vm to manage the cucm console 192.168.1.80

    3550 switch - vlan 1 ip address 192.168.1.55
    + 2 phones.

    Router = 192.168.1.1
    ip helper-address 192.168.1.86
    Last edited by JeanM; 05-15-2014 at 07:11 AM.
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #2
    I think maybe what I should do is have my 192.168.1.1 router handle dhcp , and point the the dhcp voice scope to the 192.168.1.86 and and then disable the dhcp service on the CUCM server?

    =======================================
    Update -

    Set 192.168.1.1 router with voice scope and pointed to cucm ip address. removed dhcp/subnet from cucm.

    ip dhcp pool VOICE_SCOPE
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    option 150 ip 192.168.1.86
    !
    !
    interface FastEthernet0/0
    description TO VOICE SWITCH
    ip address 192.168.1.1 255.255.255.0
    ip helper-address 192.168.1.86
    duplex auto
    speed auto

    Phones got IP addresses now, and CUCM shows phones as registered
    Last edited by JeanM; 05-15-2014 at 06:40 AM.
    Reply With Quote Quote  

  4. Senior Member
    Join Date
    Dec 2012
    Location
    UK
    Posts
    225

    Certifications
    CCNP:R&S, CCNA:Voice, MSc Networking Technologies
    #3
    Interesting, I've not used CUCM yet, thats this weekend, just finished dial-peers and that... Surely though if there is a DHCP server on CUCM, you should be able to use it? Did you trunk to the CUCM box?
    Reply With Quote Quote  

  5. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #4
    Yep, I am re-working my lab so I am going to try this again and see what I missed.

    I just added NM-2v + vic-2fxs + analog phone to 2600xm and 1760 is on the way to act as another voice gateway for analog phone , and then two 3550s poe for my 3 voip phones with 2811s for cme + cucm in VM. I've only setup publisher, and want to add subscriber to the mix next and see what I can do with that.

    How is your labbing going, did you end up installing CUCM in your lab?
    Reply With Quote Quote  

  6. Senior Member
    Join Date
    Dec 2012
    Location
    UK
    Posts
    225

    Certifications
    CCNP:R&S, CCNA:Voice, MSc Networking Technologies
    #5
    Yeah I've run into a few issues which drove me mad!

    The first was, I also had NM-2v + VIC-2FXS & FXO and discovered in the end, that my phone line into my house is down, thought I was going mad, buying new cables, making different types etc, took my lab to another house and it worked fine!

    With CUCM I set it up on my laptop, took the whole evening as its not great spec. Anyway I set off following CBT nuggets and for some reason the phones wouldnt register, spent the whole day trying to figure it out when it turns out that Call Manager would start but then fail after 5 minutes... You can click to start it so I assumed it had and never checked back! I moved CUCM to my i7 PC and it worked fine, guessing the spec was just too low!

    So wasted a lot of time but done a shed load of troubleshooting and learning CUCM to try and figure it out! All sorted now so smooth sailing hopefully...

    As for your DHCP issue, I'm actually using my home router for giving the phones IP's as CUCM is running on my home's subnet, so I manually added the tftp location to them. So I've not tried using CUCM for DHCP yet.

    I'm going on holiday on the 4th July so trying to get it done before then but its a bit of a struggle fitting it all in!
    Reply With Quote Quote  

  7. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #6
    Very nice! Last night I installed CUPS , but I guess I didn't write down my password for cucmadmin account. CUCM has been running for over a week with no issues, but I am going to re-do it over the weekend and try to bring up another CUCM and then link it with CUPS + AD. I would like to try getting CUPS to work with CUCM + XMPP client like Jabber.

    We'll see how it goes!
    Reply With Quote Quote  

  8. Senior Member
    Join Date
    May 2009
    Location
    DMV
    Posts
    2,204

    Certifications
    CCNP, CCNP(V), S+ CCIE V(written)
    #7
    You can restore the cups password if you forgot it.
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
    Reply With Quote Quote  

  9. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #8
    Quote Originally Posted by shodown View Post
    You can restore the cups password if you forgot it.
    Yep, got that done using the pwreset process last night I then started AXL service on CUCM for CUPS integrated, but now getting stuck on CUPS part where it's asking about some kind of IPSec password. Haven't figured this out yet. I currently don't have a full CUCM cluster, just a single node running as publisher/sub.

    " Security Password not valid for the given CUCM IP Address."


    Post Install Setup

    The IPSec Security password is used to secure communication among CUCM and CUP nodes. This password must match the security password as configured on the CUCM Publisher node.
    Reply With Quote Quote  

  10. Senior Member
    Join Date
    May 2009
    Location
    DMV
    Posts
    2,204

    Certifications
    CCNP, CCNP(V), S+ CCIE V(written)
    #9
    you should have a security password that you used when you setup your CUCM. Most of the time it should be the same password as your CUCM. Some places security posture require to you have different passwords.
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
    Reply With Quote Quote  

  11. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #10
    Tried the cucmadmin password and it didn't like it, but it works for the AXL setup.
    Reply With Quote Quote  

  12. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #11
    So, I made a few changes, have CUCM 8.6.2 Pub and another VM for Sub. Also added 8.6.2 CUPS (just one) and installing Unity for kicks, but I won't worry about that for now

    I am not using DNS yet, so it's just based on class C ip range. I have the 7940/7960 and IP Communicator working with CUCM, can make calls to each other etc...but I can't seem to figure out how to make CUPS work so that I can login on VM or physical machine connected on the lab subnet with Cisco Jabber client?

    Has anybody done this and have you followed a guide that you can share that I can check step by step against my config to troubleshoot it?

    I basically would like to have a lab setup where on top of my physical 79xx phones and IP communicator soft-phone I can also use CUPS to login with Jabber client to my CUCM/CUPS server and use it as softphone + IM ?
    Reply With Quote Quote  

  13. Senior Member
    Join Date
    Jul 2010
    Location
    Chicago, Illinois
    Posts
    149

    Certifications
    MCSE:2003 / CCNA/A+
    #12

    Default CUPS & Active Directory

    Better if you tried setting everything up using Active Directory.

    Then AD controls the user accounts

    That way the user name and passwords for users on Jabber authenticate with AD.

    Just a hint.

    BTW if you can't log into CUPS and don't remember the username and password, reinstall or restore from snapshot.

    Personally using a snapshot right after you successfully log in is the best way to "go back" or "system restore".
    That's the best way to "fix CUPS".
    Reply With Quote Quote  

  14. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #13
    Got all the usernames/passwords figured out, I was just not used to the configuration where you have admin user/pwd, then security password on top of user/pass .

    I thought maybe w/o AD it would be easier at first to keep things simple. But as said, I've been thinking that with AD it should make authentication of clients easier in a way as well. I'll spin one up and play with it.
    Reply With Quote Quote  

  15. Senior Member
    Join Date
    Jul 2010
    Location
    Chicago, Illinois
    Posts
    149

    Certifications
    MCSE:2003 / CCNA/A+
    #14
    Quote Originally Posted by JeanM View Post
    Has anybody done this and have you followed a guide that you can share that I can check step by step against my config to troubleshoot it?

    I basically would like to have a lab setup where on top of my physical 79xx phones and IP communicator soft-phone I can also use CUPS to login with Jabber client to my CUCM/CUPS server and use it as softphone + IM ?
    The best recommendation I can give is the Cisco Community Forums. There you can get advise on how to setup Jabber on CUCM/CUPS that works with Microsoft IM and/or other IM's as well as email programs like Outlook. And further video conferencing.
    Reply With Quote Quote  

  16. Member fov001's Avatar
    Join Date
    Aug 2013
    Location
    NYC
    Posts
    32

    Certifications
    CCENT, VCA-Cloud & Datacenter, A+, Net+, HP, Apple, MCITP, MCSA
    #15
    This is a nice setup man! I am wondering if you could help me set this up as well? I already have CUCM running on my ESXi host. I also have x4 3550s but they are not power lined. I am a total newbee at the voice/collaboration track with CCNA level understanding. started a new job as a voice and video design engineer. I will be sent out for training eventually, but I always like to have my own lab at home to take the initiative.

    Let me know!!
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks