+ Reply to Thread
Results 1 to 8 of 8
  1. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #1

    Default Can't initialize Skinny server ?

    Hi,

    Just spent about half an hour searching all over google and can't seem to find a solution to this.

    Router started throwing this message every few seconds. Turning it off and back on (as some posts suggested) did not fix it. Erased the config, rebooted. Manually added config back.... message still comes back.

    Running latest IOS as well.


    Jan 26 09:14:03.977: %SKINNYSERVER-3-NOINIT: Can't initialize Skinny server
    Jan 26 09:14:03.977: %SKINNYSERVER-3-NOINIT: Can't initialize Skinny server
    Jan 26 09:14:13.977: %SKINNYSERVER-3-NOINIT: Can't initialize Skinny server

    So basics -


    CME#sh ver
    Cisco IOS Software, C2600 Software (C2600-ADVENTERPRISEK9-M), Version 12.4(25d), RELEASE SOFTWARE (fc1)
    Technical Support: Support and Documentation - Cisco Systems
    Copyright (c) 1986-2010 by Cisco Systems, Inc.
    Compiled Wed 18-Aug-10 04:49 by prod_rel_team


    ROM: System Bootstrap, Version 12.2(8r) [cmong 8r], RELEASE SOFTWARE (fc1)


    CME uptime is 18 minutes
    System returned to ROM by reload
    System restarted at 01:55:03 PST Mon Jan 26 2015
    System image file is "flash:c2600-adventerprisek9-mz.124-25d.bin"




    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.


    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    Export Compliance Product Report Application


    If you require further assistance please contact us by sending email to
    export@cisco.com.


    Cisco 2620XM (MPC860P) processor (revision 3.1) with 221184K/40960K bytes of memory.
    Processor board ID FOC083529VX
    M860 processor: part number 5, mask 2
    1 FastEthernet interface
    1 Serial interface
    2 Voice FXS interfaces
    32K bytes of NVRAM.
    49152K bytes of processor board System flash (Read/Write)


    Configuration register is 0x2102


    CME#
    CME#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    CME(config)#
    CME(config)#no scc
    Jan 26 09:16:13.978: %SKINNYSERVER-3-NOINIT: Can't initialize Skinny server
    Jan 26 09:16:13.978: %SKINNYSERVER-3-NOINIT: Can't initialize Skinny serverp
    SCCP operational state is down already.
    CME(config)#
    CME(config)#














    CME#sh run
    Building configuration...


    Current configuration : 1895 bytes
    !
    ! Last configuration change at 02:16:38 PST Mon Jan 26 2015
    ! NVRAM config last updated at 02:06:01 PST Mon Jan 26 2015
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname CME
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 15
    clock timezone PST -7
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !
    !
    !
    ip name-server 192.168.1.1
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    !
    !
    !
    !
    !
    !
    voice service voip
    allow-connections sip to sip
    sip
    !
    !
    !
    !
    !
    !
    !
    --More--
    Jan 26 09:17:33.979: %SKINNYSERVER-3-NOINIT: Can't initialize Skinny server
    Jan 26 09:17:33.979: %SKINNYSERVER-3-NOINIT: Can't initialize Ski! r
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    description TO EDGE
    ip address 192.168.1.99 255.255.255.0
    duplex auto
    speed auto
    !
    interface Serial0/0
    no ip address
    shutdown
    no fair-queue
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    !
    !
    ip http server
    no ip http secure-server
    no ip nat service skinny tcp port 2000
    !
    !
    !
    !
    control-plane
    !
    !
    !
    voice-port 1/1/0
    station-id name A
    station-id number 7701
    caller-id enable
    !
    voice-port 1/1/1
    station-id name B
    station-id number 7702
    caller-id enable
    !
    !
    !
    !
    !
    dial-peer voice 1 voip
    description TO call other CME over WAN
    destination-pattern 20..
    session protocol sipv2
    session target ipv4:10.10.1.1
    dtmf-relay h245-alphanumeric
    codec g711alaw
    no vad
    !
    dial-peer voice 10 pots
    destination-pattern 7701
    port 1/1/0
    !
    dial-peer voice 11 pots
    destination-pattern 7702
    port 1/1/1
    !
    !
    !
    !
    telephony-service
    max-ephones 4
    max-dn 5
    ip source-address 192.168.1.99 port 5060
    auto assign 1 to 1
    create cnf-files version-stamp 7960 Jan 26 2015 02:05:52
    max-conferences 4 gain -6
    !
    !
    !
    ntp clock-period 17179869
    ntp server 66.228.42.59
    !
    end
    CME#
    Reply With Quote Quote  

  2. SS -->
  3. Network Engineer Hondabuff's Avatar
    Join Date
    Aug 2012
    Location
    USA
    Posts
    637

    Certifications
    CCNA:S, CCNA, CCENT, CCNP:R&S,MECP, A+, Network+, Security+, Network Security Diploma
    #2
    Quote Originally Posted by JeanM View Post
    Hi,

    Just spent about half an hour searching all over google and can't seem to find a solution to this.

    Router started throwing this message every few seconds. Turning it off and back on (as some posts suggested) did not fix it. Erased the config, rebooted. Manually added config back.... message still comes back.

    Running latest IOS as well.


    Jan 26 09:14:03.977: %SKINNYSERVER-3-NOINIT: Can't initialize Skinny server
    Jan 26 09:14:03.977: %SKINNYSERVER-3-NOINIT: Can't initialize Skinny server
    Jan 26 09:14:13.977: %SKINNYSERVER-3-NOINIT: Can't initialize Skinny server

    So basics -


    CME#sh ver
    Cisco IOS Software, C2600 Software (C2600-ADVENTERPRISEK9-M), Version 12.4(25d), RELEASE SOFTWARE (fc1)
    Technical Support: Support and Documentation - Cisco Systems
    Copyright (c) 1986-2010 by Cisco Systems, Inc.
    Compiled Wed 18-Aug-10 04:49 by prod_rel_team


    ROM: System Bootstrap, Version 12.2(8r) [cmong 8r], RELEASE SOFTWARE (fc1)


    CME uptime is 18 minutes
    System returned to ROM by reload
    System restarted at 01:55:03 PST Mon Jan 26 2015
    System image file is "flash:c2600-adventerprisek9-mz.124-25d.bin"




    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.


    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    Export Compliance Product Report Application


    If you require further assistance please contact us by sending email to
    export@cisco.com.


    Cisco 2620XM (MPC860P) processor (revision 3.1) with 221184K/40960K bytes of memory.
    Processor board ID FOC083529VX
    M860 processor: part number 5, mask 2
    1 FastEthernet interface
    1 Serial interface
    2 Voice FXS interfaces
    32K bytes of NVRAM.
    49152K bytes of processor board System flash (Read/Write)


    Configuration register is 0x2102


    CME#
    CME#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    CME(config)#
    CME(config)#no scc
    Jan 26 09:16:13.978: %SKINNYSERVER-3-NOINIT: Can't initialize Skinny server
    Jan 26 09:16:13.978: %SKINNYSERVER-3-NOINIT: Can't initialize Skinny serverp
    SCCP operational state is down already.
    CME(config)#
    CME(config)#














    CME#sh run
    Building configuration...


    Current configuration : 1895 bytes
    !
    ! Last configuration change at 02:16:38 PST Mon Jan 26 2015
    ! NVRAM config last updated at 02:06:01 PST Mon Jan 26 2015
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname CME
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 15
    clock timezone PST -7
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !
    !
    !
    ip name-server 192.168.1.1
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    !
    !
    !
    !
    !
    !
    voice service voip
    allow-connections sip to sip
    sip
    !
    !
    !
    !
    !
    !
    !
    --More--
    Jan 26 09:17:33.979: %SKINNYSERVER-3-NOINIT: Can't initialize Skinny server
    Jan 26 09:17:33.979: %SKINNYSERVER-3-NOINIT: Can't initialize Ski! r
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    description TO EDGE
    ip address 192.168.1.99 255.255.255.0
    duplex auto
    speed auto
    !
    interface Serial0/0
    no ip address
    shutdown
    no fair-queue
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    !
    !
    ip http server
    no ip http secure-server
    no ip nat service skinny tcp port 2000
    !
    !
    !
    !
    control-plane
    !
    !
    !
    voice-port 1/1/0
    station-id name A
    station-id number 7701
    caller-id enable
    !
    voice-port 1/1/1
    station-id name B
    station-id number 7702
    caller-id enable
    !
    !
    !
    !
    !
    dial-peer voice 1 voip
    description TO call other CME over WAN
    destination-pattern 20..
    session protocol sipv2
    session target ipv4:10.10.1.1
    dtmf-relay h245-alphanumeric
    codec g711alaw
    no vad
    !
    dial-peer voice 10 pots
    destination-pattern 7701
    port 1/1/0
    !
    dial-peer voice 11 pots
    destination-pattern 7702
    port 1/1/1
    !
    !
    !
    !
    telephony-service
    max-ephones 4
    max-dn 5
    ip source-address 192.168.1.99 port 5060
    auto assign 1 to 1
    create cnf-files version-stamp 7960 Jan 26 2015 02:05:52
    max-conferences 4 gain -6
    !
    !
    !
    ntp clock-period 17179869
    ntp server 66.228.42.59
    !
    end
    CME#
    I didn't see in your config where your phones are directed to the tftp server?
    Reply With Quote Quote  

  4. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #3
    Right, because they are not This is a voice gateway for fxs module and analog phones on the port 1/1/0 and 1/1/1.

    I don't get why this skinny server message comes up?
    What prompts this?
    Reply With Quote Quote  

  5. Network Engineer Hondabuff's Avatar
    Join Date
    Aug 2012
    Location
    USA
    Posts
    637

    Certifications
    CCNA:S, CCNA, CCENT, CCNP:R&S,MECP, A+, Network+, Security+, Network Security Diploma
    #4
    Found this deep in a Cisco forum I used to visit when I was doing Voice.

    The error message is
    because the system runs out of sockets.
    Bug
    CSCeh67334 has already
    been filed for this issue but since this message is a symptom of serveral causes, we have no IOS recommendation but it should be fixed in 12.4(9)T or newer.
    There are few scenarios where you will see this message.
    (1) You're trying to register too many ephones. Please do "show ephone
    registered" and find out how many have registered successfully. Please also do "show ip socket detail" to correlate the registered ephones with sockets. Please ensure you are only trying to register no more then 240 ephones.
    (2) We might have a socket leak. The "show ip socket detail" command should tell you how many sockets are opened. Again, compare it w/ the show ephone registered.
    (3) This message has appeared when someone continues to repeatedly do "no telephony service and telephony service" that removes the skinny server and reinitializes it.
    (4) Insufficient RAM on the router (How much memory does the router have install)?
    This problem is caused by memory shortage in the ISR once you have all
    the possible services configured. If the current memory installed on the
    ISR is 256MB DRAM, will be OK for now even though will be better to upgarde to 512 MB
    DRAM since they are alot of services.
    Reply With Quote Quote  

  6. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #5
    Yep, saw that too but I am on 12.4(25d) . I think that bug was specific to 3845 serious router after configuring 240 ephones.. and I am on 2620xm with no ephones...

    "After configuring 240 ephones on a 3845, when using callgen to register all ephones, error
    message"

    1. no ephones
    2. none
    3. negative, shows after a cold reboot or new config.
    4. 48flash/256mb dram.


    Last edited by JeanM; 01-27-2015 at 12:43 AM.
    Reply With Quote Quote  

  7. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #6
    Anyone?
    Reply With Quote Quote  

  8. Senior Member
    Join Date
    Jul 2010
    Location
    Chicago, Illinois
    Posts
    149

    Certifications
    MCSE:2003 / CCNA/A+
    #7

    Default Analog FXS/FXO phones?? or IP phones

    and so I'll ask: why do you have this: no ip nat service skinny tcp port 2000

    is that to try and turn off the SCCP [skinny] server?

    The Telephony-Service is SCCP [skinny] so it will always try to start on load.

    maybe your flash/RAM memory is getting flaky
    Last edited by Jollycork; 02-02-2015 at 03:08 AM.
    Reply With Quote Quote  

  9. Senior Member
    Join Date
    Mar 2014
    Location
    Atlanta, GA
    Posts
    170

    Certifications
    CCNP Voice, CCNA R/S,
    #8
    Jean, where we were labbing, I had that error come up as soon as I changed the port in ip source address to 5060 from the default 2000. The error was gone when I changed it back to 2000.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks