+ Reply to Thread
Results 1 to 6 of 6
  1. Member
    Join Date
    Jul 2012
    Posts
    86
    #1

    Default Can't register phones with CUCM

    I have a snow day from work so I'm taking the time to lab things up. I have 7961g's and cannot seem to register these damn phones. These phones do register with CME when configured. I disabled the telephony service in the voice gateway to avoid any conflict. I originally tried the manual route by adding the phone's mac address in cucm but nothing it doesn't display the ip address it just shows the status as unknown. So I figured I take the easy route and enabled the auto-registration in the cucm group and in the pub and sub..still no response. I made sure the tftp and call manager service was activated. I checked the status message in the phones settings and it says SEP<MAC ADDRESS>.cn.xml timeout.

    On the gateway router I copied the sep.xml file from the cucm onto the router and issued the cmd
    #more sep<mac>.cnf.xml
    and it had all of the tftp settings, cucm group settings, dp settings. So CUCM has generated the appropriate xml file for the phone. I thought it might me a firmware issues so loaded 9.2.1 on the router and upgraded the phones to match the version running on cucm, the upgrade made no difference.

    The phone is getting the dhcp ip address from the router. It shows it in the device settings, under network config

    This is the router dhcp config
    ip dhcp excluded-address 20.1.1.1 20.1.1.10
    ip dhcp pool PHONES
    network 20.1.1.0 255.255.255.0
    default-router 20.1.1.1
    option 150 ip 192.168.15.10 <-- this is the PUB ip address

    If anyone says the pub is in a different subnet that is why I can't communicate I have router on stick configured between the switch and router for the Voice vlan 20 20.1.1.0 and Data vlan 10 192.168.15.0. I can ping both sides.

    I've wasted to much time on this any help would be greatly appreciated. This just aggravates me because I figure it would be the most basic thing to do. I can't really continue until I have phones to test cucm with. I wonder if theres a way to run a debug on cucm like on cme debug tftp events so I could know whats going on..
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member
    Join Date
    Jul 2010
    Location
    Chicago, Illinois
    Posts
    149

    Certifications
    MCSE:2003 / CCNA/A+
    #2

    Default try static network addressing on the phone

    just to see if that will work. are these used phones that you've never connected to that CUCM?
    Reply With Quote Quote  

  4. Member
    Join Date
    Jul 2012
    Posts
    86
    #3
    yes correct these were ebay phones. I removed all configs on the phone network, user, ctl files, reset to factory default loaded the firmware that way. I'll statically applying it on the phones but with dhcp these phones are getting all of the cm address, tftp server, ip addresses.

    Im having trouble confirming this since in the book it states to set tftp to pub, sub. I looked on the cisco support page forum and they say they normally do it sub, pub.
    Reply With Quote Quote  

  5. Senior Member
    Join Date
    Jul 2010
    Location
    Chicago, Illinois
    Posts
    149

    Certifications
    MCSE:2003 / CCNA/A+
    #4
    Quote Originally Posted by techiie View Post
    yes correct these were ebay phones. I removed all configs on the phone network, user, ctl files, reset to factory default loaded the firmware that way. I'll statically applying it on the phones but with dhcp these phones are getting all of the cm address, tftp server, ip addresses.

    Im having trouble confirming this since in the book it states to set tftp to pub, sub. I looked on the cisco support page forum and they say they normally do it sub, pub.
    I do pub sub... and I do static not DHCP because I only have a few phones. I do know that if my CUCM gateway isn't up before I spin up CUCM on VM, I have trouble with phones finding CUCM...like never.... I have to shut down CUCM, make sure the gateway router is up, then spin up CUCM. With my pub sub TFTP, it does take several minutes for them to register. irritating but it they eventually register.

    I also don't do auto register the books I read recommended to turn off auto register on CUCM, basically negating rogue phones. I actually make phone "accounts" in CUCM with their MAC addresses.
    Reply With Quote Quote  

  6. Member
    Join Date
    Jul 2012
    Posts
    86
    #5
    Yes I know that the books do not recommend auto register but I flipped it on because manually adding it wasn't working so I thought it should be easier to detect the auto way. But yes your comment about the voice gateway being up was actually the issue. I found out yesterday when looking at the saved network docs for my home topology. I originally figured I could cheat it and not have the router on and configure my 3560 as a layer 3 switch and assign the default gateway to a created svi and have the switch running dhcp.

    I did it this way just so I can play with call manager without having the router on making noise in the background. After I changed to the ip address on the router to reflect the configured default gateway the phones automatically updated the firmware through cucm then registered.
    Reply With Quote Quote  

  7. Senior Member
    Join Date
    Jul 2010
    Location
    Chicago, Illinois
    Posts
    149

    Certifications
    MCSE:2003 / CCNA/A+
    #6

    Default cool...

    I was having trouble with phones finding CUCM and believed it was the phone itself.

    when I checked the Redhat server gateway config running CUCM, found it didn't find the gateway router. After I fixed that,
    phones found CUCM.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks