+ Reply to Thread
Results 1 to 4 of 4
  1. Junior Member
    Join Date
    Oct 2008
    Posts
    25

    Certifications
    CCENT, MCTS 70-640
    #1

    Default can't get address from DHCP...

    I have a UC520 and have plugged a 7960 into fa0/1/0 but it won't get an address from DHCP. Here's what I have:

    UC520#sh run int fa0/1/0
    Building configuration...

    Current configuration : 110 bytes
    !
    interface FastEthernet0/1/0
    switchport access vlan 2
    switchport voice vlan 3
    spanning-tree portfast
    end

    UC520#sh run | se dhcp
    ip dhcp excluded-address 10.10.3.0 10.10.3.20
    ip dhcp pool VOICE
    network 10.10.3.0 255.255.255.128
    default-router 10.10.3.1
    dns-server 10.10.3.1
    option 150 ip 10.10.3.2

    UC520#sh run int fa0/0.3
    Building configuration...

    Current configuration : 105 bytes
    !
    interface FastEthernet0/0.3
    encapsulation dot1Q 3 native
    ip address 10.10.3.2 255.255.255.128
    end

    I know the DHCP server is working because I have a 2960 connected to the WAN port of the UC520 and any phone plugged into the 2960 gets an IP address fine. Any ideas?
    Reply With Quote Quote  

  2. SS -->
  3. Member Fish!'s Avatar
    Join Date
    Mar 2009
    Location
    Ohio
    Posts
    42

    Certifications
    CCNA, CCNA:Security, CCNA:Wireless, CCNA:Voice, BCMSN
    #2
    This ought to take care of it:


    no interface FastEthernet0/0.3

    interface vlan3
    ip address 10.10.3.2 255.255.255.128
    no shut

    interface FastEthernet0/1/0
    switchport mode access



    IP address 10.10.3.2 needs to be on interface vlan3 not on a subinterface on interface FastEthernet0/0. Also I think you need 'switchport mode access' on the switch port - otherwise it defaults to switchport mode dynamic desirable - a trunk - and the access+voice commands don't take effect until the mode is access.

    EDIT: Oh, wait, I just noticed you have a switch hanging off of int f0/0.

    OK, move the 2960 switch to one of the switch ports on the UC520 and create a trunk.

    -OR-

    Leave the 2960 on f0/0 and do IRB.


    bridging irb
    bridge 1 route ip

    int fa0/0.3
    bridge-group 1
    no ip address

    int vlan3
    bridge-group 1
    no ip address

    int bvi1
    ip address 10.10.3.2 255.255.255.128

    Much more yucky, but it works.
    Last edited by Fish!; 03-31-2009 at 12:27 AM.
    Reply With Quote Quote  

  4. Junior Member
    Join Date
    Oct 2008
    Posts
    25

    Certifications
    CCENT, MCTS 70-640
    #3
    I don't care what they say about you. You're a good man! I moved the trunk over to fa0/1/8(the "expansion" port) and removed fa0/0.3... worked like a charm. Thanks a lot. I don't even know what IRB is so I won't even attempt that method.
    Reply With Quote Quote  

  5. APA
    APA is offline
    Senior Member APA's Avatar
    Join Date
    Jun 2006
    Location
    Sydney, Australia
    Posts
    956

    Certifications
    CompTIA, Microsoft, Juniper & Cisco (Check Signature)
    #4
    your original config would have worked.....

    should have encapsulation dot1q 3 without the native command on the fa port....

    You obviously had that port hooked up to the 2960 as a trunk right??? So the native vlans would have been matching meaning all the 3 traffic would be untagged...... remember the native vlan traffic is always untagged with dot1q unless you tell it to be tagged...

    Hence plugging a phone into the 2960 was working....
    ------------------------------------------------------------
    CCNA | CCNA:Security | CCNP | CCIP
    JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
    JNCIS:SP | JNCIP:SP
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks