+ Reply to Thread
Results 1 to 24 of 24
  1. Member
    Join Date
    Feb 2010
    Location
    Ireland
    Posts
    44
    #1

    Default Directory & Moh problem

    I have two issues at the moment. I cannot get the directory list to appear when I hit the directory button on the set. All I get are the first 4

    Missed Calls
    Received Calls
    Placed Calls
    Intercom History

    No "Local Directory" listing.

    The other issue is music on hold. It will work going out fxs interfaces but not with the ip sets? If I make a call between two IP sets on the same lan, the moh doesn't play. I don't even get the 3 beeps if I configure the moh.



    Here are my configs

    Switch
    Code:
    SW_3550#sh run
    Building configuration...
    
    Current configuration : 4518 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname SW_3550
    !
    enable secret 5 $1$fOAR$W7949NkZP9Vvub1kyx7Gu1
    !
    ip subnet-zero
    !
    no ip domain-lookup
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    !
    interface FastEthernet0/1
     description 2611XM fa0/0
     switchport access vlan 30
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/2
     description 2621 R2 fa0/0
     switchport access vlan 30
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/3
     description 2620 R3 fa0/0
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/4
     description 1841 fa0/0
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/5
     description 3745 fa0/0
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/6
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/7
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/8
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/9
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/10
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/11
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/12
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/13
     description 7970G
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/14
     description Desktop PC
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/15
     description 7960G
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/16
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/17
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/18
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/19
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/20
     switchport access vlan 10
     switchport trunk encapsulation dot1q
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/21
     switchport access vlan 10
     switchport trunk encapsulation dot1q
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/22
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/23
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 5
     no ip address
     spanning-tree portfast
    !
    interface FastEthernet0/24
     switchport trunk encapsulation dot1q
     switchport mode trunk
     no ip address
    !
    interface GigabitEthernet0/1
     switchport mode dynamic desirable
     no ip address
    !
    interface GigabitEthernet0/2
     switchport mode dynamic desirable
     no ip address
    !
    interface Vlan1
     ip address 192.168.3.250 255.255.255.0
    !
    interface Vlan5
     ip address 192.168.1.250 255.255.255.0
    !
    interface Vlan10
     ip address 192.168.0.250 255.255.255.0
    !
    ip classless
    ip http server
    !
    !
    alias exec s sh ip int brief
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
    line vty 0 4
     exec-timeout 0 0
     password cisco
     logging synchronous
     login
    line vty 5 15
     login
    !
    end
    CME Router

    Code:
    R3745#sh run
    Building configuration...
    
    Current configuration : 10259 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R3745
    !
    boot-start-marker
    boot system flash slot0:c3745-adventerprisek9_ivs-mz.124-15.T8.bin
    boot-end-marker
    !
    enable secret 5 $1$Y65d$F8XfOBZGxIYx5uNsCzC43/
    !
    no aaa new-model
    no network-clock-participate wic 1
    ip cef
    !
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.0.199
    ip dhcp excluded-address 192.168.0.250
    ip dhcp excluded-address 192.168.1.250
    ip dhcp excluded-address 192.168.1.199
    ip dhcp excluded-address 192.168.0.71
    ip dhcp excluded-address 192.168.0.200
    ip dhcp excluded-address 192.168.1.200
    !
    ip dhcp pool VOICE
       network 192.168.1.0 255.255.255.0
       option 150 ip 192.168.1.199
       default-router 192.168.1.199
    !
    ip dhcp pool DATA
       network 192.168.0.0 255.255.255.0
       option 150 ip 192.168.1.199
       default-router 192.168.0.199
    !
    !
    no ip domain lookup
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    crypto pki trustpoint TP-self-signed-43410932
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-43410932
     revocation-check none
     rsakeypair TP-self-signed-43410932
    !
    !
    crypto pki certificate chain TP-self-signed-43410932
     certificate self-signed 01
      30820239 308201A2 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      2F312D30 2B060355 04031324 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 34333431 30393332 301E170D 31303035 30313231 31343533
      5A170D32 30303130 31303030 3030305A 302F312D 302B0603 55040313 24494F53
      2D53656C 662D5369 676E6564 2D436572 74696669 63617465 2D343334 31303933
      3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 8100C614
      A19EE6EC 5003A8E9 5FEDF87E 80C8F645 3617E931 50FF7154 D8BD07AA 94BCABE5
      662A60A3 69831685 136DCC76 ECF96C48 114560BB 64F88D05 4DD7B030 6299FFB4
      2DD36B3F BDFDBA2C 17B1FF93 1E07D291 CEE78C51 6671229A BD25A498 177AB149
      250D4D08 BBFC6763 0AAF4D12 B069E6AE AB0763E9 2879117E 049B1D40 42510203
      010001A3 65306330 0F060355 1D130101 FF040530 030101FF 30100603 551D1104
      09300782 05523337 3435301F 0603551D 23041830 168014F9 C9D8358A A46071A5
      CF508989 69732CE1 F675C430 1D060355 1D0E0416 0414F9C9 D8358AA4 6071A5CF
      50898969 732CE1F6 75C4300D 06092A86 4886F70D 01010405 00038181 00434895
      F138F2AF 5F67A7F7 1D33232F 06153997 3355F625 0BBA8413 E520C59A 6D753542
      ED131237 D368E900 0A577E25 66771582 6A5560F3 E2F3240B 0447BE32 D4244F90
      F984988C 0C423B86 CACE0E3B 201E44B2 2844B51B E902387E 997C77A1 C97AE527
      474C7AEE D5D9ED98 4473F4CF BE90575C A875B97B DE174201 FF8C5A2A 0E
            quit
    !
    !
    archive
     log config
      hidekeys
    !
    !
    !
    !
    controller E1 0/1
    !
    !
    !
    !
    !
    interface FastEthernet0/0
     no ip address
     duplex auto
     speed auto
    !
    interface FastEthernet0/0.5
     encapsulation dot1Q 5
     ip address 192.168.1.199 255.255.255.0
    !
    interface FastEthernet0/0.10
     encapsulation dot1Q 10
     ip address 192.168.0.199 255.255.255.0
    !
    interface Serial0/0
     no ip address
     shutdown
     clock rate 2000000
    !
    interface FastEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface Integrated-Service-Engine3/0
     ip address 192.168.2.5 255.255.255.0
     service-module ip address 192.168.2.1 255.255.255.0
     service-module ip default-gateway 192.168.2.5
     no keepalive
    !
    router rip
     version 2
     network 192.168.0.0
     network 192.168.1.0
     network 192.168.2.0
    !
    ip forward-protocol nd
    ip route 192.168.2.0 255.255.255.0 Integrated-Service-Engine3/0
    !
    !
    ip http server
    ip http secure-server
    ip http path flash:/gui
    !
    !
    !
    !
    !
    !
    tftp-server flash:/phone/P00308000500.bin alias P00308000500.bin
    tftp-server flash:/phone/P00308000500.loads alias P00308000500..loads
    tftp-server flash:/phone/P00308000500.sb2 alias P00308000500.sb2
    tftp-server flash:/phone/P00308000500.sbn alias P00308000500.sbn
    tftp-server flash:/music-on-hold.au alias music-on-hold.au
    tftp-server flash:/phone/P00308000500.loads alias P00308000500.loads
    tftp-server slot0:police.wav
    tftp-server flash:/Desktops/320x212x12/CampusNight.png
    tftp-server flash:/Desktops/320x212x12/CiscoFountain.png
    tftp-server flash:/Desktops/320x212x12/List.xml
    tftp-server flash:/Desktops/320x212x12/MorroRock.png
    tftp-server flash:/Desktops/320x212x12/NantucketFlowers.png
    tftp-server flash:/Desktops/320x212x12/TN-CampusNight.png
    tftp-server flash:/Desktops/320x212x12/TN-CiscoFountain.png
    tftp-server flash:/Desktops/320x212x12/TN-Fountain.png
    tftp-server flash:/Desktops/320x212x12/TN-MorroRock.png
    tftp-server flash:/Desktops/320x212x12/TN-NantucketFlowers.png
    tftp-server flash:/Desktops/320x212x12/Fountain.png
    tftp-server flash:/phone/7970-7971/apps70.8-3-2-27.sbn alias apps70.8-3-2-27.sbn
    tftp-server flash:/phone/7970-7971/cnu70.8-3-2-27.sbn alias cnu70.8-3-2-27.sbn
    tftp-server flash:/phone/7970-7971/cvm70sccp.8-3-2-27.sbn alias cvm70sccp.8-3-2-27.sbn
    tftp-server flash:/phone/7970-7971/dsp70.8-3-2-27.sbn alias dsp70.8-3-2-27.sbn
    tftp-server flash:/phone/7970-7971/jar70sccp.8-3-2-27.sbn alias jar70sccp.8-3-2-27.sbn
    tftp-server flash:/phone/7970-7971/SCCP70.8-3-3S.loads alias SCCP70.8-3-3S.loads
    tftp-server flash:/phone/7970-7971/term70.default.loads alias term70.default.loads
    tftp-server flash:/phone/7970-7971/term71.default.loads alias term71.default.loads
    tftp-server flash:Desktops/320x212x12/CampusNight.png
    tftp-server flash:Desktops/320x212x12/CiscoFountain.png
    tftp-server flash:Desktops/320x212x12/List.xml
    tftp-server flash:Desktops/320x212x12/MorroRock.png
    tftp-server flash:Desktops/320x212x12/NantucketFlowers.png
    tftp-server flash:Desktops/320x212x12/TN-CampusNight.png
    tftp-server flash:Desktops/320x212x12/TN-CiscoFountain.png
    tftp-server flash:Desktops/320x212x12/TN-Fountain.png
    tftp-server flash:Desktops/320x212x12/TN-MorroRock.png
    tftp-server flash:Desktops/320x212x12/TN-NantucketFlowers.png
    tftp-server flash:Desktops/320x212x12/Fountain.png
    tftp-server flash:ringtones/Analog1.raw
    tftp-server flash:ringtones/Analog2.raw
    tftp-server flash:ringtones/AreYouThere.raw
    tftp-server flash:ringtones/AreYouThereF.raw
    tftp-server flash:ringtones/Bass.raw
    tftp-server flash:ringtones/CallBack.raw
    tftp-server flash:ringtones/Chime.raw
    tftp-server flash:ringtones/Classic1.raw
    tftp-server flash:ringtones/Classic2.raw
    tftp-server flash:ringtones/ClockShop.raw
    tftp-server flash:ringtones/DistinctiveRingList.xml
    tftp-server flash:ringtones/Drums1.raw
    tftp-server flash:ringtones/Drums2.raw
    tftp-server flash:ringtones/FilmScore.raw
    tftp-server flash:ringtones/HarpSynth.raw
    tftp-server flash:ringtones/Jamaica.raw
    tftp-server flash:ringtones/KotoEffect.raw
    tftp-server flash:ringtones/MusicBox.raw
    tftp-server flash:ringtones/Piano1.raw
    tftp-server flash:ringtones/Piano2.raw
    tftp-server flash:ringtones/Pop.raw
    tftp-server flash:ringtones/Pulse1.raw
    tftp-server flash:ringtones/Ring1.raw
    tftp-server flash:ringtones/Ring2.raw
    tftp-server flash:ringtones/Ring3.raw
    tftp-server flash:ringtones/Ring4.raw
    tftp-server flash:ringtones/Ring5.raw
    tftp-server flash:ringtones/Ring6.raw
    tftp-server flash:ringtones/Ring7.raw
    tftp-server flash:ringtones/RingList.xml
    tftp-server flash:ringtones/Sax1.raw
    tftp-server flash:ringtones/Sax2.raw
    tftp-server flash:ringtones/Vibe.raw
    tftp-server slot0:cue-installer.nme.3.2.4 alias cue-installer.nme.3.2.4
    tftp-server slot0:cue-vm-en_US-langpack.nme.3.2.4.prt1 alias cue-vm-en_US-langpack.nme.3.2.4.prt1
    tftp-server slot0:cue-vm-full-k9.nme.3.2.4.prt1
    tftp-server slot0:cue-vm-installer-k9.nme.3.2.4.prt1
    tftp-server slot0:cue-vm-k9.nme.3.2.4.pkg
    tftp-server slot0:cue-vm-langpack.nme.3.2.4.pkg
    tftp-server slot0:cue-vm-license_8port_ivr_3.2.4.pkg
    tftp-server slot0:cue-vm-license_250mbx_cme_3.2.4.pkg
    tftp-server flash:Desktops/320x212x12/TN-RR.png
    tftp-server flash:Desktops/320x212x12/RR.png
    !
    control-plane
    !
    !
    !
    voice-port 2/0/0
    !
    voice-port 2/0/1
    !
    !
    !
    !
    !
    dial-peer voice 700 voip
     description CUE
     destination-pattern 70.
     session protocol sipv2
     session target ipv4:192.168.2.1
     dtmf-relay sip-notify
     codec g711ulaw
     no vad
    !
    !
    !
    !
    gatekeeper
     shutdown
    !
    !
    telephony-service
     max-ephones 24
     max-dn 50
     ip source-address 192.160.1.199 port 2000
     system message Rugrat City
     url services http://192.168.2.1/voiceview/common/login.do
     url authentication http://192.168.2.1/voiceview/authentication/authenticate.do
     voicemail 700
     max-conferences 8 gain -6
     moh music-on-hold.au
     multicast moh 239.1.1.55 port 2136
     web admin system name admin password cisco
     dn-webedit
     time-webedit
     transfer-system full-consult
     directory entry 2 44556666 name FourStarPizza
    !
    !
    ephone-template  1
    !
    !
    ephone-dn  1  dual-line
     number 101
     name 7960 Phone
    !
    !
    ephone-dn  2  dual-line
     number 102
     name Laptop Softphone
    !
    !
    ephone-dn  3
     number A100...
     mwi on
    !
    !
    ephone-dn  4
     number A101...
     mwi off
    !
    !
    ephone-dn  5
     number 200
     paging ip 239.1.1.6 port 2222
    !
    !
    ephone-dn  6  dual-line
     number 103
     name 7970G Phone
    !
    !
    ephone-dn  7
     number A300
     intercom A301 label "Intercom to 103"
    !
    !
    ephone-dn  8
     number A301
     intercom A300 label "Intercom to 101"
    !
    !
    ephone-dn  9
     number 300
     park-slot timeout 60 limit 2 recall
    !
    !
    ephone-dn  10
     number 500
    !
    !
    ephone-dn  11
     number 500
    !
    !
    ephone-dn  12
     number 500
    !
    !
    ephone-dn  13
     number 500
    !
    !
    ephone-dn  14
     number 500
    !
    !
    ephone-dn  16  dual-line
     number 104
    !
    !
    ephone-dn  17
     number 202
    !
    !
    ephone-dn  18
     number 201
    !
    !
    ephone-dn  19
     number 204
    !
    !
    ephone-dn  20
     number 203
    !
    !
    ephone  1
     device-security-mode none
     description 7960 Phone
     mac-address 0003.6B40.8DC7
     button  1:1 2:18 3:7 4o10,11,12,13,14
    !
    !
    !
    ephone  2
     device-security-mode none
     description Laptop Softphone
     mac-address 0002.B38C.7232
     button  1:2 2:17 3:9 4o10,11,12,13,14
    !
    !
    !
    ephone  3
     device-security-mode none
     description 7970G phone
     mac-address 0014.6948.1DBF
     button  1:6 2:20 3:8 4o10,11,12,13,14
     button  8:9
    !
    !
    !
    ephone  4
     device-security-mode none
     description Desktop PC
     mac-address 0050.8D9D.875F
     button  1:16 2:19 4o10,11,12,13,14
    !
    !
    !
    ephone  6
     device-security-mode none
    !
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
     speed 115200
    line 97
     no activation-character
     no exec
     transport preferred none
     transport input all
     transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
    line aux 0
    line vty 0 4
     exec-timeout 0 0
     privilege level 15
     password cisco
     login
     terminal-type monitor
    !
    ntp server 82.68.206.125
    !
    end
    Any ideas?
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member chmorin's Avatar
    Join Date
    Feb 2010
    Location
    Texas
    Posts
    1,443

    Certifications
    CCNP:Voice, CCNA:V(IIUC), CCNA, CCENT, Security +, Network +, A+,CIW
    #2
    Concerning MOH, you need to configure multicasting on the network. I forget how off the top of my head I'll have to look it up. remove the multicast string and moh should work.

    As far as directories goes, does this happen on all of the phones?
    Reply With Quote Quote  

  4. Member
    Join Date
    Feb 2010
    Location
    Ireland
    Posts
    44
    #3
    Tried with Multicast off but it brings back the 3 beeps when on hold. Weird thing is, if I park a call, the music on hold plays through (still only using ip phones). Not sure whats going on there.

    With the Directories, it the same on all phones
    Reply With Quote Quote  

  5. Senior Member
    Join Date
    Apr 2008
    Location
    Tampa, Fl
    Posts
    1,097

    Certifications
    A Few....
    #4
    Quote Originally Posted by Fatbunny View Post
    Tried with Multicast off but it brings back the 3 beeps when on hold. Weird thing is, if I park a call, the music on hold plays through (still only using ip phones). Not sure whats going on there.

    With the Directories, it the same on all phones
    Fatbunny,

    I am having the same issue. Are you using CME 4.1? That's the version I am using... I'm wondering if this was fixed in version 4.3. I'm currently reading the CCNA Voice Official Exam Cert Guide and I believe they are using 4.3. Can someone confirm this? Thanks.

    The local directory was a problem for me once before when I didn't have http enabled. You appear to have that covered. Is it all phones that's having the problem?
    Reply With Quote Quote  

  6. Member
    Join Date
    Feb 2010
    Location
    Ireland
    Posts
    44
    #5
    a "Show Telephony-Service" shows that its 4.1 although cisco's feature navigator only shows Call Manager Express 4.0(3) for that image. I think that will confirm the moh issue with 4.1. If your local directory is working mine should too, will have to look in to that more. What platform/image are you running ?
    Reply With Quote Quote  

  7. Senior Member
    Join Date
    Apr 2008
    Location
    Tampa, Fl
    Posts
    1,097

    Certifications
    A Few....
    #6
    Quote Originally Posted by Fatbunny View Post
    a "Show Telephony-Service" shows that its 4.1 although cisco's feature navigator only shows Call Manager Express 4.0(3) for that image. I think that will confirm the moh issue with 4.1. If your local directory is working mine should too, will have to look in to that more. What platform/image are you running ?
    I'm running CME 4.1 on (2) 1760s and a 2621XM, and neither of them will play music on hold unless I park a call. If I configure the moh for unicast or multicast, I still will not get the moh until the calls are parked. I'm guessing its a CME 4.1 limitation. I'm going to check the cisco docs shortly.

    -Peanut
    Reply With Quote Quote  

  8. Senior Member
    Join Date
    Jun 2009
    Location
    Gosford, Australia
    Posts
    567

    Certifications
    CCNA, CCDA, CCNA:Voice(IIUC), CCNP:Voice
    #7
    I had the same MOH problem on my 1760 running CME 4.1. I had to run MOH in multicast to get it to work, and reload the router. Try;

    Code:
    moh flash:music-on-hold.au
    multicast moh 239.1.1.55 port 2100
    You'll also notice that the activity LEDs on the router and switch are very active after as well.
    Reply With Quote Quote  

  9. Senior Member
    Join Date
    Apr 2008
    Location
    Tampa, Fl
    Posts
    1,097

    Certifications
    A Few....
    #8
    Quote Originally Posted by azaghul View Post
    I had the same MOH problem on my 1760 running CME 4.1. I had to run MOH in multicast to get it to work, and reload the router. Try;

    Code:
    moh flash:music-on-hold.au
    multicast moh 239.1.1.55 port 2100
    You'll also notice that the activity LEDs on the router and switch are very active after as well.
    Hadn't tried to reload after I ran the multicast... actually, reloads really don't come to mind unless I'm working with MS products!
    I'll give that a shot... thanks for the info...
    Reply With Quote Quote  

  10. Senior Member chmorin's Avatar
    Join Date
    Feb 2010
    Location
    Texas
    Posts
    1,443

    Certifications
    CCNP:Voice, CCNA:V(IIUC), CCNA, CCENT, Security +, Network +, A+,CIW
    #9
    Quote Originally Posted by azaghul View Post
    I had the same MOH problem on my 1760 running CME 4.1. I had to run MOH in multicast to get it to work, and reload the router. Try;

    Code:
    moh flash:music-on-hold.au
    multicast moh 239.1.1.55 port 2100
    You'll also notice that the activity LEDs on the router and switch are very active after as well.
    Is the flash: portion of it needed? I'd bet in the 4.1 version it could make a difference. Reload too eh? Cisco has read to many MCP books.
    Reply With Quote Quote  

  11. Senior Member
    Join Date
    Apr 2008
    Location
    Tampa, Fl
    Posts
    1,097

    Certifications
    A Few....
    #10
    Quote Originally Posted by chmorin View Post
    Is the flash: portion of it needed? I'd bet in the 4.1 version it could make a difference. Reload too eh? Cisco has read to many MCP books.
    Chmorin,

    I've tried both methods

    Code:
    moh flash:music-on-hold.au
    moh music-on-hold.au
    Neither method had worked before... but I have not tried to do those methods with flash, multicast, and a reload. So I'll try to lab that up when I get home.
    Reply With Quote Quote  

  12. Senior Member
    Join Date
    Jun 2009
    Location
    Gosford, Australia
    Posts
    567

    Certifications
    CCNA, CCDA, CCNA:Voice(IIUC), CCNP:Voice
    #11
    Can't say for certain if the flash: part was needed, all I know is thats what worked for me after a lot of pulling the hair out (not much left anyway) and trial and error.
    Reply With Quote Quote  

  13. Member
    Join Date
    Feb 2010
    Location
    Ireland
    Posts
    44
    #12
    Quote Originally Posted by azaghul View Post
    I had the same MOH problem on my 1760 running CME 4.1. I had to run MOH in multicast to get it to work, and reload the router. Try;

    Code:
    moh flash:music-on-hold.au
    multicast moh 239.1.1.55 port 2100
    You'll also notice that the activity LEDs on the router and switch are very active after as well.
    I tried that too before but no luck. The flash: option is not needed as the music plays through when a call is parked and plays also to fxs ports. I do tend to reload alot when having problems (usually pointless but why not).

    azaghul, what platform / cme version were you running? Do you have a copy of the working config?

    Still having no luck with the local directory. I started a "debug ip http all" hoping to see some requests from the phones but nothing. Have to try and get more info on the process.
    Reply With Quote Quote  

  14. Senior Member
    Join Date
    Jun 2009
    Location
    Gosford, Australia
    Posts
    567

    Certifications
    CCNA, CCDA, CCNA:Voice(IIUC), CCNP:Voice
    #13
    I'm running a 1760 with IOS c1700-adventerprisek9-mz.124-15.T11.bin.

    I also have a 3725, so the baby brother to your 3745. Its currently in the middle of my CIPT1 studies, and I only have a partial CME config at this stage (redoing my notes), so I'll try it over the weekend for you.

    I currently have 2 x 7960's plugged in and am getting MoH between each handset. I've got a full config if needed. Send me a PM with an email address if needed, its quite lengthy...

    Code:
    sh telephony-service
    CONFIG (Version=4.1(0))
    =====================
    Version 4.1(0)
    Cisco Unified Communications Manager Express
    According to the readme file, the GUI is CME v4.1.0.1 for IOS v12.4(11)XJ, but that should not impact MoH.

    Code:
    sh run | s telephony
    telephony-service
     no auto-reg-ephone
     load 7960-7940 P0030702T023
     load 7914 S00104000100
     load 7912 CP7912080001SCCP051117A
     max-ephones 25
     max-dn 75
     ip source-address 192.168.11.1 port 2000
     caller-id block code *999
     system message Belegost (Melbourne)
     time-zone 48
     time-format 24
     date-format dd-mm-yy
     max-conferences 8 gain -6
     moh flash:music-on-hold.au
     multicast moh 239.1.1.55 port 2100
     web admin system name CMEadmin password cmeadmin
     dn-webedit
     transfer-system full-consult
     create cnf-files version-stamp 7960 Mar 01 2010 15:20:57
    Last edited by azaghul; 05-28-2010 at 12:15 PM.
    Reply With Quote Quote  

  15. Member
    Join Date
    Feb 2010
    Location
    Ireland
    Posts
    44
    #14
    Thanks for that. I'm on 124-15.T8 ios, I must see if I can get a T11 or higher image. Can you do a "more system:its/XMLDefault.cnf.xml" and see if there is a tag for Directories url?
    Reply With Quote Quote  

  16. Senior Member
    Join Date
    Jun 2009
    Location
    Gosford, Australia
    Posts
    567

    Certifications
    CCNA, CCDA, CCNA:Voice(IIUC), CCNP:Voice
    #15
    Ok, just working through my 3725.

    So far not getting any MoH, wierd.

    1760: debug ephone moh
    Code:
    # debug ephone moh
    EPHONE music-on-hold debugging is enabled
    000081: 01:01:53: MoH route If FastEthernet0/0.11 ETHERNET 192.168.11.1 via ARP
    000082: 01:01:58: MoH route If FastEthernet0/0.11 ETHERNET 192.168.11.1 via ARP
    000083: 01:02:00: McastMoh is Available (made call and placed it on-hold)
    000084: 01:02:03: MoH route If FastEthernet0/0.11 ETHERNET 192.168.11.1 via ARP
    000085: 01:02:08: MoH route If FastEthernet0/0.11 ETHERNET 192.168.11.1 via ARP
    000086: 01:02:11: ifs_read flash:music-on-hold.au end of file at 491198 read 5323 = 496521
    000087: 01:02:11: moh tail fill from 24 at 0x84222CD7 length 2677
    Both 1760 and 3725 show the same debug info, but the 3725 does not play MoH

    1760: more system:its/XMLDefault.cnf.xml
    Code:
    # more system:its/XMLDefault.cnf.xml
    <Default>
    <callManagerGroup>
    <members>
    <member  priority="0">
    <callManager>
    <ports>
    <ethernetPhonePort>2000</ethernetPhonePort>
    </ports>
    <processNodeName>192.168.11.1</processNodeName>
    </callManager>
    </member>
    </members>
    </callManagerGroup>
    <loadInformation6  model="IP Phone 7910"></loadInformation6>
    <loadInformation124  model="Addon  7914">S00104000100</loadInformation124>
    <loadInformation227  model="Addon  7915-12"></loadInformation227>
    <loadInformation228  model="Addon  7915-24"></loadInformation228>
    <loadInformation229  model="Addon  7916-12"></loadInformation229>
    <loadInformation230  model="Addon  7916-24"></loadInformation230>
    <loadInformation9  model="IP Phone 7935"></loadInformation9>
    <loadInformation8  model="IP Phone  7940">P0030702T023</loadInformation8>
    <loadInformation7  model="IP Phone  7960">P0030702T023</loadInformation7>
    <loadInformation20000  model="IP Phone  7905"></loadInformation20000>
    <loadInformation30008  model="IP Phone  7902"></loadInformation30008>
    <loadInformation30002  model="IP Phone  7920"></loadInformation30002>
    <loadInformation365  model="IP Phone  7921"></loadInformation365>
    <loadInformation30019  model="IP Phone  7936"></loadInformation30019>
    <loadInformation30006  model="IP Phone  7970"></loadInformation30006>
    <loadInformation30018  model="IP Phone  7961"></loadInformation30018>
    <loadInformation308  model="IP Phone  7961GE"></loadInformation308>
    <loadInformation115  model="IP Phone  7941"></loadInformation115>
    <loadInformation309  model="IP Phone  7941GE"></loadInformation309>
    <loadInformation348  model="IP Phone  7931"></loadInformation348>
    <loadInformation307  model="IP Phone  7911"></loadInformation307>
    <loadInformation369  model="IP Phone  7906"></loadInformation369>
    <loadInformation302  model="IP Phone  7985"></loadInformation302>
    <loadInformation30007  model="IP Phone  7912">CP7912080001SCCP051117A</loadInformation30007>
    <loadInformation119  model="IP Phone  7971"></loadInformation119>
    <loadInformation404  model="IP Phone  7962"></loadInformation404>
    <loadInformation434  model="IP Phone  7942"></loadInformation434>
    <loadInformation435  model="IP Phone  7945"></loadInformation435>
    <loadInformation436  model="IP Phone  7965"></loadInformation436>
    <loadInformation437  model="IP Phone  7975"></loadInformation437>
    </Default>
    No reference to the directories tag, and my 'Directories' button brings up (both 1760 and 3725)...

    1 Missed Calls
    2 Received Calls
    3 Placed Calls
    4 Local Directory
    5 Local Speed Dial
    6 Personal Speed Dial
    Last edited by azaghul; 05-28-2010 at 09:08 PM.
    Reply With Quote Quote  

  17. Senior Member
    Join Date
    Jun 2009
    Location
    Gosford, Australia
    Posts
    567

    Certifications
    CCNA, CCDA, CCNA:Voice(IIUC), CCNP:Voice
    #16
    Finally...

    More trial and error...

    It seems MoH will only work if the ip source address belongs to a REAL interface. My 3725 had been using the Loopback0 IP address (no MoH), my 1760 is using the FastEthernet 0.11 IP addfress (MoH works).

    So I changed the IP address and presto!

    Now why won't the Loopback0 IP address work, as I'm sure that would be one of the CME best practices. Just checked the CCNA-Voice book, and Loopback is what is recommended...
    Last edited by azaghul; 05-28-2010 at 09:23 PM.
    Reply With Quote Quote  

  18. Senior Member chmorin's Avatar
    Join Date
    Feb 2010
    Location
    Texas
    Posts
    1,443

    Certifications
    CCNP:Voice, CCNA:V(IIUC), CCNA, CCENT, Security +, Network +, A+,CIW
    #17
    Quote Originally Posted by azaghul View Post
    Finally...

    More trial and error...

    It seems MoH will only work if the ip source address belongs to a REAL interface. My 3725 had been using the Loopback0 IP address (no MoH), my 1760 is using the FastEthernet 0.11 IP addfress (MoH works).

    So I changed the IP address and presto!

    Now why won't the Loopback0 IP address work, as I'm sure that would be one of the CME best practices. Just checked the CCNA-Voice book, and Loopback is what is recommended...
    Something to do with routing?
    Reply With Quote Quote  

  19. Senior Member
    Join Date
    Jun 2009
    Location
    Gosford, Australia
    Posts
    567

    Certifications
    CCNA, CCDA, CCNA:Voice(IIUC), CCNP:Voice
    #18
    I don't think its routing, both IP network ranges are in my routing table, plus both are also locally attached networks.... I'm really at a loss to explain why this fixes it.
    Reply With Quote Quote  

  20. Senior Member
    Join Date
    Apr 2008
    Location
    Tampa, Fl
    Posts
    1,097

    Certifications
    A Few....
    #19
    I was successful in getting my moh to work. I am using an actual interface as my source address. I configured multicast on port 2000 using the ip address: 239.1.1.100. Not sure what changed (if anything)... I did perform a reboot... but coincidentally, I reboot every night when I turn my equipment off, so I'm not sure if it was the reboot that did it for me. I'm running CME 4.1 on 1-2621XM and 2-1760. HTH.

    -Peanut
    Reply With Quote Quote  

  21. Member
    Join Date
    Feb 2010
    Location
    Ireland
    Posts
    44
    #20
    Excellent Azaghul!! Just looking at my config as I thought I had been using a real (sub) interface already and seen a typo in my ip source address

    I did have some success with the Directory listing, only on my 7960 though. I had to check the following path in a web browser

    http://192.168.1.199/localdirectory

    Although I was getting an xml parsing error I knew there was a file there so it was being shared out. I removed the "ip http path flash:gui" and then it appeared on 7960, no difference on the 7970 or softphone but I think that might be a version and firmware revision issues. going to update them when I get the time and see.
    Reply With Quote Quote  

  22. Senior Member chmorin's Avatar
    Join Date
    Feb 2010
    Location
    Texas
    Posts
    1,443

    Certifications
    CCNP:Voice, CCNA:V(IIUC), CCNA, CCENT, Security +, Network +, A+,CIW
    #21
    Quote Originally Posted by Fatbunny View Post
    Excellent Azaghul!! Just looking at my config as I thought I had been using a real (sub) interface already and seen a typo in my ip source address
    I have probably spent hours total troubleshooting an issue that turned out to be as simple as my source address having a typeo. You are not alone =)
    Reply With Quote Quote  

  23. Member
    Join Date
    Feb 2010
    Location
    Ireland
    Posts
    44
    #22
    That was it . Updated the source address and moh worked fine. Funny that without the source address (the correct one anyway) my phones were still able to register (although intermittently they wouldn't).
    Reply With Quote Quote  

  24. Senior Member chmorin's Avatar
    Join Date
    Feb 2010
    Location
    Texas
    Posts
    1,443

    Certifications
    CCNP:Voice, CCNA:V(IIUC), CCNA, CCENT, Security +, Network +, A+,CIW
    #23
    Quote Originally Posted by Fatbunny View Post
    That was it . Updated the source address and moh worked fine. Funny that without the source address (the correct one anyway) my phones were still able to register (although intermittently they wouldn't).
    Hm. Without a proper source address the phones should not have been being directed to the proper location, unless the typo was in the dhcp server option 150 as well.
    Reply With Quote Quote  

  25. Member
    Join Date
    Feb 2010
    Location
    Ireland
    Posts
    44
    #24
    I didn't put the typo in the option 150 setting, only in the source address. I think because it failed it probably attempted to use the option 150 ip address as the source address. I wouldn't surprised if if it was in cisco's code to do something like that. However, some phones wouldn't register on random days, other days they would be fine. That was from the config listed above, although it wouldn't surprise if I have made a few other errors in there.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks