+ Reply to Thread
Results 1 to 8 of 8
  1. Senior Member chmorin's Avatar
    Join Date
    Feb 2010
    Location
    Texas
    Posts
    1,443

    Certifications
    CCNP:Voice, CCNA:V(IIUC), CCNA, CCENT, Security +, Network +, A+,CIW
    #1

    Default 3500/2900 voice&access vlans

    Could anyone explain to me why it is on my 3500 and 2900 my phones will not connect to my CME router when I issue on the interface:

    Code:
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan 10
    Switch(config-if)#switchport voice vlan 20
    But will connect when I issue just:

    Code:
    Switch(config-if)#switchport access vlan 20
    There is no computer attached with them, but it was my understanding that they would use the voice vlan when the phone is attached and initiates that 'mini trunk'. This occurred on both my 7906's and 7960. How would I enable the 7960 to allow a computer to work in its switchport?
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member mwgood's Avatar
    Join Date
    Feb 2004
    Location
    New Mexico
    Posts
    298

    Certifications
    MCSE, CCNP
    #2
    Make sure CDP is enabled on the port the phone attaches to.

    To allow a computer to work through the phone, just plug it into the PC port on the back of the phone.
    Reply With Quote Quote  

  4. Senior Member chmorin's Avatar
    Join Date
    Feb 2010
    Location
    Texas
    Posts
    1,443

    Certifications
    CCNP:Voice, CCNA:V(IIUC), CCNA, CCENT, Security +, Network +, A+,CIW
    #3
    Quote Originally Posted by mwgood View Post
    Make sure CDP is enabled on the port the phone attaches to.
    If I type in show cdp neighbors, It finds its attached switches/routers and it sees the IP phone, but it is tagging it with an H for host, and not P for phone. Do I need to enable cdp? I cant find the IOS command for it. EDIT: is it cdp run in global config mode?

    Quote Originally Posted by mwgood View Post
    To allow a computer to work through the phone, just plug it into the PC port on the back of the phone.
    I am aware of that, but it will be using the wrong vlan if I leave the configuration as is, if it works at all.
    Reply With Quote Quote  

  5. Senior Member pitviper's Avatar
    Join Date
    May 2008
    Location
    Right Coast, US
    Posts
    1,363

    Certifications
    CCNP:Collaboration, CCNP:R+S, CCNA:R+S, CCNA:V(IIUC), CCNA:S, CCENT, CNSS 4011
    #4
    Is it a 3524? If so the config is a little flakey = You have to configure the ports that the phones connect to as trunk ports in addition to the voice and data VLAN items.
    Reply With Quote Quote  

  6. Senior Member chmorin's Avatar
    Join Date
    Feb 2010
    Location
    Texas
    Posts
    1,443

    Certifications
    CCNP:Voice, CCNA:V(IIUC), CCNA, CCENT, Security +, Network +, A+,CIW
    #5
    Wow, it is a 3524. You hit the nail on the head pitviper, you are amazing. I'll give that a shot next time around. That is so weird, I don't recall seeing that in any of my CCNA:V studies!

    Quote Originally Posted by pitviper View Post
    Is it a 3524? If so the config is a little flakey = You have to configure the ports that the phones connect to as trunk ports in addition to the voice and data VLAN items.
    Ahh I found this now:

    VLAN management on the Cisco 3524

    That is crazy. Duely noted though. At least I am not crazy with my initial configurations though. Thanks a load pit.
    Reply With Quote Quote  

  7. Senior Member pitviper's Avatar
    Join Date
    May 2008
    Location
    Right Coast, US
    Posts
    1,363

    Certifications
    CCNP:Collaboration, CCNP:R+S, CCNA:R+S, CCNA:V(IIUC), CCNA:S, CCENT, CNSS 4011
    #6
    No problem – It’s one of those things that you won’t find in a text book because it’s a non-issue with newer hardware. I was stumped myself the first time that I tried to setup a 3524/phone (I had a few 3524s in my original voice lab).

    Here’s a sample config that I found online:

    interface FastEthernet0/3
    desc Paul Phone/Switch
    switch trunk encap dot1q
    switch trunk native vlan 100
    switch trunk allow vlan 100,200
    switch mode trunk
    switch voice vlan 200
    spanning-tree portfast trunk
    Reply With Quote Quote  

  8. Senior Member chmorin's Avatar
    Join Date
    Feb 2010
    Location
    Texas
    Posts
    1,443

    Certifications
    CCNP:Voice, CCNA:V(IIUC), CCNA, CCENT, Security +, Network +, A+,CIW
    #7
    Quote Originally Posted by pitviper View Post
    No problem – It’s one of those things that you won’t find in a text book because it’s a non-issue with newer hardware. I was stumped myself the first time that I tried to setup a 3524/phone (I had a few 3524s in my original voice lab).

    Here’s a sample config that I found online:

    interface FastEthernet0/3
    desc Paul Phone/Switch
    switch trunk encap dot1q
    switch trunk native vlan 100
    switch trunk allow vlan 100,200
    switch mode trunk
    switch voice vlan 200
    spanning-tree portfast trunk
    How does this work for allowing the PC's attached to say a 7960 to use an access vlan? would I have the native vlan as the access vlan I want them to use?
    Reply With Quote Quote  

  9. Senior Member
    Join Date
    Apr 2008
    Location
    Tampa, Fl
    Posts
    1,097

    Certifications
    A Few....
    #8
    Quote Originally Posted by chmorin View Post
    How does this work for allowing the PC's attached to say a 7960 to use an access vlan? would I have the native vlan as the access vlan I want them to use?
    Chmorin,

    That is correct. If you look at pitviper's example, the native vlan 100 is saying the untagged traffic (PC traffic) will be on vlan 100 which is the access vlan for his PC.

    -Peanut
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks