+ Reply to Thread
Results 1 to 5 of 5

Thread: 3524PWR Issues

  1. Cantankerous Old Fart hermeszdata's Avatar
    Join Date
    Jan 2010
    Location
    Colorado
    Posts
    225

    Certifications
    CCNA, CCNA:Voice (Ent) AdTran ATSA Internetworking
    #1

    Default 3524PWR Issues

    I received my 3524PRW switch today and it has been busting my brain.

    I needed to remove my HWICD-9ESW from my 2811 router because I needed more powered ports!

    I am running a router on a stick w/ vlans 1, 101, and 107 (101 is Data valn, 107 is Voice vlan, 1 is management) on f0/1 of the router. Router is set up with OSPF. Router IOS = 12.4(15)T1, Switch IOS = 12.0(5)WC17.

    PCs connected to the 7960s are able to communicate and get DHCP addresses with no issues. 7960s do not get DHCP configurations!

    The only thing that has changed is I removed the 9ESW-PWR interface and the vlans 101 and 107 where I had the same IP address assigned to the VLANs as i now have assigned to the f0/1.101 and fo/1.107 interfaces on the router.

    The 2811s sh ver is:

    Hermesz_R1#sh ver
    Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 12.4(15)T1, RELEASE SOFTWARE (fc2)
    Technical Support: Cisco - Shortcut
    Copyright (c) 1986-2007 by Cisco Systems, Inc.
    Compiled Wed 18-Jul-07 06:21 by prod_rel_team
    ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

    |

    Cisco 2811 (revision 53.50) with 247808K/14336K bytes of memory.
    Processor board ID FTX1122A41G
    2 FastEthernet interfaces
    1 Serial interface
    1 Virtual Private Network (VPN) Module
    4 Voice FXO interfaces
    2 Voice FXS interfaces
    DRAM configuration is 64 bits wide with parity enabled.
    239K bytes of non-volatile configuration memory.
    62720K bytes of ATA CompactFlash (Read/Write)
    Configuration register is 0x2102


    Router Code
    Code:
    !
    ip cef    
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.10.11.193 10.10.11.200
    ip dhcp excluded-address 10.10.11.1 10.10.11.20
    !
    ip dhcp pool HermeszPhones
       import all
       network 10.10.11.192 255.255.255.224
       default-router 10.10.11.193 
       option 150 ip 10.10.11.193 
    !
    ip dhcp pool HermeszDataLAN
       import all
       network 10.10.11.0 255.255.255.224
       default-router 10.10.11.1 
    !
    !
    interface FastEthernet0/1
     no ip address
     duplex auto
     speed auto
    !
    interface FastEthernet0/1.1
     encapsulation dot1Q 1 native
     ip address 10.10.11.225 255.255.255.224
     ip nat inside
     ip virtual-reassembly
    !         
    interface FastEthernet0/1.101
     description $Hermesz data LAN$
     encapsulation dot1Q 101
     ip address 10.10.11.1 255.255.255.224
     ip nat inside
     ip virtual-reassembly
    !
    interface FastEthernet0/1.107
     description $Hermesz Voice LAN$
     encapsulation dot1Q 107
     ip address 10.10.11.193 255.255.255.224
     ip nat inside
     ip virtual-reassembly
    !
    interface Serial0/2/0
     no ip address
     shutdown
     no fair-queue
    !
    router ospf 1
     log-adjacency-changes
     passive-interface FastEthernet0/0
     passive-interface Serial0/2/0
     network 10.10.0.0 0.0.255.255 area 0
    !
    !
    ip http server
    ip http authentication local
    no ip http secure-server
    ip nat inside source list 1 interface FastEthernet0/0 overload
    !
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 10.10.11.0 0.0.0.31
    access-list 1 permit 10.10.11.192 0.0.0.31
    access-list 1 permit 10.10.11.224 0.0.0.31
    !
    !
    Switch Code
    Code:
    interface FastEthernet0/1
     description $Connection to Office$
     switchport trunk encapsulation dot1q
     switchport trunk native vlan 101
     switchport trunk allowed vlan 1,101,107,1002-1005
     switchport mode trunk
     switchport voice vlan 107
     spanning-tree portfast
    !
     
    Output Cut
     
    !
    interface FastEthernet0/17
     description $Connection to Hermesz-R1 LAN$
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,101,107,1002-1005
     switchport mode trunk
    !
     
    Output Cut
     
    !         
    interface VLAN1
     ip address 10.10.11.226 255.255.255.224
     no ip directed-broadcast
     no ip route-cache
    !
    ip default-gateway 10.10.11.225
    ip http authentication local
    !
    When I look at the mac-address-table on the 3524PWR, I can see that the phones are connected to vlans 101 and 107 and if I open CNA, they show in the topology.

    I am able to ping all interfaces on the router and the switch's VLAN1 IP Address from any device on my network.

    What am I missing????

    John
    Last edited by hermeszdata; 10-28-2010 at 08:09 AM.
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member chmorin's Avatar
    Join Date
    Feb 2010
    Location
    Texas
    Posts
    1,443

    Certifications
    CCNP:Voice, CCNA:V(IIUC), CCNA, CCENT, Security +, Network +, A+,CIW
    #2
    Any chance we can see the interface configuration on the 3524 that the phones connect to?
    Reply With Quote Quote  

  4. Cantankerous Old Fart hermeszdata's Avatar
    Join Date
    Jan 2010
    Location
    Colorado
    Posts
    225

    Certifications
    CCNA, CCNA:Voice (Ent) AdTran ATSA Internetworking
    #3

    Default Interface Configs

    Quote Originally Posted by chmorin View Post
    Any chance we can see the interface configuration on the 3524 that the phones connect to?
    The phones were connected to f0/1. 6,7, and 8. Configs are duplicated on 6-8 as show for f0/1 in OP.

    I suspect it has something to do with the router config now. I decided to go back to my original config with the 9ESW installed and loaded what i thought was the previous config and I now get the same results with the phones pluged into the 9ESW (f0/1/0-3)

    Code:
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.10.11.1 10.10.11.20
    ip dhcp excluded-address 10.10.11.193 10.10.11.200
    !
    ip dhcp pool Hermesz_DataLAN
       import all
       network 10.10.11.0 255.255.255.224
       default-router 10.10.11.1 
    !
    ip dhcp pool Hermesz_VoiceLAN
       import all
       network 10.10.11.192 255.255.255.224
       default-router 10.10.11.193 
       option 150 ip 10.10.11.193 
    !
    !
    ip domain name hermesz.local
    !
    multilink bundle-name authenticated
     
     Output cut
     
    !
    interface FastEthernet0/1
     ip address 10.10.11.225 255.255.255.224
     ip nat inside
     ip virtual-reassembly
     duplex auto
     speed auto
    !
    interface FastEthernet0/1/0
     switchport access vlan 101
     switchport trunk native vlan 101
     switchport mode trunk
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/1
     switchport access vlan 101
     switchport trunk native vlan 101
     switchport mode trunk
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/2
     switchport access vlan 101
     switchport trunk native vlan 101
     switchport mode trunk
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/3
     switchport access vlan 101
     switchport trunk native vlan 101
     switchport mode trunk
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/4
     switchport access vlan 101
     switchport trunk native vlan 101
     switchport mode trunk
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/5
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/6
     switchport access vlan 101
     switchport voice vlan 107
     spanning-tree portfast
    !         
    interface FastEthernet0/1/7
     switchport access vlan 101
     switchport trunk native vlan 101
     switchport mode trunk
     switchport voice vlan 107
     spanning-tree portfast
    !
    interface FastEthernet0/1/8
     description Connection to Core Switch 3550
     switchport trunk allowed vlan 1,2,101,107,1002-1005
     switchport mode trunk
    !
    interface Serial0/2/0
     no ip address
     shutdown
     no fair-queue
    !
    interface Vlan1
     no ip address
     shutdown
    !
    interface Vlan101
     description Data Vlan
     ip address 10.10.11.1 255.255.255.224
     ip nat inside
     ip virtual-reassembly
    !
    interface Vlan107
     description Voice Vlan
     ip address 10.10.11.193 255.255.255.224
     ip nat inside
     ip virtual-reassembly
    !
    router ospf 1
     log-adjacency-changes
     passive-interface FastEthernet0/0
     passive-interface Serial0/2/0
     network 10.10.0.0 0.0.255.255 area 0
    !
    ip route 0.0.0.0 0.0.0.0 *.*.*.*
    !
    !
    ip http server
    ip http authentication local
    no ip http secure-server
    ip nat inside source list 1 interface FastEthernet0/0 overload
    !
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 10.10.11.0 0.0.0.31
    access-list 1 permit 10.10.11.192 0.0.0.31
    access-list 1 permit 10.10.11.224 0.0.0.31
    !
    I know it is something simple I am missing, but have been away from the studies too long.

    John
    Reply With Quote Quote  

  5. Senior Member chmorin's Avatar
    Join Date
    Feb 2010
    Location
    Texas
    Posts
    1,443

    Certifications
    CCNP:Voice, CCNA:V(IIUC), CCNA, CCENT, Security +, Network +, A+,CIW
    #4
    Forgive me, I'm a little confused. You currently have a ROAS configuration on a router with a 9ESW module installed, which you had for your IP Phones.

    You got the 3524pwr and configured it identically on the interfaces that you had on the 9ESW module, and the PC attached to the phone can get DHCP and connectivity, but the phone can not.

    If what I stated is true, I think I know the answer:

    I had the same problem a few months back, I even posted a blog post on it: Cisco Treks: 3524 Phone Connectivity

    I'll summary is so you don't need to read it:

    You need to configure the following on the 3524:
    Code:
    interface FastEthernet0/13
    switchport trunk encapsulation dot1q
     switchport trunk native vlan 10 (data VLAN)
    switchport trunk allowed vlan 1,10,20 (voice VLAN),1002-1005
     switchport mode trunk
    Where 10 is your data vlan, and 20 is your voice vlan.

    This is the old school way of configuring Voice VLANs. I learned it from some people on these forums, hopefully it helped you.
    Reply With Quote Quote  

  6. Cantankerous Old Fart hermeszdata's Avatar
    Join Date
    Jan 2010
    Location
    Colorado
    Posts
    225

    Certifications
    CCNA, CCNA:Voice (Ent) AdTran ATSA Internetworking
    #5

    Default Fixed

    Quote Originally Posted by chmorin View Post
    Forgive me, I'm a little confused. You currently have a ROAS configuration on a router with a 9ESW module installed, which you had for your IP Phones.

    You got the 3524pwr and configured it identically on the interfaces that you had on the 9ESW module, and the PC attached to the phone can get DHCP and connectivity, but the phone can not.

    If what I stated is true, I think I know the answer:

    I had the same problem a few months back, I even posted a blog post on it: Cisco Treks: 3524 Phone Connectivity

    I'll summary is so you don't need to read it:

    You need to configure the following on the 3524:
    Code:
    interface FastEthernet0/13
    switchport trunk encapsulation dot1q
     switchport trunk native vlan 10 (data VLAN)
    switchport trunk allowed vlan 1,10,20 (voice VLAN),1002-1005
     switchport mode trunk
    Where 10 is your data vlan, and 20 is your voice vlan.

    This is the old school way of configuring Voice VLANs. I learned it from some people on these forums, hopefully it helped you.

    Not sure where I FooBARed the 2811 config, but as I suspected, that is where the problem was. The good (or bad) thing about keeping copies of all the configs I have done in the past is as some point I will find a previous one that works. As I mentioned before. I re-installed the 9ESW module and tried to go back to the original config ... but I had one that did not function properly. I eventually located an earlier version that worked and the phones registered, finally while plugged into the 9ESW. I moved the phones over to the 3524PWR one at a time and they registered right away without issues.

    From there, I changed the voice VLAN IP Address to no IP address and created a sub-interface on F0/1 for VLAN 107 (Voice VLAN), setting the ip address to the prior VLAN101 IP Address and set up nat.

    Everything came up again

    Then I did the same thing for the Data VLAN 101.

    Everything came up again!!!!!

    Saved the config to start, powered off the 2811, removed the 9ESW and powered on.

    Victory ... of course, the normal errors associated with a config file that does not see a module it was expecting!

    Morale of the story ... keep track of the most recent configs that work!!!!

    John
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks