+ Reply to Thread
Results 1 to 23 of 23
  1. Junior Member
    Join Date
    Nov 2011
    Posts
    15
    #1

    Default No Audio on Phones

    I don't know where I went wrong and a friend of mine can't figure it out either.

    If I was to make a phone call the Cisco Phone have nothing on the speaker side of the phone. But when I call internally it's fine.

    Thanks
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #2
    That's not a whole lot of information?

    You make a call using the cisco phone but nothing on the speaker? OK?? Are you not getting ring back? are you connected to another IP Phone and they can hear you but not vice versa? We'll need more information

    What does your config look like, what model phone? what version are you running? all that good stuff, and a call example

    any debugs??

    are the phones registered?

    show ephone is your friend
    Last edited by drkat; 07-15-2012 at 07:13 PM.
    Reply With Quote Quote  

  4. Junior Member
    Join Date
    Nov 2011
    Posts
    15
    #3
    Hello,
    Yes the phone does ring, when I call from my cell phone to a Cisco Phone The Cisco phone can not hear me talking on my cell but when I talk on the Cisco my cell will hear me. Its not my headset because again from Cisco to Cisco phone it works fine.

    Here is my SHOW EPHONE
    ephone-1 Mac:0012.DADB.E063 TCP socket:[3] activeLine:0 REGISTERED in SCCP ver 9 and Server in ver 8
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
    IP:192.168.1.113 51907 Telecaster 7940 keepalive 95 max_line 2
    button 1: dn 10 number 1000 CH1 IDLE CH2 IDLE shared

    ephone-2 Mac:000D.BC91.0405 TCP socket:[2] activeLine:0 REGISTERED in SCCP ver 7 and Server in ver 7
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:6
    IP:192.168.1.114 3607 7912 keepalive 94 max_line 2 dual-line
    button 1: dn 11 number 1001 CH1 IDLE

    ephone-3 Mac:0016.E61D.5F1B TCP socket:[-1] activeLine:0 DECEASED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:10
    IP:192.168.1.110 50533 CIPC keepalive 41 max_line 8
    button 1: dn 10 number 1000 CH1 IDLE CH2 IDLE shared

    ephone-4 Mac:0015.638A.C7AC TCP socket:[1] activeLine:0 REGISTERED in SCCP ver 8 and Server in ver 8
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:7
    IP:192.168.1.104 3765 7912 keepalive 94 max_line 2 dual-line
    button 1: dn 10 number 1000 CH1 IDLE CH2 IDLE shared

    ephone-5 Mac:F0DE.F1C2.DEE9 TCP socket:[4] activeLine:0 REGISTERED in SCCP ver 15 and Server in ver 8
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:10
    IP:192.168.1.102 61167 CIPC keepalive 93 max_line 8
    button 1: dn 14 number 1004 CH1 IDLE CH2 IDLE
    Reply With Quote Quote  

  5. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #4
    Quote Originally Posted by jwb8734 View Post
    Hello,
    Yes the phone does ring, when I call from my cell phone to a Cisco Phone The Cisco phone can not hear me talking on my cell but when I talk on the Cisco my cell will hear me. Its not my headset because again from Cisco to Cisco phone it works fine.
    Ok, you have multiple ephones, do they all experience the same issues Off-net? how about on-net calling, sccp to sccp?

    One way audio is indicative of either a routing problem, codec mis match, possibly SIP signalling if your using a SIP Trunk - please provide more information -

    How is your stuff configured? SCCP to ?? what is your pstn portion? pri? sip? Is it on off-net origination only? or do you experience the same problem calling from the sccp phone?

    Quote Originally Posted by georgemc View Post
    I don't have the exact command in front of me, but check the bindings in your gateway. MGCP media?

    I've definitely had the same problem before (running a much older CCM though).

    I'll look it up and post it when I have access to my notes in a little while.

    He's running CME which doesnt make use of mgcp control
    Last edited by Plantwiz; 07-19-2012 at 04:53 PM. Reason: consecutive posting
    Reply With Quote Quote  

  6. Junior Member
    Join Date
    Nov 2011
    Posts
    15
    #5
    I first want to say thanks to everyone for your help.

    It have a 3745 with 1 FXO and 1 FXS.

    My router is configed to user the FXS. 2-Way communication works from all extension Cisco to Cisco phone. My phones are not set up to call out yet.

    But FXS to Cisco Phones only have 1 way communication.
    Reply With Quote Quote  

  7. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #6
    wow guess nobody responded to this.. how are you doing? if you need further assistance let me know.

    a show run would be helpful in troubleshooting
    Reply With Quote Quote  

  8. Senior Member
    Join Date
    May 2009
    Location
    DMV
    Posts
    2,205

    Certifications
    CCNP, CCNP(V), S+ CCIE V(written)
    #7
    Post a show run
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
    Reply With Quote Quote  

  9. Junior Member
    Join Date
    Nov 2011
    Posts
    15
    #8
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot system flash slot0:/c3745-advipservicesk9-mz124-15.bin
    boot system flash slot0:/c3745-js-mz.123-13b.bin
    boot-end-marker
    !
    logging buffered 51200 warnings
    enable secret 5 $1$41
    enable password $$$$$
    !
    no aaa new-model
    no ip routing
    no ip cef
    !
    !
    !
    !
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    username $$$$ privilege 15 password 0 $$$$$$
    archive
    log config
    hidekeys
    !
    !
    interface FastEthernet0/0
    ip address 192.168.1.2 255.255.255.0
    no ip route-cache
    speed auto
    full-duplex
    no mop enabled
    !
    interface FastEthernet0/1
    no ip address
    no ip route-cache
    shutdown
    duplex auto
    speed auto
    !
    ip forward-protocol nd
    !
    !
    ip http server
    no ip http secure-server
    ip http path flash:/gui
    !
    dialer-list 1 protocol ip permit
    !
    !
    !
    !
    !
    tftp-server flashesktops/320x212x12/CampusNight.png
    tftp-server flash:gui/admin_user.html
    tftp-server flash:gui/admin_user.js
    tftp-server flash:gui/CiscoLogo.gif
    tftp-server flash:gui/Delete.gif
    tftp-server flash:gui/ephone_admin.html
    tftp-server flash:ringtones/DistinctiveRingList.xml
    tftp-server flash:ringtones/Analog1.raw
    tftp-server flash:ringtones/Ring3.raw
    !
    control-plane
    !
    !
    !
    voice-port 1/0/0
    !
    voice-port 1/0/1
    !
    voice-port 1/1/0
    connection plar 1000
    caller-id enable
    !
    voice-port 1/1/1
    connection plar 1000
    caller-id enable
    !
    !
    !
    !
    !
    dial-peer voice 1000 pots
    destination-pattern 1[2-9].........
    port 1/1/0
    no register e164
    !
    dial-peer voice 1001 pots
    destination-pattern [2-9]11
    port 1/1/0
    no register e164
    !
    !
    !
    !
    telephony-service
    max-ephones 42
    max-dn 144
    ip source-address 192.168.1.2 port 2000
    auto assign 100 to 144
    url services http://phone-xml.berbee.com/menu.xml
    time-zone 12
    max-conferences 8 gain -6
    web admin system name Admin secret 5 $1$aJKU$
    dn-webedit
    time-webedit
    transfer-system full-consult
    secondary-dialtone 9
    create cnf-files version-stamp Jan 01 2002 00:00:00
    !
    !
    ephone-dn 10 dual-line
    number 1000 no-reg primary
    label 1000
    description 7940
    name 1000
    !
    !
    ephone-dn 11
    number 1001
    label 1001
    description 7912-A
    name 1001
    hold-alert 30 originator
    !
    !
    ephone-dn 12
    number 1002
    label 1002
    description 7912-B
    name 1002
    hold-alert 30 originator
    !
    !
    ephone-dn 13 dual-line
    number 1003
    label 1003
    description SoftPhone-1
    name 1003 - Soft Phone
    hold-alert 30 originator
    !
    !
    ephone-dn 14 dual-line
    number 1004
    label 1004
    description SoftPhone-2
    name 1004 - Soft Phone
    hold-alert 30 originator
    !
    !
    ephone 1
    device-security-mode none
    mac-address 0012.DADB.E063
    type 7940
    button 1:10
    !
    !
    !
    ephone 2
    device-security-mode none
    mac-address 000D.BC91.0405
    type 7912
    button 1:11
    !
    !
    !
    ephone 3
    device-security-mode none
    mac-address 0016.E61D.5F1B
    type 7912
    button 1:10
    !
    !
    !
    ephone 4
    device-security-mode none
    mac-address 0015.638A.C7AC
    type CIPC
    button 1:10
    !
    !
    !
    ephone 5
    device-security-mode none
    mac-address F0DE.F1C2.DEE9
    type CIPC
    button 1:14
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    privilege level 15
    password $$$$$
    login local
    transport input telnet
    !
    !
    end
    Here is show run
    Passwords have been replaced.
    Reply With Quote Quote  

  10. Junior Member
    Join Date
    Nov 2011
    Posts
    15
    #9
    I had posted my running config but it was held up due to the link that was in the Config File.
    Reply With Quote Quote  

  11. Junior Member
    Join Date
    Nov 2011
    Posts
    15
    #10
    Well I have been playing with this more and still no audio.
    Reply With Quote Quote  

  12. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #11
    show ip route

    I also dont see in your show run any voip services setup? what is your PSTN link? I see 1/1/0 and 1/1/1 but they're FXO it looks like because of your connection plar 1000

    show voice port summary
    show ip route
    show ip int br
    Last edited by drkat; 08-02-2012 at 05:04 PM.
    Reply With Quote Quote  

  13. Junior Member
    Join Date
    Nov 2011
    Posts
    15
    #12
    Router#show voice port summary
    IN OUT
    PORT CH SIG-TYPE ADMIN OPER STATUS STATUS EC
    ============== == ============ ===== ==== ======== ======== ==
    1/0/0 -- fxs-ls up dorm on-hook idle y
    1/0/1 -- fxs-ls up dorm on-hook idle y
    1/1/0 -- fxo-ls up dorm idle on-hook y
    1/1/1 -- fxo-ls up dorm idle on-hook y
    50/0/10 1 efxs up up on-hook idle y
    50/0/10 2 efxs up up on-hook idle y
    50/0/11 1 efxs up dorm on-hook idle y
    50/0/12 1 efxs up up on-hook idle y
    50/0/13 1 efxs up up on-hook idle y
    50/0/13 2 efxs up up on-hook idle y
    50/0/14 1 efxs up up on-hook idle y
    50/0/14 2 efxs up up on-hook idle y
    PWR FAILOVER PORT PSTN FAILOVER PORT
    ================= ==================


    show ip route
    Default gateway is not set
    Host Gateway Last Use Total Uses Interface
    ICMP redirect cache is empty

    Router#show ip int br
    Interface IP-Address OK? Method Status Protocol
    FastEthernet0/0 192.168.1.2 YES NVRAM up up
    FastEthernet0/1 unassigned YES NVRAM administratively down down
    Reply With Quote Quote  

  14. Junior Member
    Join Date
    Nov 2011
    Posts
    15
    #13
    So my system is set up like this.

    WRT54GL---C3524---C3745 (CME)
    192.168.1.1--192.168.1.3--192.168.1.2

    I have 1 FXS and 1 FXO card as seen.
    WRT54GL is my gateway and DHCP. IT does have DD-WRT in it so I can make some changes but never really played with it. I only used it to make changes to the WIFI signal.
    Reply With Quote Quote  

  15. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #14
    Ok so you have SCCP end points registering to the CME at 192.168.1.2

    How do you complete calls inbound from your cell phone?? What service are you using to connect the PSTN to the CME



    so this is all layer 2 so I'm assuming the phones are assigned 192.168.1.1 as it's gateway..

    Possibly NAT on the WRT - I'd put the CME in the DMZ - I'd do a debug too


    I see no dial-peers or voice services.. as well
    Last edited by drkat; 08-02-2012 at 05:13 PM.
    Reply With Quote Quote  

  16. Junior Member
    Join Date
    Nov 2011
    Posts
    15
    #15
    Quote Originally Posted by drkat View Post
    How do you complete calls inbound from your cell phone?? What service are you using to connect the PSTN to the CME
    I am using POTS via my ISP Voice Modem.

    I DMZ the CME Router.

    If I have no dial-peers what should I set them to.
    Reply With Quote Quote  

  17. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #16
    Oh it was just a observation..

    Ok I get it.. so you have your modem going into the CME for inbound calls..

    OK... you're gonna want to check your codecs then and run some debugs.



    I'm confused honestly... I'm trying to look at your config but ..

    incoming calls

    voice-port 1/1/0
    connection plar 1000
    caller-id enable
    !
    voice-port 1/1/1
    connection plar 1000
    caller-id enable

    do a debug ccapi inout and check your dialpeer matching.. it looks like you're going to be using dial-peer 0 which is the default dial-peer

    you may have codec mismatch causing the one way audio
    Last edited by drkat; 08-02-2012 at 06:03 PM.
    Reply With Quote Quote  

  18. Junior Member
    Join Date
    Nov 2011
    Posts
    15
    #17
    What my plan is to do is each phone has it's own extension but when I get a call it rings to all phones. I think we copied the command you have above to test out the port to make sure it was not defective.

    II enabled DEBUG CDAPI. I wil do some testing tomorrow.
    Reply With Quote Quote  

  19. Junior Member
    Join Date
    Nov 2011
    Posts
    15
    #18
    Here is the debug cdapi

    *Jul 15 18:19:06.810: CDAPI: cdapi_free_raw_msg_buf(): Attempt to free NULL pointer
    *Jul 15 18:19:06.818: CDAPI: cdapi_free_raw_msg_buf(): Type = SMALL
    *Jul 15 18:19:06.818: CDAPI: cdapi_free_raw_msg(): Raw Msg = 0x66C26000, Type = SMALL
    *Jul 15 18:19:06.818: CDAPI: cdapi_free_raw_msg(): Freed dynamic raw buffer, Type = SMALL, dynamic count: 4
    *Jul 15 18:19:06.818: CDAPI: cdapi_free_raw_msg_buf(): Type = SMALL
    *Jul 15 18:19:06.818: CDAPI: cdapi_free_raw_msg(): Raw Msg = 0x66932B00, Type = SMALL
    *Jul 15 18:19:06.818: CDAPI: cdapi_free_raw_msg(): Freed dynamic raw buffer, Type = SMALL, dynamic count: 3
    *Jul 15 18:19:44.106: CDAPI: cdapi_free_raw_msg_buf(): Type = SMALL
    *Jul 15 18:19:44.106: CDAPI: cdapi_free_raw_msg(): Raw Msg = 0x66939218, Type = SMALL
    *Jul 15 18:19:44.106: CDAPI: cdapi_free_raw_msg(): Freed dynamic raw buffer, Type = SMALL, dynamic count: 2
    *Jul 15 18:19:44.110: CDAPI: cdapi_free_raw_msg_buf(): Type = SMALL
    *Jul 15 18:19:44.110: CDAPI: cdapi_free_raw_msg(): Raw Msg = 0x6600D2E4, Type = SMALL
    *Jul 15 18:19:44.110: CDAPI: cdapi_free_raw_msg(): Freed dynamic raw buffer, Type = SMALL, dynamic count: 1
    *Jul 15 18:19:44.110: CDAPI: cdapi_free_raw_msg_buf(): Type = SMALL
    *Jul 15 18:19:44.110: CDAPI: cdapi_free_raw_msg(): Raw Msg = 0x682A48BC, Type = SMALL
    *Jul 15 18:19:44.110: CDAPI: cdapi_free_raw_msg(): Freed dynamic raw buffer, Type = SMALL, dynamic count: 0
    *Jul 15 20:17:47.206: CDAPI: cdapi_free_raw_msg_buf(): Attempt to free NULL pointer
    *Jul 15 20:17:47.210: CDAPI: cdapi_free_raw_msg_buf(): Type = SMALL
    *Jul 15 20:17:47.210: CDAPI: cdapi_free_raw_msg(): Raw Msg = 0x66932B00, Type = SMALL
    *Jul 15 20:17:47.210: CDAPI: cdapi_free_raw_msg(): Freed dynamic raw buffer, Type = SMALL, dynamic count: 4
    *Jul 15 20:17:47.210: CDAPI: cdapi_free_raw_msg_buf(): Type = SMALL
    *Jul 15 20:17:47.210: CDAPI: cdapi_free_raw_msg(): Raw Msg = 0x66939218, Type = SMALL
    *Jul 15 20:17:47.210: CDAPI: cdapi_free_raw_msg(): Freed dynamic raw buffer, Type = SMALL, dynamic count: 3
    *Jul 15 20:19:47.210: CDAPI: cdapi_free_raw_msg_buf(): Type = SMALL
    *Jul 15 20:19:47.210: CDAPI: cdapi_free_raw_msg(): Raw Msg = 0x66C26000, Type = SMALL
    *Jul 15 20:19:47.210: CDAPI: cdapi_free_raw_msg(): Freed dynamic raw buffer, Type = SMALL, dynamic count: 2
    *Jul 15 20:19:47.214: CDAPI: cdapi_free_raw_msg_buf(): Type = SMALL
    *Jul 15 20:19:47.214: CDAPI: cdapi_free_raw_msg(): Raw Msg = 0x683051C4, Type = SMALL
    *Jul 15 20:19:47.214: CDAPI: cdapi_free_raw_msg(): Freed dynamic raw buffer, Type = SMALL, dynamic count: 1
    *Jul 15 20:19:47.214: CDAPI: cdapi_free_raw_msg_buf(): Type = SMALL
    *Jul 15 20:19:47.214: CDAPI: cdapi_free_raw_msg(): Raw Msg = 0x682A48BC, Type = SMALL
    *Jul 15 20:19:47.214: CDAPI: cdapi_free_raw_msg(): Freed dynamic raw buffer, Type = SMALL, dynamic count: 0
    *Jul 15 21:15:09.094: CDAPI: cdapi_free_raw_msg_buf(): Attempt to free NULL pointer
    *Jul 15 21:15:09.102: CDAPI: cdapi_free_raw_msg_buf(): Type = SMALL
    *Jul 15 21:15:09.102: CDAPI: cdapi_free_raw_msg(): Raw Msg = 0x66932B00, Type = SMALL
    *Jul 15 21:15:09.102: CDAPI: cdapi_free_raw_msg(): Freed dynamic raw buffer, Type = SMALL, dynamic count: 4
    *Jul 15 21:15:09.102: CDAPI: cdapi_free_raw_msg_buf(): Type = SMALL
    *Jul 15 21:15:09.102: CDAPI: cdapi_free_raw_msg(): Raw Msg = 0x66939218, Type = SMALL
    *Jul 15 21:15:09.102: CDAPI: cdapi_free_raw_msg(): Freed dynamic raw buffer, Type = SMALL, dynamic count: 3
    *Jul 15 21:15:20.566: CDAPI: cdapi_free_raw_msg_buf(): Type = SMALL
    *Jul 15 21:15:20.566: CDAPI: cdapi_free_raw_msg(): Raw Msg = 0x66C26000, Type = SMALL
    *Jul 15 21:15:20.566: CDAPI: cdapi_free_raw_msg(): Freed dynamic raw buffer, Type = SMALL, dynamic count: 2
    *Jul 15 21:15:26.502: CDAPI: cdapi_free_raw_msg_buf(): Type = SMALL
    *Jul 15 21:15:26.502: CDAPI: cdapi_free_raw_msg(): Raw Msg = 0x6600D030, Type = SMALL
    *Jul 15 21:15:26.502: CDAPI: cdapi_free_raw_msg(): Freed dynamic raw buffer, Type = SMALL, dynamic count: 1
    *Jul 15 21:15:26.502: CDAPI: cdapi_free_raw_msg_buf(): Type = SMALL
    *Jul 15 21:15:26.502: CDAPI: cdapi_free_raw_msg(): Raw Msg = 0x682A48BC, Type = SMALL
    *Jul 15 21:15:26.502: CDAPI: cdapi_free_raw_msg(): Freed dynamic raw buffer, Type = SMALL, dynamic count: 0
    Reply With Quote Quote  

  20. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #19
    CCAPI not cdapi

    debug ccapi inout
    debug dial-peer


    I dont see any voip dial-peers -- i'm assuming you're hitting dial-peer 0 and well... thats your problem


    If you want, we can webex and I can go over the config live and do live traces and explain it - this voice stuff can be a bit complicated when you're trying to do it all alone
    Last edited by drkat; 08-03-2012 at 08:56 PM.
    Reply With Quote Quote  

  21. Junior Member
    Join Date
    Nov 2011
    Posts
    15
    #20
    Quote Originally Posted by drkat View Post
    debug ccapi inout
    Router#debug ccapi inout
    ^
    % Invalid input detected at '^' marker.
    Reply With Quote Quote  

  22. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #21
    ... sorry debug voip ccapi inout
    Reply With Quote Quote  

  23. Junior Member
    Join Date
    Nov 2011
    Posts
    15
    #22
    I just enabled the command. I will do some testing in the AM. But just one dest shows expansive logs after almost 5 rings.
    Reply With Quote Quote  

  24. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #23
    well you can put it in terminal monitor
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks