+ Reply to Thread
Results 1 to 22 of 22
  1. Brain Dumps Smell Bad boostinbadger's Avatar
    Join Date
    Dec 2007
    Location
    Virginia
    Posts
    256

    Certifications
    CCENT - CCNA - WCSP - MCE
    #1

    Default Outbound Calling

    I just got both a 7960 and 7940 communicating between one another using CME. I have a registration to flowroute configured on a 1760. I originally had the 7960 phone working dialing outbound but not the 7940. I loaded new firmware and got both phones working between each other but I can no longer make outbound calls. When I pick the handset up I get dialtone. When I dial a number I get a fast busy. My sip service via flowroute is registered:

    5NINER1760CME#show sip-ua register status
    Line peer expires(sec) registered
    ============ ============= ============ ===========
    5406455901 20002 97 no
    5406455902 20004 97 no
    5901 20001 93 no
    5902 20003 93 no
    86377095 -1 583 yes


    The first two numbers are not correct. I don't know when they showed up. The DID I have registered does begin 540-645 though.
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #2
    debug ccsip messages and debug voip ccapi inout

    when you attempt to do the voice call
    Reply With Quote Quote  

  4. Brain Dumps Smell Bad boostinbadger's Avatar
    Join Date
    Dec 2007
    Location
    Virginia
    Posts
    256

    Certifications
    CCENT - CCNA - WCSP - MCE
    #3
    It looks like the calling number is incorrect. I have one DID 540645xxxx. I have replaced the dialed number with 1540xxxxxxx. When I pick up the handset it is using 1540645 and then putting the extensions I created (5901, 5902, etc) at the end. I don't want it to do that. I want both phones to use the one DID line that I have.

    5NINER1760CME#terminal monitor
    5NINER1760CME#
    Aug 24 03:03:44.238: //-1/264633248039/CCAPI/cc_api_display_ie_subfields:
    cc_api_call_setup_ind_common:
    cisco-username=
    ----- ccCallInfo IE subfields -----
    cisco-ani=5406455902
    cisco-anitype=0
    cisco-aniplan=0
    cisco-anipi=0
    cisco-anisi=0
    dest=
    cisco-desttype=0
    cisco-destplan=0
    cisco-rdie=FFFFFFFF
    cisco-rdn=
    cisco-rdntype=0
    cisco-rdnplan=0
    cisco-rdnpi=0
    cisco-rdnsi=0
    cisco-redirectreason=0
    Aug 24 03:03:44.242: //-1/264633248039/CCAPI/cc_api_call_setup_ind_common:
    Interface=0x8431C714, Call Info(
    Calling Number=5406455902(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
    Called Number=(TON=Unknown, NPI=Unknown),
    Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE,
    Incoming Dial-peer=20004, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), Calling IE Present=TRUE,
    Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1
    Aug 24 03:03:44.242: //-1/264633248039/CCAPI/ccCheckClipClir:
    In: Calling Number=5406455902(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
    Aug 24 03:03:44.242: //-1/264633248039/CCAPI/ccCheckClipClir:
    Out: Calling Number=5406455902(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
    Aug 24 03:03:44.246: //130/264633248039/CCAPI/cc_api_call_setup_ind_common:
    Set Up Event Sent;
    Call Info(Calling Number=5406455902(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
    Called Number=(TON=Unknown, NPI=Unknown))
    Aug 24 03:03:44.250: //130/264633248039/CCAP
    5NINER1760CME#I/cc_process_call_setup_ind:
    Event=0x83E7B8C8
    Aug 24 03:03:44.250: //130/264633248039/CCAPI/ccCallSetContext:
    Context=0x82E19A1C
    Aug 24 03:03:44.250: //130/264633248039/CCAPI/cc_process_call_setup_ind:
    >>>>CCAPI handed cid 130 with tag 20004 to app "_ManagedAppProcess_Default"
    Aug 24 03:03:44.250: //130/264633248039/CCAPI/ccCallSetupAck:
    Call Id=130
    Aug 24 03:03:44.254: //130/264633248039/CCAPI/cc_api_set_transfer_info:
    Transfer Number=, Transfer Reason=0x0
    Aug 24 03:03:44.254: //130/264633248039/CCAPI/ccGenerateToneInfo:
    Stop Tone On Digit=TRUE, Tone=Dial Tone,
    Tone Direction=Network, Params=0x0, Call Id=130
    Aug 24 03:03:44.254: //130/264633248039/CCAPI/ccSetDigitTimeouts:
    Initial Digit Timeout=-1000(ms), Inter Digit Timeout=-1000(ms)
    Aug 24 03:03:44.254: //130/264633248039/CCAPI/ccSetDigitTimeouts:
    Call Entry(Inter Digit Timeout=10000(ms), Initial Digit Timeout=10000(ms))
    Aug 24 03:03:44.254: //130/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:
    (callID=0x82, digit_event=0x1, enable=TRUE, consume=FALSE)
    Aug 24 03:03:44.254: //130/264633248039/CCAPI/ccCallReportDigits:
    Enabled=TRUE, Call Id=130
    Aug 24 03:03:44.258: //130/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:
    (vdbPtr=0x8431C714, callID=0x82, disp=0, digit_event=0x1, enable=TRUE, consume=FALSE)
    Aug 24 03:03:44.258: //130/264633248039/CCAPI/cc_api_call_report_digits_done:
    Enabled=TRUE, Disposition=0x0, Interface=0x8431C714, Call Id=130
    Aug 24 03:03:44.258: //130/264633248039/CCAPI/cc_api_call_report_digits_done:
    Call Entry(Initial Digit Timeout=10000(ms), Inter Digit Timeout=10000(ms))
    5NINER1760CME#
    Aug 24 03:03:46.530: //130/264633248039/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=1, DigitBeginFlags=0x0,
    Rtp Timestamp=0xAE8F8, Rtp Expiration=0x0
    Aug 24 03:03:46.534: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=1, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 24 03:03:46.534: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 24 03:03:46.690: //130/264633248039/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=5, DigitBeginFlags=0x0,
    Rtp Timestamp=0xB65F8, Rtp Expiration=0x0
    Aug 24 03:03:46.690: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=5, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 24 03:03:46.690: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 24 03:03:46.846: //130/264633248039/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=4, DigitBeginFlags=0x0,
    Rtp Timestamp=0xBE2F8, Rtp Expiration=0x0
    Aug 24 03:03:46.846: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=4, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 24 03:03:46.846: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 24 03:03:47.002: //130/264633248039/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=0, DigitBeginFlags=0x0,
    Rtp Timestamp=0xC5FF8, Rtp Expiration=0x0
    Aug 24 03:03:47.002: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=0, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 24 03:03:47.002: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 24 03:03:47.158: //130/264633248039/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=3, DigitBeginFlags=0x0,
    Rtp Timestamp=0xCDCF8, Rtp Expiration=0x0
    Aug 24 03:03:47.158: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=3, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 24 03:03:47.158: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 24 03:03:47.314: //130/264633248039/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=2, DigitBeginFlags=0x0,
    Rtp Timestamp=0xD59F8, Rtp Expiration=0x0
    Aug 24 03:03:47.314: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=2, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 24 03:03:47.314: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 24 03:03:47.470: //130/264633248039/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=7, DigitBeginFlags=0x0,
    Rtp Timestamp=0xDD6F8, Rtp Expiration=0x0
    Aug
    5NINER1760CME# 24 03:03:47.470: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=7, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 24 03:03:47.470: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 24 03:03:47.626: //130/264633248039/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=1, DigitBeginFlags=0x0,
    Rtp Timestamp=0xE53F8, Rtp Expiration=0x0
    Aug 24 03:03:47.626: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=1, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 24 03:03:47.626: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 24 03:03:47.782: //130/264633248039/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=7, DigitBeginFlags=0x0,
    Rtp Timestamp=0xED0F8, Rtp Expiration=0x0
    Aug 24 03:03:47.782: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=7, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 24 03:03:47.782: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 24 03:03:47.938: //130/264633248039/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=8, DigitBeginFlags=0x0,
    Rtp Timestamp=0xF4DF8, Rtp Expiration=0x0
    Aug 24 03:03:47.938: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=8, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 24 03:03:47.938: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 24 03:03:48.094: //130/264633248039/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=9, DigitBeginFlags=0x0,
    Rtp Timestamp=0xFCAF8, Rtp Expiration=0x0
    Aug 24 03:03:48.094: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=130, Digit=9, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 24 03:03:48.094: //130/264633248039/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 24 03:03:48.098: //130/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:
    (callID=0x82, digit_event=0x0, enable=FALSE, consume=FALSE)
    Aug 24 03:03:48.098: //130/264633248039/CCAPI/ccCallReportDigits:
    Enabled=TRUE, Call Id=130
    Aug 24 03:03:48.098: //130/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:
    (vdbPtr=0x8431C714, callID=0x82, disp=0, digit_event=0x0, enable=FALSE, consume=FALSE)
    Aug 24 03:03:48.098: //130/264633248039/CCAPI/cc_api_call_report_digits_done:
    Enabled=TRUE, Disposition=0x0, Interface=0x8431C714, Call Id=130
    Aug 24 03:03:48.102: //130/264633248039/CCAPI/cc_api_call_report_digits_done:
    Call Entry(Initial Digit Timeout=10000(ms), Inter Digit Timeout=10000(ms))
    Aug 24 03:03:48.106: //130/264633248039/CCAPI/ccCallSetupRequest:
    Destination=, Calling IE Present=TRUE, Mode=0,
    Outgoing Dial-peer=1, Params=0x82E1A6BC, Progress Indication=ORIGINATING SIDE IS NON ISDN(3)
    Aug 24 03:03:48.110: //130/264633248039/CCAPI/ccCheckClipClir:
    In: Calling Number=5406455902(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
    Aug 24 03:03:48.110: //130/264633248039/CCAPI/ccCheckClipClir:
    Out: Calling Number=5406455902(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
    Aug 24 03:03:48.110: //130/264633248039/CCAPI/ccCallSetupRequest:
    Destination Pattern=1[2-9]..[2-9]......, Called Number=1540xxxxxxx, Digit Strip=FALSE
    Aug 24 03:03:48.110: //130/264633248039/CCAPI/ccCallSetupRequest:
    Calling Number=5406455902(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
    Called Number=1540xxxxxxx(TON=Unknown, NPI=Unknown),
    Redirect Number=, Display Info=Kitchen
    Account Number=, Final Destination Flag=FALSE,
    Guid=26463324-ECCF-11E1-8039-B5BD624C466F, Outgoing Dial-peer=1
    Aug 24 03:03:48.110: //130/264633248039/CCAPI/cc_api_display_ie_subfields:
    ccCallSetupRequest:
    cisco-username=
    ----- ccCallInfo IE subfields -----
    cisco-ani=5406455902
    cisco-anitype=0
    cisco-aniplan=0
    cisco-anipi=0
    cisco-anisi=0
    dest=1540xxxxxxx
    cisco-desttype=0
    cisco-destplan=0
    cisco-rdie=FFFFFFFF
    cisco-rdn=
    cisco-rdntype=0
    cisco-rdnplan=0
    cisco-rdnpi=0
    cisco-rdnsi=0
    cisco-redirectreason=0
    Aug 24 03:03:48.114: //130/264633248039/CCAPI/ccIFCallSetupRequestPrivate:
    Interface=0x83A983A8, Interface Type=3, Destination=, Mode=0x0,
    Call Params(Calling Number=5406455902(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
    Called Number=1540xxxxxxx(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,
    Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE, Outgoing Dial-peer=1, Call Count On=FALSE,
    Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)
    Aug 24 03:03:48.114: //131/264633248039/CCAPI/ccIFCallSetupRequestPrivate:
    SPI Call Setup Request Is Success; Interface Type=3, FlowMode=1
    Aug 24 03:03:48.118: //131/264633248039/CCAPI/ccCallSetContext:
    Context=0x82E1A66C
    Aug 24 03:03:48.118: //130/264633248039/CCAPI/ccSaveDialpeerTag:
    Outgoing Dial-peer=1
    Aug 24 03:03:48.122: //131/264633248039/CCAPI/cc_api_call_proceeding:
    Interface=0x83A983A8, Progress Indication=NULL(0)
    Aug 24 03:03:48.134: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    INVITE sip:1540xxxxxxx@sip.flowroute.com:5060 SIP/2.0

    Via: SIP/2.0/UDP 10.59.1.4:5060;branch=z9hG4bK822372

    From: "Kitchen" <sip:1540645xxxx@sip.flowroute.com>;tag=1F3DD0-D49

    To: <sip:1540xxxxxxx@sip.flowroute.com>

    Date: Fri, 24 Aug 2012 03:03:48 GMT

    Call-ID: 289779F7-ECCF11E1-803CB5BD-624C466F@10.59.1.4

    Supported: 100rel,timer,resource-priority,replaces

    Min-SE: 1800

    Cisco-Guid: 642134820-3972993505-2151265725-1649165935

    User-Agent: Cisco-SIPGateway/IOS-12.x

    Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER

    CSeq: 101 INVITE

    Max-Forwards: 70

    Timestamp: 1345777428

    Contact: <sip:1540645xxxx@10.59.1.4:5060>

    Call-Info: <sip:10.59.1.4:5060>;method="NOTIFY;Event=telephon e-event;Duration=2000"

    Expires: 180

    Allow-Events: telephone-event

    Content-Type: application/sdp

    Content-Disposition: session;handling=required

    Content-Length: 265



    v=0

    o=CiscoSystemsSIP-GW-UserAgent 5263 4653 IN IP4 10.59.1.4

    s=SIP Call

    c=IN IP4 10.59.1.4

    t=0 0

    m=audio 18918 RTP/AVP 18 0 8 19

    c=IN IP4 10.59.1.4

    a=rtpmap:18 G729/8000

    a=fmtp:18 annexb=no

    a=rtpmap:0 PCMU/8000

    a=rtpmap:8 PCMA/8000

    a=rtpmap:19 CN/8000


    Aug 24 03:03:48.138: //130/264633248039/CCAPI/ccCallProceeding:
    Progress Indication=NULL(0)
    Aug 24 03:03:48.234: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Received:
    SIP/2.0 407 Proxy Authentication Required

    Via: SIP/2.0/UDP 10.59.1.4:5060;rport=49202;received=174.53.75.18;b ranch=z9hG4bK822372

    From: "Kitchen" <sip:1540645xxxx@sip.flowroute.com>;tag=1F3DD0-D49

    To: <sip:1540xxxxxxx@sip.flowroute.com>;tag=da160a8e05 34d7b0db4afd8620a22cb
    5NINER1760CME#7.a738

    Call-ID: 289779F7-ECCF11E1-803CB5BD-624C466F@10.59.1.4

    CSeq: 101 INVITE

    Proxy-Authenticate: Digest realm="sip.flowroute.com", nonce="UDbwQVA27xVt5HNVZtJ+bPiG3DQsLb4L", qop="auth"

    Content-Length: 0





    Aug 24 03:03:48.238: //131/264633248039/CCAPI/cc_api_call_disconnected:
    Cause Value=47, Interface=0x83A983A8, Call Id=131
    Aug 24 03:03:48.242: //131/264633248039/CCAPI/cc_api_call_disconnected:
    Call Entry(Responsed=TRUE, Cause Value=47, Retry Count=0)
    Aug 24 03:03:48.242: //130/xxxxxxxxxxxx/CCAPI/ccCallReleaseResources:
    release reserved xcoding resource.
    Aug 24 03:03:48.242: //131/264633248039/CCAPI/ccCallSetAAA_Accounting:
    Accounting=0, Call Id=131
    Aug 24 03:03:48.242: //131/264633248039/CCAPI/ccCallDisconnect:
    Cause Value=47, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=47)
    Aug 24 03:03:48.242: //131/264633248039/CCAPI/ccCallDisconnect:
    Cause Value=47, Call Entry(Responsed=TRUE, Cause Value=47)
    Aug 24 03:03:48.246: //131/264633248039/CCAPI/cc_api_call_disconnect_done:
    Disposition=0, Interface=0x83A983A8, Tag=0x0, Call Id=131,
    Call Entry(Disconnect Cause=47, Voice Class Cause Code=0, Retry Count=0)
    Aug 24 03:03:48.250: //131/264633248039/CCAPI/cc_api_call_disconnect_done:
    Call Disconnect Event Sent
    Aug 24 03:03:48.254: //130/264633248039/CCAPI/ccCallDisconnect:
    Cause Value=47, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
    Aug 24 03:03:48.254: //130/264633248039/CCAPI/ccCallDisconnect:
    Cause Value=47, Call Entry(Responsed=TRUE, Cause Value=47)
    Aug 24 03:03:48.254: //130/264633248039/CCAPI/cc_api_get_transfer_info:
    Transfer Number Is Null
    Aug 24 03:03:48.254: //130/264633248039/CCAPI/cc_api_call_disc_cause_update:
    Cause Value=16
    Aug 24 03:03:48.254: //130/264633248039/CCAPI/cc_api_call_disc_cause_update:
    Call Entry(Disconnect Cause=16)
    Aug 24 03:03:48.262: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    ACK sip:1540xxxxxxx@sip.flowroute.com:5060 SIP/2.0

    Via: SIP/2.0/UDP 10.59.1.4:5060;branch=z9hG4bK822372

    From: "Kitchen" <sip:1540645xxxx@sip.flowroute.com>;tag=1F3DD0-D49

    To: <sip:1540xxxxxxx@sip.flowroute.com>;tag=da160a8e05 34d7b0db4afd8620a22cb7.a738

    Date: Fri, 24 Aug 2012 03:03:48 GMT

    Call-ID: 289779F7-ECCF11E1-803CB5BD-624C466F@10.59.1.4

    Max-Forwards: 70

    CSeq: 101 ACK

    Content-Length: 0





    5NINER1760CME#
    Aug 24 03:03:54.926: //130/264633248039/CCAPI/cc_api_call_disconnect_done:
    Disposition=0, Interface=0x8431C714, Tag=0x0, Call Id=130,
    Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
    Aug 24 03:03:54.926: //130/264633248039/CCAPI/cc_api_call_disconnect_done:
    Call Disconnect Event Sent
    5NINER1760CME#
    Last edited by boostinbadger; 08-24-2012 at 11:55 AM.
    Reply With Quote Quote  

  5. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #4
    The call fails because the DID that is presented as the calling number probably isnt on your account. What you'll need to do is create a voice translation rule to translate the outbound DID to the one on your trunk.

    voice translation-rule 20
    rule 1 /.*/ /1XXX-XXXX/

    voice translation-profile Outbound-DID
    translate calling 20



    Apply this to your outbound voip dial-peer to flowroute and re-test.
    Last edited by drkat; 08-24-2012 at 11:43 PM.
    Reply With Quote Quote  

  6. Brain Dumps Smell Bad boostinbadger's Avatar
    Join Date
    Dec 2007
    Location
    Virginia
    Posts
    256

    Certifications
    CCENT - CCNA - WCSP - MCE
    #5
    Still fast busy....

    Here is the CME router config. Did I get the commands you told me to put in right?



    5NINER1760CME#show conf
    Using 4010 out of 29688 bytes
    !
    ! Last configuration change at 22:33:17 EDT Fri Aug 24 2012 by
    ! NVRAM config last updated at 22:33:17 EDT Fri Aug 24 2012 by
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname 5NINER1760CME
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 xxxxxxxx
    !
    aaa new-model
    !
    !
    aaa authentication login default local
    aaa authorization exec default local
    aaa authorization network default local
    !
    aaa session-id common
    !
    resource policy
    !
    clock timezone EST -5
    clock summer-time EDT recurring
    ip cef
    !
    !
    no ip dhcp use vrf connected
    !
    ip dhcp pool VOICE-SCOPE
    network 10.159.1.0 255.255.255.248
    default-router 10.159.1.1
    dns-server 216.146.36.36
    option 150 ip 10.159.1.1
    !
    !
    ip domain name 5NINER
    ip name-server 216.146.35.35
    ip name-server 216.146.36.36
    !
    !
    !
    voice service voip
    allow-connections sip to sip
    sip
    !
    !
    !
    voice class codec 1
    codec preference 1 g729r8
    codec preference 2 g711ulaw
    codec preference 3 g711alaw
    !
    !
    !
    !
    !
    !
    !
    voice register global
    mode cme
    !
    !
    voice translation-rule 159
    rule 1 /.*/ /645xxxx/ #TOOK LAST FOUR DIGITS OUT
    !
    !
    voice translation-profile Outbound-DID
    translate calling 159
    !
    !
    !
    !
    username boostinbadger privilege 15 secret 5 xxxxxxx
    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    speed 100
    !
    interface FastEthernet0/0.59
    description ROUTER INTERFACE FOR DATA VLAN
    encapsulation dot1Q 59 native
    ip address 10.59.1.4 255.255.255.224
    no snmp trap link-status
    !
    interface FastEthernet0/0.159
    description ROUTER INTERFACE FOR VOICE VLAN
    encapsulation dot1Q 159
    ip address 10.159.1.1 255.255.255.248
    no snmp trap link-status
    !
    interface FastEthernet0/1
    switchport access vlan 59
    !
    interface FastEthernet0/2
    switchport access vlan 59
    !
    interface FastEthernet0/3
    switchport access vlan 159
    !
    interface FastEthernet0/4
    switchport access vlan 159
    !
    interface Vlan1
    no ip address
    shutdown
    !
    interface Vlan59
    no ip address
    no autostate
    !
    interface Vlan159
    no ip address
    no autostate
    !
    ip default-gateway 10.59.1.1
    ip route 0.0.0.0 0.0.0.0 10.59.1.1
    !
    ip http server
    ip http authentication local
    no ip http secure-server
    !
    tftp-server flash:P00303020209.bin
    tftp-server flash0030801sr02
    tftp-server flash0030801sr02.bin
    tftp-server flash0030801sr02.sbn
    tftp-server flash0030801sr02.sb2
    tftp-server flash0030801sr02.loads
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    dial-peer voice 1 voip
    destination-pattern 1[2-9]..[2-9]......
    translate-outgoing called 159
    voice-class codec 1
    session protocol sipv2
    session target dns:sip.flowroute.com
    dtmf-relay sip-notify
    !
    sip-ua
    credentials username xxxxxxxx password xxxxxxxx realm sip.flowroute.com
    calling-info pstn-to-sip from number set 1540645xxxx #TOOK LAST FOUR DIGITS OUT
    no remote-party-id
    registrar dns:sip.flowroute.com expires 3600
    !
    !
    telephony-service
    max-ephones 5
    max-dn 5
    ip source-address 10.159.1.1 port 2000
    auto assign 1 to 5
    system message
    create cnf-files version-stamp 7960 Aug 23 2012 22:18:38
    dialplan-pattern 1 5406455... extension-length 4
    max-conferences 4 gain -6
    transfer-system full-consult
    !
    !
    ephone-dn 1
    number 5901
    label Basement
    name Basement
    !
    !
    ephone-dn 2
    number 5902
    label Kitchen
    name Kitchen
    !
    !
    ephone-dn 3
    number 5903
    !
    !
    ephone-dn 4
    number 5904
    !
    !
    ephone-dn 5
    number 5905
    !
    !
    ephone 1
    mac-address 0016.C815.5A6D
    type 7960
    button 1:1
    !
    !
    !
    ephone 2
    mac-address 0015.2BD4.1926
    type 7940
    button 1:2
    !
    !
    !
    ephone 3
    !
    !
    !
    ephone 4
    !
    !
    !
    ephone 5
    !
    !
    !
    line con 0
    exec-timeout 5 0
    password 7 xxxxxxxx
    logging synchronous
    stopbits 1
    line aux 0
    line vty 0 4
    exec-timeout 30 0
    password 7 xxxxxxxx
    logging synchronous
    line vty 5 15
    exec-timeout 30 0
    password 7 xxxxxxxx
    logging synchronous
    !
    ntp clock-period 17180262
    ntp server 198.82.1.201 key 0 prefer
    ntp server 198.82.1.202 key 0
    end
    Reply With Quote Quote  

  7. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #6
    dial-peer voice 1 voip
    destination-pattern 1[2-9]..[2-9]......
    translation-profile outgoing 159
    voice-class codec 1
    session protocol sipv2
    session target dns:sip.flowroute.com
    dtmf-relay sip-notify
    Reply With Quote Quote  

  8. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #7
    add that and re-do your sip debug
    Reply With Quote Quote  

  9. Brain Dumps Smell Bad boostinbadger's Avatar
    Join Date
    Dec 2007
    Location
    Virginia
    Posts
    256

    Certifications
    CCENT - CCNA - WCSP - MCE
    #8
    I applied the changes you suggested. Still not getting out...The calling number still is appending the extension onto 540645 which is the first six of my DID.

    Here is the debug:



    5NINER1760CME#terminal monitor
    5NINER1760CME#
    Aug 27 01:18:49.347: //-1/FD773B50801B/CCAPI/cc_api_display_ie_subfields:
    cc_api_call_setup_ind_common:
    cisco-username=
    ----- ccCallInfo IE subfields -----
    cisco-ani=5406455902
    cisco-anitype=0
    cisco-aniplan=0
    cisco-anipi=0
    cisco-anisi=0
    dest=
    cisco-desttype=0
    cisco-destplan=0
    cisco-rdie=FFFFFFFF
    cisco-rdn=
    cisco-rdntype=0
    cisco-rdnplan=0
    cisco-rdnpi=0
    cisco-rdnsi=0
    cisco-redirectreason=0
    Aug 27 01:18:49.347: //-1/FD773B50801B/CCAPI/cc_api_call_setup_ind_common:
    Interface=0x843556F4, Call Info(
    Calling Number=5406455902(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
    Called Number=(TON=Unknown, NPI=Unknown),
    Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE,
    Incoming Dial-peer=20004, Progress Indication=ORIGINATING SIDE IS NON ISDN(3), Calling IE Present=TRUE,
    Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1
    Aug 27 01:18:49.351: //-1/FD773B50801B/CCAPI/ccCheckClipClir:
    In: Calling Number=5406455902(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
    Aug 27 01:18:49.351: //-1/FD773B50801B/CCAPI/ccCheckClipClir:
    Out: Calling Number=5406455902(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
    Aug 27 01:18:49.351: //25/FD773B50801B/CCAPI/cc_api_call_setup_ind_common:
    Set Up Event Sent;
    Call Info(Calling Number=5406455902(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
    Called Number=(TON=Unknown, NPI=Unknown))
    Aug 27 01:18:49.355: //25/FD773B50801
    5NINER1760CME#B/CCAPI/cc_process_call_setup_ind:
    Event=0x842135C8
    Aug 27 01:18:49.359: //25/FD773B50801B/CCAPI/ccCallSetContext:
    Context=0x82E16BDC
    Aug 27 01:18:49.359: //25/FD773B50801B/CCAPI/cc_process_call_setup_ind:
    >>>>CCAPI handed cid 25 with tag 20004 to app "_ManagedAppProcess_Default"
    Aug 27 01:18:49.359: //25/FD773B50801B/CCAPI/ccCallSetupAck:
    Call Id=25
    Aug 27 01:18:49.359: //25/FD773B50801B/CCAPI/cc_api_set_transfer_info:
    Transfer Number=, Transfer Reason=0x0
    Aug 27 01:18:49.363: //25/FD773B50801B/CCAPI/ccGenerateToneInfo:
    Stop Tone On Digit=TRUE, Tone=Dial Tone,
    Tone Direction=Network, Params=0x0, Call Id=25
    Aug 27 01:18:49.363: //25/FD773B50801B/CCAPI/ccSetDigitTimeouts:
    Initial Digit Timeout=-1000(ms), Inter Digit Timeout=-1000(ms)
    Aug 27 01:18:49.363: //25/FD773B50801B/CCAPI/ccSetDigitTimeouts:
    Call Entry(Inter Digit Timeout=10000(ms), Initial Digit Timeout=10000(ms))
    Aug 27 01:18:49.363: //25/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:
    (callID=0x19, digit_event=0x1, enable=TRUE, consume=FALSE)
    Aug 27 01:18:49.363: //25/FD773B50801B/CCAPI/ccCallReportDigits:
    Enabled=TRUE, Call Id=25
    Aug 27 01:18:49.363: //25/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:
    (vdbPtr=0x843556F4, callID=0x19, disp=0, digit_event=0x1, enable=TRUE, consume=FALSE)
    Aug 27 01:18:49.367: //25/FD773B50801B/CCAPI/cc_api_call_report_digits_done:
    Enabled=TRUE, Disposition=0x0, Interface=0x843556F4, Call Id=25
    Aug 27 01:18:49.367: //25/FD773B50801B/CCAPI/cc_api_call_report_digits_done:
    Call Entry(Initial Digit Timeout=10000(ms), Inter Digit Timeout=10000(ms))
    5NINER1760CME#
    Aug 27 01:18:52.647: //25/FD773B50801B/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=1, DigitBeginFlags=0x0,
    Rtp Timestamp=0x57E40, Rtp Expiration=0x0
    Aug 27 01:18:52.651: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=1, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 27 01:18:52.651: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 27 01:18:52.903: //25/FD773B50801B/CCAPI/cc_api_call_digit_begin:

    5NINER1760CME#Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=5, DigitBeginFlags=0x0,
    Rtp Timestamp=0x5FB40, Rtp Expiration=0x0
    Aug 27 01:18:52.903: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=5, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 27 01:18:52.907: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 27 01:18:53.159: //25/FD773B50801B/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=4, DigitBeginFlags=0x0,
    Rtp Timestamp=0x67840, Rtp Expiration=0x0
    Aug 27 01:18:53.159: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=4, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 27 01:18:53.163: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 27 01:18:53.667: //25/FD773B50801B/CCAPI/cc_api_call_digit_begin:

    5NINER1760CME#Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=0, DigitBeginFlags=0x0,
    Rtp Timestamp=0x6F540, Rtp Expiration=0x0
    Aug 27 01:18:53.667: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=0, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 27 01:18:53.671: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 27 01:18:54.427: //25/FD773B50801B/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=3, DigitBeginFlags=0x0,
    Rtp Timestamp=0x77240, Rtp Expiration=0x0
    Aug 27 01:18:54.431: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=3, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 27 01:18:54.431: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 27 01:18:54.683: //25/FD773B50801B/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=2, DigitBeginFlags=0x0,
    Rtp Timestamp=0x7EF40, Rtp Expiration=0x0
    Aug 27 01:18:54.687: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=2, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 27 01:18:54.687: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 27 01:18:54.939: //25/FD773B50801B/CCAPI/cc_api_call_digit_begin:

    5NINER1760CME#Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=7, DigitBeginFlags=0x0,
    Rtp Timestamp=0x86C40, Rtp Expiration=0x0
    Aug 27 01:18:54.939: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=7, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 27 01:18:54.943: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 27 01:18:55.447: //25/FD773B50801B/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=1, DigitBeginFlags=0x0,
    Rtp Timestamp=0x8E940, Rtp Expiration=0x0
    Aug 27 01:18:55.451: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=1, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 27 01:18:55.451: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 27 01:18:55.703: //25/FD773B50801B/CCAPI/cc_api_call_digit_begin:

    5NINER1760CME#Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=7, DigitBeginFlags=0x0,
    Rtp Timestamp=0x96640, Rtp Expiration=0x0
    Aug 27 01:18:55.703: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=7, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 27 01:18:55.707: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 27 01:18:56.211: //25/FD773B50801B/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=8, DigitBeginFlags=0x0,
    Rtp Timestamp=0x9E340, Rtp Expiration=0x0
    Aug 27 01:18:56.211: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=8, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 27 01:18:56.215: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 27 01:18:56.467: //25/FD773B50801B/CCAPI/cc_api_call_digit_begin:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=9, DigitBeginFlags=0x0,
    Rtp Timestamp=0xA6040, Rtp Expiration=0x0
    Aug 27 01:18:56.471: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Destination Interface=0x0, Destination Mask=0x3, Destination Call Id=-1,
    Source Call Id=25, Digit=9, Duration=100,
    Xrule Calling Tag=0, Xrule Called Tag=0, Digit Tone Mode=DTMF
    Aug 27 01:18:56.471: //25/FD773B50801B/CCAPI/cc_api_call_digit_end:
    Call Entry(Handoff Depth=0)
    Aug 27 01:18:56.471: //25/xxxxxxxxxxxx/CCAPI/ccCallReportDigits:
    (callID=0x19, digit_event=0x0, enable=FALSE, consume=FALSE)
    Aug 27 01:18:56.475: //25/FD773B50801B/CCAPI/ccCallReportDigits:
    Enabled=TRUE, Call Id=25
    Aug 27 01:18:56.475: //25/xxxxxxxxxxxx/CCAPI/cc_api_call_report_digits_done:
    (vdbPtr=0x843556F4, callID=0x19, disp=0, digit_event=0x0, enable=FALSE, consume=FALSE)
    Aug 27 01:18:56.475: //25/FD773B50801B/CCAPI/cc_api_call_report_digits_done:
    Enabled=TRUE, Disposition=0x0, Interface=0x843556F4, Call Id=25
    Aug 27 01:18:56.475: //25/FD773B50801B/CCAPI/cc_api_call_report_digits_done:
    Call Entry(Initial Digit Timeout=10000(ms), Inter Digit Timeout=10000(ms))
    Aug 27 01:18:56.483: //25/FD773B50801B/CCAPI/ccCallSetupRequest:
    Destination=, Calling IE Present=TRUE, Mode=0,
    Outgoing Dial-peer=1, Params=0x82E1787C, Progress Indication=ORIGINATING SIDE IS NON ISDN(3)
    Aug 27 01:18:56.483: //25/FD773B50801B/CCAPI/ccCheckClipClir:
    In: Calling Number=5406455902(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
    Aug 27 01:18:56.483: //25/FD773B50801B/CCAPI/ccCheckClipClir:
    Out: Calling Number=5406455902(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
    Aug 27 01:18:56.483: //25/FD773B50801B/CCAPI/ccCallSetupRequest:
    Destination Pattern=1[2-9]..[2-9]......, Called Number=1540327####, Digit Strip=FALSE
    Aug 27 01:18:56.483: //25/FD773B50801B/CCAPI/ccCallSetupRequest:
    Calling Number=5406455902(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
    Called Number=1540327####(TON=Unknown, NPI=Unknown),
    Redirect Number=, Display Info=Kitchen
    Account Number=, Final Destination Flag=FALSE,
    Guid=FD773B50-EF1B-11E1-801B-BD624C466F78, Outgoing Dial-peer=1
    Aug 27 01:18:56.487: //25/FD773B50801B/CCAPI/cc_api_display_ie_subfields:
    ccCallSetupRequest:
    cisco-username=
    ----- ccCallInfo IE subfields -----
    cisco-ani=5406455902
    cisco-anitype=0
    cisco-aniplan=0
    cisco-anipi=0
    cisco-anisi=0
    dest=1540327####
    cisco-desttype=0
    cisco-destplan=0
    cisco-rdie=FFFFFFFF
    cisco-rdn=
    cisco-rdntype=0
    cisco-rdnplan=0
    cisco-rdnpi=0
    cisco-rdnsi=0
    cisco-redirectreason=0
    Aug 27 01:18:56.487: //25/FD773B50801B/CCAPI/ccIFCallSetupRequestPrivate:
    Interface=0x83B393A8, Interface Type=3, Destination=, Mode=0x0,
    Call Params(Calling Number=5406455902(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
    Called Number=1540327####(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,
    Subscriber Type Str=RegularLine, FinalDestinationFlag=FALSE, Outgoing Dial-peer=1, Call Count On=FALSE,
    Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)
    Aug 27 01:18:56.491: //26/FD773B50801B/CCAPI/ccIFCallSetupRequestPrivate:
    SPI Call Setup Request Is Success; Interface Type=3, FlowMode=1
    Aug 27 01:18:56.491: //26/FD773B50801B/CCAPI/ccCallSetContext:
    Context=0x82E1782C
    Aug 27 01:18:56.491: //25/FD773B50801B/CCAPI/ccSaveDialpeerTag:
    Outgoing Dial-peer=1
    Aug 27 01:18:56.495: //26/FD773B50801B/CCAPI/cc_api_call_proceeding:
    Interface=0x83B393A8, Progress Indication=NULL(0)
    Aug 27 01:18:56.511: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    INVITE sip:1540327####@sip.flowroute.com:5060 SIP/2.0

    Via: SIP/2.0/UDP 10.59.1.4:5060;branch=z9hG4bK1712FB

    From: "Kitchen" <sip:1540645####@sip.flowroute.com>;tag=3B723-264A

    To: <sip:1540327####@sip.flowroute.com>

    Date: Mon, 27 Aug 2012 01:18:56 GMT

    Call-ID: 1BA9048-EF1C11E1-801EBD62-4C466F78@10.59.1.4

    Supported: 100rel,timer,resource-priority,replaces

    Min-SE: 1800

    Cisco-Guid: 4252449616-4011528673-2149301602-1279684472

    User-Agent: Cisco-SIPGateway/IOS-12.x

    Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER

    CSeq: 101 INVITE

    Max-Forwards: 70

    Timestamp: 1346030336

    Contact: <sip:1540645####@10.59.1.4:5060>

    Call-Info: <sip:10.59.1.4:5060>;method="NOTIFY;Event=telephon e-event;Duration=2000"

    Expires: 180

    Allow-Events: telephone-event

    Content-Type: application/sdp

    Content-Disposition: session;handling=required

    Content-Length: 265



    v=0

    o=CiscoSystemsSIP-GW-UserAgent 4676 7512 IN IP4 10.59.1.4

    s=SIP Call

    c=IN IP4 10.59.1.4

    t=0 0

    m=audio 17316 RTP/AVP 18 0 8 19

    c=IN IP4 10.59.1.4

    a=rtpmap:18 G729/8000

    a=fmtp:18 annexb=no

    a=rtpmap:0 PCMU/8000

    a=rtpmap:8 PCMA/8000

    a=rtpmap:19 CN/8000


    Aug 27 01:18:56.511: //25/FD773B50801B/CCAPI/ccCallProceeding:
    Progress Indication=NULL(0)
    Aug 27 01:18:56.607: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Received:
    SIP/2.0 100 Trying

    Via: SIP/2.0/UDP 10.59.1.4:5060;branch=z9hG4bK1712FB;received=174.5 3.75.18

    From: "Kitchen" <sip:1540645####@sip.flowroute.com>;tag=3B723-264A

    To: <sip:1540327####@sip.flowroute.com>

    Call-ID: 1BA9048-EF1C11E1-801EBD62-4C466F78@10.59.1.4

    CSeq: 101 INVITE

    Content-Length: 0





    Aug 27 01:18:56.611: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Received:
    SIP/2.0 407 Proxy Authentication Required

    Via: SIP/2.0/UDP 10.59.1.4:5060;rport=55766;received=174.53.75.18;b ranch=z9hG4bK1712FB

    From: "Kitchen" <sip:1540645####@sip.flowroute.com>;tag=3B723-264A

    To: <sip:1540327####@sip.flowroute.com>;tag=da160a8e05 34d7b0db4afd8620a22cb7.707e

    Call-ID: 1BA9048-EF1C11E1-801EBD62-4C466F78@10.59.1.4

    CSeq: 101 INVITE

    Proxy-Authenticate: Digest realm="sip.flowroute.com", nonce="UDrMLVA6ywEEhfQMqB0b+Sk0YaBVsFZ0", qop="auth"

    Content-Length: 0





    Aug 27 01:18:56.615: //26/FD773B50801B/CCAPI/cc_api_call_disconnected:
    Cause Value=47, Interface=0x83B393A8, Call Id=26
    Aug 27 01:18:56.619: //26/FD773B50801B/CCAPI/cc_api_call_disconnected:
    Call Entry(Responsed=TRUE, Cause Value=47, Retry Count=0)
    Aug 27 01:18:56.619: //25/xxxxxxxxxxxx/CCAPI/ccCallReleaseResources:
    release reserved xcoding resource.
    Aug 27 01:18:56.619: //26/FD773B50801B/CCAPI/ccCallSetAAA_Accounting:
    Accounting=0, Call Id=26
    Aug 27 01:18:56.619: //26/FD773B50801B/CCAPI/ccCallDisconnect:
    Cause Value=47, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=47)
    Aug 27 01:18:56.619: //26/FD773B50801B/CCAPI/ccCallDisconnect:
    Cause Value=47, Call Entry(Responsed=TRUE, Cause Value=47)
    Aug 27 01:18:56.623: //26/FD773B50801B/CCAPI/cc_api_call_disconnect_done:
    Disposition=0, Interface=0x83B393A8, Tag=0x0, Call Id=26,
    Call Entry(Disconnect Cause=47, Voice Class Cause Code=0, Retry Count=0)
    Aug 27 01:18:56.627: //26/FD773B50801B/CCAPI/cc_api_call_disconnect_done:
    Call Disconnect Event Sent
    Aug 27 01:18:56.631: //25/FD773B50801B/CCAPI/ccCallDisconnect:
    Cause Value=47, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
    Aug 27 01:18:56.631: //25/FD773B50801B/CCAPI/ccCallDisconnect:
    Cause Value=47, Call Entry(Responsed=TRUE, Cause Value=47)
    Aug 27 01:18:56.631: //25/FD773B50801B/CCAPI/cc_api_get_transfer_info:
    Transfer Number Is Null
    Aug 27 01:18:56.631: //25/FD773B50801B/CCAPI/cc_api_call_disc_cause_update:
    Cause Value=16
    Aug 27 01:18:56.635: //25/FD773
    5NINER1760CME#B50801B/CCAPI/cc_api_call_disc_cause_update:
    Call Entry(Disconnect Cause=16)
    Aug 27 01:18:56.639: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    ACK sip:1540327####@sip.flowroute.com:5060 SIP/2.0

    Via: SIP/2.0/UDP 10.59.1.4:5060;branch=z9hG4bK1712FB

    From: "Kitchen" <sip:1540645####@sip.flowroute.com>;tag=3B723-264A

    To: <sip:1540327####@sip.flowroute.com>;tag=da160a8e05 34d7b0db4afd8620a22cb7.707e

    Date: Mon, 27 Aug 2012 01:18:56 GMT

    Call-ID: 1BA9048-EF1C11E1-801EBD62-4C466F78@10.59.1.4

    Max-Forwards: 70

    CSeq: 101 ACK

    Content-Length: 0





    5NINER1760CME#
    Aug 27 01:19:00.063: //25/FD773B50801B/CCAPI/cc_api_call_disconnect_done:
    Disposition=0, Interface=0x843556F4, Tag=0x0, Call Id=25,
    Call Entry(Disconnect Cause=16, Voice Class Cause Code=0, Retry Count=0)
    Aug 27 01:19:00.063: //25/FD773B50801B/CCAPI/cc_api_call_disconnect_done:
    Call Disconnect Event Sent
    Aug 27 01:19:01.171: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Received:
    OPTIONS sip:174.53.75.18:55766 SIP/2.0

    Max-Forwards: 10

    Record-Route: <sip:216.115.69.144;lr>

    Via: SIP/2.0/UDP 216.115.69.144;branch=z9hG4bK5d51.6680dee944894223 a7e38ed9a5410bbf.0

    Via: SIP/2.0/UDP 70.167.153.136:5060;branch=0

    Route: <sip:216.115.69.144;lr;received="sip:174.53.75.18: 55766">

    From: siping@invalid;tag=e262dbe3

    To: sip:174.53.75.18:55766

    Call-ID: 3bed14f2-93d688d7-a08ff16@70.167.153.136

    CSeq: 1 OPTIONS

    Content-Length: 0
    Last edited by boostinbadger; 08-27-2012 at 01:29 AM.
    Reply With Quote Quote  

  10. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #9
    You keep stripping digits from your posts:

    What is the DID associated with your flowroute account? What is the FULL DID.. Do you have multiple DID's on this trunk?
    How are you suppose to authenticate to flowroute? I see in the debugs a 407 Proxy Auth Required - I would take XLite and register the soft-phone to flowroute to make sure everything is kosher.

    You say the calling number is incorrect, explain. ?? I see calling-info pstn-to-sip from number set 1540645xxxx in your config.. take this out

    re-run your debug but dont do voip ccapi inout just the debug ccsip messages
    Reply With Quote Quote  

  11. Brain Dumps Smell Bad boostinbadger's Avatar
    Join Date
    Dec 2007
    Location
    Virginia
    Posts
    256

    Certifications
    CCENT - CCNA - WCSP - MCE
    #10
    I will send you a PM with all the numbers in the debug output.
    Reply With Quote Quote  

  12. Brain Dumps Smell Bad boostinbadger's Avatar
    Join Date
    Dec 2007
    Location
    Virginia
    Posts
    256

    Certifications
    CCENT - CCNA - WCSP - MCE
    #11
    Here is the output from show telephony-service:

    5NINER1760CME#show telephony-service
    CONFIG [Version=3.4(0)]
    ========================
    Version 3.4(0)
    Cisco CallManager Express
    For on-line documentation please see:
    Cisco CallManager Express and Cisco IOS Telephony

    ip source-address 10.159.1.1 port 2000
    max-ephones 5
    max-dn 5
    max-conferences 4 gain -6
    dspfarm units 0
    dspfarm transcode sessions 0
    hunt-group report delay 1 hours
    max-redirect 5
    dialplan-pattern 1 5406455... extension-length 4
    time-format 12
    date-format mm-dd-yy
    timezone 0 Greenwich Standard Time
    keepalive 30
    timeout interdigit 10
    timeout busy 10
    timeout ringing 180
    caller-id name-only: enable
    system message
    web admin system name Admin
    web admin customer name Customer
    edit DN through Web: disabled.
    edit TIME through web: disabled.
    Log (table parameters):
    max-size: 150
    retain-timer: 15
    create cnf-files version-stamp 7960 Aug 23 2012 22:18:38
    transfer-system full-consult
    auto assign 1 to 5
    local directory service: enabled.
    Reply With Quote Quote  

  13. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #12
    take out dialplan-pattern 1 5406455... extension-length 4
    Reply With Quote Quote  

  14. Brain Dumps Smell Bad boostinbadger's Avatar
    Join Date
    Dec 2007
    Location
    Virginia
    Posts
    256

    Certifications
    CCENT - CCNA - WCSP - MCE
    #13
    Made the change. Still the same problem. After dialing the numbers I get a fast busy.
    Reply With Quote Quote  

  15. Brain Dumps Smell Bad boostinbadger's Avatar
    Join Date
    Dec 2007
    Location
    Virginia
    Posts
    256

    Certifications
    CCENT - CCNA - WCSP - MCE
    #14
    A fast busy plus "Unknown Number" on the display
    Reply With Quote Quote  

  16. Brain Dumps Smell Bad boostinbadger's Avatar
    Join Date
    Dec 2007
    Location
    Virginia
    Posts
    256

    Certifications
    CCENT - CCNA - WCSP - MCE
    #15
    Big breakthrough....

    I now have outbound calling working from both phones along with phone to phone. My active SIP registrations at flowroute are showing up weird now though. Instead of showing one I am showing 10:


    sip:174.xx.xx.xx:50403 2012-09-05 00:09:33 Cisco-SIPGateway/IOS-12.x
    sip:174.xx.xx.xx:50403 2012-09-05 00:09:33 Cisco-SIPGateway/IOS-12.x
    sip:174.xx.xx.xx:50403 2012-09-05 00:09:33 Cisco-SIPGateway/IOS-12.x
    sip:174.xx.xx.xx:50403 2012-09-05 00:09:33 Cisco-SIPGateway/IOS-12.x
    sip:174.xx.xx.xx:50403 2012-09-05 00:09:33 Cisco-SIPGateway/IOS-12.x
    sip:174.xx.xx.xx:56444 2012-09-05 00:09:16 Cisco-SIPGateway/IOS-12.x
    sip:174.xx.xx.xx:56444 2012-09-05 00:09:16 Cisco-SIPGateway/IOS-12.x
    sip:174.xx.xx.xx:56444 2012-09-05 00:09:16 Cisco-SIPGateway/IOS-12.x
    sip:174.xx.xx.xx:56444 2012-09-05 00:09:16 Cisco-SIPGateway/IOS-12.x
    sip:174.xx.xx.xx:56444 2012-09-05 00:09:16 Cisco-SIPGateway/IOS-12.x

    Here is the output from a "show sip-ua register status"

    5NINER1760CME#show sip-ua register status
    Line peer expires(sec) registered
    ============ ============= ============ ===========
    5901 20001 2176 yes
    5902 20002 2176 yes
    5903 20003 2176 yes
    5904 20004 2176 yes
    5905 20005 1970 yes


    My flowroute username used to appear under the first five line's and it would be the only one registered. Now it doesn't show up at all and all five of my lines are showing as registered. 5903-5905 don't even exist.

    I did take out (from sip-ua):

    credentials username xxxxxxxx password xxxxxxxx realm sip.flowroute.com

    and replaced it with

    authentication username xxxxxxxx password xxxxxxxx realm sip.flowroute.com




    Here is the current config:

    hostname 5NINER1760CME
    !
    boot-start-marker
    boot-end-marker
    !
    aaa new-model
    !
    !
    aaa authentication login default local
    aaa authorization exec default local
    aaa authorization network default local
    !
    aaa session-id common
    !
    resource policy
    !
    clock timezone EST -5
    clock summer-time EDT recurring
    ip cef
    !
    no ip dhcp use vrf connected
    !
    ip dhcp pool VOICE-SCOPE
    network 10.159.1.0 255.255.255.248
    default-router 10.159.1.1
    dns-server 216.146.36.36
    option 150 ip 10.159.1.1
    !
    ip domain name 5NINER
    ip name-server 216.146.35.35
    ip name-server 216.146.36.36
    !
    voice service voip
    allow-connections sip to sip
    sip
    !
    voice class codec 1
    codec preference 1 g729r8
    codec preference 2 g711ulaw
    codec preference 3 g711alaw
    !
    voice register global
    mode cme
    !
    voice translation-rule 159
    rule 1 /.*/ /xxxxxxx/ #removed
    !
    voice translation-profile Outbound-DID
    translate calling 159
    !
    interface FastEthernet0/0
    no ip address
    speed 100
    !
    interface FastEthernet0/0.59
    description ROUTER INTERFACE FOR DATA VLAN
    encapsulation dot1Q 59 native
    ip address 10.59.1.4 255.255.255.224
    no snmp trap link-status
    !
    interface FastEthernet0/0.159
    description ROUTER INTERFACE FOR VOICE VLAN
    encapsulation dot1Q 159
    ip address 10.159.1.1 255.255.255.248
    no snmp trap link-status
    !
    interface FastEthernet0/1
    switchport access vlan 59
    !
    interface FastEthernet0/2
    switchport access vlan 59
    !
    interface FastEthernet0/3
    switchport access vlan 159
    !
    interface FastEthernet0/4
    switchport access vlan 159
    !
    interface Vlan1
    no ip address
    shutdown
    !
    interface Vlan59
    no ip address
    no autostate
    !
    interface Vlan159
    no ip address
    no autostate
    !
    ip default-gateway 10.59.1.1
    ip route 0.0.0.0 0.0.0.0 10.59.1.1
    !
    ip http server
    ip http authentication local
    no ip http secure-server
    !
    tftp-server flash:P00303020209.bin
    tftp-server flash0030801sr02
    tftp-server flash0030801sr02.bin
    tftp-server flash0030801sr02.sbn
    tftp-server flash0030801sr02.sb2
    tftp-server flash0030801sr02.loads
    !
    control-plane
    !
    dial-peer voice 1 voip
    translation-profile outgoing 159
    destination-pattern 1[2-9]..[2-9]......
    translate-outgoing called 159
    voice-class codec 1
    session protocol sipv2
    session target dns:sip.flowroute.com
    dtmf-relay sip-notify
    !
    sip-ua
    authentication username xxxxxxxx password xxxxxxxx realm sip.flowroute.com
    calling-info pstn-to-sip from number set xxxxxxxxxxx
    no remote-party-id
    registrar dns:sip.flowroute.com expires 3600
    !
    telephony-service
    max-ephones 5
    max-dn 5
    ip source-address 10.159.1.1 port 2000
    auto assign 1 to 5
    create cnf-files version-stamp 7960 Aug 23 2012 22:18:38
    max-conferences 4 gain -6
    transfer-system full-consult
    !
    ephone-dn 1
    number 5901
    label Basement
    name Basement
    !
    ephone-dn 2
    number 5902
    label Kitchen
    name Kitchen
    !
    ephone-dn 3
    number 5903
    !
    ephone-dn 4
    number 5904
    !
    ephone-dn 5
    number 5905
    !
    ephone 1
    mac-address 0016.C815.5A6D
    type 7960
    button 1:1
    !
    ephone 2
    mac-address 0015.2BD4.1926
    type 7940
    button 1:2
    !
    ephone 3
    !
    ephone 4
    !
    ephone 5
    !
    ntp clock-period 17180300
    ntp server 198.82.1.201 key 0 prefer
    ntp server 198.82.1.202 key 0
    end
    Reply With Quote Quote  

  17. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #16
    Well a fast busy is just a call failure, where is your sip debug?
    Reply With Quote Quote  

  18. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #17
    dial-peer voice 1 voip
    translation-profile outgoing 159
    destination-pattern 1[2-9]..[2-9]......
    translate-outgoing called 159 <--- ?? why are you translating the called number
    Last edited by drkat; 09-05-2012 at 02:26 PM.
    Reply With Quote Quote  

  19. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #18
    any update on this bud?
    Reply With Quote Quote  

  20. Brain Dumps Smell Bad boostinbadger's Avatar
    Join Date
    Dec 2007
    Location
    Virginia
    Posts
    256

    Certifications
    CCENT - CCNA - WCSP - MCE
    #19
    Actually yes...

    I was working on it last Friday evening. I called my cell and it rang. I called my DID from my cell and someone else picked up. I updated my ticket with flowroute and they just got back to me and said the DID I had picked last year was ported around the same time last year. They refunded all the money that was used from my account and said I could pick another number.
    Reply With Quote Quote  

  21. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #20
    nice.......
    Reply With Quote Quote  

  22. Brain Dumps Smell Bad boostinbadger's Avatar
    Join Date
    Dec 2007
    Location
    Virginia
    Posts
    256

    Certifications
    CCENT - CCNA - WCSP - MCE
    #21
    Ok....I am revisiting my CME setup. I made several changes to my config but I am still getting a "all circuits are busy now" when dialing inboud. Outbound calls are working fine. When I look at my flowroute account it shows two active registrations as does show sip-ua registrar status.

    My CME router does sit behind my home Linksys router.

    Here is my config. I think I am pretty close:

    no ip dhcp use vrf connected
    !
    ip dhcp pool VOICE-SCOPE
    network 10.159.1.0 255.255.255.248
    default-router 10.159.1.1
    dns-server 216.146.36.36
    option 150 ip 10.159.1.1
    !
    !
    ip domain name 5NINER
    ip name-server 216.146.35.35
    ip name-server 216.146.36.36
    ip ddns update method no-ip
    !
    !
    !
    !
    voice service voip
    allow-connections sip to sip
    sip
    registrar server expires max 3600 min 3600
    !
    !
    !
    voice class codec 1
    codec preference 1 g729r8
    codec preference 2 g711ulaw
    codec preference 3 g711alaw
    !
    !
    !
    !
    !
    !
    !
    !
    voice translation-rule 159
    rule 1 /.*/ /5514005/
    !
    !
    voice translation-profile Outbound-DID
    translate called 159
    !
    !
    !
    !

    !
    !
    !
    interface FastEthernet0/0
    no ip address speed 100
    !
    interface FastEthernet0/0.59
    description ROUTER INTERFACE FOR DATA VLAN
    encapsulation dot1Q 59 native
    ip address 10.59.1.4 255.255.255.224
    !
    interface FastEthernet0/0.159
    description ROUTER INTERFACE FOR VOICE VLAN
    encapsulation dot1Q 159
    ip address 10.159.1.1 255.255.255.248
    !
    interface FastEthernet0/1
    switchport access vlan 59
    !
    interface FastEthernet0/2
    switchport access vlan 59
    !
    interface FastEthernet0/3
    switchport access vlan 159
    !
    interface FastEthernet0/4
    switchport access vlan 159
    !
    interface Vlan1
    no ip address
    shutdown
    !
    interface Vlan59
    no ip address
    no autostate
    !
    interface Vlan159
    no ip address
    no autostate
    !
    ip default-gateway 10.59.1.1
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 10.59.1.1
    !
    ip http server
    ip http authentication local
    no ip http secure-server
    !
    tftp-server flash:P00308000400.bin
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    dial-peer voice 1 voip
    description INCOMING CALL FROM FLOWROUTE
    translation-profile incoming Outbound-DID
    voice-class codec 1
    session protocol sipv2
    session target sip-server
    incoming called-number .%
    dtmf-relay rtp-nte
    no vad
    !
    dial-peer voice 2 voip
    description OUTGOING CALL TO FLOWROUTE
    destination-pattern 1[2-9]..[2-9]......
    voice-class codec 1
    session protocol sipv2
    session target sip-server
    dtmf-relay rtp-nte
    no vad
    !
    sip-ua
    authentication username 86377111 password 141102330E0F330C010E6A2111
    calling-info pstn-to-sip from number set 15405514111
    no remote-party-id
    retry invite 2
    retry register 10
    timers connect 100
    registrar dns:sip.flowroute.com expires 3600
    sip-server dns:sip.flowroute.com
    !
    !
    telephony-service
    load 7960-7940 P00308000400
    max-ephones 2
    max-dn 2
    ip source-address 10.159.1.1 port 2000
    auto assign 1 to 2
    create cnf-files version-stamp 7960 Nov 26 2012 22:30:48
    max-conferences 4 gain -6
    !
    !
    ephone-dn 1
    number 5901
    label Basement
    name Basement
    !
    !
    ephone-dn 2
    number 5902
    label Kitchen
    name Kitchen
    !
    !
    ephone 1
    mac-address 0016.C815.5A6D
    type 7960
    button 1:1 2:2
    !
    !
    !
    ephone 2
    mac-address 0015.2BD4.1926
    type 7940
    button 1:2 2:1
    !
    !
    !
    !
    ntp clock-period 17180279
    ntp master
    ntp server 198.82.1.201 key 0 prefer
    ntp server 198.82.1.202 key 0
    end
    Reply With Quote Quote  

  23. Senior Member
    Join Date
    May 2009
    Location
    DMV
    Posts
    2,202

    Certifications
    CCNP, CCNP(V), S+ CCIE V(written)
    #22
    do a debug

    debug ccsip calls
    debug ccsip messages
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks