+ Reply to Thread
Page 2 of 2 First 12
Results 26 to 37 of 37
  1. Member Diggs's Avatar
    Join Date
    Jun 2012
    Location
    Paradise
    Posts
    97

    Certifications
    A+, Network+, CCENT, CCNA
    #26
    I've tried adding the SCCP41.8-5-3S load command already with no success.

    No I did not look to see what the firmware version of the phones were - I was having issues getting them to register originally (which was likely just an incorrect config) and I thought it would be best to wipe them and start fresh.

    I have no idea what's currently on the phones and don't know how to check...I can only assume it's pre version 6.

    If I manage to track down a copy of the 7.0(2) version of the firmware does that look like that may help or is it possible I've completely bricked these things?

    If you factory reset them should they not at least work with the version of firmware they were shipped from the factory with?
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member
    Join Date
    Jan 2012
    Posts
    1,250

    Certifications
    BS IT (CCNA R&S, Security, Voice) CCDA, MCP XP, A+, L+, P+, LPIC-1, SUSE CLA
    #27
    If you factory reset them they will keep cycling on and off looking for the software.
    In life you have to make your own opportunities. Don't let anyone stop you from your dreams to many negative people want you to fail because they can't succeed.
    Reply With Quote Quote  

  4. Member Diggs's Avatar
    Join Date
    Jun 2012
    Location
    Paradise
    Posts
    97

    Certifications
    A+, Network+, CCENT, CCNA
    #28
    Should they work with an older version of firmware like 7.0(2) if I can acquire it?

    If so would I be able to buy another 7961 / 7941 off ebay with the version of firmware I need, extract a copy off the phone into the routers flash and serve it to my other phones?

    How can I check to see what firmware version the phone is running on?
    Reply With Quote Quote  

  5. Senior Member
    Join Date
    Jan 2012
    Posts
    1,250

    Certifications
    BS IT (CCNA R&S, Security, Voice) CCDA, MCP XP, A+, L+, P+, LPIC-1, SUSE CLA
    #29
    I don't think you can upload the files from the phone onto the flash. Remember the phone is essentially a dummy terminal it gets all the data from call manager. If you can access the settings you find out the version

    -press settings on the keypad
    -model information
    -scroll down and see the load file
    In life you have to make your own opportunities. Don't let anyone stop you from your dreams to many negative people want you to fail because they can't succeed.
    Reply With Quote Quote  

  6. Senior Member
    Join Date
    Jan 2012
    Posts
    1,250

    Certifications
    BS IT (CCNA R&S, Security, Voice) CCDA, MCP XP, A+, L+, P+, LPIC-1, SUSE CLA
    #30
    It just came to mind one thing you can try is make your pc option 150 and run the tftp program to see what software its looking for and do a search online to see what version its for.
    In life you have to make your own opportunities. Don't let anyone stop you from your dreams to many negative people want you to fail because they can't succeed.
    Reply With Quote Quote  

  7. Member Diggs's Avatar
    Join Date
    Jun 2012
    Location
    Paradise
    Posts
    97

    Certifications
    A+, Network+, CCENT, CCNA
    #31
    Can't access the settings on the phone - they just continually power cycle.

    I was able to do a cdp neigh detail and it says 79XX_default_load.

    Have also tried using my PC and my router for the TFTP server - pretty sure it just wants the term61.default.load file.
    Reply With Quote Quote  

  8. Senior Member
    Join Date
    Jan 2012
    Posts
    1,250

    Certifications
    BS IT (CCNA R&S, Security, Voice) CCDA, MCP XP, A+, L+, P+, LPIC-1, SUSE CLA
    #32
    Quote Originally Posted by Diggs View Post
    Have also tried using my PC and my router for the TFTP server - pretty sure it just wants the term61.default.load file.
    Well are you pretty sure or are you sure that the only file its prompting for is the term61.default.load on the tftp server running on your computer. Does the folder that its pointed too have that file?
    In life you have to make your own opportunities. Don't let anyone stop you from your dreams to many negative people want you to fail because they can't succeed.
    Reply With Quote Quote  

  9. Member Diggs's Avatar
    Join Date
    Jun 2012
    Location
    Paradise
    Posts
    97

    Certifications
    A+, Network+, CCENT, CCNA
    #33
    The term61.default.load file is the only file that I can ever recall it requesting specifically.

    I have made sure that all of the files that they are requesting, or even should request (that are in my flash) are in the TFTP servers directory.
    Reply With Quote Quote  

  10. Senior Member pitviper's Avatar
    Join Date
    May 2008
    Location
    Right Coast, US
    Posts
    1,363

    Certifications
    CCNP:Collaboration, CCNP:R+S, CCNA:R+S, CCNA:V(IIUC), CCNA:S, CCENT, CNSS 4011
    #34
    See if this command is available on the router - I don't recall running into it before 15.2, but it might be worth a check.

    file privilege 0
    Reply With Quote Quote  

  11. Member Diggs's Avatar
    Join Date
    Jun 2012
    Location
    Paradise
    Posts
    97

    Certifications
    A+, Network+, CCENT, CCNA
    #35
    It doesn't look like that command is recognized in the version of IOS my router is running (15.1(4)M5)

    I tried it in global config and telephony-service.
    Reply With Quote Quote  

  12. Member Diggs's Avatar
    Join Date
    Jun 2012
    Location
    Paradise
    Posts
    97

    Certifications
    A+, Network+, CCENT, CCNA
    #36
    OK so a bit of an update:

    One of the sellers I purchased the IP Phones from was able to forward me a copy of the firmware files I requested - at least I think they're the ones I need but at few of them seem to follow a slightly different naming convention. The term41 / 61 loads files are capitalized and I expected to see a SCCP41.7.0.2 file of some sort which there wasn't. Do they look like they're complete?

    These are the files I was sent which have been served to the CME router:

    Code:
    176    1926568 Mar 12 2013 21:23:36 +00:00 cnu41.2-7-5-50.sbn
    177    1941998 Mar 12 2013 21:24:22 +00:00 CVM41.2-0-1-45.sbn
    178     689772 Mar 12 2013 21:24:36 +00:00 Jar41.2-9-1-45.sbn
    179        591 Mar 12 2013 21:24:52 +00:00 TERM41.7-0-2-0S.loads
    180        591 Mar 12 2013 21:25:14 +00:00 TERM41.DEFAULT.loads
    181        591 Mar 12 2013 21:25:42 +00:00 TERM61.DEFAULT.loads
    I have each of these files listed as a TFTP-Server global config command - when the phones fired up they appeared to request all of these just fine

    I tried the telephony-service command load 7961 TERM41.7-0-2-0S

    The phones at least load up now but spin out trying to register and eventually say "Defaulting to TFTP Server"

    This is what I get from debugging TFTP events:

    Code:
    *Mar 13 18:05:44.835: TFTP: Looking for CTLSEP001E4AF2CA3E.tlv
    *Mar 13 18:05:45.019: TFTP: Looking for SEP001E4AF2CA3E.cnf.xml
    *Mar 13 18:05:45.095: TFTP: Looking for XmlDefault.cnf.xml
    CME_R4#
    *Mar 13 18:05:59.159: TFTP: Looking for CTLSEP002497356769.tlv
    *Mar 13 18:05:59.279: TFTP: Looking for SEP002497356769.cnf.xml
    *Mar 13 18:05:59.283: TFTP: Opened system:/its/vrf1/XMLDefault7961.cnf.xml, fd 0, size 0 for process 339
    *Mar 13 18:05:59.283: TFTP: Finished system:/its/vrf1/XMLDefault7961.cnf.xml, time 00:00:00 for process 339
    CME_R4#
    *Mar 13 18:06:00.579: TFTP: Looking for CTLSEP001D450C38A3.tlv
    *Mar 13 18:06:00.759: TFTP: Looking for SEP001D450C38A3.cnf.xml
    *Mar 13 18:06:00.759: TFTP: Opened system:/its/vrf1/XMLDefault7961.cnf.xml, fd 0, size 0 for process 339
    *Mar 13 18:06:00.763: TFTP: Finished system:/its/vrf1/XMLDefault7961.cnf.xml, time 00:00:00 for process 339
    I'm not sure why one of the 3 show a quasi different result than the other 2.

    CDP shows them all running term61.default

    Code:
    POE_S1#show cdp neig det
    -------------------------
    Device ID: SEP001D450C38A3
    Entry address(es):
      IP address: 192.168.5.61
    Platform: Cisco IP Phone 7961,  Capabilities: Host Phone
    Interface: FastEthernet0/19,  Port ID (outgoing port): Port 1
    Holdtime : 129 sec
    
    Version :
    term61.default
    
    advertisement version: 2
    Duplex: full
    Power drawn: 6.300 Watts
    Power request id: 14499, Power management id: 3
    Power request levels are:6300 0 0 0 0
    Management address(es):
    
    -------------------------
    My current CME router's running-config:

    Code:
    CME_R4#show run
    Building configuration...
    
    
    Current configuration : 4852 bytes
    !
    ! Last configuration change at 18:00:39 UTC Wed Mar 13 2013
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname CME_R4
    !
    boot-start-marker
    boot-end-marker
    !
    !
    enable secret 4 tnhtc92DXBhelxjYk8LWJrPV36S2i4ntXrpb4RFmfqY
    !
    no aaa new-model
    !
    no network-clock-participate wic 0
    !
    dot11 syslog
    ip source-route
    !
    !
    ip cef
    !
    ip dhcp excluded-address 192.168.5.1 192.168.5.49
    ip dhcp excluded-address 192.168.5.250 192.168.5.255
    !
    ip dhcp pool IP_PHONE_POOL
     network 192.168.5.0 255.255.255.0
     default-router 192.168.5.1
     dns-server 4.2.2.2
     option 150 ip 192.168.5.1
    !
    !
    no ip domain lookup
    ip domain name DOMAIN.ca
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    voice-card 0
    !
    crypto pki token default removal timeout 0
    !
    crypto pki trustpoint TP-self-signed-2061784196
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-2061784196
     revocation-check none
     rsakeypair TP-self-signed-2061784196
    !
    !
    crypto pki certificate chain TP-self-signed-2061784196
     certificate self-signed 01
     
          quit
    !
    !
    license udi pid CISCO2811 sn FTX1143A49P
    username Admin privilege 15 secret 4 tnhtc92DXBhelxjYk8LWJrPV36S2i4ntXrpb4RFmfqY
    !
    redundancy
    !
    !
    controller T1 0/0/0
    !
    controller T1 0/0/1
    !
    ip ssh version 2
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
     no ip address
     duplex auto
     speed auto
    !
    interface FastEthernet0/0.1
     encapsulation dot1Q 1 native
     ip address 192.168.1.1 255.255.255.0
    !
    interface FastEthernet0/0.5
     encapsulation dot1Q 5
     ip address 192.168.5.1 255.255.255.0
    !
    interface FastEthernet0/0.7
     encapsulation dot1Q 7
     ip address 192.168.7.1 255.255.255.0
    !
    interface FastEthernet0/0.15
     encapsulation dot1Q 15
     ip address 192.168.15.1 255.255.255.0
    !
    interface FastEthernet0/1
     no ip address
     duplex auto
     speed auto
    !
    interface Serial0/2/0
     no ip address
     shutdown
     no fair-queue
     clock rate 2000000
    !
    interface Service-Engine1/0
     no ip address
     shutdown
    !
    ip forward-protocol nd
    ip http server
    ip http secure-server
    !
    !
    !
    !
    !
    !
    !
    !
    tftp-server flash:cnu41.2-7-5-50.sbn
    tftp-server flash:CVM41.2-0-1-45.sbn
    tftp-server flash:Jar41.2-9-1-45.sbn
    tftp-server flash:TERM41.7-0-2-0S.loads
    tftp-server flash:TERM41.DEFAULT.loads
    tftp-server flash:TERM61.DEFAULT.loads
    !
    control-plane
    !
    !
    voice-port 0/1/0
    !
    voice-port 0/1/1
    !
    voice-port 0/1/2
    !
    voice-port 0/1/3
    !
    !
    !
    mgcp profile default
    !
    !
    !
    !
    !
    telephony-service
     max-ephones 10
     max-dn 15
     ip source-address 192.168.5.1 port 2000
     load 7961 TERM41.7-0-2-0S
     max-conferences 8 gain -6
     transfer-system full-consult
    !
    !
    ephone-dn  1
     number 1000
    !
    !
    ephone-dn  2
     number 1001
    !
    !
    ephone-dn  3
     number 1002
    !
    !
    ephone  1
     device-security-mode none
     mac-address 0024.9735.6769
     type 7961
     button  1:1
    !
    !
    !
    ephone  2
     device-security-mode none
     mac-address 001E.4AF2.CA3E
     type 7961
     button  2:2
    !
    !
    !
    ephone  3
     device-security-mode none
     mac-address 001D.450C.38A3
     type 7961
     button  3:3
    !
    !
    !
    banner motd ^C
    *********************
    *      BANNER       *
    *********************
    ^C
    !
    line con 0
     exec-timeout 0 0
     password 7 094F471A1A0A
     logging synchronous
     login
     history size 32
    line aux 0
    line 66
     no activation-character
     no exec
     transport preferred none
     transport input all
     transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
    line vty 0 4
     exec-timeout 0 0
     privilege level 15
     logging synchronous
     login local
     transport input telnet ssh
    !
    scheduler allocate 20000 1000
    end
    
    CME_R4#
    Code:
    CME_R4#show ephone
    
    ephone-1[0] Mac:0024.9735.6769 TCP socket:[-1] activeLine:0 whisperLine:0 UNREGISTERED
    mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:0
    IP:0.0.0.0* 0 Unknown 0  keepalive 0 max_line 0 available_line 0
    button 1: cw:1 ccw:(0)
      dn 1  number 1000 CH1   DOWN
    Preferred Codec: g711ulaw
    Lpcor Type: none
    
    ephone-2[1] Mac:001E.4AF2.CA3E TCP socket:[-1] activeLine:0 whisperLine:0 UNREGISTERED
    mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:0
    IP:0.0.0.0* 0 Unknown 0  keepalive 0 max_line 0 available_line 0
    Preferred Codec: g711ulaw
    Lpcor Type: none
    
    ephone-3[2] Mac:001D.450C.38A3 TCP socket:[-1] activeLine:0 whisperLine:0 UNREGISTERED
    mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:0
    IP:0.0.0.0* 0 Unknown 0  keepalive 0 max_line 0 available_line 0
    button 3: cw:1 ccw:(0)
      dn 3  number 1002 CH1   DOWN
    Preferred Codec: g711ulaw
    Lpcor Type: none
    Code:
    CME_R4#show ephone attempted-registrations
    
    CME_R4#
    I tried switching the load file to term61.default but I get the same results from the TFTP debugging

    I then thought that the 7.0 version might be too old for the version of CME I'm running on the 2811 (8.6) so I removed the previous tftp-server commands, added tftp-server commands for the 8.5 version that's on my flash and changed the load 7961 telephony-service command:

    Code:
    CME_R4#show run | incl tftp-
    tftp-server flash:apps41.8-5-3TH1-6.sbn
    tftp-server flash:cvm41sccp.8-5-3TH1-6.sbn
    tftp-server flash:SCCP41.8-5-3S.loads
    tftp-server flash:jar41sccp.8-5-3TH1-6.sbn
    tftp-server flash:dsp41.8-5-3TH1-6.sbn
    tftp-server flash:cnu41.8-5-3TH1-6.sbn
    tftp-server flash:term41.default.loads
    tftp-server flash:term61.default.loads
    CME_R4#show run | incl load 7961
     load 7961 SCCP41.8-5-3S
    CME_R4#
    I get the same tftp events logged as what I have above...also CDP shows them all still running term61.default

    Any direction from here? As I'm sure you can understand I'm itching to get back up and running on my studies.

    TLDR?
    Reply With Quote Quote  

  13. Member Diggs's Avatar
    Join Date
    Jun 2012
    Location
    Paradise
    Posts
    97

    Certifications
    A+, Network+, CCENT, CCNA
    #37
    Crisis averted - I wiped the config on my CME router and started fresh removing all of the tftp-server commands and telephony-service load command and the phones are now registering...

    Thanks everyone for your help!
    Reply With Quote Quote  

+ Reply to Thread
Page 2 of 2 First 12

Social Networking & Bookmarks