+ Reply to Thread
Results 1 to 9 of 9
  1. Junior Member
    Join Date
    Sep 2012
    Posts
    15
    #1

    Default Phone won't register

    Hey guys,

    I have two Cisco IP phones. They are the exam same model (7960) one registers and the other doesn't. On the CME I keep getting these messages from debug tftp events:

    *Mar 1 05:26:39.222: TFTP: Looking for CTLSEP00137F6BF9BD.tlv
    *Mar 1 05:26:39.247: TFTP: Looking for SEP00137F6BF9BD.cnf.xml
    *Mar 1 05:26:39.271: TFTP: Looking for SIP00137F6BF9BD.cnf
    *Mar 1 05:26:39.303: TFTP: Looking for MGC00137F6BF9BD.cnf
    *Mar 1 05:26:39.327: TFTP: Looking for XMLDefault.cnf.xml
    *Mar 1 05:26:39.331: TFTP: Opened system:/its/XMLDefault.cnf.xml, fd 0, size 1104 for process 140
    *Mar 1 05:26:39.339: TFTP: Finished system:/its/XMLDefault.cnf.xml, time 00:00:00 for process 140

    I've looked everywhere online but the only Cisco doc I can find is IP Phone 7940/7960 Fails to Boot - Protocol Application Invalid - Cisco Systems which doesn't help at all.

    Could any of the voip geniuses out there throw me a bone?
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member DexterPark's Avatar
    Join Date
    May 2012
    Location
    West Coast
    Posts
    112

    Certifications
    CCNP, followed by alphabet soup.
    #2
    Basically, it's looking for a config file and isn't finding it..

    Check the config on your router and make sure it looks like the first phones. You may have typo'ed the MAC address. Check that and if it is not, post a config from your router. Also, look under settings and find out if the two phones has the same firmware version.
    My advice to anyone looking to advance their career would be to learn DevOps tools and methodologies. Learn how to write code in languages like Python and JavaScript. Not to be a programmer, but a network automation specialist who can do the job of 10 engineers in 1/3 of the time. Create a GitHub account, download PyCharm, play with Ansible, Chef, or Puppet. Automation isn't the future, it's here today and the landscape is changing dramatically.
    Reply With Quote Quote  

  4. Junior Member
    Join Date
    Sep 2012
    Posts
    15
    #3
    Dexter,

    They have identical configs:

    -------------------------
    Device ID: SEP00137F6BF9BD
    Entry address(es):
    IP address: 172.16.1.3
    Platform: Cisco IP Phone 7960, Capabilities: Host Phone
    Interface: FastEthernet0/13, Port ID (outgoing port): Port 1
    Holdtime : 176 sec


    Version :
    P00308010200


    advertisement version: 2
    Duplex: full
    Power drawn: 6.300 Watts


    -------------------------
    Device ID: SEP00137F53FDD8
    Entry address(es):
    IP address: 172.16.1.4
    Platform: Cisco IP Phone 7960, Capabilities: Host Phone
    Interface: FastEthernet0/14, Port ID (outgoing port): Port 1
    Holdtime : 132 sec


    Version :
    P00308010200


    advertisement version: 2
    Duplex: full
    Power drawn: 6.300 Watts


    Here is my config on the CME router:

    CME_A#show run
    Building configuration...

    Current configuration : 1363 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname CME_A
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    !
    resource policy
    !
    clock timezone Central 5
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip subnet-zero
    ip cef
    !
    !
    no ip dhcp use vrf connected
    !
    ip dhcp pool VOICE_POOL
    network 172.16.1.0 255.255.255.0
    default-router 172.16.1.1
    option 150 ip 172.16.1.1
    !
    !
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 172.16.1.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.100
    !
    interface Serial0/0
    no ip address
    shutdown
    no fair-queue
    no dce-terminal-timing-enable
    !
    ip classless
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    telephony-service
    max-ephones 10
    max-dn 10
    ip source-address 172.16.1.1 port 2000
    create cnf-files version-stamp Jan 01 2002 00:00:00
    max-conferences 4 gain -6
    !
    !
    ephone-dn 1
    number 1001
    !
    !
    ephone-dn 2
    number 1002
    !
    !
    ephone-dn 10
    number 5005 secondary 5006
    !
    !
    ephone 1
    mac-address 0013.7F53.FDD8
    button 1:1 3:10
    !
    !
    !
    ephone 2
    mac-address 0013.7F6B.F9BD
    button 1:2
    !
    !
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    transport input all
    line vty 0 4
    login
    !
    !
    end




    Thanks a ton for looking at my question. I've been trying to fix this for so long
    Reply With Quote Quote  

  5. Senior Member
    Join Date
    Dec 2011
    Posts
    330

    Certifications
    CCNP Collab, CCDP, CCNP R&S, CCNP V, CCP-N NetScaler, Net+, A+
    #4
    Remove the CNF file of the phone that will not register by deleting the file from flash. Then reset the phone.
    Reply With Quote Quote  

  6. Junior Member
    Join Date
    Sep 2012
    Posts
    15
    #5
    aaron,

    I have no files in flash:



    CME_A#dir flash:
    Directory of flash:/


    1 -rw- 24674228 <no date> c2600-ipvoicek9-mz.124-4.T.bin


    49807356 bytes total (24318228 bytes free)

    Since these phones already have the right phone firmware I just left them alone... I'm very new to the voice game so please let me know if I'm missing something obvious
    Reply With Quote Quote  

  7. Senior Member
    Join Date
    Dec 2011
    Posts
    330

    Certifications
    CCNP Collab, CCDP, CCNP R&S, CCNP V, CCP-N NetScaler, Net+, A+
    #6
    CNF (Config) files have to be there or the phone can't register. Run command show flash. If empty try show telephony-service tftp-bindings. Post your output.
    Last edited by aaron0011; 04-17-2013 at 02:44 AM.
    Reply With Quote Quote  

  8. Junior Member
    Join Date
    Sep 2012
    Posts
    15
    #7
    CME_A#show flash


    System flash directory:
    File Length Name/status
    1 24674228 c2600-ipvoicek9-mz.124-4.T.bin
    2 3987 admin_user.html [deleted]
    3 677822 admin_user.js [deleted]
    4 1029 CiscoLogo.gif [deleted]
    5 617 CME_GUI_README.TXT [deleted]
    6 953 Delete.gif [deleted]
    7 16344 dom.js [deleted]
    8 864 downarrow.gif [deleted]
    9 6146 ephone_admin.html [deleted]
    10 4558 logohome.gif [deleted]
    11 3866 normal_user.html [deleted]
    12 78428 normal_user.js [deleted]
    13 1347 Plus.gif [deleted]
    14 843 sxiconad.gif [deleted]
    15 174 Tab.gif [deleted]
    16 2431 telephony_service.html [deleted]
    17 870 uparrow.gif [deleted]
    18 9968 xml-test.html [deleted]
    19 3412 xml.template [deleted]
    [25489128 bytes used, 24318228 available, 49807356 total]
    49152K bytes of processor board System flash (Read/Write)


    CME_A#show telephony-service tftp-bindings
    tftp-server system:/its/SEPDEFAULT.cnf
    tftp-server system:/its/SEPDEFAULT.cnf alias SEPDefault.cnf
    tftp-server system:/its/XMLDefault.cnf.xml alias XMLDefault.cnf.xml
    tftp-server system:/its/ATADefault.cnf.xml
    tftp-server system:/its/united_states/7960-tones.xml alias United_States/7960-tones.xml
    tftp-server system:/its/united_states/7960-font.xml alias English_United_States/7960-font.xml
    tftp-server system:/its/united_states/7960-dictionary.xml alias English_United_States/7960-dictionary.xml
    tftp-server system:/its/united_states/7960-kate.xml alias English_United_States/7960-kate.xml
    tftp-server system:/its/united_states/SCCP-dictionary.xml alias English_United_States/SCCP-dictionary.xml
    tftp-server system:/its/XMLDefault7960.cnf.xml alias SEP00137F53FDD8.cnf.xml

    Those [deleted] files were for the CME GUI I think. This router was purchased used. All I did was write erase and then started using it.

    I'll go ahead and make tftp-server commands for P00308010200
    Reply With Quote Quote  

  9. Senior Member
    Join Date
    Dec 2011
    Posts
    330

    Certifications
    CCNP Collab, CCDP, CCNP R&S, CCNP V, CCP-N NetScaler, Net+, A+
    #8
    CME(config)#telephony-service
    CME(config-telephony)#cnf-file location flash:
    CME(config-telephony)#cnf-file perphone

    Reboot router. Then reset phones.
    Reply With Quote Quote  

  10. Junior Member
    Join Date
    Sep 2012
    Posts
    15
    #9
    Turns out I just had to specify the firmware files for the 7960s after loading them in flash and then type "create cnf-files"

    Directory of flash:/


    1 -rw- 24674228 <no date> c2600-ipvoicek9-mz.124-4.T.bin
    20 -rw- 130552 <no date> phone/7940-7960/P00308010200.bin
    21 -rw- 461 <no date> phone/7940-7960/P00308010200.loads
    22 -rw- 708448 <no date> phone/7940-7960/P00308010200.sb2
    23 -rw- 130956 <no date> phone/7940-7960/P00308010200.sbn

    CME_A#show run | i tftp-s
    tftp-server flash:/phone/7940-7960/P00308010200.bin alias P00308010200.bin
    tftp-server flash:/phone/7940-7960/P00308010200.loads alias P00308010200.loads
    tftp-server flash:/phone/7940-7960/P00308010200.sb2 alias P00308010200.sb2
    tftp-server flash:/phone/7940-7960/P00308010200.sbn alias P00308010200.sbn

    under telephony-service, type load 7960-7940 P00308010200

    Thanks a ton aaron and Dexter
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks