+ Reply to Thread
Results 1 to 6 of 6
  1. Junior Member Registered Member
    Join Date
    Apr 2013
    Posts
    2
    #1

    Question 7912-G not registering

    Hi all,

    I'm new to the CCNA Voice world i need help, i have 2811 router and 3550 switch, on the router i have CME 8.6 install , i have two 7912g phones.

    the phones are getting IP address, TFTP settings ,VLANS etc. i also have a computer with IP communicator and is registering okay, i don't know if I'm missing anything help will be appreciated.... here is my configuration {{the phone are using sip}}

    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname CME_VOICE
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    no aaa new-model
    !
    clock timezone newyork -4 0
    clock summer-time cdt recurring
    !
    dot11 syslog
    ip source-route
    !
    !
    ip cef
    !
    ip dhcp excluded-address 192.168.10.1 192.168.10.10
    ip dhcp excluded-address 192.168.20.1 192.168.20.10
    !
    ip dhcp pool VOICE
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.1
    dns-server 4.2.2.2
    option 150 ip 192.168.10.1
    !
    ip dhcp pool DATA
    network 192.168.20.0 255.255.255.0
    default-router 192.168.20.1
    dns-server 4.2.2.2
    option 150 ip 192.168.10.1
    !
    !
    no ip domain lookup
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    voice-card 0
    !
    crypto pki token default removal timeout 0
    !
    !
    !
    !
    license udi pid CISCO2811 sn FTX1326A04M
    !
    redundancy
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.10
    description Voice Vlan
    encapsulation dot1Q 10
    ip address 192.168.10.1 255.255.255.0
    !
    interface FastEthernet0/0.20
    description DATA Vlan
    encapsulation dot1Q 20
    ip address 192.168.20.1 255.255.255.0
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/0/0
    ip address 192.168.0.2 255.255.255.0
    service-module t1 clock source internal
    !
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    !
    !
    !
    logging esm config
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    mgcp profile default
    !
    !
    !
    !
    !
    telephony-service
    no auto-reg-ephone
    max-ephones 20
    max-dn 25
    ip source-address 192.168.10.1 port 2000
    cnf-file location flash:
    load 7912 CP7912080004SCCP080108A.sbin
    max-conferences 8 gain -6
    transfer-system full-consult
    create cnf-files version-stamp 7960 may 02 2002 04:34:18
    !
    !
    ephone-dn 1 dual-line
    number 3001
    !
    !
    ephone-dn 2 dual-line
    number 3002
    !
    !
    ephone-dn 3 dual-line
    number 3003
    !
    !
    ephone-dn 4 dual-line
    number 3004
    !
    !
    ephone-dn 5 dual-line
    number 3005
    !
    !
    ephone 1
    device-security-mode none
    mac-address 0015.C54D.80C2
    button 1:1
    !
    !
    !
    ephone 2
    device-security-mode none
    !
    !
    !
    banner motd ^C
    *******************************************
    CME-VOICE
    *******************************************^C
    !
    line con 0
    exec-timeout 0 0
    password 7 094F471A1A0A
    logging synchronous
    login
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    password 7 094F471A1A0A
    logging synchronous
    login
    transport input all
    line vty 5 15
    exec-timeout 0 0
    password 7 094F471A1A0A
    logging synchronous
    login
    transport input all
    !
    scheduler allocate 20000 1000
    ntp server 192.168.0.1
    end
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member DexterPark's Avatar
    Join Date
    May 2012
    Location
    West Coast
    Posts
    112

    Certifications
    CCNP, followed by alphabet soup.
    #2
    Ok, so you say that the phones are using SIP but you configured telephony-service (Not SIP) and the firmware version you are using is clearly Skinny: load 7912 CP7912080004SCCP080108A.sbin

    What are your phones saying? Registration rejected or something else?
    My advice to anyone looking to advance their career would be to learn DevOps tools and methodologies. Learn how to write code in languages like Python and JavaScript. Not to be a programmer, but a network automation specialist who can do the job of 10 engineers in 1/3 of the time. Create a GitHub account, download PyCharm, play with Ansible, Chef, or Puppet. Automation isn't the future, it's here today and the landscape is changing dramatically.
    Reply With Quote Quote  

  4. Junior Member Registered Member
    Join Date
    Apr 2013
    Posts
    2
    #3
    It doesn't give me an error message...i just configure a 7942 and is working okay registering to the CME router but i cannot get the 7912 to work
    Reply With Quote Quote  

  5. Senior Member DexterPark's Avatar
    Join Date
    May 2012
    Location
    West Coast
    Posts
    112

    Certifications
    CCNP, followed by alphabet soup.
    #4
    Post a Dir flash: and add this to your config: tftp-server flash:/phone/7912/CP7912080004SCCP080108A.sbin alias CP7912080004SCCP080108A.sbin


    You may need to modify the path if it is different than the one above. I checked to CME 8.6 firmware version guide and it looks like you have the right firmware for a 7912.


    I'm assuming that MAC address in the ephone 1 statement is one of your 7912's correct?


    What is the current firmware version on the phones under Settings>Model Information> Load files


    Another thing you can do is debug tftp events, plug your 7912 in and post the output. This is fun, you are going to learn to troubleshoot today!


    SOURCE: Cisco Unified CME 8.6 Supported Firmware, Platforms, Memory, and Voice Products [Cisco Unified Communications Manager Express] - Cisco Systems
    My advice to anyone looking to advance their career would be to learn DevOps tools and methodologies. Learn how to write code in languages like Python and JavaScript. Not to be a programmer, but a network automation specialist who can do the job of 10 engineers in 1/3 of the time. Create a GitHub account, download PyCharm, play with Ansible, Chef, or Puppet. Automation isn't the future, it's here today and the landscape is changing dramatically.
    Reply With Quote Quote  

  6. Senior Member
    Join Date
    May 2004
    Location
    Milwaukee, WI
    Posts
    441

    Certifications
    CCNA CCNA Voice CCNP (+CSPFA, QoS, & CCIE R&S written), MCSA/MCSE on Win2k , Network+, Security+.
    #5
    Try a factory reset on the phone. (most phones are hold down the # key while the phone powers up, once the headset, mute, and speaker buttons start to flash in sequence, push 123456789*0#)
    Reply With Quote Quote  

  7. Junior Member Registered Member
    Join Date
    Jan 2013
    Posts
    1
    #6
    What is the Topology?
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks