+ Reply to Thread
Page 1 of 2 1 2 Last
Results 1 to 25 of 27
  1. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #1

    Default Absolute minimum configured to make internal calls using CME

    Trying to understand how the different hardware (dsp/aim/pvdm etc components) and software configured components work together.

    This is a stand alone lab, not connected to anything else. One 2811 CME router, One 3550 POE switch, and 2 7940G phones.

    So, what I've done so far is configured a 2811 with Call Manager Express 4.3.0.0 (I want to try different versions to see their differents as I go through this). It's got the tftp files for the phones loaded .



    tftp-server flash:/phone/7940-7960/P00308000500.bin alias P00308000500.bin
    tftp-server flash:/phone/7940-7960/P00308000500.loads alias P00308000500.loads
    tftp-server flash:/phone/7940-7960/P00308000500.sb2 alias P00308000500.sb2
    tftp-server flash:/phone/7940-7960/P00308000500.sbn alias P00308000500.sbn


    Telephony services is running, using IOS 12.4(24) T8.. I have the 2811 trunked to a 3550poe switch, where I have configured voice and data vlans and a trunk port.


    interface FastEthernet0/0.10
    description ROUTER INTERFACE FOR VOICE VLAN
    encapsulation dot1Q 10
    ip address 172.16.1.1 255.255.255.0
    ip helper-address 172.16.2.5
    !
    interface FastEthernet0/0.50
    description ROUTER INTERFACE FOR DATA VLAN
    encapsulation dot1Q 50
    ip address 172.16.2.1 255.255.255.0


    telephony configuration below, I tried configured ephone DN's to see what that will do


    telephony-service
    xml user jean password jean 15
    max-ephones 24
    max-dn 48
    ip source-address 172.16.1.1 port 2000
    system message "hello this is a test message"
    max-conferences 8 gain -6
    web admin system name Admin password web
    dn-webedit
    transfer-system full-consult
    create cnf-files version-stamp Jan 01 2002 00:00:00
    !
    !
    ephone-dn 1
    number 2000
    label David (2000)
    name David
    !
    !
    ephone-dn 2
    number 3000
    label Norman(3000)
    name Norman
    !
    !
    ephone 1
    mac-address 0014.F243.EF4B
    speed-dial 1 1 label "Jean"
    !
    !
    !
    ephone 2
    mac-address 0014.F243.EC46
    speed-dial 1 1 label "Jean"


    I have connected two 7940g phones to the 3550 switch, and they power up and get their ip addresses.

    #sh ephone on the cme router shows the following
    ephone-1[0] Mac:0014.F243.EF4B TCP socket:[3] activeLine:0 whisperLine:0 REGISTERED in SCCP ver 11/9 max_streams=0
    mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
    IP:172.16.1.10 49854 Telecaster 7940 keepalive 14 max_line 2 available_line 1
    speed dial 1:1 Jean
    Preferred Codec: g711ulaw

    ephone-2[1] Mac:0014.F243.EC46 TCP socket:[1] activeLine:0 whisperLine:0 REGISTERED in SCCP ver 11/9 max_streams=0
    mediaActive:0 whisper_mediaActive:0 startMedia:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
    IP:172.16.1.11 49868 Telecaster 7940 keepalive 14 max_line 2 available_line 1
    speed dial 1:1 Jean
    Preferred Codec: g711ulaw



    What am I missing in order to get the INTERNAL calls working just between these two phones?

    Thanks much!
    Last edited by JeanM; 01-06-2014 at 02:50 AM.
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member
    Join Date
    May 2009
    Location
    DMV
    Posts
    2,202

    Certifications
    CCNP, CCNP(V), S+ CCIE V(written)
    #2
    of the top of my head I don't see a DHCP server with option 150
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
    Reply With Quote Quote  

  4. Senior Member wgroom's Avatar
    Join Date
    Dec 2013
    Location
    Ohio
    Posts
    147

    Certifications
    CCNA: V, R&S
    #3
    What happens when you dial the opposing DN from a phone? Anything? Can you ping the phones from the router? I would suspect the switch port connected to the router is trunked? It would seem so due to the ephones showing registered. I am weak on CME, but those are my initial thoughts.
    Reply With Quote Quote  

  5. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #4
    Quote Originally Posted by shodown View Post
    of the top of my head I don't see a DHCP server with option 150
    DHCP is running, phones get their ip addresses.

    ip dhcp excluded-address 172.16.1.1 172.16.1.9
    ip dhcp excluded-address 172.16.2.1 172.16.2.9
    !
    ip dhcp pool DATA_SCOPE
    network 172.16.2.0 255.255.255.0
    default-router 172.16.2.1
    dns-server 4.2.2.2
    !
    ip dhcp pool VOICE_SCOPE
    network 172.16.1.0 255.255.255.0
    default-router 172.16.1.1
    option 150 ip 172.16.1.1
    Reply With Quote Quote  

  6. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #5
    Quote Originally Posted by wgroom View Post
    What happens when you dial the opposing DN from a phone? Anything? Can you ping the phones from the router? I would suspect the switch port connected to the router is trunked? It would seem so due to the ephones showing registered. I am weak on CME, but those are my initial thoughts.
    Nothing happens, there is no dial tone and no ringing the other phone.

    Switch port is trunked from the switch to the CME router.

    Phones are pingable from the cme router.

    CMERouter#ping 172.16.1.10
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.1.10, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
    CMERouter#
    CMERouter#ping 172.16.1.11
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.1.11, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
    CMERouter#
    CMERouter#
    Reply With Quote Quote  

  7. Senior Member wgroom's Avatar
    Join Date
    Dec 2013
    Location
    Ohio
    Posts
    147

    Certifications
    CCNA: V, R&S
    #6
    Try assigning ephone1 to ephone-dn1 and 2 to 2, let us know what happens. Maybe the two need linked, right now they are two separate entities.
    Reply With Quote Quote  

  8. Senior Member
    Join Date
    Mar 2013
    Posts
    103
    #7
    Instead of speed dials use button
    Reply With Quote Quote  

  9. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #8
    wgroom - like this ?

    ephone-dn 1
    number 1000
    label Norman 1000
    name Norman
    !
    !
    ephone-dn 2
    number 2000
    label David 2000
    name David
    !
    !
    ephone 1
    mac-address 0014.F243.EF4B
    speed-dial 1 1000 label "Norman"
    !
    !
    !
    ephone 2
    mac-address 0014.F243.EC46
    speed-dial 1 2000 label "David"
    Last edited by JeanM; 01-06-2014 at 02:21 AM.
    Reply With Quote Quote  

  10. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #9
    Quote Originally Posted by bobfromfpl View Post
    Instead of speed dials use button
    bobfromfpl - When trying to dial 1000 or 2000 on either phone, there is no sound or any indication of dialing, and then phone flashes "AutoDial Cancelled" on it's screen.


    Rebooted router and phones as well, no difference.

    CMERouter>
    *Jan 6 05:10:49.255: %IPPHONE-6-REG_ALARM: 14: Name=SEP0014F243EF4B Load=8.1(2.0) Last=CM-closed-TCP
    *Jan 6 05:10:49.259: %IPPHONE-6-REGISTER: ephone-1:SEP0014F243EF4B IP:172.16.1.10 Socket:1 DeviceType:Phone has registered.
    CMERouter>
    *Jan 6 05:10:51.127: %IPPHONE-6-REG_ALARM: 14: Name=SEP0014F243EC46 Load=8.1(2.0) Last=CM-closed-TCP
    *Jan 6 05:10:51.131: %IPPHONE-6-REGISTER: ephone-2:SEP0014F243EC46 IP:172.16.1.11 Socket:2 DeviceType:Phone has registered.
    Last edited by JeanM; 01-06-2014 at 02:22 AM.
    Reply With Quote Quote  

  11. Senior Member wgroom's Avatar
    Join Date
    Dec 2013
    Location
    Ohio
    Posts
    147

    Certifications
    CCNA: V, R&S
    #10
    ephone-dn 1
    number 1000
    ephone 1
    label Norman 1000
    name Norman
    !
    !
    ephone-dn 2
    number 2000
    ephone 2
    label David 2000
    name David


    Try this.
    Reply With Quote Quote  

  12. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #11
    wgroom - Once I enter "ephone 1" or "ephone 2" from the (config-ephone-dn) mode, it goes into the (config-ephone) mode where "label" and "name" commands aren't recognized.

    The label and name commands work under the (config-ephone-dn) mode though.

    Let's remove the speed dial configuration from this completely, how should it work for direct dialing each phone?
    Last edited by JeanM; 01-06-2014 at 03:13 AM.
    Reply With Quote Quote  

  13. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #12
    In CME GUI, under Configure - Phones, i see the following

    0014F243EC46 shows phone sequence number 2, does not show any primary line number and caller ID
    0014F243EF4B shows phone sequence number 1, does not show any primary line number and caller ID

    In CME GUI, under Configure - Extensions, i see the following

    Telephone number 1000, has Sequence Number 1, and no Caller ID/Name, Type = Normal
    Telephone number 2000, has Sequence Number 2, and no Caller ID/Name, Type = Normal

    Dialing 1000 or 2000 or any other numbers, on either phone acts like it's trying to dial for a second, no errors, then flashes a "AutoDial Cancelled" ?
    Last edited by JeanM; 01-06-2014 at 03:22 AM.
    Reply With Quote Quote  

  14. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #13
    Well, made some more progress

    I am now getting dial tone, and I can actually hear it dialing etc. My specific issue had to do with routing!
    Reply With Quote Quote  

  15. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #14
    Alright, it's now working both directions

    !
    ephone-dn 1
    number 2000
    label Norman 2000
    name Norman
    !
    !
    ephone-dn 2
    number 1000
    label David 1000
    name David
    !
    !
    ephone 1
    mac-address 0014.F243.EF4B
    speed-dial 1 1000 label "DAVID"
    button 1:2
    !
    !
    !
    ephone 2
    mac-address 0014.F243.EC46
    speed-dial 1 2000 label "NORMAN"
    button 1:1
    Reply With Quote Quote  

  16. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #15
    How do you configure Call History to show for let's say 24 hours? It seems to not keep previous call records and I can't find a command that controls for how long these show etc? Cisco Unified CallManager Express Solution Reference Network Design Guide - Managing and Monitoring Cisco Unified CallManager Express Systems* [Cisco Unified Communications Manager Express] - Cisco Systems



    Reports > Call History

    ID Start Time Originating Number Terminating Number Duration
    1 09:01:46 UTC Mon Jan 6 2014 1000 2000 00:10:23
    Reply With Quote Quote  

  17. Senior Member
    Join Date
    May 2009
    Location
    DMV
    Posts
    2,202

    Certifications
    CCNP, CCNP(V), S+ CCIE V(written)
    #16
    CDR's are pretty odd in CME. You can setup a free syslog server and have them send the CDR's to a external server.
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
    Reply With Quote Quote  

  18. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #17
    Odd as in no configuration changes can be made? I guess I'll spin up a VM with a free syslog / splunk if there is no other way.
    Reply With Quote Quote  

  19. Senior Member
    Join Date
    May 2009
    Location
    DMV
    Posts
    2,202

    Certifications
    CCNP, CCNP(V), S+ CCIE V(written)
    #18
    Quote Originally Posted by JeanM View Post
    Odd as in no configuration changes can be made? I guess I'll spin up a VM with a free syslog / splunk if there is no other way.

    CDR Logging Configuration with Syslog Servers and Cisco IOS Gateways* [Gateway Protocols] - Cisco Systems


    Here is the link to setup CDR's with CME.
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
    Reply With Quote Quote  

  20. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #19
    Sweet! I'll do that tonight!
    Reply With Quote Quote  

  21. Senior Member wgroom's Avatar
    Join Date
    Dec 2013
    Location
    Ohio
    Posts
    147

    Certifications
    CCNA: V, R&S
    #20
    Congratulations on getting dial tone and two way calling! Maybe I did not see it, or if I did do not understand completely, but what step allowed dial tone to come across?
    Reply With Quote Quote  

  22. Senior Member
    Join Date
    Jul 2010
    Location
    Chicago, Illinois
    Posts
    149

    Certifications
    MCSE:2003 / CCNA/A+
    #21

    Default Button assignment for the ephone dn line no.

    Appears to be assigning the ehone line to a button I think the 7940s have 4 buttons for 4 line.
    Reply With Quote Quote  

  23. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #22
    wgroom - what call manager do you use, like?

    Quote Originally Posted by Jollycork View Post
    Appears to be assigning the ehone line to a button I think the 7940s have 4 buttons for 4 line.
    I'll break it and confirm when I have time.
    Reply With Quote Quote  

  24. Senior Member
    Join Date
    Mar 2013
    Posts
    103
    #23
    Using the button command associated the ephone-dn to that line button, whereas previously you had only speed dial 1 configured. When the phones were registered they didn't have a line number assigned. This happens more often than I'd like in my work environment when junior admins delete a directory number versus disassociating it from a device.
    Reply With Quote Quote  

  25. Senior Member pitviper's Avatar
    Join Date
    May 2008
    Location
    Right Coast, US
    Posts
    1,363

    Certifications
    CCNP:Collaboration, CCNP:R+S, CCNA:R+S, CCNA:V(IIUC), CCNA:S, CCENT, CNSS 4011
    #24
    yup, you won't get dial-tone without a DN assigned to a button.
    Reply With Quote Quote  

  26. Senior Member wgroom's Avatar
    Join Date
    Dec 2013
    Location
    Ohio
    Posts
    147

    Certifications
    CCNA: V, R&S
    #25
    JeanM, I use Unified Call Manager 8.6.1 and Nortel Options 11, 61C, and 81C for a large hospital system. Over 7K phones all told. No experience with CUCME, but as soon as my 2821 arrives I will load CME and get started. This intrigued me, thank you for sharing.
    Reply With Quote Quote  

+ Reply to Thread
Page 1 of 2 1 2 Last

Social Networking & Bookmarks