+ Reply to Thread
Results 1 to 20 of 20
  1. Senior Member
    Join Date
    Oct 2010
    Location
    United States
    Posts
    1,099

    Certifications
    CCNA, CCNA:Sec CCNA:Voice, A+, Project+, Sec+, Linux+, MCTS, ITIL v3, VCP-DCV
    #1

    Default CUCME phones not registering

    I have two 7942 phones, a 3750, and a 2811. Can anyone tell me if you see something wrong in the config of the 2811? I've been stuck on this all day. The phones get an IP. I can ping the phones, but they are not registering.

    I tried debug tftp events and am not getting any traffic. I probably did something braindead My mind is melting from all of this studying!

    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname 2811-lab
    !
    boot-start-marker
    boot system flash:c2800nm-adventerprisek9-mz.124-24.T8.bin
    boot-end-marker
    !
    logging message-counter syslog
    logging console critical
    !
    no aaa new-model
    no network-clock-participate wic 0
    !
    dot11 syslog
    ip source-route
    !
    !
    ip cef
    no ip dhcp use vrf connected
    !
    ip dhcp pool VOICE
    network 172.26.1.0 255.255.255.0
    default-router 172.26.1.1
    option 150 ip 172.26.1.1
    !
    !
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    voice service voip
    allow-connections h323 to sip
    allow-connections sip to h323
    fax protocol cisco
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    voice-card 0
    dspfarm
    !
    !
    !
    !
    !

    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    controller T1 0/0/0
    !
    controller T1 0/0/1
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    description 3750-lab
    ip address 172.26.1.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface Serial0/1/0
    no ip address
    shutdown
    no fair-queue
    clock rate 2000000
    !
    interface Serial0/1/1
    no ip address
    shutdown
    clock rate 2000000
    !
    ip forward-protocol nd
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    !
    !
    tftp-server flash:Analog1.raw
    tftp-server flash:Analog2.raw
    tftp-server flash:AreYouThere.raw
    tftp-server flash:AreYouThereF.raw
    tftp-server flash:Bass.raw
    tftp-server flash:CallBack.raw
    tftp-server flash:Chime.raw
    tftp-server flash:Classic1.raw
    tftp-server flash:Classic2.raw
    tftp-server flash:ClockShop.raw
    tftp-server flashistinctiveRingList.xml
    tftp-server flashrums1.raw
    tftp-server flashrums2.raw
    tftp-server flash:FilmScore.raw
    tftp-server flash:HarpSynth.raw
    tftp-server flash:Jamaica.raw
    tftp-server flash:KotoEffect.raw
    tftp-server flash:MusicBox.raw
    tftp-server flash:Piano1.raw
    tftp-server flash:Piano2.raw
    tftp-server flash:Pop.raw
    tftp-server flash:Pulse1.raw
    tftp-server flash:Ring1.raw
    tftp-server flash:Ring2.raw
    tftp-server flash:Ring3.raw
    tftp-server flash:Ring4.raw
    tftp-server flash:Ring5.raw
    tftp-server flash:Ring6.raw
    tftp-server flash:Ring7.raw
    tftp-server flash:RingList.xml
    tftp-server flash:SCCP42.8-4-2S.loads
    tftp-server flash:SCCP42.9-2-1S.loads
    tftp-server flash:Sax1.raw
    tftp-server flash:Sax2.raw
    tftp-server flash:Vibe.raw
    tftp-server flash:apps42.8-4-1-23.sbn
    tftp-server flash:apps42.9-2-1TH1-13.sbn
    tftp-server flash:c2800nm-adventerprisek9-mz.124-24.T8.bin
    tftp-server flash:cnu42.8-4-1-23.sbn
    tftp-server flash:cnu42.9-2-1TH1-13.sbn
    tftp-server flash:cvm42sccp.8-4-1-23.sbn
    tftp-server flash:cvm42sccp.9-2-1TH1-13.sbn
    tftp-server flash:dsp42.8-4-1-23.sbn
    tftp-server flash:dsp42.9-2-1TH1-13.sbn
    tftp-server flash:its
    tftp-server flash:jar42sccp.8-4-1-23.sbn
    tftp-server flash:jar42sccp.9-2-1TH1-13.sbn
    tftp-server flash:term42.default.loads
    tftp-server flash:term62.default.loads
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    telephony-service
    max-ephones 5
    max-dn 5
    ip source-address 172.26.1.1 port 2000
    auto assign 1 to 5
    cnf-file location flash:
    load 7941GE SCCP41.8-2-2SR2S
    load 7942 SCCP42.8-4-2S
    load 7945 SCCP45.8-3-2S
    load 7961 SCCP41.8-2-2SR2S
    load 7961GE SCCP41.8-2-2SR2S
    load 7962 SCCP42.8-3-2S
    load 7965 SCCP45.8-3-2S
    load 7970 SCCP70.8-2-2SR2S
    load 7971 SCCP70.8-2-2SR2S
    load 7975 SCCP75.8-3-2S
    dialplan-pattern 1 2225... extension-length 4
    max-conferences 8 gain -6
    transfer-system full-consult
    create cnf-files version-stamp Jan 01 2002 00:00:00
    !
    !
    ephone-dn 1 dual-line
    number 5001
    !
    !
    ephone-dn 2 dual-line
    number 5002
    !
    !
    ephone-dn 3 dual-line
    number 5003
    !
    !
    ephone-dn 4 dual-line
    number 5004
    !
    !
    ephone-dn 5 dual-line
    number 5005
    !
    !
    ephone 1
    device-security-mode none
    !
    !
    !
    ephone 2
    device-security-mode none
    !
    !
    !
    ephone 3
    device-security-mode none
    !
    !
    !
    ephone 4
    device-security-mode none
    !
    !
    !
    ephone 5
    device-security-mode none
    !
    !
    !
    line con 0
    logging synchronous
    line aux 0
    line vty 0 4
    login
    !
    scheduler allocate 20000 1000
    end
    Last edited by ehnde; 01-31-2014 at 09:16 PM.
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member
    Join Date
    Mar 2013
    Posts
    103
    #2
    Are your phones at a white background attempting to download the firmware? Or the blue background stuck at a spinning wheel?
    Reply With Quote Quote  

  4. Senior Member
    Join Date
    May 2009
    Location
    DMV
    Posts
    2,205

    Certifications
    CCNP, CCNP(V), S+ CCIE V(written)
    #3
    1. What version of CME are you on?

    2. I don't see any ephone mac addresses in your config?

    3. I assume on your putting all of this in VLAN1?

    4. How are you serving up the files from your TFTP server?

    Try this link

    https://learningnetwork.cisco.com/se...ice%20VoIP.pdf
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
    Reply With Quote Quote  

  5. Senior Member
    Join Date
    Oct 2010
    Location
    United States
    Posts
    1,099

    Certifications
    CCNA, CCNA:Sec CCNA:Voice, A+, Project+, Sec+, Linux+, MCTS, ITIL v3, VCP-DCV
    #4
    I could have sworn I had auto-reg-ephone in there, but I'll put the mac addresses in there instead. That's definitely a showstopper! CME version is 7.1. Yes, everything is in vlan1.

    Doesn't the tftp-server flash:<filename> make the router function as a tftp server?

    Thank you for the flow chart, that is a good find.

    @bobfromfpl:
    The 7942 phones that I have don't have a color display. If I were only that lucky The phones have an IP from DHCP, but they are in phone purgatory constantly trying to register and never able to.

    The lab is at work and I'm at home. I'm half tempted to go to work right now just to see if I can get it to work.
    Last edited by ehnde; 01-31-2014 at 12:47 AM. Reason: no need for quoting
    Reply With Quote Quote  

  6. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #5
    Hi, here is my config also on 2811 with cme 7.1 if you like to compare...


    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname CMERouter
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog


    !
    no aaa new-model
    !
    dot11 syslog
    ip source-route
    !
    !
    ip cef
    ip dhcp excluded-address 172.16.1.1 172.16.1.9
    ip dhcp excluded-address 172.16.2.1 172.16.2.9
    !
    ip dhcp pool DATA_SCOPE
    network 172.16.2.0 255.255.255.0
    default-router 172.16.2.1
    dns-server 4.2.2.2
    !
    ip dhcp pool VOICE_SCOPE
    network 172.16.1.0 255.255.255.0
    default-router 172.16.1.1
    option 150 ip 172.16.1.1
    !
    !
    ip name-server 192.168.1.1
    no ipv6 cef
    multilink bundle-name authenticated
    !
    !
    !
    voice service voip
    fax protocol cisco
    sip
    !
    !
    !
    voice class codec 1
    codec preference 1 g711alaw
    codec preference 2 g711ulaw
    !
    !
    !
    voice-card 0
    !
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.10
    description ROUTER INTERFACE FOR VOICE VLAN
    encapsulation dot1Q 10
    ip address 172.16.1.1 255.255.255.0
    ip helper-address 172.16.2.5
    !
    interface FastEthernet0/0.50
    description ROUTER INTERFACE FOR DATA VLAN
    encapsulation dot1Q 50
    ip address 172.16.2.1 255.255.255.0
    !
    interface FastEthernet0/1
    ip address 192.168.1.199 255.255.255.0
    duplex auto
    speed auto
    !


    !
    ip default-gateway 192.168.1.1
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    !
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http path flash:gui
    !
    !
    logging 192.168.1.200
    !
    !
    tftp-server flash:/phone/7940-7960/P00308000500.bin alias P00308000500.bin
    tftp-server flash:/phone/7940-7960/P00308000500.loads alias P00308000500.loads
    tftp-server flash:/phone/7940-7960/P00308000500.sb2 alias P00308000500.sb2
    tftp-server flash:/phone/7940-7960/P00308000500.sbn alias P00308000500.sbn
    tftp-server flash:/ringtones/DistinctiveRingList.xml
    tftp-server flashistinctiveRingList.xml
    !
    control-plane
    !
    !
    dial-peer voice 1003 voip
    description ** local dialing dial peer **
    translation-profile outgoing outbound
    destination-pattern 1916.......
    voice-class sip dtmf-relay force rtp-nte
    session protocol sipv2
    session target sip-server
    dtmf-relay rtp-nte
    ip qos dscp ef signaling
    no vad
    !
    dial-peer voice 1004 voip
    description ** long distance dialing dial peer **
    translation-profile outgoing outbound
    destination-pattern 91[2-9]..[2-9]......
    voice-class sip dtmf-relay force rtp-nte
    session protocol sipv2
    session target sip-server
    dtmf-relay rtp-nte
    ip qos dscp ef signaling
    no vad
    !
    !
    sip-ua
    authentication username xxxxxxxxx password 7 xxxxxxxx
    registrar dns:sip.flowroute.com expires 3600
    sip-server dns:sip.flowroute.com
    presence enable
    !
    !
    telephony-service
    xml user jean password jean 15
    max-ephones 24
    max-dn 48
    ip source-address 172.16.1.1 port 2000
    max-conferences 8 gain -6
    web admin system name Admin password web
    dn-webedit
    transfer-system full-consult
    create cnf-files version-stamp Jan 01 2002 00:00:00
    !
    !
    ephone-dn 1
    number 808
    label Norms phone
    name Norm
    !
    !
    ephone-dn 2
    number 1111
    label Davids phone
    name David
    !
    !
    ephone-dn 3
    number 3333
    label Jean
    name Jean
    !
    !
    ephone 1
    mac-address 0014.F243.EF4B
    speed-dial 1 2222 label "Norm"
    button 1:2
    !
    !
    !
    ephone 2
    mac-address 0014.F243.EC46
    speed-dial 1 1111 label "DAVID"
    button 1:1
    !
    !
    !
    ephone 3
    mac-address 0015.C63E.7F98
    speed-dial 1 1111 label "Call Norm"
    speed-dial 2 2222 label "Call Dave"
    type 7960
    button 3:1 4:2
    night-service bell
    !
    Reply With Quote Quote  

  7. Senior Member
    Join Date
    Mar 2013
    Posts
    103
    #6
    Jean... half the fun of learning CME is figuring it out for yourself!! lol
    Reply With Quote Quote  

  8. Senior Member
    Join Date
    Oct 2010
    Location
    United States
    Posts
    1,099

    Certifications
    CCNA, CCNA:Sec CCNA:Voice, A+, Project+, Sec+, Linux+, MCTS, ITIL v3, VCP-DCV
    #7
    Thanks Jean! I'll get a dial tone today.

    I'd ask you guys what happens if you don't use the alias with tftp-server, but I'll just try it and see what happens...AFTER I get the dial tone.
    Reply With Quote Quote  

  9. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #8
    Quote Originally Posted by bobfromfpl View Post
    Jean... half the fun of learning CME is figuring it out for yourself!! lol
    No kidding!!!
    Reply With Quote Quote  

  10. Senior Member
    Join Date
    Oct 2010
    Location
    United States
    Posts
    1,099

    Certifications
    CCNA, CCNA:Sec CCNA:Voice, A+, Project+, Sec+, Linux+, MCTS, ITIL v3, VCP-DCV
    #9


    *Jan 31 21:39:40.094: TFTP: Looking for CTLSEPA8B1D41E0838.tlv
    *Jan 31 21:39:40.194: TFTP: Looking for ITLSEPA8B1D41E0838.tlv
    *Jan 31 21:39:40.306: TFTP: Looking for ITLFile.tlv
    *Jan 31 21:39:40.594: TFTP: Looking for SEPA8B1D41E0838.cnf.xml.sgn
    *Jan 31 21:39:40.774: TFTP: Looking for XMLDefault.cnf.xml.sgn
    *Jan 31 21:39:41.518: TFTP: Looking for CTLSEPA8B1D41E0838.tlv
    *Jan 31 21:39:41.630: TFTP: Looking for ITLSEPA8B1D41E0838.tlv
    *Jan 31 21:39:41.750: TFTP: Looking for ITLFile.tlv
    *Jan 31 21:39:42.034: TFTP: Looking for SEPA8B1D41E0838.cnf.xml.sgn
    *Jan 31 21:39:42.206: TFTP: Looking for XMLDefault.cnf.xml.sgn
    Those files do not exist. I ran create cnf-files. Is there another command that I need to run?
    Reply With Quote Quote  

  11. Senior Member
    Join Date
    Oct 2010
    Location
    United States
    Posts
    1,099

    Certifications
    CCNA, CCNA:Sec CCNA:Voice, A+, Project+, Sec+, Linux+, MCTS, ITIL v3, VCP-DCV
    #10
    I did the following and the phone appears to be upgrading:
    no create cnf-files
    create cnf-files
    reset phone to factory defaults: powercycle, hold # until lights flash, then 123456789*0#

    And I see this:
    *Jan 31 21:55:06.189: TFTP: Looking for term42.default.loads

    2811-lab#show flash: | inc loads
    6 676 Jan 30 2014 22:15:04 SCCP42.9-2-1S.loads
    7 662 Jan 30 2014 23:38:16 term42.default.loads
    8 662 Jan 30 2014 23:38:16 term62.default.loads
    176 658 Jan 30 2014 23:38:16 SCCP42.8-4-2S.loads
    After rebooting twice it looked for the files I posted in my last post. Those files are not there. My phones are back in phone purgatory, forever rebooting.

    2811-lab#show telephony-service tftp-bindings
    tftp-server flash:/jar42sccp.8-4-1-23.sbn alias jar42sccp.8-4-1-23.sbn
    tftp-server flash:/cnu42.8-4-1-23.sbn alias cnu42.8-4-1-23.sbn
    tftp-server flash:/apps42.8-4-1-23.sbn alias apps42.8-4-1-23.sbn
    tftp-server flash:/dsp42.8-4-1-23.sbn alias dsp42.8-4-1-23.sbn
    tftp-server flash:/cvm42sccp.8-4-1-23.sbn alias cvm42sccp.8-4-1-23.sbn
    tftp-server flash:/SCCP42.8-4-2S.loads alias SCCP42.8-4-2S.loads
    tftp-server flash:/its/united_states_7960-tones.xml alias United_States/7960-tones.xml
    tftp-server flash:/its/united_states_lddefault.cfg alias United_States/lddefault.cfg
    tftp-server flash:/its/united_states_gkdefault.cfg alias United_States/gkdefault.cfg
    tftp-server flash:/its/united_states_ffdefault.cfg alias United_States/ffdefault.cfg
    tftp-server flash:/its/united_states_7960-font.xml alias English_United_States/7960-font.xml
    tftp-server flash:/its/united_states_7960-font.xml alias English_United_States/7920-font.xml
    tftp-server flash:/its/united_states_7960-dictionary.xml alias English_United_States/7960-dictionary.xml
    tftp-server flash:/its/united_states_7960-kate.xml alias English_United_States/7960-kate.xml
    tftp-server flash:/its/united_states_7960-kate.xml alias English_United_States/7920-kate.xml
    tftp-server flash:/its/united_states_SCCP-dictionary.xml alias English_United_States/SCCP-dictionary.xml
    tftp-server flash:/its/SEPDEFAULT.cnf alias SEPDefault.cnf
    tftp-server flash:/its/vrf1/XMLDefault.cnf.xml alias XMLDefault.cnf.xml
    tftp-server flash:/its/vrf1/ATADefault.cnf.xml alias ATADefault.cnf.xml

    Last edited by ehnde; 01-31-2014 at 07:20 PM.
    Reply With Quote Quote  

  12. Senior Member
    Join Date
    Jan 2012
    Posts
    1,250

    Certifications
    BS IT (CCNA R&S, Security, Voice) CCDA, MCP XP, A+, L+, P+, LPIC-1, SUSE CLA
    #11
    Can you give the output where the files are located type this command:

    dir flash:
    Reply With Quote Quote  

  13. Senior Member
    Join Date
    Mar 2013
    Posts
    103
    #12
    Also can you repost your newest running config? Did you figure out why you need the 'alias' statement yet?
    Reply With Quote Quote  

  14. Senior Member
    Join Date
    Oct 2010
    Location
    United States
    Posts
    1,099

    Certifications
    CCNA, CCNA:Sec CCNA:Voice, A+, Project+, Sec+, Linux+, MCTS, ITIL v3, VCP-DCV
    #13
    Quote Originally Posted by bobfromfpl View Post
    Also can you repost your newest running config? Did you figure out why you need the 'alias' statement yet?
    I still haven't managed to get a dial tone. You can't break what's already broken!

    dir flash:
    2811-lab#dir flash:
    Directory of flash:/


    1 -rw- 4639974 Jan 30 2014 22:14:32 +00:00 apps42.9-2-1TH1-13.sbn
    2 -rw- 575495 Jan 30 2014 22:14:36 +00:00 cnu42.9-2-1TH1-13.sbn
    3 -rw- 2208583 Jan 30 2014 22:14:48 +00:00 cvm42sccp.9-2-1TH1-13.sbn
    4 -rw- 356907 Jan 30 2014 22:14:52 +00:00 dsp42.9-2-1TH1-13.sbn
    5 -rw- 1759967 Jan 30 2014 22:15:02 +00:00 jar42sccp.9-2-1TH1-13.sbn
    6 -rw- 676 Jan 30 2014 22:15:04 +00:00 SCCP42.9-2-1S.loads
    7 -rw- 662 Jan 30 2014 23:38:16 +00:00 term42.default.loads
    8 -rw- 662 Jan 30 2014 23:38:16 +00:00 term62.default.loads
    9 -rw- 59490092 Jan 30 2014 22:26:54 +00:00 c2800nm-adventerprisek9-mz.124-24.T8.bin
    10 -rw- 8160 Jan 30 2014 23:38:34 +00:00 Analog1.raw
    11 -rw- 8160 Jan 30 2014 23:38:34 +00:00 Analog2.raw
    12 -rw- 5280 Jan 30 2014 23:38:34 +00:00 AreYouThere.raw
    13 -rw- 5040 Jan 30 2014 23:38:36 +00:00 AreYouThereF.raw
    14 -rw- 8160 Jan 30 2014 23:38:36 +00:00 Bass.raw
    15 -rw- 12240 Jan 30 2014 23:38:36 +00:00 CallBack.raw
    16 -rw- 16040 Jan 30 2014 23:38:36 +00:00 Chime.raw
    17 -rw- 8160 Jan 30 2014 23:38:38 +00:00 Classic1.raw
    18 -rw- 16080 Jan 30 2014 23:38:38 +00:00 Classic2.raw
    19 -rw- 10800 Jan 30 2014 23:38:38 +00:00 ClockShop.raw
    20 -rw- 2823 Jan 30 2014 23:38:38 +00:00 DistinctiveRingList.xml
    21 -rw- 9600 Jan 30 2014 23:38:40 +00:00 Drums1.raw
    22 -rw- 13440 Jan 30 2014 23:38:40 +00:00 Drums2.raw
    23 -rw- 15840 Jan 30 2014 23:38:40 +00:00 FilmScore.raw
    24 -rw- 16080 Jan 30 2014 23:38:40 +00:00 HarpSynth.raw
    25 -rw- 8160 Jan 30 2014 23:38:42 +00:00 Jamaica.raw
    26 -rw- 16080 Jan 30 2014 23:38:42 +00:00 KotoEffect.raw
    27 -rw- 12720 Jan 30 2014 23:38:42 +00:00 MusicBox.raw
    28 -rw- 8160 Jan 30 2014 23:38:42 +00:00 Piano1.raw
    29 -rw- 15360 Jan 30 2014 23:38:42 +00:00 Piano2.raw
    30 -rw- 9360 Jan 30 2014 23:38:44 +00:00 Pop.raw
    31 -rw- 7200 Jan 30 2014 23:38:44 +00:00 Pulse1.raw
    32 -rw- 4000 Jan 30 2014 23:38:44 +00:00 Ring1.raw
    33 -rw- 4000 Jan 30 2014 23:38:44 +00:00 Ring2.raw
    34 -rw- 4000 Jan 30 2014 23:38:46 +00:00 Ring3.raw
    35 -rw- 4000 Jan 30 2014 23:38:46 +00:00 Ring4.raw
    36 -rw- 4000 Jan 30 2014 23:38:46 +00:00 Ring5.raw
    37 -rw- 4000 Jan 30 2014 23:38:46 +00:00 Ring6.raw
    38 -rw- 4000 Jan 30 2014 23:38:48 +00:00 Ring7.raw
    39 -rw- 495 Jan 30 2014 23:38:48 +00:00 RingList.xml
    40 -rw- 10800 Jan 30 2014 23:38:48 +00:00 Sax1.raw
    41 -rw- 14160 Jan 30 2014 23:38:48 +00:00 Sax2.raw
    42 -rw- 16080 Jan 30 2014 23:38:48 +00:00 Vibe.raw
    43 drw- 0 Jan 30 2014 22:35:16 +00:00 its
    175 -rw- 2918613 Jan 30 2014 23:37:50 +00:00 apps42.8-4-1-23.sbn
    171 -rw- 485066 Jan 30 2014 23:37:52 +00:00 cnu42.8-4-1-23.sbn
    174 -rw- 2659498 Jan 30 2014 23:38:08 +00:00 cvm42sccp.8-4-1-23.sbn
    173 -rw- 335003 Jan 30 2014 23:38:10 +00:00 dsp42.8-4-1-23.sbn
    172 -rw- 628112 Jan 30 2014 23:38:14 +00:00 jar42sccp.8-4-1-23.sbn
    176 -rw- 658 Jan 30 2014 23:38:16 +00:00 SCCP42.8-4-2S.loads

    newest config:
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname 2811-lab
    !
    boot-start-marker
    boot system flash:c2800nm-adventerprisek9-mz.124-24.T8.bin
    boot-end-marker
    !
    logging message-counter syslog
    no logging console
    !
    no aaa new-model
    no network-clock-participate wic 0
    !
    dot11 syslog
    ip source-route
    !
    !
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 172.26.1.1
    ip dhcp excluded-address 172.26.1.100
    !
    ip dhcp pool VOICE
    network 172.26.1.0 255.255.255.0
    default-router 172.26.1.1
    option 150 ip 172.26.1.1
    !
    !
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    voice service voip
    allow-connections h323 to sip
    allow-connections sip to h323
    fax protocol cisco
    !
    !
    !
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g711alaw
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    voice-card 0
    dspfarm
    !
    !
    !
    !
    !


    archive
    log config
    hidekeys
    !
    !
    !
    !
    !
    controller T1 0/0/0
    !
    controller T1 0/0/1
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex full
    speed 100
    !
    interface FastEthernet0/1
    description 3750-lab
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/1.100
    description VOICE VLAN
    encapsulation dot1Q 100
    ip address 172.26.1.1 255.255.255.0
    !
    interface Serial0/1/0
    no ip address
    shutdown
    no fair-queue
    clock rate 2000000
    !
    interface Serial0/1/1
    no ip address
    shutdown
    clock rate 2000000
    !
    ip forward-protocol nd
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    !
    !
    tftp-server flash:Analog1.raw
    tftp-server flash:Analog2.raw
    tftp-server flash:AreYouThere.raw
    tftp-server flash:AreYouThereF.raw
    tftp-server flash:Bass.raw
    tftp-server flash:CallBack.raw
    tftp-server flash:Chime.raw
    tftp-server flash:Classic1.raw
    tftp-server flash:Classic2.raw
    tftp-server flash:ClockShop.raw
    tftp-server flashistinctiveRingList.xml
    tftp-server flashrums1.raw
    tftp-server flashrums2.raw
    tftp-server flash:FilmScore.raw
    tftp-server flash:HarpSynth.raw
    tftp-server flash:Jamaica.raw
    tftp-server flash:KotoEffect.raw
    tftp-server flash:MusicBox.raw
    tftp-server flash:Piano1.raw
    tftp-server flash:Piano2.raw
    tftp-server flash:Pop.raw
    tftp-server flash:Pulse1.raw
    tftp-server flash:Ring1.raw
    tftp-server flash:Ring2.raw
    tftp-server flash:Ring3.raw
    tftp-server flash:Ring4.raw
    tftp-server flash:Ring5.raw
    tftp-server flash:Ring6.raw
    tftp-server flash:Ring7.raw
    tftp-server flash:RingList.xml
    tftp-server flash:SCCP42.9-2-1S.loads
    tftp-server flash:Sax1.raw
    tftp-server flash:Sax2.raw
    tftp-server flash:Vibe.raw
    tftp-server flash:apps42.8-4-1-23.sbn alias apps42.8-4-1-23
    tftp-server flash:apps42.9-2-1TH1-13.sbn alias apps42.9-2-1TH1-13
    tftp-server flash:cnu42.8-4-1-23.sbn alias cnu42.8-4-1-23
    tftp-server flash:cnu42.9-2-1TH1-13.sbn
    tftp-server flash:cvm42sccp.8-4-1-23.sbn alias cvm42sccp.8-4-1-23
    tftp-server flash:cvm42sccp.9-2-1TH1-13.sbn
    tftp-server flash:dsp42.8-4-1-23.sbn alias dsp42.8-4-1-23
    tftp-server flash:dsp42.9-2-1TH1-13.sbn
    tftp-server flash:its
    tftp-server flash:jar42sccp.8-4-1-23.sbn alias jar42sccp.8-4-1-23
    tftp-server flash:jar42sccp.9-2-1TH1-13.sbn
    tftp-server flash:term42.default.loads alias term42.default
    tftp-server flash:term62.default.loads
    tftp-server flash:term42.default.loads alias term4service
    tftp-server flash:apps42.9-2-1TH1-13.sbn alias apps42.9-2-1TH1-13.sbn
    tftp-server flash:term42.default.loads alias term42.default.sbn
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    telephony-service
    max-ephones 5
    max-dn 5
    ip source-address 172.26.1.1 port 2000
    auto assign 1 to 5
    cnf-file location flash:
    load 7941GE SCCP41.8-2-2SR2S
    load 7942 SCCP42.8-4-2S.loads
    load 7945 SCCP45.8-3-2S
    load 7961 SCCP41.8-2-2SR2S
    load 7961GE SCCP41.8-2-2SR2S
    load 7962 SCCP42.8-3-2S
    load 7965 SCCP45.8-3-2S
    load 7970 SCCP70.8-2-2SR2S
    load 7971 SCCP70.8-2-2SR2S
    load 7975 SCCP75.8-3-2S
    dialplan-pattern 1 2225... extension-length 4
    max-conferences 8 gain -6
    transfer-system full-consult
    create cnf-files version-stamp Jan 01 2002 00:00:00
    !
    !
    ephone-dn 1 dual-line
    number 5001
    label Tyler lab phone
    name Tyler
    !
    !
    ephone-dn 2 dual-line
    number 5002
    !
    !
    ephone-dn 3 dual-line
    number 5003
    !
    !
    ephone-dn 4 dual-line
    number 5004
    !
    !
    ephone-dn 5 dual-line
    number 5005
    !
    !
    ephone 1
    device-security-mode none
    mac-address FCFB.FB11.A363
    button 1:1
    !
    !
    !
    ephone 2
    device-security-mode none
    !
    !
    !
    ephone 3
    device-security-mode none
    !
    !
    !
    ephone 4
    device-security-mode none
    !
    !
    !
    ephone 5
    device-security-mode none
    !
    !
    !
    line con 0
    logging synchronous
    line aux 0
    line vty 0 4
    login
    !
    scheduler allocate 20000 1000
    end

    Reply With Quote Quote  

  15. Senior Member
    Join Date
    Mar 2013
    Posts
    103
    #14
    You're almost there.. revisit your 'tftp-server flash:' file configs!
    Reply With Quote Quote  

  16. Senior Member
    Join Date
    Oct 2010
    Location
    United States
    Posts
    1,099

    Certifications
    CCNA, CCNA:Sec CCNA:Voice, A+, Project+, Sec+, Linux+, MCTS, ITIL v3, VCP-DCV
    #15
    Quote Originally Posted by bobfromfpl View Post
    You're almost there.. revisit your 'tftp-server flash:' file configs!
    Sure enough, that was it! There were errors in the aliases, and the aliases were not necessary because the files being served by tftp were in the root of flash:

    2811-lab#show ephone phone-load
    DeviceName CurrentPhoneload PreviousPhoneload LastReset
    ================================================== ===================
    SEPFCFBFB11A363 SCCP42.8-4-2S Initialized
    I do have one other question...in alot of demonstrations and documentation I see a the files in flash: organized in directories. Mine didn't come this way and I dumped everything right at the root. Was I supposed to make a flashhones/ and flash:ringtones/ directory?
    Reply With Quote Quote  

  17. Senior Member pitviper's Avatar
    Join Date
    May 2008
    Location
    Right Coast, US
    Posts
    1,363

    Certifications
    CCNP:Collaboration, CCNP:R+S, CCNA:R+S, CCNA:V(IIUC), CCNA:S, CCENT, CNSS 4011
    #16
    Quote Originally Posted by ehnde View Post
    I do have one other question...in alot of demonstrations and documentation I see a the files in flash: organized in directories. Mine didn't come this way and I dumped everything right at the root. Was I supposed to make a flashhones/ and flash:ringtones/ directory?
    It doesn’t matter – it’s better from an organizational standpoint (sanity) but it works fine either way.
    Reply With Quote Quote  

  18. Senior Member
    Join Date
    Oct 2010
    Location
    United States
    Posts
    1,099

    Certifications
    CCNA, CCNA:Sec CCNA:Voice, A+, Project+, Sec+, Linux+, MCTS, ITIL v3, VCP-DCV
    #17
    Ok, good to know. Thank you!
    Reply With Quote Quote  

  19. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #18
    ehnde - did you get the phones up and running?
    Reply With Quote Quote  

  20. Senior Member
    Join Date
    Oct 2010
    Location
    United States
    Posts
    1,099

    Certifications
    CCNA, CCNA:Sec CCNA:Voice, A+, Project+, Sec+, Linux+, MCTS, ITIL v3, VCP-DCV
    #19
    Quote Originally Posted by JeanM View Post
    ehnde - did you get the phones up and running?
    Yes, I've got dial tones and 2 7942's able to call each other. That was VERY educational. This stuff is no longer just words on a page.
    Reply With Quote Quote  

  21. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #20
    Nice! Set up a sip trunk next .
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks