+ Reply to Thread
Page 1 of 2 1 2 Last
Results 1 to 25 of 47
  1. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    287
    #1

    Default Configuring CME router

    Guys, could you help me with configuring 2811 router as CME and TFTP. To be precise:
    1. The list of required software.
    2. The list of required hardware (at least for small business).
    3. How to upload IP phones frimware and CME software.

    Probably the list above is not full, but this is what i'd like to know at the moment.

    Thanks in advance.
    Best, sacredboy!
    Reply With Quote Quote  

  2. SS -->
  3. Network Engineer Dieg0M's Avatar
    Join Date
    Jun 2013
    Location
    Montreal
    Posts
    853

    Certifications
    CCIE #48240, CCDP
    #2
    I believe a 2811 can only support ~32 phones. You will be able to create up to 36 ephones but only 32 will be supported.Also, you will need to upload the firmware of the phone on the flash. You don't need any CME software, just to configure the telephony-services.
    Follow my CCDE journey at www.routingnull0.com
    Reply With Quote Quote  

  4. Senior Member
    Join Date
    May 2009
    Location
    DMV
    Posts
    2,204

    Certifications
    CCNP, CCNP(V), S+ CCIE V(written)
    #3
    https://learningnetwork.cisco.com/se...ice%20VoIP.pdf

    You need to download the CME device pack. Also if this is for a live business make sure you don't forget voicemail.
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
    Reply With Quote Quote  

  5. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    287
    #4
    Guys I'm a bit confused in terms of CME software. Should I install Cisco Unified CME 4/7/8/9 or not?
    And how to create /phone/7940-7960 directory?

    shodown
    , could you clarify what doesCME device pack mean please.
    Last edited by sacredboy; 03-20-2014 at 08:30 PM.
    Best, sacredboy!
    Reply With Quote Quote  

  6. /threadkiller ande0255's Avatar
    Join Date
    Sep 2013
    Location
    Around
    Posts
    1,160

    Certifications
    CCNA R&S, Voice, Security
    #5
    I believe device pack is the package with the files that need to be loaded into flash for CME if they aren't preloaded on the router, and you don't need to configure CME itself, but configure phone system settings (so CME as a service is not "configured" but loaded into flash like an IOS).

    Ideally you'd want CME 8 or 9, but I practiced on 4.x and was fine.
    Reply With Quote Quote  

  7. Senior Member
    Join Date
    May 2009
    Location
    DMV
    Posts
    2,204

    Certifications
    CCNP, CCNP(V), S+ CCIE V(written)
    #6
    The device pak loads all the files onto the flash of the router. Most of them you don't need, but you never know. It has firmware, MOH, ACD files, things of that nature.
    Currently Reading

    CUCM SRND 9x/10, UCCX SRND 10x, QOS SRND, SIP Trunking Guide, anything contact center related
    Reply With Quote Quote  

  8. Senior Member
    Join Date
    Jan 2012
    Posts
    1,240

    Certifications
    BS IT (CCNA R&S, Security, Voice) CCDA, MCP XP, A+, L+, P+, LPIC-1, SUSE CLA
    #7
    The Device pack is all of the phone loads, GUI files, MOH that pertain to a certain CME version.

    You listed having a 2811 so ver 9.0 is not compatible. It really depends on what you have access too and the IOS thats running on the router. The newer the better. For the 2811 8.6 is the best bet but of course you need IOS 15.1 (4). With 15.1 its additional configurations that need to made before you can receive calls. With 12.4 you could run version 7.1.

    To make a directory mkdir flash:/phone

    If you have the device pack you can extract it to flash
    archive tar /xtract tftp://tftp-server-ip-address/cme-full-8.5.0.0.tar flash:

    It will create all of the directories and subdirectory but make sure you have a flash card thats big enough.

    If your flash card is smaller you could just upload the tar file for the phone load you need you can extract it to flash:/phone directory. The tar file will create a subdirectory in the Phone directory. You can also upload each file individually onto the router which will take quite some time. For sanity sake you should create a subdirectory in the phone directory and upload the files for the specific phone into that directory.

    mkdir flash:/phone/7940-7960

    For configuring CME the link shodown provided gives you everything you need to set it up.
    Reply With Quote Quote  

  9. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #8
    Quote Originally Posted by sacredboy View Post
    Guys I'm a bit confused in terms of CME software. Should I install Cisco Unified CME 4/7/8/9 or not?
    And how to create /phone/7940-7960 directory?

    shodown
    , could you clarify what doesCME device pack mean please.
    Read the pdf file shodown shared, step #5
    Reply With Quote Quote  

  10. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    287
    #9
    Guys, will this scheme with TFTP and IP phones in different IP subnets work?

    screen.jpg
    Best, sacredboy!
    Reply With Quote Quote  

  11. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    287
    #10
    ip dhcp excluded-address 172.16.1.1 172.16.1.10
    ip dhcp excluded-address 192.168.1.1 192.168.1.10
    !
    ip dhcp pool DATA_POOL
    network 192.168.1.0 255.255.255.0
    default-router 192.168.1.1
    dns-server 4.2.2.2
    !
    ip dhcp pool VOICE_POOL
    network 172.16.1.0 255.255.255.0
    default-router 172.16.1.1
    dns-server 4.2.2.2
    option 150 ip 192.168.1.10
    !
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 172.16.1.1 255.255.255.0
    !
    interface FastEthernet0/0.50
    encapsulation dot1Q 50
    ip address 192.168.1.1 255.255.255.0
    The thing is that IP phones receive TCP/IP config successfully, but can't find TFTP server.

    And could you also expain why this command isn't working:

    CME_RTR (config)#tftp-server flash:/phone/7940-7960/P00308010200.bin alias P00308010200.bin

    CME_RTR#sh flash:
    -#- --length-- -----date/time------ path
    1 36030824 Nov 30 1987 04:00:00 c2800nm-ipbasek9-mz.151-1.XB.bin
    2 59455672 Apr 07 2014 14:33:40 c2800nm-adventerprisek9-mz.124-24.T2.bin
    3 0 Apr 07 2014 16:51:32 phone
    4 0 Apr 07 2014 16:51:36 phone/7940-7960

    416604160 bytes available (95510528 bytes used)
    And finally, is it mandatory to install cme-full-7.1.0.1.tar?
    Last edited by sacredboy; 04-07-2014 at 06:05 PM.
    Best, sacredboy!
    Reply With Quote Quote  

  12. Senior Member cisco_nerd's Avatar
    Join Date
    Dec 2010
    Location
    Brisbane, Australia
    Posts
    198
    #11
    Your phones may not pick up the firmware if you do not actually have the file structure flash:/phone/7940-7960/ and have the specified files within the folder.

    The other issue that could exist is that there is a typo in the tftp-server command and it does not match the exact spelling or characters of the file name within the flash.

    Have a look at those and see how you go.
    Last edited by cisco_nerd; 04-14-2014 at 04:41 AM.
    Reply With Quote Quote  

  13. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    287
    #12
    Finally managed to start up two phones. The problem was related to ip phones firmware.
    Best, sacredboy!
    Reply With Quote Quote  

  14. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    287
    #13
    Guys, is it mandatory to configure DHCP parameters for data traffic or workstations? The things is that I'm going to use DHCP server on Windows OS, and, thereby don't need this service on the router.
    Last edited by sacredboy; 05-09-2014 at 10:08 AM.
    Best, sacredboy!
    Reply With Quote Quote  

  15. Senior Member
    Join Date
    Dec 2012
    Location
    UK
    Posts
    225

    Certifications
    CCNP:R&S, CCNA:Voice, MSc Networking Technologies
    #14
    I wouldn't have thought so. Just get rid of the data pool and set the ip helper-address on the connecting interface to the Windows machine.
    Reply With Quote Quote  

  16. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    287
    #15
    Quote Originally Posted by wallpaper_01 View Post
    I wouldn't have thought so. Just get rid of the data pool and set the ip helper-address on the connecting interface to the Windows machine.
    Oh, I've totally forgotten to say that Windows DHCP server is in the same subnet as workstations so there is no need to configure ip helper-address, is there?
    Best, sacredboy!
    Reply With Quote Quote  

  17. Senior Member
    Join Date
    Dec 2012
    Location
    UK
    Posts
    225

    Certifications
    CCNP:R&S, CCNA:Voice, MSc Networking Technologies
    #16
    Oh right yeah got you! Yeah I think it works. I'm at work so cant properly test but according to packet tracer you can do it! you can plug the server into one of the switch ports with the data vlan configured I think.
    Reply With Quote Quote  

  18. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    287
    #17
    Guys I've tried the scheme with Windows DHCP server for data VLAN but VoIP doesn't work. Below are my sh run outputs from L3 switch and CME router (some line were omitted for brevity).
    CME_RTR#sh run

    ip dhcp excluded-address 172.16.1.1 172.16.1.10
    !
    ip dhcp pool VOICE_POOL
    network 172.16.1.0 255.255.255.0
    default-router 172.16.1.1
    dns-server 4.2.2.2
    option 150 ip 172.16.1.1
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 172.16.1.1 255.255.255.0
    !
    interface FastEthernet0/0.50
    encapsulation dot1Q 50
    ip address 192.168.1.1 255.255.255.0
    !
    tftp-server flash:P00308010100.bin
    tftp-server flash:P00308010100.loads
    tftp-server flash:P00308010100.sb2
    tftp-server flash:P00308010100.sbn
    !
    end
    DSW2#sh cdp neighborsCapability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
    S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
    D - Remote, C - CVTA, M - Two-port Mac Relay

    Device ID Local Intrfce Holdtme Capability Platform Port ID
    SEP001A6D0F98DC Fas 3/0/11 144 H P M IP Phone Port 1
    SEP0018BA9B6956 Fas 3/0/12 148 H P M IP Phone Port 1
    CME_RTR Fas 3/0/1 158 R S I 2811 Fas 0/0

    DSW2#sh vlan

    VLAN Name Status Ports
    ---- -------------------------------- --------- -------------------------------
    1 default active Fa3/0/17, Fa3/0/18, Fa3/0/19
    Fa3/0/20, Fa3/0/21, Fa3/0/22
    Fa3/0/23, Fa3/0/24, Gi3/0/1
    Gi3/0/2
    10 VOICE_VLAN active Fa3/0/13, Fa3/0/14, Fa3/0/15
    Fa3/0/16
    50 DATA_VLAN active Fa3/0/2, Fa3/0/3, Fa3/0/4
    Fa3/0/5, Fa3/0/6, Fa3/0/7
    Fa3/0/8, Fa3/0/9, Fa3/0/10
    Fa3/0/11, Fa3/0/12, Fa3/0/13
    Fa3/0/14, Fa3/0/15, Fa3/0/16

    interface FastEthernet3/0/1
    description "CONNECTION TO CME_RTR"
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface FastEthernet3/0/2
    switchport access vlan 50
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet3/0/13
    switchport access vlan 50
    switchport mode access
    switchport voice vlan 10
    spanning-tree portfast
    !
    end
    All workstations receive IP from Windows DHCP server successfully. However, IP phones don't receive IP from DHCP configured on CME router.

    Any thoughts what can be the reason of the problem?
    Last edited by sacredboy; 05-15-2014 at 05:52 AM.
    Best, sacredboy!
    Reply With Quote Quote  

  19. Senior Member cisco_nerd's Avatar
    Join Date
    Dec 2010
    Location
    Brisbane, Australia
    Posts
    198
    #18
    Quote Originally Posted by sacredboy View Post
    Guys I've tried the scheme with Windows DHCP server for data VLAN but VoIP doesn't work. Below are my sh run outputs from L3 switch and CME router (some line were omitted for brevity).



    All workstations receive IP from Windows DHCP server successfully. However, IP phones don't receive IP from DHCP configured on CME router.

    Any thoughts what can be the reason of the problem?

    From your output, your phones are not connected to the correct Voice VLAN. They are sitting on your Data VLAN and therefore will no get back to the CME. Your Phones are connected to 3/0/11 and 12... your switchports are configured for the Voice vlan on 3/0/13. Ports 3/0/11 and 12 are only in your data vlan.
    Reply With Quote Quote  

  20. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    287
    #19
    cisco_nerd, yep, that's my inattentiveness.
    Best, sacredboy!
    Reply With Quote Quote  

  21. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    287
    #20
    telephony-service
    moh music-on-hold.au
    Should I configure something else for Music on Hold to work? For now it doesn't work.
    Best, sacredboy!
    Reply With Quote Quote  

  22. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    287
    #21
    Guys, what device (and what modules) can play a role of PBX?
    Best, sacredboy!
    Reply With Quote Quote  

  23. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    287
    #22
    Guys, I totally forgot what these files are aimed for.

    P00308010200.bin
    P00308010200.loads
    P00308010200.sb2
    P00308010200.sbn

    Could you remind me that please.
    Last edited by sacredboy; 11-21-2014 at 06:54 PM.
    Best, sacredboy!
    Reply With Quote Quote  

  24. Senior Member
    Join Date
    Mar 2014
    Location
    Atlanta, GA
    Posts
    170

    Certifications
    CCNP Voice, CCNA R/S,
    #23
    Looks like it's firmware for 7940/7960 :

    Cisco Unified IP Phone 7940/7960 SCCP Firmware Load 8.1(2)
    Reply With Quote Quote  

  25. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    287
    #24
    Guys, is it possible in CME to change standard tone (beep beep beep) for some melody in the same way it is realized at mobile operators?
    Best, sacredboy!
    Reply With Quote Quote  

  26. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    287
    #25
    Guys, below is my diagram:

    6wjntz-i4r.jpg

    On the left side (Moscow) the IP phones 1001, 1002, 1003 and analogue phones 2001 and 2002
    On the right side (Saint Petersburg) the IP phones 7001, 7002, 7003

    Calls between the IP phones in Moscow and St Petersburg work fine. Calls between the IP phones and the analogue phones in Moscow also work fine.

    The problem is that calls between the analogue phones in Moscow and the IP phones in St Petersburg don't work.

    Below is a chunk of sh run command:
    Code:
    MSC_CME#sh run | s dial-peer 
    dial-peer voice 7000 voip 
     destination-pattern 7... 
     session target ipv4:10.1.1.2 
    dial-peer voice 2001 pots 
     destination-pattern 2001 
     port 0/2/0 
    dial-peer voice 2002 pots 
     destination-pattern 2002 
     port 0/2/1 
    dial-peer voice 8000 voip 
     destination-pattern 8... 
     session target ipv4:10.1.1.2 
     codec g711ulaw 
    
    STP_CME#sh run | s dial-peer 
    dial-peer voice 1000 voip 
     destination-pattern 1... 
     session target ipv4:10.1.1.1 
    dial-peer voice 2000 voip 
     destination-pattern 2... 
     session target ipv4:10.1.1.1 
     codec g711ulaw
    I tried to specify the numbers of analogue phones explicitly in destination-pattern but it didn't help.

    Please, have a look to solve this issue.
    Best, sacredboy!
    Reply With Quote Quote  

+ Reply to Thread
Page 1 of 2 1 2 Last

Social Networking & Bookmarks