+ Reply to Thread
Results 1 to 9 of 9
  1. Senior Member
    Join Date
    Dec 2012
    Location
    Chicago, IL
    Posts
    328

    Certifications
    Juniper/Cisco/CompTIA Gandam
    #1

    Default Different simultaneous issue - VTP

    This is is a different simultaneous issue along with "Hiccup on setting up first IP Phone."


    Please take a look at these two switches and notice any issue for VTP and trunking. PWR-SW's fa 0/23 is connected to SW-2's fa 0/24.



    [PWR-SW]



    Building configuration...


    Current configuration : 5701 bytes
    !
    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    no service dhcp
    !
    hostname sndlt3550
    !
    enable secret 5 $1$e1To$0rFwIzZOKxA9r8hpGolzq0
    enable password 7 000A161106095B575B
    !
    username sndlt password 7 0208014C09545F7018
    no aaa new-model
    ip subnet-zero
    ip domain-name sndlt.com
    !
    ip dhcp-server 10.10.10.10
    !
    !
    crypto pki trustpoint TP-self-signed-3185929216
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-3185929216
    revocation-check none
    rsakeypair TP-self-signed-3185929216
    !
    !
    crypto pki certificate chain TP-self-signed-3185929216
    certificate self-signed 01
    3082024B 308201B4 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
    31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
    6FF 301E0603

    55E59 1C98A69F BA2743AD 5675E103

    895E3656 FCE89C11 293A2E5F 09D6DDC4 3176AAC1 0C91E78A 78E95915 D6C3CD0B
    A26A4204 D257D464 68A8EB03 AB8D26
    quit
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    ip ssh version 2
    !
    !
    interface FastEthernet0/1
    no switchport
    no ip address
    duplex full
    !
    interface FastEthernet0/2
    switchport access vlan 50
    switchport mode access
    switchport voice vlan 10
    spanning-tree portfast
    !


    interface FastEthernet0/24
    switchport access vlan 50
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport voice vlan 10
    spanning-tree portfast
    !
    interface GigabitEthernet0/1
    switchport mode dynamic desirable
    !
    interface GigabitEthernet0/2
    switchport mode dynamic desirable
    !
    interface Vlan1
    ip address 10.10.10.12 255.255.255.0
    !
    ip default-gateway 10.10.10.10
    ip classless
    ip http server
    ip http secure-server
    !
    !
    control-plane
    !
    !
    line con 0
    line vty 0 4
    login local
    transport input ssh
    line vty 5
    login local
    transport input none
    line vty 6 15
    login
    !
    end





    #show vtp sta
    VTP Version : running VTP2

    Configuration Revision : 3
    Maximum VLANs supported locally : 1005
    Number of existing VLANs : 7
    VTP Operating Mode : Server
    VTP Domain Name : sndlt.com
    VTP Pruning Mode : Disabled
    VTP V2 Mode : Enabled
    VTP Traps Generation : Disabled
    MD5 digest : 0x13 0xEF 0x2E 0x5D 0x78 0x69 0xAA 0x8E
    Configuration last modified by 10.10.10.12 at 3-1-93 03:30:49
    Local updater ID is 10.10.10.12 on interface Vl1 (lowest numbered VLAN interface found)



    [SW-2]



    Building configuration...


    Current configuration : 1524 bytes
    !
    version 12.1
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname sndlt
    !
    enable secret 5 $1$dPtF$LmMU2BgqpGblALK68HgZN.
    !
    username sndlt password 7 1419171C0E567A7A70
    ip subnet-zero
    !
    ip domain-name sndlt.com
    ip ssh time-out 120
    ip ssh authentication-retries 3
    !
    !
    spanning-tree mode pvst
    no spanning-tree optimize bpdu transmission
    spanning-tree extend system-id
    spanning-tree vlan 1 priority 0
    !
    !
    !
    !
    interface FastEthernet0/1
    !
    interface FastEthernet0/2
    !
    interface FastEthernet0/3
    !
    interface FastEthernet0/4
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !


    !
    interface FastEthernet0/23
    !
    interface FastEthernet0/24
    switchport mode trunk

    !
    interface Vlan1
    ip address 10.10.10.6 255.255.255.0
    no ip route-cache
    !
    ip default-gateway 10.10.10.10
    ip http server
    !
    line con 0
    line vty 0 4
    password 7 09424B1E1B5747435F
    login local
    transport input ssh
    line vty 5
    password 7 011D03135959565E75
    login local
    transport input ssh
    line vty 6 15
    login local
    transport input ssh
    !
    !
    end


    #show vtp pas
    The VTP password is not configured.
    sndlt#show vtp stat
    VTP Version : 2
    Configuration Revision : 0
    Maximum VLANs supported locally : 128
    Number of existing VLANs : 5
    VTP Operating Mode : Client
    VTP Domain Name : sndlt.com
    VTP Pruning Mode : Disabled
    VTP V2 Mode : Disabled
    VTP Traps Generation : Disabled
    MD5 digest : 0x47 0x2E 0xC4 0xCA 0xDB 0x2F 0xAD 0xB3
    Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

    Reply With Quote Quote  

  2. SS -->
  3. Senior Member
    Join Date
    Nov 2013
    Posts
    146
    #2
    VTP only works over trunk links. Is PWR-SW's fa 0/23 a trunk? It is not included in the configuration your provided.
    Reply With Quote Quote  

  4. Senior Member
    Join Date
    Dec 2012
    Location
    Chicago, IL
    Posts
    328

    Certifications
    Juniper/Cisco/CompTIA Gandam
    #3
    I concluded that because it's not a crossover cable since it's not new IOS, it can't auto-change cabling mode.
    Reply With Quote Quote  

  5. Senior Member cisco_nerd's Avatar
    Join Date
    Dec 2010
    Location
    Brisbane, Australia
    Posts
    198
    #4
    It is advisable to always use the correct cabling when connecting same layer devices.

    You need to configure trunk ports on both the switches. As stated above, VTP only works over trunks. Fix this and it should work. Ensure that if you are using a password for VTP updates that they explicitly match on both switches.
    Reply With Quote Quote  

  6. Senior Member
    Join Date
    Oct 2009
    Location
    Madrid
    Posts
    148

    Certifications
    A+, Net+, CCENT, CCNA R&S
    #5
    Hi, i do not understand the point of having this configuration on PWR-SW

    !
    interface FastEthernet0/24
    switchport access vlan 50
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport voice vlan 10
    spanning-tree portfast
    !

    is this a trunk port or an access port???

    Last edited by Gngogh; 04-13-2014 at 06:29 PM.
    Reply With Quote Quote  

  7. ABL - Always Be Labbin' Iristheangel's Avatar
    Join Date
    Dec 2009
    Location
    Pasadena, CA
    Posts
    3,668

    Certifications
    CISSP, CCIE DC, CCNP R&S/DC, CCDP, CCNA:RS/S/V/DC, CCDA, BCVRE, BCEFP, BCNE, CEH, CHFI, MCSE:S, MCDST, A/S/L/P/N+, some useless Citrix and CIW certs
    #6
    If that's the connection between the two switches, I would clean up the config a bit. Lots of unnecessary lines in there.
    Remove switchport access vlan 50, switchport voice vlan 10, and spanning-tree portfast. Maybe throw in spanning-tree portfast trunk

    Also, did you notice this:

    #show vtp sta
    VTP Version : running VTP2

    Configuration Revision : 3
    Maximum VLANs supported locally : 1005
    Number of existing VLANs : 7
    VTP Operating Mode : Server
    VTP Domain Name : sndlt.com
    VTP Pruning Mode : Disabled
    VTP V2 Mode : Enabled
    VTP Traps Generation : Disabled
    MD5 digest : 0x13 0xEF 0x2E 0x5D 0x78 0x69 0xAA 0x8E
    Configuration last modified by 10.10.10.12 at 3-1-93 03:30:49
    Local updater ID is 10.10.10.12 on interface Vl1 (lowest numbered VLAN interface found)

    #show vtp pas
    The VTP password is not configured.
    sndlt#show vtp stat
    VTP Version : 2
    Configuration Revision : 0
    Maximum VLANs supported locally : 128
    Number of existing VLANs : 5
    VTP Operating Mode : Client
    VTP Domain Name : sndlt.com
    VTP Pruning Mode : Disabled
    VTP V2 Mode : Disabled
    VTP Traps Generation : Disabled
    MD5 digest : 0x47 0x2E 0xC4 0xCA 0xDB 0x2F 0xAD 0xB3
    Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00


    One switch is running VTP version 1 and the other is running VTP version 2
    Last edited by Iristheangel; 04-13-2014 at 06:45 PM.
    BS, MS, and CCIE #50931
    Blog: www.network-node.com
    Bonus TE Fun: Nerd Photos
    Reply With Quote Quote  

  8. Senior Member
    Join Date
    Dec 2012
    Location
    Chicago, IL
    Posts
    328

    Certifications
    Juniper/Cisco/CompTIA Gandam
    #7
    Yea, I noticed the V2/V1 difference. I had to switch to transparent, turn on V2 and go back to Client since it wouldn't let me swap at client mode.
    I just ordered myself some crossover patch cables.
    It took me 2 hours of this slow mind to suddenly realize that for older switches, you need crossover as they can't auto-detect cable type. (Because the lights on switches wouldn't even lit up other than when connected to a host or a router).
    Oh silly me!
    Reply With Quote Quote  

  9. Senior Member cisco_nerd's Avatar
    Join Date
    Dec 2010
    Location
    Brisbane, Australia
    Posts
    198
    #8
    Quote Originally Posted by sendalot View Post
    Yea, I noticed the V2/V1 difference. I had to switch to transparent, turn on V2 and go back to Client since it wouldn't let me swap at client mode.
    I just ordered myself some crossover patch cables.
    It took me 2 hours of this slow mind to suddenly realize that for older switches, you need crossover as they can't auto-detect cable type. (Because the lights on switches wouldn't even lit up other than when connected to a host or a router).
    Oh silly me!
    Or you could make them...
    Reply With Quote Quote  

  10. Senior Member
    Join Date
    Jan 2012
    Posts
    1,237

    Certifications
    BS IT (CCNA R&S, Security, Voice) CCDA, MCP XP, A+, L+, P+, LPIC-1, SUSE CLA
    #9
    Get yourself a wire crimper for a few bucks and some ethernet connectors then you could make whatever cable your heart desires.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks