+ Reply to Thread
Results 1 to 25 of 25
  1. Senior Member websponge's Avatar
    Join Date
    Aug 2008
    Posts
    119

    Certifications
    A+, Network +, MCP, CCENT, CCNA, CCNA Security, CCNP
    #1

    Default ASA Site to Site VPN Woes!

    Simple branch office on an ASA 5505, VPN to head office on a 5515.
    Allready a VPN up and working, have to move the connection to a new 5515 (new building)

    set up everything, local and remote networks, same shared key etc (this has been triple checked!) did it all through the GUI wizard, (yeah I know, but its quicker)

    data will only transmit from the branch office, and wont receive anything, Head office doesn't de-crypt..? tunnel is up , it just not allowing data from the head office.. totally stumped. have an any any rule on the outside and inside of the new ASA whilst I set this up.

    I put the old tunnel back up, and it connects immediately! there is nothing different except the peer IP on the head office, checked everything.. doing my nut! any advice?
    thanks
    Reply With Quote Quote  

  2. SS -->
  3. Mow
    Mow is offline
    Membrane Mow's Avatar
    Join Date
    Apr 2015
    Posts
    431

    Certifications
    CCNP Collaboration, CCNA, CCDA, CCNA Sec
    #2
    reconnect new tunnel, clear xlate, make sure your NAT 0 is correct
    Reply With Quote Quote  

  4. Achieve excellence daily
    Join Date
    May 2012
    Location
    Washington State
    Posts
    1,380

    Certifications
    CISSP
    #3
    Is the new IP in the encryption domain?
    When you go the extra mile, there's no traffic.
    Reply With Quote Quote  

  5. Senior Member websponge's Avatar
    Join Date
    Aug 2008
    Posts
    119

    Certifications
    A+, Network +, MCP, CCENT, CCNA, CCNA Security, CCNP
    #4
    The encryption domains are the same, branch office is 192.168.1.0 , head office on the 172.16.0.0
    what do you mean by NAT 0?
    Reply With Quote Quote  

  6. Achieve excellence daily
    Join Date
    May 2012
    Location
    Washington State
    Posts
    1,380

    Certifications
    CISSP
    #5
    The new public IP
    When you go the extra mile, there's no traffic.
    Reply With Quote Quote  

  7. Mow
    Mow is offline
    Membrane Mow's Avatar
    Join Date
    Apr 2015
    Posts
    431

    Certifications
    CCNP Collaboration, CCNA, CCDA, CCNA Sec
    #6
    NAT 0 = No NAT. It prevents the ASA from trying to NAT traffic bound for the VPN tunnel.

    Example:
    object-group network LOCAL
    network-object 172.16.0.0 255.255.200.0
    object-network BRANCH
    network-object 192.168.1.0 255.255.255.0
    nat (Inside,Outside) source static LOCAL LOCAL destination static BRANCH BRANCH no-proxy-arp route-lookup
    Reply With Quote Quote  

  8. Senior Member websponge's Avatar
    Join Date
    Aug 2008
    Posts
    119

    Certifications
    A+, Network +, MCP, CCENT, CCNA, CCNA Security, CCNP
    #7
    yes, the no nat is on there, (natting to itself)

    the tunnel comes up fine, but the remote site is transmitting data, but recieving nothing, same on the other end, loads recieved but none sent...

    so it must be the head office ASA,

    here is the result on that one for "show crypto ipsec sa"

    interface: internet
    Crypto map tag: internet_map, seq num: 1, local addr: 2.2.2.2 (changed this obviously)

    access-list internet_cryptomap extended permit ip 172.16.0.0 255.254.0.0 192.168.7.0 255.255.255.0
    local ident (addr/mask/prot/port): (172.16.0.0/255.254.0.0/0/0)
    remote ident (addr/mask/prot/port): (192.168.7.0/255.255.255.0/0/0)
    current_peer: 2.2.2.2

    #pkts encaps: 0, #pkts encrypt: 0, #pkts digest: 0
    #pkts decaps: 67, #pkts decrypt: 67, #pkts verify: 67
    #pkts compressed: 0, #pkts decompressed: 0
    #pkts not compressed: 0, #pkts comp failed: 0, #pkts decomp failed: 0
    #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
    #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
    #TFC rcvd: 0, #TFC sent: 0
    #Valid ICMP Errors rcvd: 0, #Invalid ICMP Errors rcvd: 0
    #send errors: 0, #recv errors: 0

    local crypto endpt.: 81.128.141.106/500, remote crypto endpt.: 79.77.41.45/500
    path mtu 1500, ipsec overhead 74(44), media mtu 1500
    PMTU time remaining (sec): 0, DF policy: copy-df
    ICMP error validation: disabled, TFC packets: disabled
    current outbound spi: 22E1254A
    current inbound spi : 12F2A06C

    inbound esp sas:
    spi: 0x12F2A06C (31789066
    transform: esp-aes-256 esp-sha-hmac no compression
    in use settings ={L2L, Tunnel, PFS Group 2, IKEv2, }
    slot: 0, conn_id: 729088, crypto-map: internet_map
    sa timing: remaining key lifetime (kB/sec): (4101115/28404)
    IV size: 16 bytes
    replay detection support: Y
    Anti replay bitmap:
    0xFFFFFFFF 0xFFFFFFFF
    outbound esp sas:
    spi: 0x22E1254A (585180490)
    transform: esp-aes-256 esp-sha-hmac no compression
    in use settings ={L2L, Tunnel, PFS Group 2, IKEv2, }
    slot: 0, conn_id: 729088, crypto-map: internet_map
    sa timing: remaining key lifetime (kB/sec): (3962880/28404)
    IV size: 16 bytes
    replay detection support: Y
    Anti replay bitmap:
    0x00000000 0x00000001

    really getting me down now!!
    Reply With Quote Quote  

  9. Member
    Join Date
    Jul 2010
    Location
    Location
    Posts
    94

    Certifications
    CCNA R&S, CCNP R&S, CCNA Security, JNCIA, JNCIS-SEC, CCNA DataCenter
    #8
    I will try to help you if you can share the configuration from both ASA.
    Reply With Quote Quote  

  10. Senior Member Edificer's Avatar
    Join Date
    Dec 2013
    Location
    Kurdistan
    Posts
    181

    Certifications
    CCENT, CCNA R&S/Security/SECFND
    #9
    One way communication could be the results of incorrect route statements
    can you post the output of sh route outside

    Head office dropping packets, or not decrypting?
    can you post the output of sh crypto isakmp stats

    Run the
    debug crypto ikev1 255
    debug crypto ipsec 255


    Post output of these too.


    I was faced with a similar issue, in my case on the remote site the VPN on a 5505 wouldn't come up unless data was sent through the tunnel, after plugging a 7960 the ASAs were encrypting and decrypting.

    In another case, after several days of rigorous troubleshooting I finally called up my ISP and we found out the problem was on their side.
    Last edited by Edificer; 07-28-2015 at 08:01 AM.
    “Our greatest glory is not in never falling, but in rising every time we fall.” ― Confucius
    Reply With Quote Quote  

  11. Senior Member websponge's Avatar
    Join Date
    Aug 2008
    Posts
    119

    Certifications
    A+, Network +, MCP, CCENT, CCNA, CCNA Security, CCNP
    #10
    Disconnect the tunnel for now, as its not working (its connected to another remote building)
    here is the route on the head office ASA, Where I think the issue is:

    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route

    Gateway of last resort is X.X.X.105 to network 0.0.0.0

    C X.X.X.104 255.255.255.248 is directly connected, internet
    S* 0.0.0.0 0.0.0.0 [1/0] via 81.128.141.105, internet

    ----------------------------------------------------------------------------

    Here is the full running. remote site is Fields-Cardiff, local site is Fields-Group


    hostname xxxxxx
    domain-name xxxxxxx
    enable password Z/IJwK7qDAnIuIX3 encrypted
    names
    !
    interface GigabitEthernet0/0
    nameif internet
    security-level 0
    ip address x.x.x.106 255.255.255.248
    !
    interface GigabitEthernet0/1
    shutdown
    no nameif
    no security-level
    no ip address
    !
    interface GigabitEthernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    !
    interface GigabitEthernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    !
    interface GigabitEthernet0/4
    shutdown
    no nameif
    no security-level
    no ip address
    !
    interface GigabitEthernet0/5
    nameif Inside-Core
    security-level 100
    no ip address
    !
    interface GigabitEthernet0/5.1
    vlan 5
    nameif vlan5
    security-level 100
    ip address 172.17.10.3 255.255.255.248
    !
    interface Management0/0
    management-only
    no nameif
    no security-level
    no ip address
    !
    ftp mode passive
    clock timezone GMT/BST 0
    clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
    dns server-group DefaultDNS
    domain-name fields.com
    same-security-traffic permit inter-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network Fields-Group
    subnet 172.16.0.0 255.254.0.0
    description Fields Major Network
    object network Fields-Gavin
    host 172.17.1.24
    description Static address for Management
    object network Fields-Vlan10
    subnet 172.17.1.0 255.255.255.0
    description Fields Associates - Vlan 10
    object network Fields-Thailand
    subnet 192.168.6.0 255.255.255.0
    description Fields Thailand Subnet
    object network Fields-Crossways
    subnet 192.168.11.0 255.255.255.0
    description Daryls Home Network
    object network Fields-Cardiff
    subnet 192.168.7.0 255.255.255.0
    description Cardiff Network
    object network Action-Direct-Voice
    subnet 172.17.12.0 255.255.255.0
    description Vlan 120 for Action Direct Voice VLAN
    object-group service DM_INLINE_SERVICE_1
    service-object ip
    service-object icmp echo-reply
    service-object icmp time-exceeded
    service-object icmp echo
    service-object icmp
    access-list vlan5_access_in extended permit ip object obj_any any
    access-list internet_access_in extended permit object-group DM_INLINE_SERVICE_1 any any
    access-list internet_cryptomap extended permit ip object Fields-Group object Fields-Cardiff
    pager lines 24
    logging enable
    logging asdm informational
    mtu internet 1500
    mtu Inside-Core 1500
    mtu vlan5 1500
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    nat (vlan5,internet) source dynamic obj_any interface
    nat (vlan5,internet) source static Fields-Group Fields-Group destination static Fields-Cardiff Fields-Cardiff no-proxy-arp route-lookup
    !
    object network obj_any
    nat (Inside-Core,internet) dynamic interface
    access-group internet_access_in in interface internet
    access-group vlan5_access_in in interface vlan5
    route internet 0.0.0.0 0.0.0.0 x.x.x.x.105 1
    route vlan5 172.16.0.0 255.254.0.0 172.17.10.6 1
    route vlan5 172.17.1.0 255.255.255.0 172.17.10.6 1
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    aaa authentication ssh console LOCAL
    aaa authentication http console LOCAL
    http server enable
    http 0.0.0.0 0.0.0.0 internet
    http 172.17.1.0 255.255.255.0 Inside-Core
    http 172.17.1.0 255.255.255.0 vlan5
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS esp-aes esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS mode transport
    crypto ipsec ikev2 ipsec-proposal AES256
    protocol esp encryption aes-256
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES192
    protocol esp encryption aes-192
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES
    protocol esp encryption aes
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal 3DES
    protocol esp encryption 3des
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal DES
    protocol esp encryption des
    protocol esp integrity sha-1 md5
    crypto ipsec security-association pmtu-aging infinite
    crypto map internet_map 1 match address internet_cryptomap
    crypto map internet_map 1 set pfs
    crypto map internet_map 1 set peer 79.77.41.45
    crypto map internet_map 1 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map internet_map 1 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
    crypto map internet_map interface internet
    crypto ca trustpoint _SmartCallHome_ServerCA
    crl configure
    crypto ca trustpool policy
    crypto ca certificate chain _SmartCallHome_ServerCA
    certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
    308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
    0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
    30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
    13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
    0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
    20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
    65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
    65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
    30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
    30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
    496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
    74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
    68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
    3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
    63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
    0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
    a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
    9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
    7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
    15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
    63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
    18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
    4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
    81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
    db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
    7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
    ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
    45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
    2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
    1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
    03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
    69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
    02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
    6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
    c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
    69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
    1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
    551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
    1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
    2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
    4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
    b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
    6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
    481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
    b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
    5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
    6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
    6c2527b9 deb78458 c61f381e a4c4cb66
    quit
    crypto ikev2 policy 1
    encryption aes-256
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 10
    encryption aes-192
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 20
    encryption aes
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 30
    encryption 3des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 40
    encryption des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 enable internet
    crypto ikev2 enable vlan5
    crypto ikev1 enable internet
    crypto ikev1 enable Inside-Core
    crypto ikev1 enable vlan5
    crypto ikev1 policy 10
    authentication pre-share
    encryption aes-256
    hash sha
    group 2
    lifetime 28800
    crypto ikev1 policy 20
    authentication rsa-sig
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 30
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 40
    authentication crack
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 50
    authentication rsa-sig
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 60
    authentication pre-share
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 70
    authentication crack
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 80
    authentication rsa-sig
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 90
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 100
    authentication crack
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 110
    authentication rsa-sig
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 130
    authentication crack
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 140
    authentication rsa-sig
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 150
    authentication pre-share
    encryption des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh 172.17.0.0 255.255.0.0 Inside-Core
    ssh 0.0.0.0 0.0.0.0 vlan5
    ssh timeout 5
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    dhcp-client update dns
    threat-detection basic-threat
    threat-detection scanning-threat
    threat-detection statistics host
    threat-detection statistics port number-of-rate 2
    threat-detection statistics protocol number-of-rate 2
    threat-detection statistics access-list
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    ntp server 85.91.1.180 source internet prefer
    group-policy GroupPolicy_79.77.41.45 internal
    group-policy GroupPolicy_79.77.41.45 attributes
    vpn-tunnel-protocol ikev1 ikev2
    username fg-admin password rRRkO2HwjU1OnJDA encrypted privilege 15
    tunnel-group 79.77.41.45 type ipsec-l2l
    tunnel-group 79.77.41.45 general-attributes
    default-group-policy GroupPolicy_79.77.41.45
    tunnel-group 79.77.41.45 ipsec-attributes
    ikev1 pre-shared-key *****
    ikev2 remote-authentication pre-shared-key *****
    ikev2 local-authentication pre-shared-key *****
    !
    !
    !
    policy-map global-policy
    class class-default
    user-statistics accounting
    !
    service-policy global-policy global
    prompt hostname context
    call-home reporting anonymous
    call-home
    profile CiscoTAC-1
    no active
    destination address http https://tools.cisco.com/its/service/...es/DDCEService
    destination address email callhome@cisco.com
    destination transport-method http
    subscribe-to-alert-group diagnostic
    subscribe-to-alert-group environment
    subscribe-to-alert-group inventory periodic monthly 19
    subscribe-to-alert-group configuration periodic monthly 19
    subscribe-to-alert-group telemetry periodic daily
    hpm topN enable
    Cryptochecksum:8508cbf632c1601c5c787b742cee4eba
    : end
    Reply With Quote Quote  

  12. Member
    Join Date
    Jul 2010
    Location
    Location
    Posts
    94

    Certifications
    CCNA R&S, CCNP R&S, CCNA Security, JNCIA, JNCIS-SEC, CCNA DataCenter
    #11
    1. What the object-group obj_any contain? Also i think that the second line is not quit alright ( i will search tomorrow at work)

    nat (vlan5,internet) source dynamic obj_any interface
    nat (vlan5,internet) source static Fields-Group Fields-Group destination static Fields-Cardiff Fields-Cardiff no-proxy-arp route-lookup

    2. If you try to ping for example "192.168.7.1" did you get any hitcounts in acl internet_cryptomap ? (making this test will exclude any routing issues before ASA 55xx.
    Reply With Quote Quote  

  13. Senior Member websponge's Avatar
    Join Date
    Aug 2008
    Posts
    119

    Certifications
    A+, Network +, MCP, CCENT, CCNA, CCNA Security, CCNP
    #12
    tried again tonight,

    the branch office isakmp is:

    Type : L2L Role : responder
    Rekey : no State : MM_WAIT_MSG5

    head office is waiting for PSK to be checked? (the passkey is 100% correct)
    Reply With Quote Quote  

  14. Senior Member websponge's Avatar
    Join Date
    Aug 2008
    Posts
    119

    Certifications
    A+, Network +, MCP, CCENT, CCNA, CCNA Security, CCNP
    #13
    Quote Originally Posted by zimskiz View Post
    1. What the object-group obj_any contain? Also i think that the second line is not quit alright ( i will search tomorrow at work)

    nat (vlan5,internet) source dynamic obj_any interface
    nat (vlan5,internet) source static Fields-Group Fields-Group destination static Fields-Cardiff Fields-Cardiff no-proxy-arp route-lookup

    2. If you try to ping for example "192.168.7.1" did you get any hitcounts in acl internet_cryptomap ? (making this test will exclude any routing issues before ASA 55xx.
    obj_any is any network.. (0.0.0.0 0.0.0.0)
    on show access-list there are no hits (there wouldnt be though as the tunnel isnt active)

    really appreciate you guys helping me out..
    Reply With Quote Quote  

  15. Senior Member
    Join Date
    Jan 2013
    Posts
    169
    #14
    How are you testing to bring the tunnel up? Also can you paste the output of the debug logs
    Reply With Quote Quote  

  16. Senior Member Edificer's Avatar
    Join Date
    Dec 2013
    Location
    Kurdistan
    Posts
    181

    Certifications
    CCENT, CCNA R&S/Security/SECFND
    #15
    Quote Originally Posted by websponge View Post
    tried again tonight,

    the branch office isakmp is:

    Type : L2L Role : responder
    Rekey : no State : MM_WAIT_MSG5

    head office is waiting for PSK to be checked? (the passkey is 100% correct)
    Any hits on the authentication fails counter?
    “Our greatest glory is not in never falling, but in rising every time we fall.” ― Confucius
    Reply With Quote Quote  

  17. Member
    Join Date
    Jul 2010
    Location
    Location
    Posts
    94

    Certifications
    CCNA R&S, CCNP R&S, CCNA Security, JNCIA, JNCIS-SEC, CCNA DataCenter
    #16
    No matter what is the status of the IPsec tunnel, using ping towards 192.168.7.x will increase the hitcount of that access list. Further more, delete nat (vlan5,internet) source static Fields-Group Fields-Group destination static Fields-Cardiff Fields-Cardiff no-proxy-arp route-lookup.
    Can we establish a skype session later ? (to troubleshoot in your live environment)


    Reply With Quote Quote  

  18. Senior Member websponge's Avatar
    Join Date
    Aug 2008
    Posts
    119

    Certifications
    A+, Network +, MCP, CCENT, CCNA, CCNA Security, CCNP
    #17
    Quote Originally Posted by zimskiz View Post
    No matter what is the status of the IPsec tunnel, using ping towards 192.168.7.x will increase the hitcount of that access list. Further more, delete nat (vlan5,internet) source static Fields-Group Fields-Group destination static Fields-Cardiff Fields-Cardiff no-proxy-arp route-lookup.
    Can we establish a skype session later ? (to troubleshoot in your live environment)


    I can probably get a teamviewer session going tomorrow?
    one question though, if I delete that nat statement then the ASA will globally nat the traffic and we don't want that surely? we want to preserve the source and destination in the packet.
    Reply With Quote Quote  

  19. Senior Member websponge's Avatar
    Join Date
    Aug 2008
    Posts
    119

    Certifications
    A+, Network +, MCP, CCENT, CCNA, CCNA Security, CCNP
    #18
    Quote Originally Posted by TheNewITGuy View Post
    How are you testing to bring the tunnel up? Also can you paste the output of the debug logs
    I am bringing it up live.. (well trying too!)
    I don't have ssh for the debug command, only https access, and the CLI in ASDM doesn't allow debug!
    Reply With Quote Quote  

  20. Senior Member websponge's Avatar
    Join Date
    Aug 2008
    Posts
    119

    Certifications
    A+, Network +, MCP, CCENT, CCNA, CCNA Security, CCNP
    #19
    So, still on this

    created a brand new tunnel, this came up fine. new shared secret etc..

    isakmp all good, ipsec no good.. only transmitting from the branch office, not receiving anything back.

    #pkts encaps: 0, #pkts encrypt: 0, #pkts digest: 0
    #pkts decaps: 14, #pkts decrypt: 14, #pkts verify: 14
    #pkts compressed: 0, #pkts decompressed: 0
    #pkts not compressed: 0, #pkts comp failed: 0, #pkts decomp failed: 0
    #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
    #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0


    #pkts encaps: 14, #pkts encrypt: 14, #pkts digest: 14
    #pkts decaps: 0, #pkts decrypt: 0, #pkts verify: 0
    #pkts compressed: 0, #pkts decompressed: 0
    #pkts not compressed: 14, #pkts comp failed: 0, #pkts decomp failed: 0
    #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
    #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
    Reply With Quote Quote  

  21. Network Engineer Dieg0M's Avatar
    Join Date
    Jun 2013
    Location
    Montreal
    Posts
    853

    Certifications
    CCIE #48240, CCDP
    #20
    Do a traceroute from the 172.16.0.0 network to the 192.168.1.0 network and make sure it it is ending on the ASA. Looks like a routing issue.
    Follow my CCDE journey at www.routingnull0.com
    Reply With Quote Quote  

  22. Senior Member
    Join Date
    Jan 2013
    Posts
    169
    #21
    Honestly at this point I'd log into ASDM and go into monitoring and look at the live log - then do a packet tracer
    Reply With Quote Quote  

  23. Senior Member Edificer's Avatar
    Join Date
    Dec 2013
    Location
    Kurdistan
    Posts
    181

    Certifications
    CCENT, CCNA R&S/Security/SECFND
    #22
    Post the outputs of the following debugs:
    debug crypto isakmp 255
    debug crypto ipsec 255
    “Our greatest glory is not in never falling, but in rising every time we fall.” ― Confucius
    Reply With Quote Quote  

  24. Senior Member websponge's Avatar
    Join Date
    Aug 2008
    Posts
    119

    Certifications
    A+, Network +, MCP, CCENT, CCNA, CCNA Security, CCNP
    #23
    Thanks all, issue is solved at last!
    Two things causing this, the no nat was after the global pat, so the reason it wouldn't come up some of the time was it was natting before it could no nat!

    Tunnel traffic was one sided, as there was no route back out from where the destination traffic was, turned out it was a server off a core switch, that had a default route out via a different wan link. I added a static and voila, !

    All,good, thank you all.
    Reply With Quote Quote  

  25. Mow
    Mow is offline
    Membrane Mow's Avatar
    Join Date
    Apr 2015
    Posts
    431

    Certifications
    CCNP Collaboration, CCNA, CCDA, CCNA Sec
    #24
    Quote Originally Posted by websponge View Post
    Thanks all, issue is solved at last!
    Two things causing this, the no nat was after the global pat, so the reason it wouldn't come up some of the time was it was natting before it could no nat!

    Tunnel traffic was one sided, as there was no route back out from where the destination traffic was, turned out it was a server off a core switch, that had a default route out via a different wan link. I added a static and voila, !

    All,good, thank you all.
    Awesome! Such a great feeling to track down an issue like this and solve it. Good job!
    Reply With Quote Quote  

  26. Senior Member Edificer's Avatar
    Join Date
    Dec 2013
    Location
    Kurdistan
    Posts
    181

    Certifications
    CCENT, CCNA R&S/Security/SECFND
    #25
    Fantastic!
    “Our greatest glory is not in never falling, but in rising every time we fall.” ― Confucius
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks