+ Reply to Thread
Results 1 to 5 of 5
  1. Junior Member Registered Member
    Join Date
    Apr 2015
    Posts
    1
    #1

    Question confusion in bgp using ospf

    Please help me out for the is lab

    here i attached all the all config of r1 r2 r3 r4 why i am not able to ping

    from r2 to r3
    from r1 to r4

    but i can ping r3 to r2 and r4 to r1






    r1
    -----------------------------------------------------------------
    R1#sh run
    Building configuration...


    Current configuration : 1438 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R1
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    ip subnet-zero
    no ip icmp rate-limit unreachable
    !
    !
    no ip domain lookup
    !
    ip cef
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    ip tcp synwait-time 5
    !
    !
    !
    interface Loopback0
    ip address 131.108.2.1 255.255.255.0
    !
    interface Loopback1
    ip address 131.108.3.1 255.255.255.0
    !
    interface Loopback2
    ip address 131.108.4.1 255.255.255.0
    !
    interface Ethernet0/0
    ip address 131.108.1.1 255.255.255.0
    half-duplex
    !
    interface Serial0/0
    ip address 131.108.255.5 255.255.255.252
    clock rate 125000
    !
    interface Serial0/1
    no ip address
    shutdown
    !
    router ospf 1
    log-adjacency-changes
    network 131.108.1.0 0.0.0.255 area 0
    network 131.108.2.0 0.0.0.255 area 0
    network 131.108.3.0 0.0.0.255 area 0
    network 131.108.4.0 0.0.0.255 area 0
    !
    router bgp 1
    no synchronization
    bgp log-neighbor-changes
    network 131.108.2.0 mask 255.255.255.0
    network 131.108.3.0 mask 255.255.255.0
    network 131.108.4.0 mask 255.255.255.0
    neighbor 131.108.1.2 remote-as 1
    neighbor 131.108.255.6 remote-as 3
    no auto-summary
    !
    no ip http server
    ip classless
    !
    !
    no cdp log mismatch duplex
    !
    !
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line vty 0 4
    login
    !
    !
    end


    R1#




    -----------------------------------------------------------------




    R2#


    R2#sh run
    Building configuration...


    Current configuration : 1468 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R2
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    ip subnet-zero
    no ip icmp rate-limit unreachable
    !
    !
    no ip domain lookup
    !
    ip cef
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    ip tcp synwait-time 5
    !
    !
    !
    interface Loopback0
    ip address 131.108.5.1 255.255.255.0
    !
    interface Loopback1
    ip address 131.108.6.1 255.255.255.0
    !
    interface Loopback2
    ip address 131.108.7.1 255.255.255.0
    !
    interface Ethernet0/0
    ip address 131.108.1.2 255.255.255.0
    half-duplex
    !
    interface Serial0/0
    ip address 131.108.255.1 255.255.255.0
    clock rate 128000
    !
    interface Serial0/1
    no ip address
    shutdown
    !
    router ospf 1
    log-adjacency-changes
    network 131.108.1.0 0.0.0.255 area 0
    network 131.108.5.0 0.0.0.255 area 0
    network 131.108.6.0 0.0.0.255 area 0
    network 131.108.7.0 0.0.0.255 area 0
    !
    router bgp 1
    no synchronization
    bgp log-neighbor-changes
    network 131.108.5.0 mask 255.255.255.0
    network 131.108.6.0 mask 255.255.255.0
    network 131.108.7.0 mask 255.255.255.0
    redistribute ospf 1 metric 100
    neighbor 131.108.1.1 remote-as 1
    neighbor 131.108.255.2 remote-as 2
    no auto-summary
    !
    no ip http server
    ip classless
    !
    !
    no cdp log mismatch duplex
    !
    !
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line vty 0 4
    login
    !
    !
    end


    R2#
    ----------------------------------------------------------------








    R3#sh run
    Building configuration...


    Current configuration : 1037 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R3
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    ip subnet-zero
    no ip icmp rate-limit unreachable
    !
    !
    no ip domain lookup
    !
    ip cef
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    ip tcp synwait-time 5
    !
    !
    !
    interface Ethernet0/0
    ip address 141.108.1.1 255.255.255.0
    half-duplex
    !
    interface Serial0/0
    bandwidth 125
    ip address 131.108.255.6 255.255.255.252
    !
    interface Serial0/1
    ip address 131.108.255.9 255.255.255.252
    !
    router bgp 3
    no synchronization
    bgp log-neighbor-changes
    network 141.108.1.0 mask 255.255.255.0
    neighbor 131.108.255.5 remote-as 1
    neighbor 131.108.255.10 remote-as 2
    neighbor 131.108.255.10 weight 1
    no auto-summary
    !
    no ip http server
    ip classless
    !
    !
    no cdp log mismatch duplex
    !
    !
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line vty 0 4
    login
    !
    !
    end


    -------------------------------------------------------------------






    R4#sh run
    Building configuration...


    Current configuration : 998 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R4
    !
    boot-start-marker
    boot-end-marker
    !
    enable password cisco
    !
    no aaa new-model
    ip subnet-zero
    no ip icmp rate-limit unreachable
    !
    !
    no ip domain lookup
    !
    ip cef
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    ip tcp synwait-time 5
    !
    !
    !
    interface Ethernet0/0
    ip address 151.108.1.1 255.255.255.0
    shutdown
    half-duplex
    !
    interface Serial0/0
    ip address 131.108.255.2 255.255.255.252
    !
    interface Serial0/1
    ip address 131.108.255.10 255.255.255.252
    !
    router bgp 2
    no synchronization
    bgp log-neighbor-changes
    network 151.108.1.0 mask 255.255.255.0
    neighbor 131.108.255.1 remote-as 1
    neighbor 131.108.255.9 remote-as 3
    no auto-summary
    !
    no ip http server
    ip classless
    !
    !
    no cdp log mismatch duplex
    !
    !
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line aux 0
    exec-timeout 0 0
    privilege level 15
    logging synchronous
    line vty 0 4
    login
    !
    !
    end


    R4#
    Reply With Quote Quote  

  2. SS -->
  3. DCD
    DCD is offline
    Senior Member DCD's Avatar
    Join Date
    Jan 2013
    Location
    San Francisco , Ca
    Posts
    437

    Certifications
    CCNA
    #2
    This is off the subject but why are your interfaces at half duplex? Also can you put the show for BGP, OSFP and Route.
    Reply With Quote Quote  

  4. Went to the dark side.... Moderator networker050184's Avatar
    Join Date
    Jul 2007
    Posts
    11,665

    Certifications
    CCNA, CCNP, CCIP, JNCIA-JUNOS, JNCIS-SP, JNCIP-SP, MCA200
    #3
    Think what address is that icmp packet going to use as a source? Does the other router have a route to that?
    An expert is a man who has made all the mistakes which can be made.
    Reply With Quote Quote  

  5. Junior Member
    Join Date
    May 2016
    Posts
    28
    #4
    Really old topic, but this is a classic case of where to use next-hop self
    Reply With Quote Quote  

  6. Senior Member pevangel's Avatar
    Join Date
    Feb 2014
    Location
    'Murica!
    Posts
    333

    Certifications
    CCNP, JNCIP-SEC, JNCSP-SEC, CCNA Security, JNCIS-SP/ENT, ITIL
    #5
    Next-hop-self is not necessary here but still a good idea. Being able to ping one way but not the other is usually an indication of not properly sourcing your pings which is what networker was hinting at. Not configuring next-hop-self would result in asymmetric routing in the OP's setup, but pings should still work as long as they are loopback to loopback.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks