+ Reply to Thread
Results 1 to 3 of 3
  1. Member
    Join Date
    Jul 2010
    Location
    Location
    Posts
    94

    Certifications
    CCNA R&S, CCNP R&S, CCNA Security, JNCIA, JNCIS-SEC, CCNA DataCenter
    #1

    Default MPLS L3 VPN -- stupid problem i belive

    I cannot find the reason why i can't redistribute bgp into ospf. The main concern is for 1.1.1.1/32.


    R5 config :


    RP/0/0/CPU0:R5#sh run
    Sat Aug 8 21:12:52.904 UTC
    Building configuration...
    !! IOS XR Configuration 5.3.1
    !! Last configuration change at Sat Aug 8 21:08:05 2015 by cisco
    !
    hostname R5
    vrf Cust_R56
    address-family ipv4 unicast
    import route-target
    1:111
    !
    export route-target
    56:6
    !
    !
    !
    interface Loopback5
    description peer_de_bgp
    ipv4 address 192.168.0.5 255.255.255.255
    !
    interface MgmtEth0/0/CPU0/0
    shutdown
    !
    interface GigabitEthernet0/0/0/0
    description to_R4_
    ipv4 address 192.168.45.1 255.255.255.252
    !
    interface GigabitEthernet0/0/0/1
    description to_R6
    vrf Cust_R56
    ipv4 address 10.5.6.5 255.255.255.0
    !
    route-policy PASS
    pass
    end-policy
    !
    router ospf 1
    passive enable
    area 0.0.0.0
    interface Loopback5
    passive disable
    !
    interface GigabitEthernet0/0/0/0
    passive disable
    !
    !
    !
    router ospf 56
    redistribute bgp 1 route-policy PASS
    redistribute bgp 12302
    address-family ipv4 unicast
    vrf Cust_R56
    redistribute bgp 1 route-policy PASS
    redistribute bgp 12302
    address-family ipv4 unicast
    area 0.0.0.0
    interface GigabitEthernet0/0/0/1
    !
    !
    !
    !
    router bgp 12302
    address-family ipv4 unicast
    !
    address-family vpnv4 unicast
    !
    neighbor 192.168.0.2
    remote-as 12302
    update-source Loopback5
    address-family vpnv4 unicast
    route-policy PASS in
    route-policy PASS out
    !
    !
    !
    mpls oam
    !
    mpls ldp
    interface GigabitEthernet0/0/0/0
    !
    !
    end

    ALSO

    RP/0/0/CPU0:R5#sh bgp vpnv4 uni nei 192.168.0.2 routes
    Sat Aug 8 21:14:09.379 UTC
    BGP router identifier 192.168.0.5, local AS number 12302
    BGP generic scan interval 60 secs
    Non-stop routing is enabled
    BGP table state: Active
    Table ID: 0x0 RD version: 0
    BGP main routing table version 11
    BGP NSR Initial initsync version 1 (Reached)
    BGP NSR/ISSU Sync-Group versions 0/0
    BGP scan interval 60 secs


    Status codes: s suppressed, d damped, h history, * valid, > best
    i - internal, r RIB-failure, S stale, N Nexthop-discard
    Origin codes: i - IGP, e - EGP, ? - incomplete
    Network Next Hop Metric LocPrf Weight Path
    Route Distinguisher: 1:111
    *>i1.1.1.1/32 192.168.0.2 0 100 0 1 i
    *>i10.2.1.0/24 192.168.0.2 0 100 0 1 ?


    Processed 2 prefixes, 2 paths
    RP/0/0/CPU0:R5#



    R6 config :

    RP/0/0/CPU0:R6#sh run
    Sat Aug 8 21:13:28.253 UTC
    Building configuration...
    !! IOS XR Configuration 5.3.1
    !! Last configuration change at Sat Aug 8 17:37:02 2015 by cisco
    !
    hostname R6
    interface Loopback6
    ipv4 address 6.6.6.6 255.255.255.255
    !
    interface MgmtEth0/0/CPU0/0
    shutdown
    !
    interface GigabitEthernet0/0/0/0
    description to_R5
    ipv4 address 10.5.6.6 255.255.255.0
    !
    router ospf 100
    area 0.0.0.0
    interface Loopback6
    !
    interface GigabitEthernet0/0/0/0
    !
    !
    !
    end



    Any ideas?
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member
    Join Date
    Jul 2011
    Posts
    311
    #2
    Unless IOX XR does things differently, you need to add the subnets keyword to your redistribution statement.
    Reply With Quote Quote  

  4. Member
    Join Date
    Jul 2010
    Location
    Location
    Posts
    94

    Certifications
    CCNA R&S, CCNP R&S, CCNA Security, JNCIA, JNCIS-SEC, CCNA DataCenter
    #3
    I actually found the problem. It was something with the DN bit. Thank you atorven for your help!
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks