+ Reply to Thread
Results 1 to 2 of 2

Thread: Mpls te

  1. Member
    Join Date
    Jul 2010
    Location
    Location
    Posts
    94

    Certifications
    CCNA R&S, CCNP R&S, CCNA Security, JNCIA, JNCIS-SEC, CCNA DataCenter
    #1

    Default Mpls te

    Any ideas why i cannot bring up this tunnel ?

    RP/0/0/CPU0:R1#sh mpls traffic-eng tunnels
    Sun Aug 9 01:43:29.727 UTC
    Name: tunnel-te1 Destination: 3.3.3.3 Ifhandle:0x480
    Signalled-Name: R1_t1
    Status:
    Admin: up Oper: down Path: not valid Signalling: Down
    path option 1, type dynamic
    Last PCALC Error: Sun Aug 9 01:38:49 2015
    Info: No path to destination, 3.3.3.3 (node unreachable)
    G-PID: 0x0800 (derived from egress interface properties)
    Bandwidth Requested: 1 kbps CT0
    Creation Time: Sun Aug 9 00:13:42 2015 (01:29:47 ago)
    Config Parameters:
    Bandwidth: 1 kbps (CT0) Priority: 7 7 Affinity: 0x0/0xffff
    Metric Type: TE (default)
    Hop-limit: disabled
    Cost-limit: disabled
    AutoRoute: disabled LockDown: disabled Policy class: not set
    Forward class: 0 (default)
    Forwarding-Adjacency: disabled
    Loadshare: 0 equal loadshares
    Auto-bw: disabled
    Fast Reroute: Disabled, Protection Desired: None
    Path Protection: Not Enabled
    BFD Fast Detection: Disabled
    Reoptimization after affinity failure: Enabled
    Soft Preemption: Disabled
    Reason for the tunnel being down: Bidirectional is configured without Association ID
    Displayed 1 (of 1) heads, 0 (of 0) midpoints, 0 (of 0) tails
    Displayed 0 up, 1 down, 0 recovering, 0 recovered heads

    RP/0/0/CPU0:R1
    #ping 3.3.3.3
    Sun Aug 9 01:43:43.806 UTC
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

    RP/0/0/CPU0:R1
    #sh mpls ldp bin 3.3.3.3/32
    Sun Aug 9 01:44:14.294 UTC
    3.3.3.3/32, rev 33
    Local binding: label: 24006
    Remote bindings: (1 peers)
    Peer Label
    ----------------- ---------
    10.2.1.1:0 24005
    RP/0/0/CPU0:R1#



    ------------------------

    hostname R1

    interface Loopback1
    ipv4 address 1.1.1.1 255.255.255.255
    !
    interface tunnel-te1
    ipv4 unnumbered Loopback1
    signalled-bandwidth 1
    destination 3.3.3.3
    bidirectional
    !
    path-option 1 dynamic
    !
    interface GigabitEthernet0/0/0/0
    description to_R2
    ipv4 address 10.2.1.2 255.255.255.0
    !
    router ospf 1
    area 0.0.0.0
    mpls ldp auto-config
    mpls traffic-eng
    interface Loopback1
    !
    interface GigabitEthernet0/0/0/0
    mpls oam
    !
    rsvp
    interface GigabitEthernet0/0/0/0
    bandwidth 1
    !
    mpls traffic-eng
    !
    mpls ldp
    router-id 10.2.1.2
    interface GigabitEthernet0/0/0/0


    R2
    hostname R2
    interface GigabitEthernet0/0/0/0
    description to_R1
    ipv4 address 10.2.1.1 255.255.255.0
    !
    interface GigabitEthernet0/0/0/1
    description to_R3
    ipv4 address 192.168.23.2 255.255.255.252
    !
    interface GigabitEthernet0/0/0/2
    ipv4 address 10.2.4.1 255.255.255.0
    shutdown
    !
    router ospf 1
    passive disable
    area 0.0.0.0
    mpls ldp auto-config
    mpls traffic-eng
    interface Loopback2
    passive disable
    !
    interface GigabitEthernet0/0/0/0
    passive disable
    !
    interface GigabitEthernet0/0/0/1
    passive disable
    !
    interface GigabitEthernet0/0/0/2
    passive disable
    mpls oam
    !
    rsvp
    interface GigabitEthernet0/0/0/0
    bandwidth 1
    !
    interface GigabitEthernet0/0/0/1
    bandwidth 1
    !
    interface GigabitEthernet0/0/0/2
    !
    !
    mpls traffic-eng
    !
    mpls ldp
    router-id 10.2.1.1
    interface GigabitEthernet0/0/0/0
    !
    interface GigabitEthernet0/0/0/1
    !
    interface GigabitEthernet0/0/0/2
    end


    R3

    hostname R3
    interface Loopback0
    ipv4 address 3.3.3.3 255.255.255.255
    !
    interface GigabitEthernet0/0/0/0
    description to_R2
    ipv4 address 192.168.23.1 255.255.255.252
    !
    interface GigabitEthernet0/0/0/1
    description to_R4
    ipv4 address 192.168.34.2 255.255.255.252
    !
    router ospf 1
    area 0.0.0.0
    mpls ldp auto-config
    mpls traffic-eng
    interface Loopback0
    !
    interface Loopback1
    !
    interface GigabitEthernet0/0/0/0
    !
    interface GigabitEthernet0/0/0/1
    !
    rsvp
    interface GigabitEthernet0/0/0/0
    !
    interface GigabitEthernet0/0/0/1
    !
    !
    mpls traffic-eng
    !
    mpls ldp
    router-id 3.3.3.3
    interface GigabitEthernet0/0/0/0
    !
    interface GigabitEthernet0/0/0/1
    Reply With Quote Quote  

  2. Senior Member
    Join Date
    Sep 2013
    Location
    Sweden
    Posts
    861

    Certifications
    CCNP
    #2
    You haven't enabled MPLS-TE on the interfaces, and you haven't configured a TE router-id in the OSPF process. It might be the case that you don't absolutely have to explicitly configure a router-id, but you definitely have to enable the interfaces. It should look something like this:

    !
    mpls traffic-eng
    !
    interface g1
    !
    interface g2
    !

    The fact that you've tried to verify things with LDP show commands and have enabled LDP everywhere concerns me since that's not relevant for TE except in very specific circumstances. You should also remove 'bidirectional' from the tunnel-te interface as it's not a feature that's covered in any of the basic/intermediate texts that I've read, and I have no idea how it interacts with what you are trying to do.

    MPLS-TE has like a million show commands, but some that are relevant here are:

    show mpls traffic-eng tunnels summary // to check that the TE and RSVP processes are running.
    show mpls traffic-eng link-management summary // to see that the interfaces have TE enabled (XR doesn't show that in show mpls interface like in IOS, I think)
    show mpls traffic-eng tunnels // to see the status of the tunnels
    show rsvp interface // to see that RSVP is enabled on interfaces that are to run TE (texts say that you have to manually enable RSVP on interfaces in XR even if you enable TE on the interface, but this doesn't seem to be the case in XRv at least).

    Consider reading the Cisco Press title "Traffic Engineering with MPLS" if you're interested in TE because it's actually very well written and easy to understand.
    Last edited by fredrikjj; 08-29-2015 at 07:35 PM.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks