+ Reply to Thread
Results 1 to 5 of 5

Thread: BGP Ping test

  1. Junior Member Registered Member
    Join Date
    Feb 2015
    Posts
    4
    #1

    Default BGP Ping test

    Please help,

    From R1, i can ping the loopback IP(3.3.3.3) that was advertised via BGP. But from R3 cant ping the loopback IP's of the R1 that was advertise via BGP.

    R1 ----EBGP---- R2 ------IBGP----- R3


    Kinly see below config:

    R1
    interface Loopback0
    ip address 2.2.2.2 255.255.255.255
    !
    interface Loopback1
    ip
    address 192.168.1.1 255.255.255.255
    !
    interface Loopback2
    ip address 192.168.1.2 255.255.255.255
    !
    interface Loopback3
    ip address 192.168.1.3 255.255.255.255
    !
    interface Loopback4
    ip address 192.168.1.4 255.255.255.255
    !
    interface Loopback5
    ip address 192.168.1.5 255.255.255.255
    !
    interface GigabitEthernet1/0
    ip address 10.0.1.1 255.255.255.252
    negotiation auto
    !
    router bgp 100
    no synchronization
    bgp log-neighbor-changes
    redistribute connected route-map LOOPBACKS
    neighbor 4.4.4.4 remote-as 200
    neighbor 4.4.4.4 ebgp-multihop 2
    neighbor 4.4.4.4 update-source Loopback0
    no auto-summary
    !
    ip access-list standard LOOPBACKS
    permit 192.168.1.0 0.0.0.255
    !
    route-map LOOPBACKS permit 10
    match ip address LOOPBACKS
    !

    R2
    interface Loopback0
    ip address 4.4.4.4 255.255.255.255
    !
    interface GigabitEthernet1/0
    ip address 10.0.1.2 255.255.255.252
    negotiation auto
    !
    interface GigabitEthernet2/0
    ip address 10.0.1.5 255.255.255.252
    negotiation auto
    !
    router ospf 1
    log-adjacency-changes
    redistribute static subnets
    network 4.4.4.4 0.0.0.0 area 0
    network 10.0.1.0 0.0.0.3 area 0
    network 10.0.1.4 0.0.0.3 area 0
    !
    router bgp 200
    no synchronization
    bgp log-neighbor-changes
    neighbor 2.2.2.2 remote-as 100
    neighbor 2.2.2.2 ebgp-multihop 2
    neighbor 2.2.2.2 update-source Loopback0
    neighbor 3.3.3.3 remote-as 200
    neighbor 3.3.3.3 update-source Loopback0
    no auto-summary
    !

    R3
    interface Loopback0
    ip address 3.3.3.3 255.255.255.255
    !
    interface GigabitEthernet2/0
    ip address 10.0.1.6 255.255.255.252
    negotiation auto
    !
    router bgp 200
    no synchronization
    bgp log-neighbor-changes
    redistribute connected route-map LOOPBACK
    neighbor 4.4.4.4 remote-as 200
    neighbor 4.4.4.4 update-source Loopback0
    no auto-summary
    !
    route-map LOOPBACK permit 10
    match ip address LOOPBACK
    !
    ip access-list standard LOOPBACK
    permit 3.3.3.3
    !
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member
    Join Date
    Nov 2013
    Posts
    146
    #2
    At first glance, it looks like you need to permit 2.2.2.2 in your LOOPBACKS access-list on R1
    Reply With Quote Quote  

  4. Junior Member Registered Member
    Join Date
    Feb 2015
    Posts
    4
    #3
    Thanks for the help Sir!

    After permitting the 2.2.2.2, the loopbacks from R1 still cannot ping. Also I can ping the 2.2.2.2 using redistribute static under OSPF.

    Please help
    Reply With Quote Quote  

  5. Went to the dark side.... Moderator networker050184's Avatar
    Join Date
    Jul 2007
    Posts
    11,665

    Certifications
    CCNA, CCNP, CCIP, JNCIA-JUNOS, JNCIS-SP, JNCIP-SP, MCA200
    #4
    Look at what source your ping is using.
    An expert is a man who has made all the mistakes which can be made.
    Reply With Quote Quote  

  6. Junior Member
    Join Date
    Mar 2011
    Location
    Ekaterinburg
    Posts
    7

    Certifications
    CCNA/CCNP/CCIP
    #5
    Quote Originally Posted by late_collision View Post
    At first glance, it looks like you need to permit 2.2.2.2 in your LOOPBACKS access-list on R1

    late_collision, we don't need "permit 2.2.2.2 in your LOOPBACKS" because then we advertise 2.2.2.2/32 via eBGP to R2 it's not best in BGP table, cause of exist static route point to 2.2.2.2 via R1. Therefore we don't advertise this route to any peer on R2. Also R3 have route to 2.2.2.2/32, via ospf, "redistribute static subnets" on R2.

    edubillo, from you config, i'm don't see route connected of network on R2,R3 10.0.1.4/30 advertised to R1. You can add this on R2 like:
    router bgp 200
    network 10.0.1.4 mask 255.255.255.252

    And them:
    R3# ping 2.2.2.2
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

    Because ping in this case use source IP: 10.0.1.6.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks