+ Reply to Thread
Results 1 to 16 of 16
  1. Junior Member
    Join Date
    Jun 2011
    Posts
    22
    #1

    Default Home Voice Lab help request

    Hello, This was originally posted under the CCNA Voice forum, but I did not receive any responses. I am hoping someone will be able to help me here.


    I am trying to setup 2 7960 Cisco IP phones with a 2800 series router with CME and a 3560 switch.

    I believe I have the configurations proper on the router and switch, but think I am missing configuration files for the actual phones.

    Right now the way I have everything setup I have assigned extensions to the phones along with names, and they do appear on the display of the phones.

    For the life of me I can’t get the phones to call each other. One phone has a busy signal when I pick it up off the hook and the other is just dead silence.

    The phones do display “unknown number” when I pickup the headsets.


    Below are my configs from my router and switch.

    I would greatly appreciate any help.

    Thank you


    Router

    ---
    Router2800#show run
    Building configuration...


    Current configuration : 4696 bytes
    !
    ! No configuration change since last restart
    !
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router2800
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no logging buffered
    enable password !Pass1234
    !
    no aaa new-model
    !
    clock timezone NewYork -5 0
    clock summer-time NewYork date Apr 6 2003 2:00 Oct 26 2003 2:00
    !
    no dot11 syslog
    ip source-route
    !
    !
    ip cef
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.0.1 192.168.0.10
    !
    ip dhcp pool VOICE
    network 192.168.0.0 255.255.255.0
    option 150 ip 192.168.0.1
    default-router 192.168.0.1
    !
    !
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    voice-card 0
    !
    crypto pki token default removal timeout 0
    !
    crypto pki trustpoint TP-self-signed-3811012092
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-3811012092
    revocation-check none
    !
    !
    crypto pki certificate chain TP-self-signed-3811012092
    certificate self-signed 01
    3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
    31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
    69666963 6174652D 33383131 30313230 3932301E 170D3030 30313031 30303032
    32335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
    4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313130
    31323039 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
    8100BFC3 D0A2473D 2A0830FB 60B4C612 BD475F73 F2E11775 AFCAA7B7 5FD4D53D
    D3A2961C FB3880D5 6CB91504 B3A19759 CBB1BC7B 801B54C7 1BC68D3C 925BADFD
    A3429949 41C2AE48 E3BC12C7 9837E20F 13A17460 72AB3A92 65CA2FF8 DCCF9243
    4AB3C920 E145510A EFEB4174 07D7E5B5 A244C2E0 CB4D7E8E B5C7CE27 1C83A3FD
    94670203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
    551D2304 18301680 1474772F F0B75C8E AD42A2B1 70F7681B 890408CA AE301D06
    03551D0E 04160414 74772FF0 B75C8EAD 42A2B170 F7681B89 0408CAAE 300D0609
    2A864886 F70D0101 04050003 818100AD B485DC77 3E3B20DA 17CF4967 65DC23EB
    9ED0BB60 C9A97D14 E42B7703 64FE19BD C885379E D2729DB7 EFD63E4A 8638E475
    50A13A50 CA2FAB35 16A0917F 40B78D9D 201A3E7D 92188033 87B70D43 D5EBF235
    2D9009E5 D24F1313 17A770A4 EE27FD59 6E1DBCC8 13B0F160 D7A0CDC0 BF070214
    26939586 2004D644 DF440E54 1216F7
    quit
    !
    !
    license udi pid CISCO2821 sn FCZ100671KD
    archive
    log config
    hidekeys
    username admin privilege 15 secret 5 $1$hGri$XgPyh9NY88KnSIewnf0q9.
    username Mike privilege 15 password 0 !Pass1234
    !
    redundancy
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface GigabitEthernet0/0.50
    description Management_interface
    encapsulation dot1Q 50
    ip address 192.168.2.1 255.255.255.0
    !
    interface GigabitEthernet0/0.100
    description data_interface
    encapsulation dot1Q 100
    ip address 192.168.1.1 255.255.255.0
    !
    interface GigabitEthernet0/0.200
    description voice_interface
    encapsulation dot1Q 200
    ip address 192.168.0.1 255.255.255.0
    !
    interface GigabitEthernet0/1
    no ip address
    duplex auto
    speed auto
    !
    ip default-gateway 192.168.1.1
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip http path flash:
    !
    !
    !
    logging esm config
    !
    !
    !
    !
    !
    tftp-server flash:/P00308000500.bin alias P00308000500.bin
    tftp-server flash:/P00308000500.loads
    tftp-server flash:/P00308000500.sb2 alias P00308000500.sb2
    tftp-server flash:/P00308000500.sbn alias P00308000500.sbn
    tftp-server flash:/P00308000400.bin
    tftp-server flash:/P00308000400.sbn
    !
    control-plane
    !
    !
    !
    !
    mgcp profile default
    !
    !
    !
    !
    !
    telephony-service
    no auto-reg-ephone
    max-ephones 25
    max-dn 25
    ip source-address 192.168.0.1 port 2000
    application telephony-service
    system message Jensen House
    cnf-file location flash:
    max-conferences 8 gain -6
    web admin system name admin secret 5 $1$58da$HrHuH1jp3xo72RJlBR4YZ0
    transfer-system full-consult
    create cnf-files version-stamp Jan 01 2002 00:00:00
    !
    !
    ephone-dn 1
    number 1001
    label Mike Jensen
    name Mike Jensen
    application telephony-service
    !
    !
    ephone-dn 2 dual-line
    number 1002
    label Laura Jensen
    name Laura Jensen
    application telephony-service
    !
    !
    ephone 1
    device-security-mode none
    mac-address 0015.2B23.B429
    username "Mike"
    type 7960
    button 1:1
    !
    !
    !
    ephone 2
    device-security-mode none
    mac-address 001B.0C18.7C0D
    username "Laura"
    type 7960
    button 1:2
    !
    !
    !
    banner login ^C*************************UNATHORIZED ACCESS IS NOT PERMITED*********************^C
    !
    line con 0
    line aux 0
    line vty 0 4
    login local
    transport input ssh
    !
    scheduler allocate 20000 1000
    ntp master
    ntp update-calendar
    ntp server 66.187.223.4 prefer source GigabitEthernet0/0
    end

    Router2800#

    -----

    Switch:

    PoE_Switch#show run
    Building configuration...

    Current configuration : 4227 bytes
    !
    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname PoE_Switch
    !
    boot-start-marker
    boot-end-marker
    !
    !
    !
    !
    no aaa new-model
    system mtu routing 1500
    !
    !
    !
    !
    crypto pki trustpoint TP-self-signed-2454984448
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-2454984448
    revocation-check none
    rsakeypair TP-self-signed-2454984448
    !
    !
    crypto pki certificate chain TP-self-signed-2454984448
    certificate self-signed 01
    30820243 308201AC A0030201 02020101 300D0609 2A864886 F70D0101 04050030
    31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
    69666963 6174652D 32343534 39383434 3438301E 170D3933 30333031 30303031
    31305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
    4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 34353439
    38343434 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
    8100BB7A 57ED2733 4643A347 99A0DB57 C0E53764 256BF646 1CDE2556 8E86AEA4
    69548AF7 E13B9735 29FD8725 95A9E2DD E015F357 E97957E6 13875224 2BD8414B
    5F574455 7723072D C03EE5B7 08656811 D53B3896 AC64AE8C F7D97197 75322EDB
    80630371 A09D0273 EF5FBC24 FCE88042 703A7B50 BAF6463D B83F1736 4A0340BE
    79290203 010001A3 6B306930 0F060355 1D130101 FF040530 030101FF 30160603
    551D1104 0F300D82 0B506F45 5F537769 7463682E 301F0603 551D2304 18301680
    144ADBA2 1BE9B0D4 2A23FDF9 439D88A9 BB366E1A E7301D06 03551D0E 04160414
    4ADBA21B E9B0D42A 23FDF943 9D88A9BB 366E1AE7 300D0609 2A864886 F70D0101
    04050003 81810046 9709974D CA2747CA 0B64E7EB 4F203BA5 2FC6B773 55878AB2
    9772B243 8FCEE754 9AEAF8B7 518C07D8 99880F87 FE630CD1 EC96CB41 C1AAC1E1
    FEC05844 E4E41810 93C4B9F8 1BBC8D18 5B68B22A A12E9D24 55974F9E 7A45227E
    19D939C0 08320585 50A903B9 5DE8E866 7FEB4F3E 5AD2885C 9DE40970 CE832A1B
    3CB83A89 A60C0B
    quit
    !
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    !
    !
    interface FastEthernet0/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface FastEthernet0/2
    switchport access vlan 50
    switchport mode access
    !
    interface FastEthernet0/3
    switchport access vlan 100
    switchport mode access
    switchport voice vlan 200
    spanning-tree portfast
    !
    interface FastEthernet0/4
    switchport access vlan 100
    switchport mode access
    switchport voice vlan 200
    spanning-tree portfast
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface FastEthernet0/13
    !
    interface FastEthernet0/14
    !
    interface FastEthernet0/15
    !
    interface FastEthernet0/16
    !
    interface FastEthernet0/17
    !
    interface FastEthernet0/18
    !
    interface FastEthernet0/19
    !
    interface FastEthernet0/20
    !
    interface FastEthernet0/21
    !
    interface FastEthernet0/22
    !
    interface FastEthernet0/23
    !
    interface FastEthernet0/24
    !
    interface FastEthernet0/25
    !
    interface FastEthernet0/26
    !
    interface FastEthernet0/27
    !
    interface FastEthernet0/28
    !
    interface FastEthernet0/29
    !
    interface FastEthernet0/30
    !
    interface FastEthernet0/31
    !
    interface FastEthernet0/32
    !
    interface FastEthernet0/33
    !
    interface FastEthernet0/34
    !
    interface FastEthernet0/35
    !
    interface FastEthernet0/36
    !
    interface FastEthernet0/37
    !
    interface FastEthernet0/38
    !
    interface FastEthernet0/39
    !
    interface FastEthernet0/40
    !
    interface FastEthernet0/41
    !
    interface FastEthernet0/42
    !
    interface FastEthernet0/43
    !
    interface FastEthernet0/44
    !
    interface FastEthernet0/45
    !
    interface FastEthernet0/46
    !
    interface FastEthernet0/47
    !
    interface FastEthernet0/48
    !
    interface GigabitEthernet0/1
    !
    interface GigabitEthernet0/2
    !
    interface GigabitEthernet0/3
    !
    interface GigabitEthernet0/4
    !
    interface Vlan1
    no ip address
    !
    interface Vlan50
    ip address 192.168.2.2 255.255.255.0
    !
    interface Vlan100
    description Data
    ip address 192.168.1.2 255.255.255.0
    !
    interface Vlan200
    description Voice
    ip address 192.168.0.2 255.255.255.0
    !
    ip default-gateway 192.168.2.1
    ip classless
    ip http server
    ip http secure-server
    !
    !
    !
    line con 0
    line vty 0 4
    login
    line vty 5 15
    login
    !
    end
    Reply With Quote Quote  

  2. SS -->
  3. Junior Member
    Join Date
    Jun 2011
    Posts
    22
    #2

    Default Dial-peers

    Are dial-peers needed for calls to work between two IP phones off of the same router interface?
    Reply With Quote Quote  

  4. Senior Member ccnpninja's Avatar
    Join Date
    Feb 2007
    Location
    Tunisia, North Africa
    Posts
    983

    Certifications
    a few
    #3
    quick answer: no
    you only need ephone-dn and dn configurations to make LAN calls
    من طلب عزائم الأمور ، هان عليه بذل النفس فيها - محمد إبن ابي عامر
    www.keyboardbanger.com
    Reply With Quote Quote  

  5. Senior Member
    Join Date
    Jun 2009
    Location
    Gosford, Australia
    Posts
    567

    Certifications
    CCNA, CCDA, CCNA:Voice(IIUC), CCNP:Voice
    #4
    The only thing that leaps out at me is:

    Code:
    telephony-service
     load 7960-7940 <load_file> ! either P00308000500 or P00308000400 
    I'm guessing the phones are coming up in a idle state with IP addresses & DNs assigned to button 1?
    Reply With Quote Quote  

  6. Junior Member
    Join Date
    Jun 2011
    Posts
    22
    #5
    Thank you for the replies!

    Yes, the phones come up with a valid IP & the DN assigned to button 1.


    I don’t understand what the this part of the config is:
    “Telephony-service
    load 7960-7940<load_file> ! either P00308000500 or P00308000400”


    All help isgreatly appreciated. Thank you!
    Reply With Quote Quote  

  7. Senior Member
    Join Date
    Mar 2013
    Posts
    103
    #6
    Follow azaghul advice and then revisit your tftp-server config, there's something missing
    Reply With Quote Quote  

  8. Junior Member
    Join Date
    Jun 2011
    Posts
    22
    #7
    I'm still kind of lost. Should I remove the "load 7960-7940<load_file> ! either P00308000500 or P00308000400”

    In regards to something missing for tftp: Do I need to find configuration files specifically for the 7960 phones and make them available on the tftp server?
    Reply With Quote Quote  

  9. Senior Member
    Join Date
    Jun 2009
    Location
    Gosford, Australia
    Posts
    567

    Certifications
    CCNA, CCDA, CCNA:Voice(IIUC), CCNP:Voice
    #8
    Where the tftp-server commands make the firmware files eligible for downloading to the phone, the load command actually sends the firmware file set to the phones (for all intents) if the phone is not running that version of firmware.

    load 7960-7940 <load_file>

    So in this case it says for either a 7960 or 7940 load the firmware file version <load_file>, being either P00308000500 or P00308000400 in this case from the tftp-server commands. Where P00308000500 or P00308000400 are specific to the version of CME and model of phone.

    If still having issues, I'll upload my config cheat-sheet.
    Reply With Quote Quote  

  10. Junior Member
    Join Date
    Jun 2011
    Posts
    22
    #9
    Could you please upload your config cheat sheet for me? I am still having problems...
    Reply With Quote Quote  

  11. Junior Member
    Join Date
    Jun 2011
    Posts
    22
    #10
    I have entered the commands

    "config t"
    "telephony-service"
    "load 7960-7940 P00308000400"

    and receive several of these messages:

    clock is not valid or synchronized retaining old version stamps

    I then will boot the phone, it appears to download something but then quickly displays a message stating missing file DISTN .. something and the phone still will not work.
    Reply With Quote Quote  

  12. Senior Member
    Join Date
    Jun 2009
    Location
    Gosford, Australia
    Posts
    567

    Certifications
    CCNA, CCDA, CCNA:Voice(IIUC), CCNP:Voice
    #11
    Here are the links for my standard config templates for router/switch/cucme. You'll need to adjust anything location related. Some areas are still a work-in-progress.

    Code:
    http://www.4shared.com/file/_gnE0a6aba/My-Config_Router.html
    http://www.4shared.com/file/F7rGbMkuba/My-Config_Switch.html
    http://www.4shared.com/file/n3h6HdbSba/My-Config_CUCME.html
    Lets take a step back...what model router, IOS & CUCME versions are you running, and where are you getting your clock source from? If you don't have NTP configured, just manually set the clock on the router each session.

    "create cnf-files version-stamp Jan 01 2002 00:00:00" would indicate the clock is just free-wheeling, which would account for the "clock is not valid or synchronized retaining old version stamps" messages.

    Whenever (95%) you make a DN, ephone or telephony-service change, you'll need to regenerate the cnf-files.
    Reply With Quote Quote  

  13. Junior Member
    Join Date
    Jun 2011
    Posts
    22
    #12
    Hello,

    My router is a 2821 running IOS: :c2800nm-adventerprisek9-mz.151-3.T.bin
    I can't seem to find the version of CME from the command line.
    I am not using a NTP server.
    1) I manually set the clock date and time
    2) "create cnf-files"
    3) "load 7960-7940 P00308000400" and did NOT receive any errors this time.
    4) I powered on my switch, the phones booted, displayed a missing file error, and I still have the same problem
    The error I recieve in my consol session when I pickup the handset to either of the phones is this:
    Oct 16 03:12:45.019: %CALL_CONTROL-6-APP_NOT_FOUND: Application telephony-service in dial-peer 20001 not found. Handing callid 2 to the alternate app .
    I'm not sure where it is picking up this dial-peer 200001 from?
    Any further help would be greatly appreciated. Thank you!
    Reply With Quote Quote  

  14. Senior Member
    Join Date
    Jun 2009
    Location
    Gosford, Australia
    Posts
    567

    Certifications
    CCNA, CCDA, CCNA:Voice(IIUC), CCNP:Voice
    #13
    One step closer...

    Doing a show telephony-service will display the CME version for that IOS...should be v8.5. Having the wrong firmware & CME support files for your CME version can cause problems (supported/unsupported features & backward compatibility issues), so its always safest to have them matched.

    Looking at my file sets, for CME v8.5 the correct SCCP 7940/7960 firmware files appear to be (could be the wrong firmware for that model phone);
    P00308010200.bin
    P00308010200.loads
    P00308010200.sb2
    P00308010200.sbn

    If in doubt, remove your CME config off the router, delete the CME support files from flash and start over, starting with a clean slate makes so much differnece at times.

    Dial-Peer 20001 will be one of your ephone-dn, show dial-peer voice summary will display this.

    Never seen it before, but remove the command application telephony-service under the telephony-service, I think it may be the problem. Could be trying to call an application that hasn't been defined, show call application voice summary, for valid apps. I've not played with the applications, so I'm guessing here.
    Reply With Quote Quote  

  15. Junior Member
    Join Date
    Jun 2011
    Posts
    22
    #14
    telephony service
    no application telephony-service

    This did it! I get a dial tone now and the phones can call each other!

    I would like to start fresh as you described but I'm afraid of not knowing what I can delete off the router and be safe. I got the router on ebay and it came preloaded with CME. I don't actually have the application to reload. Do you know what files in flash I can safely delete? To erase all of the configs do I just do a "delete startup config" and reboot?


    Thank you!
    Reply With Quote Quote  

  16. Senior Member
    Join Date
    Jun 2009
    Location
    Gosford, Australia
    Posts
    567

    Certifications
    CCNA, CCDA, CCNA:Voice(IIUC), CCNP:Voice
    #15
    Not sure of your level of Cisco knowledge or what files are on flash:, so could not recommend what is safe to delete.
    Reply With Quote Quote  

  17. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #16
    make a copy of the flash / cf and play around with the config and files..
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks