+ Reply to Thread
Results 1 to 6 of 6
  1. Senior Member itdaddy's Avatar
    Join Date
    Jan 2006
    Posts
    2,056

    Certifications
    A+, MCP, CCNA R/S, CCNA-Security, CCNA Collaboration, CCNP R/S
    #1

    Default What if there is no Vlan for voice but you use a switchport SEE My example - HELP

    What if you find a remote office site with a vpn router and he has the Cisco phones plugged into the router and on the lan switch on the 881 you see no qos tagging. but of course their is DSCP shaping done with a policy map on the wan interface going OUT.

    I want to add a switch because they need more than 4 ports. So I am going to create the vlans on the new switch and TRUNK to the router and leave the vlan interface on their for the 1 subnet they use for both phones and workstations.

    CONCERN: do I even setup qos on the switch and turn on mls qos? don't I need to allow dscp values on the trunk to the router? can anyone help me? what do I setup for qos on the switch to then hand off DSCP values via the trunk. I have no clue here.



    interface FastEthernet0/3
    description Standard Cisco IP Phone and Workstation Port
    switchport access vlan 176
    switchport mode dynamic desirable
    no logging event link-status
    srr-queue bandwidth share 10 10 60 20
    srr-queue bandwidth shape 10 0 0 0
    priority-queue out
    auto qos voip cisco-phone
    spanning-tree portfast

    interface FastEthernet0/3
    description Standard Cisco IP Phone and Workstation Port
    switchport access vlan 789
    switchport mode dynamic desirable
    switchport voice vlan 41
    no logging event link-status
    srr-queue bandwidth share 10 10 60 20
    srr-queue bandwidth shape 10 0 0 0
    mls qos trust device cisco-phone
    mls qos trust cos
    auto qos voip cisco-phone
    spanning-tree portfast
    Reply With Quote Quote  

  2. SS -->
  3. Went to the dark side.... Moderator networker050184's Avatar
    Join Date
    Jul 2007
    Posts
    11,645

    Certifications
    CCNA, CCNP, CCIP, JNCIA-JUNOS, JNCIS-SP, JNCIP-SP, MCA200
    #2
    What have you found through your research so far? Give us what you are thinking and we can tell you if you're going in the right direction. Or if you want someone to do it for you I'm sure they'll be happy to for a small consulting fee!
    An expert is a man who has made all the mistakes which can be made.
    Reply With Quote Quote  

  4. Senior Member itdaddy's Avatar
    Join Date
    Jan 2006
    Posts
    2,056

    Certifications
    A+, MCP, CCNA R/S, CCNA-Security, CCNA Collaboration, CCNP R/S
    #3
    I really have little experience with qos and voice setup. I guess I can setup a data vlan and a voice vlan myself. I kind of get it and probably can do that. I just don't understand cisco enough to see how the remote site can use no vlan for both data and voice and only use 1 vlan for both then how can you use QQS if you only have 1 vlan? I have read of vlan 0 but I am not sure how it all works. I understand COS to DSCP mapping and why L2 to L3 etc..but I have no experience with this stuff in Route switch you dont get alot of this stuff. I can probably make a data vlan and make this correct. I was only trying to understand how does it work without QOS or is it working on some level..thanks anyways. I wasnt asking you to do it for me just help me understand cisco phones. I have seen cos 3 and cos5 coming from cisco and I am only use to Mitel phones and only 1 COS value. So just some understanding of how it works. Thank you.
    Reply With Quote Quote  

  5. Senior Member
    Join Date
    Jul 2010
    Location
    Chicago, Illinois
    Posts
    149

    Certifications
    MCSE:2003 / CCNA/A+
    #4

    Default Crappy phone service.

    Users get really crappy phone service, if it works at all, and that is "if" they can understand someone on the other end.

    yes you should have data on it's own Vlan and Phones on their own. There's no reason for data such as internet traffic from users computers to go over the phone LAN.
    Last edited by Jollycork; 10-29-2015 at 02:27 AM.
    Reply With Quote Quote  

  6. Senior Member
    Join Date
    Jan 2012
    Posts
    1,237

    Certifications
    BS IT (CCNA R&S, Security, Voice) CCDA, MCP XP, A+, L+, P+, LPIC-1, SUSE CLA
    #5
    Eh..phone quality really depends on the user count and available bandwidth. If for example at the remote site there are 2 people/2 phones running that config with a fair amount of bandwidth available then they probably will not notice any difference then compared to if it was a larger user base with that same config. Do your research so you can tune that branch site for optimized performance. If provider allows qos do it all the way through from access layer to internet edge.

    One reason you would segment voice vlan and data is that you keep the voice traffic separate from the data traffic. If both networks (data,voice) share the same vlan which means they all share the same subnet then some smart guy can run a packet sniffer and extract the voice traffic which means someone can possibly download your voice conversation. The reason why data and voice can work on the same vlan or subnet because voice is just traffic, same way how data is traffic. If from that data vlan the phones can communicate with the CUCM or wherever else they register to than it'll still work. The phones will work with or without being in a voice vlan. Its just a security measure and best practice to segment that traffic.

    If you see a lot of issues with the remote site. Make a design plan, present the observations and plan of action to whoever needs to know. Than take action. Remember no one knows everything but you have to be resourceful!
    Last edited by dmarcisco; 10-30-2015 at 01:48 AM.
    In life you have to make your own opportunities. Don't let anyone stop you from your dreams to many negative people want you to fail because they can't succeed.
    Reply With Quote Quote  

  7. Senior Member itdaddy's Avatar
    Join Date
    Jan 2006
    Posts
    2,056

    Certifications
    A+, MCP, CCNA R/S, CCNA-Security, CCNA Collaboration, CCNP R/S
    #6
    thank you guys for your help sounds great.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks