+ Reply to Thread
Results 1 to 7 of 7
  1. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    288
    #1

    Default SIP trunk between CUCM and CME

    Hi guys,
    Here is my config of SIP trunk between CUCM and CME (diagram is attached).
    Code:
    dial-peer voice 168000 voip 
    description **OUTGOING CALLS TO SYD OVER WAN** 
    destination-pattern 168... 
    session protocol sipv2 
    session target sip-server 
    ! 
    dial-peer voice 169000 voip 
    description **INCOMING CALLS FROM SYD OVER WAN** 
    session protocol sipv2 
    session target sip-server 
    incoming called-number .
    ! 
    sip-ua 
    registrar ipv4:192.168.10.5 expires 3600 
    sip-server ipv4:192.168.10.5
    The diagram and trunk, route pattern configs are on the screenshots.
    The calls from 168XXX to 169XXX are dialed successfully and connection is established if dialed from CME to CUCM. However, the calls from CUCM to CME are not dialed and hardly I press 1 button my dial is declined with beep beep beep signal. It looks like no route pattern is configured.
    Guys, could you please check my config.
    Thank you.
    Attached Images Attached Images
    Best, sacredboy!
    Reply With Quote Quote  

  2. SS -->
  3. Mow
    Mow is offline
    Membrane Mow's Avatar
    Join Date
    Apr 2015
    Posts
    431

    Certifications
    CCNP Collaboration, CCNA, CCDA, CCNA Sec
    #2
    Please post full config of CME and screens of phone & DN.
    Reply With Quote Quote  

  4. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    288
    #3
    Code:
    NY-RTR#show running-configBuilding configuration...
    
    
    
    
    Current configuration : 5256 bytes
    !
    ! No configuration change since last restart
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname NY-RTR
    !
    boot-start-marker
    boot-end-marker
    !
    !
    card type e1 0 0
    !
    no aaa new-model
    !
    clock timezone NYC -5 0
    clock summer-time NYCDST recurring
    network-clock-participate wic 0 
    !
    dot11 syslog
    ip source-route
    !
    !
    ip cef
    !
    ip dhcp excluded-address 192.169.10.1 192.169.10.10
    ip dhcp excluded-address 192.169.20.1 192.169.20.10
    !
    ip dhcp pool DATA_SCOPE
     network 192.169.10.0 255.255.255.0
     default-router 192.169.10.1 
    !
    ip dhcp pool VOICE_SCOPE
     network 192.169.20.0 255.255.255.0
     default-router 192.169.20.1 
     option 150 ip 192.169.20.1 
    !
    !
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !         
    !
    isdn switch-type primary-net5
    !
    !
    !
    !
    !
    !
    !
    !
    voice translation-profile 1
     translate called 1
    !
    !
    voice-card 0
    !
    crypto pki token default removal timeout 0
    !
    !
    !
    !
    redundancy
    !
    !
    controller E1 0/0/0
     pri-group timeslots 1-10,16
     description **VOICE CIRCUIT TO PSTN**
    !
    controller E1 0/0/1
     channel-group 0 timeslots 1-31
     description **DATA CIRCUIT TO WAN**
    !
    ! 
    !
    !
    !
    !
    !
    !
    !         
    interface Loopback0
     ip address 177.1.252.1 255.255.255.255
     ip ospf network point-to-point
    !
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface Service-Engine0/0
     no ip address
     shutdown
    !
    interface FastEthernet0/1
     no ip address
     duplex auto
     speed auto
    !
    interface FastEthernet0/1.10
     encapsulation dot1Q 10
     ip address 192.169.10.1 255.255.255.0
    !
    interface FastEthernet0/1.20
     encapsulation dot1Q 20
     ip address 192.169.20.1 255.255.255.0
    !
    interface Serial0/0/0:15
     description **VOICE CIRCUIT TO PSTN**
     no ip address
     encapsulation hdlc
     isdn switch-type primary-net5
     isdn incoming-voice voice
     no cdp enable
    !
    interface Serial0/0/1:0
     description **FRAME RELAY CIRCUIT TO WAN**
     no ip address
     encapsulation frame-relay
     frame-relay lmi-type ansi
    !
    interface Serial0/0/1:0.1 point-to-point
     description **FRAME RELAY CIRCUIT TO SYDNEY**
     ip address 177.1.102.2 255.255.255.252
     frame-relay interface-dlci 201   
    !
    interface Integrated-Service-Engine1/0
     no ip address
     shutdown
     !Application: Restarted at Fri May  5 10:01:06 2006
     no keepalive
    !
    router ospf 1
     router-id 2.2.2.2
     network 0.0.0.0 255.255.255.255 area 0
    !
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    !
    !
    tftp-server flash:/firmware/7940-7960/P00308010200.bin alias P00308010200.bin
    tftp-server flash:/firmware/7940-7960/P00308010200.loads alias P00308010200.loads
    tftp-server flash:/firmware/7940-7960/P00308010200.sb2 alias P00308010200.sb2
    tftp-server flash:/firmware/7940-7960/P00308010200.sbn alias P00308010200.sbn
    !
    control-plane
    !
    !
    voice-port 0/0/0:15
     translation-profile incoming 1
    !
    !
    !
    mgcp profile default
    !
    !
    dial-peer voice 10 pots
     description **9-DIGIT LOCAL DIALING**
     destination-pattern 9[^1].........
     port 0/0/0:15
     forward-digits 10
    !
    dial-peer voice 11 pots
     description **LONG DISTANCE DIALING**
     destination-pattern 91..........
     port 0/0/0:15
     forward-digits 11
    !
    dial-peer voice 12 pots
     description **INTERNATIONAL CALLS**
     destination-pattern 9011T
     port 0/0/0:15
     forward-digits all
    !
    dial-peer voice 168000 voip 
    description **OUTGOING CALLS TO SYD OVER WAN** 
    destination-pattern 168... 
    session protocol sipv2 
    session target sip-server 
    ! 
    dial-peer voice 169000 voip 
    description **INCOMING CALLS FROM SYD OVER WAN** 
    session protocol sipv2 
    session target sip-server 
    incoming called-number .
    ! 
    sip-ua 
    registrar ipv4:192.168.10.5 expires 3600 
    sip-server ipv4:192.168.10.5
    !
    !
    !
    telephony-service
     no auto-reg-ephone
     max-ephones 10
     max-dn 20
     ip source-address 192.169.20.1 port 2000
     load 7960-7940 P00308010200
     max-conferences 8 gain -6
     transfer-system full-consult
     create cnf-files version-stamp 7960 Jun 11 2016 02:18:53
    !
    !
    ephone-dn  1  dual-line
     number 169000
    !
    !
    ephone-dn  2  dual-line
     number 169001
    !
    !
    ephone-dn  3
     number 169002
     description IT Service Desk
     name IT Service Desk
     no huntstop
    !
    !
    ephone-dn  4
     number 169002
     description IT Service Desk
     name IT Service Desk
     preference 1
    !
    !
    ephone  1
     device-security-mode none
     mac-address 000F.F78D.F4EA
     type 7960
     button  1:1
    !
    !
    !
    ephone  2
     device-security-mode none
     mac-address 000F.F7D4.BC8F
     type 7960
     button  1:2
    !
    !
    !
    ephone  3
     device-security-mode none
     mac-address 0016.4600.1DED
     type 7960
     button  1o3,4
    !
    !
    !
    ephone  4
     device-security-mode none
     mac-address 000D.290A.C4E5
     type 7960
     button  1o3,4
    !
    !
    !
    !
    line con 0
     exec-timeout 0 0
     privilege level 15
    line aux 0
    line 66
     no activation-character
     no exec
     transport preferred none
     transport input all
     transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
    line 194
     no activation-character
     no exec
     transport preferred none
     transport input all
     transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
    line vty 0 4
     exec-timeout 0 0
     privilege level 15
     login local
     transport input all
    !
    scheduler allocate 20000 1000
    ntp server 177.1.254.1
    end
    Attached Images Attached Images
    Best, sacredboy!
    Reply With Quote Quote  

  5. Mow
    Mow is offline
    Membrane Mow's Avatar
    Join Date
    Apr 2015
    Posts
    431

    Certifications
    CCNP Collaboration, CCNA, CCDA, CCNA Sec
    #4
    The only thing I can think of is that you may want to try putting a CSS and PT on the stuff in CUCM. Make the CSS something that can call the PT, test, and let me know. An immediate beeping means it doesn't have a matching route pattern, but it should match since there are no CSSs and PTs. However, I would try that, just to be sure. Are there other route patterns in the system?
    Reply With Quote Quote  

  6. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    288
    #5
    I noticed one thing when I was trying to add Route Group/Route List. I have SIP trunks for WAN and PSTN calls flow. However, on Route Group Configuration page I cannot see the trunks I created (pls see screenshots).

    Why is it so and can it be the reason of my problems with PSTN and WAN call flows?
    Attached Images Attached Images
    Best, sacredboy!
    Reply With Quote Quote  

  7. Senior Member
    Join Date
    Mar 2014
    Location
    Atlanta, GA
    Posts
    170

    Certifications
    CCNP Voice, CCNA R/S,
    #6
    In the older versions of CUCM if you link a trunk directly to a Route Pattern it's taken out of the pool of available trunks when trying to add it to a Route Group. The general recommendation is to always use the Route List - Route Group construct.
    Reply With Quote Quote  

  8. Senior Member sacredboy's Avatar
    Join Date
    May 2012
    Location
    Australia
    Posts
    288
    #7
    Hi guys,

    Thank you very much for following up my thread. The problem is resolved. Below is my working config, and I hope it will be helpful to someone else.
    Code:
    dial-peer voice 2000 voip
    description **OUTGOING CALLS TO SYD OVER WAN**
    destination-pattern 2...
    session protocol sipv2
    session target ipv4:192.168.10.5
    !
    dial-peer voice 5000 voip
    description **INCOMING CALLS FROM SYD OVER WAN**
    session protocol sipv2
    session target ipv4:177.1.102.2
    incoming called-number 5...
    !
    !
    sip-ua
    sip-server ipv4:192.168.10.5
    I just got a couple of questions so far:


    1. As it was a lab environment the route to the subnet where CUCM resided was know to CUCME by means of routing protocol. In production environment the subnet with CUCM would be invisible from outside. At the same time, I suppose that in production environment CME sits behind firewall as well and not visible from outside. Which ports should be redirected/forwarded for SIP trunk?
    2. Is it possible for the same task (to connect CUCM and CME directly) to use some other protocol like H.323 or MGCP (or some other protocol)?

    Thank you.
    Attached Images Attached Images
    Best, sacredboy!
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks