+ Reply to Thread
Results 1 to 5 of 5
  1. Junior Member
    Join Date
    Feb 2009
    Posts
    14
    #1

    Default 1760 Dot1q to 3500XL

    Hi Guy's


    Pulling my hair out with this one! I have a 1760 I want to setup for CME and FXS/FXO and started to add the basic config to the router and swith tonight, but have a problem with the trunk port setup.

    It seems I can only have one Vlan Interface enabled at a time!
    Example:

    I have Vlan 10 and 20 configured on my swith and if i have 20 enabled I cant do a no shut on 10 (it just stays shutdown) and vice verser.

    What ever Vlan I have enabled I can ping the sub interface on my 1760 router.

    Config bellow:

    -------------------
    R20_1760#sh ver
    Cisco IOS Software, C1700 Software (C1700-IPVOICEK9-M), Version 12.4(4)XC7, RELEASE SOFTWARE (fc1)

    ROM: System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)

    R20_1760 uptime is 3 hours, 4 minutes
    System returned to ROM by power-on
    System image file is "flash:c1700-ipvoicek9-mz.124-4.XC7.BIN"

    Cisco 1760 (MPC860P) processor (revision 0x851) with 92136K/6168K bytes of memory.
    Processor board ID FOC10455H28 (1104569380), with hardware revision 0000
    MPC860P processor: part number 5, mask 2
    1 FastEthernet interface
    1 Serial(sync/async) interface
    2 Voice FXO interfaces
    2 Voice FXS interfaces
    32K bytes of NVRAM.
    65536K bytes of processor board System flash (Read/Write)

    Configuration register is 0x2102
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~
    R20_1760#sh run
    Building configuration...

    Current configuration : 1403 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname R20_1760
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$lxC4$FersMrDCfaTcDK8QuHwqW0
    !
    no aaa new-model
    !
    resource policy
    !
    voice-card 1
    !
    voice-card 3
    !
    ip cef
    !
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.20.1 192.168.20.100
    ip dhcp excluded-address 10.100.20.1 10.100.20.100
    !
    ip dhcp pool voice
    network 192.168.20.0 255.255.255.0
    option 150 ip 192.168.20.1
    default-router 192.168.20.1
    !
    ip dhcp pool access
    network 10.100.20.0 255.255.255.0
    default-router 10.100.20.1
    !
    no ip domain lookup
    !
    interface FastEthernet0/0
    no ip address
    speed auto
    !
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 10.100.20.1 255.255.255.0
    no snmp trap link-status
    !
    interface FastEthernet0/0.20
    encapsulation dot1Q 20
    ip address 192.168.20.1 255.255.255.0
    no snmp trap link-status
    !
    no ip http server
    no ip http secure-server
    !
    control-plane
    !
    voice-port 1/0
    !
    voice-port 1/1
    !
    voice-port 3/0
    !
    voice-port 3/1
    !
    !
    dial-peer voice 1000 pots
    destination-pattern 1000
    port 1/0
    !
    dial-peer voice 2000 pots
    destination-pattern 2000
    port 1/1
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    password 7 070C285F4D06
    login
    !
    end
    -------------------------------------------------------------
    Node20_3500XL#sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) C3500XL Software (C3500XL-C3H2S-M), Version 12.0(5.4)WC(1),

    ROM: Bootstrap program is C3500XL boot loader

    Node20_3500XL uptime is 30 minutes
    System returned to ROM by reload
    System image file is "flash:c3500XL-c3h2s-mz.120-5.4.WC.1.bin"

    cisco WS-C3524-PWR-XL (PowerPC403) processor (revision 0x01) with 8192K/1024K bytes of memory.
    Processor board ID FAA0532L0HS, with hardware revision 0x00
    Last reset from warm-reset

    Processor is running Enterprise Edition Software
    Cluster command switch capable
    Cluster member switch capable
    24 FastEthernet/IEEE 802.3 interface(s)
    2 Gigabit Ethernet/IEEE 802.3 interface(s)

    32K bytes of flash-simulated non-volatile configuration memory.
    Base ethernet MAC Address: 00:07:0E:C1:BA:80
    Motherboard assembly number: 73-4033-07
    Power supply part number: 34-0968-01
    Motherboard serial number: FAA0532AJYB
    Power supply serial number: DAB042005HR
    Model revision number: A0
    Motherboard revision number: B0
    Model number: WS-C3524-PWR-XL-EN
    System serial number: FAA0532L0HS
    Configuration register is 0xF
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~
    Node20_3500XL#sh run
    Building configuration...

    Current configuration:
    !
    version 12.0
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname Node20_3500XL
    !
    enable secret 5 $1$K7mi$6IRBIxHZ4V6F10RLNiLhD.
    !
    ip subnet-zero
    no ip domain-lookup
    !
    interface FastEthernet0/1
    switchport access vlan 20
    !
    interface FastEthernet0/2
    !
    interface FastEthernet0/3
    !
    interface FastEthernet0/4
    !
    interface FastEthernet0/5
    !
    interface FastEthernet0/6
    !
    interface FastEthernet0/7
    switchport access vlan 10
    !
    interface FastEthernet0/8
    !
    interface FastEthernet0/9
    !
    interface FastEthernet0/10
    !
    interface FastEthernet0/11
    !
    interface FastEthernet0/12
    !
    interface FastEthernet0/13
    !
    interface FastEthernet0/14
    !
    interface FastEthernet0/15
    !
    interface FastEthernet0/16
    !
    interface FastEthernet0/17
    !
    interface FastEthernet0/18
    !
    interface FastEthernet0/19
    !
    interface FastEthernet0/20
    !
    interface FastEthernet0/21
    !
    interface FastEthernet0/22
    !
    interface FastEthernet0/23
    !
    interface FastEthernet0/24
    description Vlan Router Port
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface GigabitEthernet0/1
    !
    interface GigabitEthernet0/2
    !
    interface VLAN1
    no ip address
    no ip directed-broadcast
    no ip route-cache
    shutdown
    !
    interface VLAN10
    description Access
    ip address 10.100.20.2 255.255.255.0
    no ip directed-broadcast
    no ip route-cache
    shutdown
    !
    interface VLAN20
    ip address 192.168.20.2 255.255.255.0
    no ip directed-broadcast
    no ip route-cache
    !
    interface VLAN100
    description Managment
    no ip directed-broadcast
    no ip route-cache
    shutdown
    !
    ip default-gateway 10.100.20.1
    !
    line con 0
    transport input none
    stopbits 1
    line vty 0 4
    password 7 00071A150754
    login
    line vty 5 15
    login
    !
    end

    Node20_3500XL#sh vlan
    VLAN Name Status Ports
    ---- -------------------------------- --------- -------------------------------
    1 default active Fa0/2, Fa0/3, Fa0/4,
    Fa0/5, Fa0/6, Fa0/8, Fa0/9,
    Fa0/10, Fa0/11, Fa0/12, Fa0/13,
    Fa0/14, Fa0/15, Fa0/16, Fa0/17,
    Fa0/18, Fa0/19, Fa0/20, Fa0/21,
    Fa0/22, Fa0/23, Gi0/1, Gi0/2
    10 Access active Fa0/7
    20 Voice active Fa0/1
    1002 fddi-default active
    1003 token-ring-default active
    1004 fddinet-default active
    1005 trnet-default active

    VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1 enet 100001 1500 - - - - - 1002 1003
    10 enet 100010 1500 - - - - - 0 0
    20 enet 100020 1500 - - - - - 0 0
    1002 fddi 101002 1500 - - - - - 1 1003
    1003 tr 101003 1500 1005 0 - - srb 1 1002
    1004 fdnet 101004 1500 - - 1 ibm - 0 0
    1005 trnet 101005 1500 - - 1 ibm - 0 0
    Node20_3500XL#sh ip int brief
    Interface IP-Address OK? Method Status Protocol
    VLAN1 unassigned YES manual up down
    VLAN10 10.100.20.2 YES NVRAM administratively down down
    VLAN20 192.168.20.2 YES manual up up
    VLAN100 unassigned YES unset administratively down down
    FastEthernet0/1 unassigned YES unset down down
    FastEthernet0/2 unassigned YES unset down down
    FastEthernet0/3 unassigned YES unset down down
    FastEthernet0/4 unassigned YES unset down down
    FastEthernet0/5 unassigned YES unset down down
    FastEthernet0/6 unassigned YES unset down down
    FastEthernet0/7 unassigned YES unset down down
    FastEthernet0/8 unassigned YES unset down down
    FastEthernet0/9 unassigned YES unset down down
    FastEthernet0/10 unassigned YES unset down down
    FastEthernet0/11 unassigned YES unset down down
    FastEthernet0/12 unassigned YES unset down down
    FastEthernet0/13 unassigned YES unset down down
    FastEthernet0/14 unassigned YES unset down down
    FastEthernet0/15 unassigned YES unset down down
    FastEthernet0/16 unassigned YES unset down down
    FastEthernet0/17 unassigned YES unset down down
    FastEthernet0/18 unassigned YES unset down down
    FastEthernet0/19 unassigned YES unset down down
    FastEthernet0/20 unassigned YES unset down down
    FastEthernet0/21 unassigned YES unset down down
    FastEthernet0/22 unassigned YES unset down down
    FastEthernet0/23 unassigned YES unset down down
    FastEthernet0/24 unassigned YES unset up up
    GigabitEthernet0/1 unassigned YES unset down down
    GigabitEthernet0/2 unassigned YES unset down down
    Last edited by xrayhead; 04-07-2009 at 06:32 AM.
    Reply With Quote Quote  

  2. SS -->
  3. Went to the dark side.... Moderator networker050184's Avatar
    Join Date
    Jul 2007
    Posts
    11,676

    Certifications
    CCNA, CCNP, CCIP, JNCIA-JUNOS, JNCIS-SP, JNCIP-SP, MCA200
    #2
    On the L2 switch you can only have one SVI active for management. You do not need more than one active for the trunk to come up though.
    An expert is a man who has made all the mistakes which can be made.
    Reply With Quote Quote  

  4. Senior Member pitviper's Avatar
    Join Date
    May 2008
    Location
    Right Coast, US
    Posts
    1,363

    Certifications
    CCNP:Collaboration, CCNP:R+S, CCNA:R+S, CCNA:V(IIUC), CCNA:S, CCENT, CNSS 4011
    #3
    You need to add both vlans to each switchport and designate the native VLAN on the trunk link.
    Reply With Quote Quote  

  5. Senior Member pitviper's Avatar
    Join Date
    May 2008
    Location
    Right Coast, US
    Posts
    1,363

    Certifications
    CCNP:Collaboration, CCNP:R+S, CCNA:R+S, CCNA:V(IIUC), CCNA:S, CCENT, CNSS 4011
    #4
    If I recall correctly on the older 3500XLs, any switchport that you plug a phone into has to be setup as a trunk port.
    Reply With Quote Quote  

  6. APA
    APA is offline
    Senior Member APA's Avatar
    Join Date
    Jun 2006
    Location
    Sydney, Australia
    Posts
    956

    Certifications
    CompTIA, Microsoft, Juniper & Cisco (Check Signature)
    #5
    Quote Originally Posted by pitviper View Post
    If I recall correctly on the older 3500XLs, any switchport that you plug a phone into has to be setup as a trunk port.
    Yeah that's right....on the XL switches there was no provision for 'switchport voice vlan', I'm pretty sure switchport voice vlan only started appearing in the 2950 series and upwards from there...

    Basic usual setup looks something like this for IP phone capability on an XL switch...

    interface fa 0/2
    switchport mode trunk
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 100,200
    switchport trunk native vlan 100
    switchport priority extend cos 0
    cdp enable
    no spanning-tree portfast

    Where -

    VLAN100 = data vlan (PC)
    VLAN200 = IP Phone vlan


    As networker said...you can only have one management SVI active on the 3500XL's.... they are considered a L2 switch with no ip routing capability...

    You have the VLAN sub-interfaces already on the 1760.... Just make sure you add the VLANs to the Vlan database on the 3500XL and then start assigning relevant IP's to hosts and VLANs to switchports...
    ------------------------------------------------------------
    CCNA | CCNA:Security | CCNP | CCIP
    JNCIA:JUNOS | JNCIA:EX | JNCIS:ENT | JNCIS:SEC
    JNCIS:SP | JNCIP:SP
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks