+ Reply to Thread
Results 1 to 23 of 23
  1. Senior Member itdaddy's Avatar
    Join Date
    Jan 2006
    Posts
    2,081

    Certifications
    A+, MCP, CCNA R/S, CCNA-Security, CCNA Collaboration, CCNP R/S
    #1

    Default ipv6/voice for my 2600xm??help!!!!!

    Hey guys
    I have looked and looked. I am limited to 32 MB for my flash for some reason. I even bought new flash and it it says 50MB for flash availabe
    but I installed a 32 MB flash module and it reads 50MBs of flash weird

    System flash directory:
    File Length Name/status
    1 12468092 c2600-telco-mz.124-2.T1.bin
    [12468156 bytes used, 37863488 available, 50331644 total]
    49152K bytes of processor board System flash (Read/Write)
    R2610XM#
    I am confused. I just installed new DRAM 128MB and 32 MB of Flash
    and above reports isnt it 50MB of flash? 50,331,644 bytes isnt that
    50 MB of flash available? I cannot access anymore than that
    I try to load a ios bin file bigger than 14 MB and it will not take it it says error. WH??what am I doing wrong what am I missing.
    I even have new module of DRAM/Flash put in my 2610xm.


    I am trying to get a ios that has voice features for a gatekeeper
    like the H323 MGCP gateway type for FXO/FXS cards?

    so how can I get an IPV6/voice image and what is up with my flash size
    is there some hidden partition I dont know about on the mobo?
    help man I feel really defeated right now ready to toss it in the trash?
    do you guys know of any IOS that has ipv6/voice features that are no over 14MB or how can I fix my flash? it says 50 above doesnt it?
    it is in Bytes right so 50 million bytes is 50MB right?
    Reply With Quote Quote  

  2. SS -->
  3. Cisco Moderator mikej412's Avatar
    Join Date
    May 2005
    Location
    Chicago
    Posts
    10,190

    Certifications
    CCNP CCIP CCSP CCVP CCDP CCDA CCNA CS-CIPSS CS-CIPTDS CS-CIPTOS CS-CIPCSS CS-CFWS CS-CVPNS CS-CISecS ISSP 4013 4011
    #2
    You've got the 16 meg fixed on board flash plus the 32 meg you added giving you the max of 48 Meg.

    What error are you getting when you try to ftp over another image to the 36 meg of free flash memory?
    Reply With Quote Quote  

  4. Senior Member
    Join Date
    Jun 2009
    Location
    Gosford, Australia
    Posts
    567

    Certifications
    CCNA, CCDA, CCNA:Voice(IIUC), CCNP:Voice
    #3
    If you've just installed additional flash to your 2610xm you will have to format it to get the full 48MB made available, just installing the extra flash won't do it, unfortunately they don't auto configure. Also make sure you have a backup IOS ready to install. It could also depend on the what boot ROM version you have in the router as to what it will recognise (unlikely as the flash size is coming up).

    With the gatekeeper IOS, I've just checked the Cisco site and the c2600-telco-mz.124-2.T1.bin does not seem to support it. You'll need one that supports High Performance Gatekeeper, the Cisco IOS Feature Navigator can help you there:

    hxxp://www.cisco.com/go/cfn

    you just need to cross reference feature against platform, but try;

    c2600-ipvoice_ivs-mz.124-25c.bin (or)

    c2600-adventerprisek9_ivs-mz.124-25c.bin

    you IOS version numbers will differ, depends what you have available(the "ivs" in the filename is the give-away for gatekeeper).
    Reply With Quote Quote  

  5. Senior Member itdaddy's Avatar
    Join Date
    Jan 2006
    Posts
    2,081

    Certifications
    A+, MCP, CCNA R/S, CCNA-Security, CCNA Collaboration, CCNP R/S
    #4
    thanks guys I will post when I get home the error on here.

    thanks so much mikej and azaghul

    ahha well will have to format it huh? wow wonder how i do that
    google is my friend ahhh
    will report back what I find; yeah going for the gatekeer thing with fxo/fxs
    thanks so much see you soon

    oops one more thing . how can i fully utilize my 256MB of DRAM i installed new?
    I think my 2610xm is only using 128mb? of dram is that a Boot rom thing version issue? if so can I change the BOOT rom or is it ROM only ? just wondering I am guessing I cannot flash a boot ROM huh? thanks
    Last edited by itdaddy; 05-29-2010 at 12:39 AM.
    Reply With Quote Quote  

  6. Senior Member itdaddy's Avatar
    Join Date
    Jan 2006
    Posts
    2,081

    Certifications
    A+, MCP, CCNA R/S, CCNA-Security, CCNA Collaboration, CCNP R/S
    #5
    Hey guys I did the sqeeze command and I thought that would reclaim the full 50mb for my flash? man the memory must be fine because I had boughten new dram and ram to replace my old (what I thought was bad) but I am doing something wrong. how can I format my 2610xm flash to combine both the 16 onboard and 32 chip? thanks for your help.
    I am exhausted. I have worked hours trying to figure this out. thanks
    keeps giving me this error below. the ios images were 34 mb 27 mb and 22 mb none work they all give this type of errror man what do i do?

    File reception completed.
    Copying file c2600-advipservicesk9-mz.123-4.T6.bin to flash.
    Erasing flash at 0x62fc0000
    program flash location 0x61000000
    program_flash: location 0x61000008 wrote 0x48d1edc5,contains 0x891edc5
    program flash failure at location 0x61000008 - aborting

    Reply With Quote Quote  

  7. was here.
    Join Date
    Apr 2008
    Posts
    4,504
    #6
    Quote Originally Posted by itdaddy View Post
    but I installed a 32 MB flash module and it reads 50MBs of flash weird
    16MB on motherboard + 32MB you added.

    Quote Originally Posted by itdaddy View Post
    I am confused. I just installed new DRAM 128MB and 32 MB of Flash and above reports isnt it 50MB of flash? 50,331,644 bytes isnt that
    50 MB of flash available?
    No. 1KB is 1024 bytes not 1000 so 50331644 is just under 48MB. The router is using 4 bytes for something so you're getting about 47.99999MB

    Quote Originally Posted by itdaddy View Post
    Hey guys I did the sqeeze command and I thought that would reclaim the full 50mb for my flash?
    Use the erase command to format the flash.
    Reply With Quote Quote  

  8. Senior Member itdaddy's Avatar
    Join Date
    Jan 2006
    Posts
    2,081

    Certifications
    A+, MCP, CCNA R/S, CCNA-Security, CCNA Collaboration, CCNP R/S
    #7
    tiersten

    will try it again but I keep getting an error like if I go with a file that is say 14MB i will install but anything over 14 mb it wont install. this has happend on my new dram/flash and on the old alike both had issues.
    and i have 2 128mb modules of dram installedbut only 128mb is being okay 132mb is being accessed and the 128 extra number 2 is not recognized any ideas why?
    thanks
    Reply With Quote Quote  

  9. was here.
    Join Date
    Apr 2008
    Posts
    4,504
    #8
    Quote Originally Posted by itdaddy View Post
    will try it again but I keep getting an error like if I go with a file that is say 14MB i will install but anything over 14 mb it wont install. this has happend on my new dram/flash and on the old alike both had issues.
    Did you actually erase it before using it? If you didn't then you'll get weird issues.

    Quote Originally Posted by itdaddy View Post
    and i have 2 128mb modules of dram installedbut only 128mb is being okay
    You need the new boot ROM to get 256MB RAM working.

    Quote Originally Posted by itdaddy View Post
    132mb is being accessed
    1KB = 1024 bytes.
    Reply With Quote Quote  

  10. Senior Member itdaddy's Avatar
    Join Date
    Jan 2006
    Posts
    2,081

    Certifications
    A+, MCP, CCNA R/S, CCNA-Security, CCNA Collaboration, CCNP R/S
    #9
    tiersten

    will try it again thanks will let youi know
    Reply With Quote Quote  

  11. Senior Member itdaddy's Avatar
    Join Date
    Jan 2006
    Posts
    2,081

    Certifications
    A+, MCP, CCNA R/S, CCNA-Security, CCNA Collaboration, CCNP R/S
    #10

    Default What am I doing wrong 2610xm flash?

    hey guys
    I am so clueless. I have a class B file system flash that I do know
    so I run the erase flash: command and it does it fine.
    I can load a 14.5 MB ios bin file to my flash and that is it period.

    I have changed both my DRAM and Flash from what I thought was defective chips on both my dram/flash. I am getting same error.
    I cannnot load bin file any bigger than 14.5 mb period
    I know I am missing something. my router can be a brick can it??


    help. how do I combin my 16MB onboard flash with my 32 MB simm? help
    and I have a 32 MB simm. it even show the correct dram/ram size what gives?? how to combin the flashes??help
    Reply With Quote Quote  

  12. was here.
    Join Date
    Apr 2008
    Posts
    4,504
    #11
    Quote Originally Posted by itdaddy View Post
    I cannnot load bin file any bigger than 14.5 mb period
    I know I am missing something. my router can be a brick can it??
    You sure the flash thats built into the router motherboard is good?

    Quote Originally Posted by itdaddy View Post
    help. how do I combin my 16MB onboard flash with my 32 MB simm? help and I have a 32 MB simm. it even show the correct dram/ram size what gives?? how to combin the flashes??help
    Post the following:

    show flash all
    show hardware
    Reply With Quote Quote  

  13. Senior Member
    Join Date
    Jun 2009
    Location
    Gosford, Australia
    Posts
    567

    Certifications
    CCNA, CCDA, CCNA:Voice(IIUC), CCNP:Voice
    #12
    Any/no errors while doing erase flash:?

    Or during the erase phase when copying an IOS to flash via copy tftp flash:?

    With and without the additional flash module?
    Last edited by azaghul; 05-30-2010 at 08:25 PM.
    Reply With Quote Quote  

  14. Senior Member itdaddy's Avatar
    Join Date
    Jan 2006
    Posts
    2,081

    Certifications
    A+, MCP, CCNA R/S, CCNA-Security, CCNA Collaboration, CCNP R/S
    #13
    Guys will get back with you tonight and check have to take my son to airport. seeyou tonight will post configs tonight

    tiersten and azaghul


    not sure if my onboard flash is good huh? will pull off the flash to see.

    weird thing is it shows the full 48MB of flash?

    no erase issue errrors either

    just wont take more than 14.5MB on the flash else it give me error or checksum issue in ROMMON...both ROMMON and reg ios copy tftp flash have issues ROMMON is check sum error while in ios mode error that i posted if the ios bin file is 15 mb or more. even with flash erased?
    Reply With Quote Quote  

  15. was here.
    Join Date
    Apr 2008
    Posts
    4,504
    #14
    Quote Originally Posted by itdaddy View Post
    not sure if my onboard flash is good huh? will pull off the flash to see.
    Take off the extra flash SIMM and reformat the flash then try to load that IOS again.

    Quote Originally Posted by itdaddy View Post
    weird thing is it shows the full 48MB of flash?
    Doesn't mean much. It doesn't actually test the flash. It just detects that it is present and includes it as available storage space.
    Reply With Quote Quote  

  16. Senior Member itdaddy's Avatar
    Join Date
    Jan 2006
    Posts
    2,081

    Certifications
    A+, MCP, CCNA R/S, CCNA-Security, CCNA Collaboration, CCNP R/S
    #15
    R2610XM# sh flash all
    Partition Size Used Free Bank-Size State Copy Mode
    1 49151K 14270K 34881K 16384K Read/Write Direct
    + 32768K
    System flash directory:
    File Length Name/status
    addr fcksum ccksum
    1 14612996 c2600-ipbasek9-mz.124-9.T.bin
    0x40 0x4113 0x4113
    [14613060 bytes used, 35718584 available, 50331644 total]
    49152K bytes of processor board System flash (Read/Write)
    Chip Bank Code Size Name
    1 1 8917 8192KB INTEL 28F640J3
    2 1 8917 8192KB INTEL 28F640J3
    1 2 8918 16384KB INTEL 28F128J3
    2 2 8918 16384KB INTEL 28F128J3
    R2610XM#


    **************************************************
    R2610XM#sh hardware
    Cisco IOS Software, C2600 Software (C2600-IPBASEK9-M), Version 12.4(9)T, RELEASE SOFTWARE (fc1)
    Technical Support: Cisco - Shortcut
    Copyright (c) 1986-2006 by Cisco Systems, Inc.
    Compiled Sat 17-Jun-06 02:46 by prod_rel_team
    ROM: System Bootstrap, Version 12.2(7r) [cmong 7r], RELEASE SOFTWARE (fc1)
    R2610XM uptime is 4 minutes
    System returned to ROM by power-on
    System image file is "flash:c2600-ipbasek9-mz.124-9.T.bin"

    This product contains cryptographic features and is subject to United
    States and local country laws governing import, export, transfer and
    use. Delivery of Cisco cryptographic products does not imply
    third-party authority to import, export, distribute or use encryption.
    Importers, exporters, distributors and users are responsible for
    compliance with U.S. and local country laws. By using this product you
    agree to comply with applicable laws and regulations. If you are unable
    to comply with U.S. and local laws, return this product immediately.
    A summary of U.S. laws governing Cisco cryptographic products may be found at:
    Export Compliance Product Report Application
    If you require further assistance please contact us by sending email to
    export@cisco.com.
    Cisco 2610XM (MPC860P) processor (revision 1.0) with 127627K/3445K bytes of memory.
    Processor board ID JAE07280GCX
    M860 processor: part number 5, mask 2
    1 FastEthernet interface
    2 Serial interfaces
    32K bytes of NVRAM.
    49152K bytes of processor board System flash (Read/Write)
    Configuration register is 0x2102
    R2610XM#
    tiersten

    does this look okay? not sure what to look for I see the two distinction between onboard 16MB and 32 MB flash chips but will try it now formating flash
    be right back
    Reply With Quote Quote  

  17. Senior Member itdaddy's Avatar
    Join Date
    Jan 2006
    Posts
    2,081

    Certifications
    A+, MCP, CCNA R/S, CCNA-Security, CCNA Collaboration, CCNP R/S
    #16
    tiersten

    dude I have to head to bed I am dead tired been going all day it is late here in wisconsin.
    so i will take my 32MB chip off to format my other flash and get back with you. man all looks good not sure what is going on? I dont know?
    I even have new flash for my 2610xm my old flash didnt work either was same thing. talk tomorrow
    robert
    thanks so much for your help really man you are the man!
    Reply With Quote Quote  

  18. was here.
    Join Date
    Apr 2008
    Posts
    4,504
    #17
    Quote Originally Posted by itdaddy View Post
    does this look okay? not sure what to look for I see the two distinction between onboard 16MB and 32 MB flash chips but will try it now formating flash
    be right back
    Looks normal. Your flash partition is slightly larger for some reason though. Unsure whether that is actually significant or not.

    You've got the old boot ROM and therefore the router doesn't support 256MB memory. you can buy the upgrade from eBay. It is a single PLCC chip that you replace on the motherboard. The full 256MB can only be used by 12.4T though.
    Reply With Quote Quote  

  19. Cisco Moderator mikej412's Avatar
    Join Date
    May 2005
    Location
    Chicago
    Posts
    10,190

    Certifications
    CCNP CCIP CCSP CCVP CCDP CCDA CCNA CS-CIPSS CS-CIPTDS CS-CIPTOS CS-CIPCSS CS-CFWS CS-CVPNS CS-CISecS ISSP 4013 4011
    #18
    Make sure your flash is seated properly.

    If you have another 2600xm, swap the flash and see if the problem follows the flash, stays with this 2600xm, or disappears.

    It's either bad flash, bad slot, or operator error.
    Reply With Quote Quote  

  20. Senior Member itdaddy's Avatar
    Join Date
    Jan 2006
    Posts
    2,081

    Certifications
    A+, MCP, CCNA R/S, CCNA-Security, CCNA Collaboration, CCNP R/S
    #19
    mikej

    I dont think it is me. i have done many devices and man it really ant rock science when doing this ..(maybe hhahah)

    but yeah I had a previous flash in there and well had same issue.
    I will try to reseat the flash but I am starting to think it is the slot!
    if that is case crap goingto just scrap my 2610xm I have 8 1760s to play with many scenarious..just wanted to have one more router on 12.4T so I could have more will report back tonight what I find out if I cannot get it to work tonight I will keep it for parts. ithas 2 or 3 cards in it that are good to use in my 1760

    thank you all for you time you guys are super friends!
    Reply With Quote Quote  

  21. was here.
    Join Date
    Apr 2008
    Posts
    4,504
    #20
    Quote Originally Posted by itdaddy View Post
    I will try to reseat the flash but I am starting to think it is the slot!
    It may be the internal flash not that it really makes a difference for you. Either way, you can still use the router. You just won't be able to fit large IOS versions on it.
    Reply With Quote Quote  

  22. Senior Member itdaddy's Avatar
    Join Date
    Jan 2006
    Posts
    2,081

    Certifications
    A+, MCP, CCNA R/S, CCNA-Security, CCNA Collaboration, CCNP R/S
    #21
    tiersten and mikej and azaghul

    thanks for you help yep this router is going to Router heaven!
    ahahah
    thanks for your help. I appreciate your time and you help. you dudes rock!
    enjoy your summer
    Reply With Quote Quote  

  23. Senior Member
    Join Date
    Jun 2009
    Location
    Gosford, Australia
    Posts
    567

    Certifications
    CCNA, CCDA, CCNA:Voice(IIUC), CCNP:Voice
    #22
    No need to trash the router, just use it for a lesser function.

    I've a 1760 with a "temperamental" FastEthernet port which barely works, however with 2 x WIC-2T's installed it makes a great frame-relay switch. It just means it has a fairly fixed config and any changes get made via the console. So not a total loss of investment.
    Reply With Quote Quote  

  24. Senior Member itdaddy's Avatar
    Join Date
    Jan 2006
    Posts
    2,081

    Certifications
    A+, MCP, CCNA R/S, CCNA-Security, CCNA Collaboration, CCNP R/S
    #23
    azaghul

    never thought of the extr frame relay hhaha thank bud! for all your help
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks