+ Reply to Thread
Results 1 to 11 of 11
  1. Junior Member
    Join Date
    Mar 2011
    Posts
    14
    #1

    Default Problem with IP Telephony Setup with Packet Tracer


    Port Assignments:

    CME: fa0/0 - 192.168.2.1/24

    CORE SW:
    fa0/2(connected to CME) - 192.168.2.2/24
    fa0/3(PC1_MIS) - DHCP obtain IP
    fa0/4(IP_PHONE MIS / PC2_MIS) - IP Phone can't obtain IP & DN Number BUT PC2_MIS was able to obtain DHCP IP.

    the rest of the toplogy below both host and IP Phone where able to obtain IP.

    all host can ping EDGE ROUTER, all IP PHONE can ping CME DEVICE via OSPF

    what's the problem with my configuration why my IP PHONE directly connected to the CORE can't obtain IP from CME?

    other Suggestion which best fit for my topology? im planning to deploy 14 IP phones and there will be growth in few month's time.

    not yet configured:
    - port security
    - queuing
    - priority

    Code:
    CCME Config:
    ip dhcp excluded-address 192.168.100.1
    !
    ip dhcp pool VOICE
    network 192.168.100.0 255.255.255.0
    default-router 192.168.100.1
    option 150 ip 192.168.2.1
    !
    interface FastEthernet0/0
    ip address 192.168.2.1 255.255.255.0
    ip nat inside
    duplex full
    speed 100
    !
    router ospf 100
    log-adjacency-changes
    network 192.168.2.0 0.0.0.255 area 0
    network 192.168.100.0 0.0.0.255 area 0
    !
    ip classless
    !
    telephony-service
    max-ephones 4
    max-dn 4
    ip source-address 192.168.2.1 port 2000
    auto assign 1 to 2
    auto assign 2 to 3
    auto assign 3 to 4
    auto assign 4 to 5
    !
    ephone-dn 1
    number 101
    !
    ephone-dn 3
    number 103
    !
    ephone-dn 4
    number 104
    !
    ephone-dn 2
    number 102
    !
    ephone 1
    device-security-mode none
    mac-address 0060.47E6.0317
    type 7960
    button 1:1
    !
    ephone 2
    device-security-mode none
    mac-address 0005.5EAE.5D54
    type 7960
    button 1:3
    !
    ephone 3
    device-security-mode none
    mac-address 0090.0C4E.8498
    type 7960
    button 1:4
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line vty 0 4
    exec-timeout 0 0
    password cisco
    logging synchronous
    login
    !
    end
    Code:
    CORE_SWITCH:
    
    ip dhcp excluded-address 192.168.10.1
    ip dhcp excluded-address 192.168.20.1
    ip dhcp excluded-address 192.168.30.1
    ip dhcp excluded-address 192.168.40.1
    !
    ip dhcp pool ADMIN
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.1
    ip dhcp pool INC_ROOM1
    network 192.168.30.0 255.255.255.0
    default-router 192.168.30.1
    ip dhcp pool MIS_ROOM
    network 192.168.20.0 255.255.255.0
    default-router 192.168.20.1
    ip dhcp pool INC_ROOM2
    network 192.168.40.0 255.255.255.0
    default-router 192.168.40.1
    ip routing
    !
    interface FastEthernet0/1
    no switchport
    ip address 150.150.150.2 255.255.255.0
    duplex full
    speed 100
    !
    interface FastEthernet0/2
    no switchport
    ip address 192.168.2.2 255.255.255.0
    duplex full
    speed 100
    !
    interface FastEthernet0/3
    switchport access vlan 20
    switchport mode access
    switchport voice vlan 100
    !
    interface FastEthernet0/4
    switchport access vlan 20
    switchport mode access
    switchport voice vlan 100
    !
    interface FastEthernet0/10
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface FastEthernet0/11
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface FastEthernet0/12
    switchport trunk encapsulation dot1q
    switchport mode trunk
    !
    interface Vlan1
    ip address 10.1.1.1 255.255.255.0
    !
    interface Vlan10
    ip address 192.168.10.1 255.255.255.0
    !
    interface Vlan20
    ip address 192.168.20.1 255.255.255.0
    !
    interface Vlan30
    ip address 192.168.30.1 255.255.255.0
    !
    interface Vlan40
    ip address 192.168.40.1 255.255.255.0
    !
    interface Vlan100
    ip address 192.168.100.1 255.255.255.0
    ip helper-address 192.168.2.1
    !
    router ospf 100
    log-adjacency-changes
    network 192.168.2.0 0.0.0.255 area 0
    network 192.168.100.0 0.0.0.255 area 0
    !
    router ospf 200
    log-adjacency-changes
    network 150.150.150.0 0.0.0.255 area 0
    network 192.168.10.0 0.0.0.255 area 0
    network 192.168.20.0 0.0.0.255 area 0
    network 192.168.30.0 0.0.0.255 area 0
    network 192.168.40.0 0.0.0.255 area 0
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 150.150.150.1 
    !
    banner motd ^C
    UNAUTHORIZED ACCESS PROHIBITED
    ^C
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line vty 0 4
    exec-timeout 0 0
    password cisco
    logging synchronous
    login
    !
    end

    Code:
    EDGE_ROUTER:
    
    interface FastEthernet0/0
    ip address 150.150.150.1 255.255.255.0
    duplex full
    speed 100
    !
    router ospf 200
    log-adjacency-changes
    network 150.150.150.0 0.0.0.255 area 0
    network 192.168.10.0 0.0.0.255 area 0
    network 192.168.20.0 0.0.0.255 area 0
    network 192.168.30.0 0.0.0.255 area 0
    network 192.168.40.0 0.0.0.255 area 0
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line vty 0 4
    exec-timeout 0 0
    password cisco
    logging synchronous
    login
    !
    end
    Last edited by cygee26; 03-03-2011 at 01:55 PM.
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member
    Join Date
    Apr 2008
    Location
    Tampa, Fl
    Posts
    1,097

    Certifications
    A Few....
    #2
    You need to add the ip helper-address interface command so your phone knows how to get to the DHCP server. Check out Cisco's site or other documentation regarding a helper address! HTH.

    -Peanut
    Reply With Quote Quote  

  4. Junior Member
    Join Date
    Mar 2011
    Posts
    14
    #3
    Quote Originally Posted by peanutnoggin View Post
    You need to add the ip helper-address interface command so your phone knows how to get to the DHCP server. Check out Cisco's site or other documentation regarding a helper address! HTH.

    -Peanut
    I already added the IP Helper-address to VLAN 100 with that my IP Phones on ACCESS SWITCH where able to get their designated IP NUMBERS as well as their respective DN Numbers.

    interface Vlan40
    ip address 192.168.40.1 255.255.255.0
    !
    interface Vlan100
    ip address 192.168.100.1 255.255.255.0
    ip helper-address 192.168.2.1

    !
    router ospf 100
    log-adjacency-changes
    network 192.168.2.0 0.0.0.255 area 0
    network 192.168.100.0 0.0.0.255 area 0
    Reply With Quote Quote  

  5. Senior Member chmorin's Avatar
    Join Date
    Feb 2010
    Location
    Texas
    Posts
    1,443

    Certifications
    CCNP:Voice, CCNA:V(IIUC), CCNA, CCENT, Security +, Network +, A+,CIW
    #4
    You have a benifit of using packet tracer. Watch the DHCP requests (in simulation mode), where do they get sent to and stopped at?
    Reply With Quote Quote  

  6. Junior Member
    Join Date
    Mar 2011
    Posts
    14
    #5
    Quote Originally Posted by chmorin View Post
    You have a benifit of using packet tracer. Watch the DHCP requests (in simulation mode), where do they get sent to and stopped at?
    thank you for the reply...

    i selected edit filter to enable dhcp only. but what should the pdu settings? no dhcp on the choices of application.

    if i select "Others" my source port is 2000 but i dont have a destination port.

    the IP phone connected on the core switch keeps on sending a dhcp request. the switch is broadcasting to all ports except towards the CME. the pdu ends on the last broadcast towards the host connected to the ip phone.
    Last edited by cygee26; 03-03-2011 at 11:20 PM.
    Reply With Quote Quote  

  7. Senior Member chmorin's Avatar
    Join Date
    Feb 2010
    Location
    Texas
    Posts
    1,443

    Certifications
    CCNP:Voice, CCNA:V(IIUC), CCNA, CCENT, Security +, Network +, A+,CIW
    #6
    Why do you have a static route?
    Code:
    ip route 0.0.0.0 0.0.0.0 150.150.150.1
    Can I see a show IP Route on the core?

    And one of the L2 switches configurations?
    Reply With Quote Quote  

  8. Cantankerous Old Fart hermeszdata's Avatar
    Join Date
    Jan 2010
    Location
    Colorado
    Posts
    225

    Certifications
    CCNA, CCNA:Voice (Ent) AdTran ATSA Internetworking
    #7
    Quote Originally Posted by chmorin View Post
    Why do you have a static route?
    Code:
    ip route 0.0.0.0 0.0.0.0 150.150.150.1
    Can I see a show IP Route on the core?

    And one of the L2 switches configurations?

    That and why all the network statements under ospf that do not exist on the devices?

    Multiple ospf ASs? What is the reasoning?

    Just wondering.
    Reply With Quote Quote  

  9. Junior Member
    Join Date
    Mar 2011
    Posts
    14
    #8
    Quote Originally Posted by chmorin View Post
    Why do you have a static route?
    Code:
    ip route 0.0.0.0 0.0.0.0 150.150.150.1
    Can I see a show IP Route on the core?

    And one of the L2 switches configurations?
    About the Static Route: i forgot to removed it from my config after i implemented OSPF.

    CORE
    Code:
    CORE_SWITCH#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is 150.150.150.1 to network 0.0.0.0
    
         10.0.0.0/24 is subnetted, 1 subnets
    C       10.1.1.0 is directly connected, Vlan1
         150.150.0.0/24 is subnetted, 1 subnets
    C       150.150.150.0 is directly connected, FastEthernet0/1
    C    192.168.2.0/24 is directly connected, FastEthernet0/2
    C    192.168.10.0/24 is directly connected, Vlan10
    C    192.168.20.0/24 is directly connected, Vlan20
    C    192.168.30.0/24 is directly connected, Vlan30
    C    192.168.40.0/24 is directly connected, Vlan40
    C    192.168.100.0/24 is directly connected, Vlan100
    S*   0.0.0.0/0 [1/0] via 150.150.150.1

    ADMIN L2 SWITCH
    Code:
    Switch#show run
    Building configuration...
    
    Current configuration : 2813 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Switch
    !
    !
    !
    interface FastEthernet0/1
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/2
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/3
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/4
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/5
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/6
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/7
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/8
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/9
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/10
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/11
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/12
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/13
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/14
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/15
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/16
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/17
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/18
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/19
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/20
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/21
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/22
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/23
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 100
    !
    interface FastEthernet0/24
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    interface Vlan1
     ip address 10.1.1.2 255.255.255.0
    !
    !
    line con 0
    !
    line vty 0 4
     login
    line vty 5 15
     login
    !
    !
    end

    That and why all the network statements under ospf that do not exist on the devices?

    Multiple ospf ASs? What is the reasoning?

    Just wondering.
    i was trying to isolate VOICE_VLAN Network from DATA_VLAN networks
    Reply With Quote Quote  

  10. Junior Member
    Join Date
    Mar 2011
    Posts
    14
    #9
    Code:
    CCME(config-router)#
    00:55:55: %OSPF-5-ADJCHG: Process 100, Nbr 192.168.100.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
    
    CCME(config-router)#
    %IPPHONE-6-REGISTER: ephone-1 IP:192.168.100.4 Socket:2 DeviceType:Phone has registered.
    
    %IPPHONE-6-REGISTER: ephone-2 IP:192.168.100.5 Socket:2 DeviceType:Phone has registered.
    
    %IPPHONE-6-REGISTER: ephone-3 IP:192.168.100.3 Socket:2 DeviceType:Phone has registered.
    when OSPF negotiated on CME only 3 phones where registered.

    re configured my OSPF by isolating to different area assignment, now IP phones in L2 Switch can ping edge router which it should. which i see the reason why. i used 192.168.0.0 0.0.255.255 which covers my DATA_VLAN and VOICE_VLAN
    Reply With Quote Quote  

  11. Junior Member Registered Member
    Join Date
    Mar 2011
    Posts
    1
    #10

    Default Network Topology PT

    Hello, please yuo can send me your Packet Tracer file to my mail, I'm studing to CCNA voice certification and your topology is very interesting to study. Thank you for you help and colaboration.


    Last edited by mikej412; 03-13-2011 at 01:02 AM. Reason: Removed email address, can setup in profile to receive email from members.
    Reply With Quote Quote  

  12. Junior Member Registered Member
    Join Date
    Apr 2011
    Posts
    1
    #11
    Can you try the following:

    CORE(config)#interface FastEthernet0/4
    CORE(config-if)#switchport access vlan 20
    CORE(config-if)#switchport mode trunk
    CORE(config-if)#switchport voice vlan 100


    k kafle
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks