+ Reply to Thread
Page 1 of 2 1 2 Last
Results 1 to 25 of 28
  1. Senior Member
    Join Date
    Mar 2011
    Posts
    195

    Certifications
    CCNA,CCNA Security, Nortel DMS,Nortel Norstar,Avaya IP, Telecom Engineer, ITIL v3 Foundation
    #1

    Default Voice DHCP Pool VLAN Question.

    I have a remote site, using site to site VPN tunneling just for voice.
    My question is, when using a 3560 switch, and having that switch hand out DHCP from a IP Pool, in the line
    "option 43 ascii "id:ipphone.mitel.com;sw_tftp=10.0.3.9;call_srv=10 .0.3.9;vlan=3;I2p=6;dscp=46"
    default-router 10.3.11.2"
    For vlan=3, is that the vlan for the distant network, acting as the source and holder for the Call Manager? Or is that the vlan for the local network, that sources the voice vlan on the switch?

    Basically, Primary/Corp network is VLAN 3 for Voice.
    Remote site is VLAN 4 for Voice.
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member pitviper's Avatar
    Join Date
    May 2008
    Location
    Right Coast, US
    Posts
    1,363

    Certifications
    CCNP:Collaboration, CCNP:R+S, CCNA:R+S, CCNA:V(IIUC), CCNA:S, CCENT, CNSS 4011
    #2
    Not familiar with MiTel phones, but that vendor string looks to me like it's instructing the phone to use voice VLAN3, on the local subnet.

    Check this out - it's based on a Windows DHCP server but the process makes sense in theory:
    Deploying Mitel IP Phones in a VLAN/DHCP Environment

    In Cisco world, the only time that I've ever seen option 43 in use was for a light weight WAP deployment
    Reply With Quote Quote  

  4. Senior Member pitviper's Avatar
    Join Date
    May 2008
    Location
    Right Coast, US
    Posts
    1,363

    Certifications
    CCNP:Collaboration, CCNP:R+S, CCNA:R+S, CCNA:V(IIUC), CCNA:S, CCENT, CNSS 4011
    #3
    Also, according to that documentation, it looks like you may need the vendor option 43 in the DHCP scope for the native VLAN, as well as the DHCP scope for the voice VLAN.
    Reply With Quote Quote  

  5. Senior Member
    Join Date
    Mar 2011
    Posts
    195

    Certifications
    CCNA,CCNA Security, Nortel DMS,Nortel Norstar,Avaya IP, Telecom Engineer, ITIL v3 Foundation
    #4
    Here is the DHCP Pool config.
    Locally, the Voice VLAN is 4 IP 10.3.11.0

    ip dhcp pool voice
    network 10.3.11.0 255.255.255.0
    dns-server 68.87.85.98 68.87.69.146
    domain-name X.X.X.X
    option 43 ascii "id:ipphone.mitel.com;sw_tftp=10.0.3.9;call_srv=10 .0.3.9;vlan=4;I2p=6;dscp=46"
    default-router 10.3.11.2
    Reply With Quote Quote  

  6. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #5
    what is happening?
    Reply With Quote Quote  

  7. Senior Member
    Join Date
    Mar 2011
    Posts
    195

    Certifications
    CCNA,CCNA Security, Nortel DMS,Nortel Norstar,Avaya IP, Telecom Engineer, ITIL v3 Foundation
    #6
    Can't get the VoIP set to connect. Sh int status shows nothing for it, and nothing in ARP.
    Reply With Quote Quote  

  8. Senior Member pitviper's Avatar
    Join Date
    May 2008
    Location
    Right Coast, US
    Posts
    1,363

    Certifications
    CCNP:Collaboration, CCNP:R+S, CCNA:R+S, CCNA:V(IIUC), CCNA:S, CCENT, CNSS 4011
    #7
    Do you have option 43 in the native/data DHCP scope as well? That doc mentions that the phone needs to grab an IP from the native/data VLAN first, then it looks at the vendor string, sets it's voice VLAN, and releases/grabs an IP from the voice subnet.

    Also:

    Make sure that the VLANs were created on the switch (show vlan brief) and post the config of the switchport that the phone is connected to; should look something like this:
    Code:
    interface FastEthernet0/1
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 4
     mls qos trust cos
     spanning-tree portfast
    Last edited by pitviper; 08-06-2012 at 09:12 PM.
    Reply With Quote Quote  

  9. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #8
    Check your mitel phones - can you statically assign the vlan to one of them for testing purposes?
    Reply With Quote Quote  

  10. Senior Member
    Join Date
    Nov 2008
    Location
    Elk River, MN
    Posts
    232

    Certifications
    CCNP R&S, CCIP, CCNA Security, JNCIA-JUNOS, VCP4, Security+, MCP
    #9
    We use Mitel phones. Use either CDP with switchport voice vlan 3 on the ports connecting to the IP sets or use LLDP-MED to do the same with a network policy that establishes voice VLAN as well as CoS/DSCP values for signaling and voice-bearer traffic. Typically the MCD handles the DHCP assignment (assuming you are using a 3300).

    As pitviper says above, if you're not using CDP/LLDP-MED then the DHCP configuration in the native VLAN should have option 43 configured as well. The phone will get an IP from the DHCP scope on the native/data VLAN, reads option 43, takes note of the parameters, releases the original IP, requests a new one from the voice VLAN.
    Reply With Quote Quote  

  11. Senior Member
    Join Date
    Mar 2011
    Posts
    195

    Certifications
    CCNA,CCNA Security, Nortel DMS,Nortel Norstar,Avaya IP, Telecom Engineer, ITIL v3 Foundation
    #10
    Here is the Config for the DHCP pools.
    ip dhcp pool user
    network 10.1.11.0 255.255.255.0
    domain-name X.X.X.X
    default-router 10.1.11.1
    dns-server 75.75.75.75 75.75.76.76
    !
    ip dhcp pool voice
    network 10.3.11.0 255.255.255.0
    dns-server 68.87.85.98 68.87.69.146
    domain-name X.X.X.X
    option 43 ascii "id:ipphone.mitel.com;sw_tftp=10.0.3.9;call_srv=10 .0.3.9;vlan=4;I2p=6;dscp=46"
    default-router 10.3.11.2


    And all the interfaces, except the ASA connection are configured as follows:
    interface FastEthernet0/1 - 47
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport voice vlan 4
    no ip address
    duplex full
    speed 100
    no mdix auto
    spanning-tree portfast trunk
    spanning-tree bpduguard enable
    Reply With Quote Quote  

  12. Senior Member
    Join Date
    Mar 2011
    Posts
    195

    Certifications
    CCNA,CCNA Security, Nortel DMS,Nortel Norstar,Avaya IP, Telecom Engineer, ITIL v3 Foundation
    #11
    The VoIP set will power up, but sits in DHCP mode.
    There is no change from the "sh int status | inc connected" command to show that it is even connecting at Layer 1.
    Reply With Quote Quote  

  13. Senior Member
    Join Date
    Apr 2011
    Location
    San Antonio, TX
    Posts
    1,727

    Certifications
    [Reserved]
    #12
    Did you try configuring it as an access port as the example above in this thread? Your configlet above shows "trunk".

    I'm just looking at disimilarities here. I've always seen phones configured to access ports. Why are you configuring a trunk?

    I briefly googled, and I saw where to some effect, the mitel phone acquires even what vlan it's supposed to use for voice via dhcp (which is what I think that string above refers to as far as vlan assignment).

    Unfortunately, it's port is probably not set to negotiate for trunking, and thus never connects.

    could you modify that setting from trunk to access, and then provide us an update?

    Hope this helps.
    Reply With Quote Quote  

  14. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #13
    You never stated if the phone is actually showing being in the voice vlan. Have you statically configured the voice vlan on the phone to verify the config works but may be a port configuration?
    Reply With Quote Quote  

  15. Senior Member
    Join Date
    Nov 2008
    Location
    Elk River, MN
    Posts
    232

    Certifications
    CCNP R&S, CCIP, CCNA Security, JNCIA-JUNOS, VCP4, Security+, MCP
    #14
    Quote Originally Posted by kmcintosh78 View Post
    Here is the Config for the DHCP pools.
    ip dhcp pool user
    network 10.1.11.0 255.255.255.0
    domain-name X.X.X.X
    default-router 10.1.11.1
    dns-server 75.75.75.75 75.75.76.76
    !
    ip dhcp pool voice
    network 10.3.11.0 255.255.255.0
    dns-server 68.87.85.98 68.87.69.146
    domain-name X.X.X.X
    option 43 ascii "id:ipphone.mitel.com;sw_tftp=10.0.3.9;call_srv=10 .0.3.9;vlan=4;I2p=6;dscp=46"
    default-router 10.3.11.2


    And all the interfaces, except the ASA connection are configured as follows:
    interface FastEthernet0/1 - 47
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport voice vlan 4
    no ip address
    duplex full
    speed 100
    no mdix auto
    spanning-tree portfast trunk
    spanning-tree bpduguard enable
    Default an interface and start from scratch.
    Code:
    mls qos
    mls qos map cos-dscp 0 8 16 24 32 46 48 56
    spanning-tree portfast default
    spanning-tree portfast bpduguard default
    
    int f0/1
    switchport mode access
    switchport access vlan <data_vlan_id>
    switchport voice vlan 4
    mls qos trust dscp
    I don't believe you mentioned what model switch it is so I can't show any further QoS config, but at this point I wouldn't worry about it. Once you get it registered then we can slap on the proper QoS config as well as security features.

    If the above does not work, then do as drkat says and hard code the VVLAN ID into the phone and report back.
    Reply With Quote Quote  

  16. Senior Member
    Join Date
    Mar 2011
    Posts
    195

    Certifications
    CCNA,CCNA Security, Nortel DMS,Nortel Norstar,Avaya IP, Telecom Engineer, ITIL v3 Foundation
    #15
    Quote Originally Posted by drkat View Post
    You never stated if the phone is actually showing being in the voice vlan. Have you statically configured the voice vlan on the phone to verify the config works but may be a port configuration?
    Nope. Nothing on the interface, nothing in ARP, nothing in MAC
    I am thinking it is an issue with the cable. POE rides unused pairs, from the traditional network pairs.
    Reply With Quote Quote  

  17. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #16
    Are you doing this all remotely?? I mean you could just take the phone into the switch room and test.
    Reply With Quote Quote  

  18. Senior Member pitviper's Avatar
    Join Date
    May 2008
    Location
    Right Coast, US
    Posts
    1,363

    Certifications
    CCNP:Collaboration, CCNP:R+S, CCNA:R+S, CCNA:V(IIUC), CCNA:S, CCENT, CNSS 4011
    #17
    Not best practice by any means, but a phone will actually work fine in a switchport that is configured as a dot1q trunk – it is after all really a “mini” switch. The older voice switches (3524XLs come to mind) actually required the port to be in trunking mode.
    Reply With Quote Quote  

  19. Senior Member pitviper's Avatar
    Join Date
    May 2008
    Location
    Right Coast, US
    Posts
    1,363

    Certifications
    CCNP:Collaboration, CCNP:R+S, CCNA:R+S, CCNA:V(IIUC), CCNA:S, CCENT, CNSS 4011
    #18
    Quote Originally Posted by kmcintosh78 View Post
    Here is the Config for the DHCP pools.
    ip dhcp pool user
    network 10.1.11.0 255.255.255.0
    domain-name X.X.X.X
    default-router 10.1.11.1
    dns-server 75.75.75.75 75.75.76.76
    !
    ip dhcp pool voice
    network 10.3.11.0 255.255.255.0
    dns-server 68.87.85.98 68.87.69.146
    domain-name X.X.X.X
    option 43 ascii "id:ipphone.mitel.com;sw_tftp=10.0.3.9;call_srv=10 .0.3.9;vlan=4;I2p=6;dscp=46"
    default-router 10.3.11.2


    And all the interfaces, except the ASA connection are configured as follows:
    interface FastEthernet0/1 - 47
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport voice vlan 4
    no ip address
    duplex full
    speed 100
    no mdix auto
    spanning-tree portfast trunk
    spanning-tree bpduguard enable
    Looks like you are still missing:

    option 43 ascii "id:ipphone.mitel.com;sw_tftp=10.0.3.9;call_sr v=10 .0.3.9;vlan=4;I2p=6;dscp=46"

    in the user DHCP pool.
    Reply With Quote Quote  

  20. Senior Member
    Join Date
    Mar 2011
    Posts
    195

    Certifications
    CCNA,CCNA Security, Nortel DMS,Nortel Norstar,Avaya IP, Telecom Engineer, ITIL v3 Foundation
    #19
    Quote Originally Posted by drkat View Post
    Are you doing this all remotely?? I mean you could just take the phone into the switch room and test.
    Unfortunately, yes.
    Reply With Quote Quote  

  21. Senior Member
    Join Date
    Mar 2011
    Posts
    195

    Certifications
    CCNA,CCNA Security, Nortel DMS,Nortel Norstar,Avaya IP, Telecom Engineer, ITIL v3 Foundation
    #20
    Quote Originally Posted by pitviper View Post
    Looks like you are still missing:

    option 43 ascii "id:ipphone.mitel.com;sw_tftp=10.0.3.9;call_sr v=10 .0.3.9;vlan=4;I2p=6;dscp=46"

    in the user DHCP pool.
    That won't negatively affect the PC using the DHCP pool?
    Reply With Quote Quote  

  22. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #21
    no it shouldnt
    Reply With Quote Quote  

  23. Senior Member
    Join Date
    Mar 2011
    Posts
    195

    Certifications
    CCNA,CCNA Security, Nortel DMS,Nortel Norstar,Avaya IP, Telecom Engineer, ITIL v3 Foundation
    #22
    Quote Originally Posted by drkat View Post
    no it shouldnt
    Tried it and still no luck.

    The Interface is not even coming up. It has to be a Layer 1 issue.
    Reply With Quote Quote  

  24. Senior Member
    Join Date
    Mar 2011
    Posts
    195

    Certifications
    CCNA,CCNA Security, Nortel DMS,Nortel Norstar,Avaya IP, Telecom Engineer, ITIL v3 Foundation
    #23
    Just defaulted all the ports and that did not correct the issue as well.
    Reply With Quote Quote  

  25. Senior Member
    Join Date
    Aug 2011
    Posts
    683

    Certifications
    CCNA/CCNA:V/ATSA-IN
    #24
    looks like you're going to need someone on site to describe the issue
    Reply With Quote Quote  

  26. Senior Member
    Join Date
    Mar 2011
    Posts
    195

    Certifications
    CCNA,CCNA Security, Nortel DMS,Nortel Norstar,Avaya IP, Telecom Engineer, ITIL v3 Foundation
    #25
    Quote Originally Posted by drkat View Post
    looks like you're going to need someone on site to describe the issue
    I am sure I know the issue. But the phone powers up, tries to negotiate DHCP, can't find it, so it sits in the DHCP discovery mode.
    I am almost sure that the MITEL Phones use the spare pairs for POE, as opposed to the used pairs with power injected into it.
    It appears that the phone is not making a DATA connection to the switch, but is getting power. I am thinking it is a bad patch cable, with a faulty single cable or pair.
    Reply With Quote Quote  

+ Reply to Thread
Page 1 of 2 1 2 Last

Social Networking & Bookmarks