+ Reply to Thread
Results 1 to 3 of 3
  1. /threadkiller ande0255's Avatar
    Join Date
    Sep 2013
    Location
    Around
    Posts
    1,160

    Certifications
    CCNA R&S, Voice, Security
    #1

    Thumbs down 3-way Redistribution on same router, is it possible? *Topology and sh run attached*

    In the Topology I've attached I've configured fairly successfully Redistribution of routing protocols into other protocols domains using route-tagging via route-maps across the entire network (multi-point 2-way redistribution), however I was trying to go for the gold with 3-way Redistribution where EIGRP / OSPF / RIP meet on R3.

    - (R1-R5) EIGRP AS 100 can see all OSPF, RIP, and EIGRP AS 200 routes
    - (R1 - R2 - R3) OSPF Area 0 can see RIP routes, and routes from both EIGRP AS 100 and AS 200
    - (R3 - R4) is able to see EIGRP AS 100 and OSPF routes, but I cannot for the life of me get it to see RIP routes

    All I had to do was get RIP and OSPF redistributing, and R5's EIGRP AS 100 got routes no problem and with no further configuration than the OSPF to EIGRP 2-way Redistribution up that way, but for some reason R4 did not get any RIP routes from the OSPF domain, so I set up route-tags and a route-map and Redistributed into each other and still nothing.

    I even got so desperate as to try configuring a permit match tag 120 (RIP's tag #) on the OSPF to EIGRP (AS 200) config on R3 and still nothing.

    So here is R3's show run, showing the route-maps in place, the RIP2OSPF and OSPF2RIP working fine to get RIP routes up to R5's EIGRP AS:
    R3(config-router)#do sh run
    Building configuration...

    Current configuration : 2647 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R3
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$R0ce$N83Bj3UeiHYf9ctvAxitE.
    !
    no aaa new-model
    !
    resource policy
    !
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    !
    !
    !
    !
    key chain CCNP
    key 1
    key-string CISCO
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    controller T1 0/0
    framing sf
    linecode ami
    !
    controller T1 0/1
    framing sf
    linecode ami
    !
    !
    !
    !
    !
    !
    interface Loopback3
    ip address 3.3.3.3 255.255.255.255
    !
    interface Loopback33
    ip address 33.33.33.3 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 172.12.23.3 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    ip address 172.12.34.3 255.255.255.0
    ip authentication mode eigrp 200 md5
    ip authentication key-chain eigrp 200 CCNP
    duplex auto
    speed auto
    !
    interface Serial0/2
    ip address 172.12.123.3 255.255.255.0
    encapsulation frame-relay
    ip ospf authentication message-digest
    ip ospf message-digest-key 1 md5 CCNP
    ip ospf priority 0
    frame-relay map ip 172.12.123.2 321
    frame-relay map ip 172.12.123.1 321 broadcast
    no frame-relay inverse-arp
    frame-relay lmi-type cisco
    !
    interface Serial0/3
    no ip address
    shutdown
    !
    router eigrp 200
    redistribute ospf 1 route-map OSPF2EIGRP
    redistribute rip route-map RIP2EIGRP
    network 172.12.34.0 0.0.0.255
    default-metric 1544 10 255 1 1500
    no auto-summary
    !
    router ospf 1
    log-adjacency-changes
    redistribute eigrp 200 subnets route-map EIGRP2OSPF
    redistribute rip metric 2 subnets route-map RIP2OSPF
    network 3.3.3.3 0.0.0.0 area 0
    network 172.12.123.0 0.0.0.255 area 0
    !
    router rip
    version 2
    redistribute eigrp 200 metric 2 route-map EIGRP2RIP
    redistribute ospf 1 metric 2 route-map OSPF2RIP
    network 33.0.0.0
    network 172.12.0.0
    no auto-summary
    !
    !
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    route-map EIGRP2RIP deny 10
    match tag 120
    !
    route-map EIGRP2RIP permit 20
    set tag 200
    !
    route-map RIP2EIGRP deny 10
    set tag 200
    !
    route-map RIP2EIGRP permit 20
    set tag 120
    !
    route-map EIGRP2OSPF deny 5
    match tag 110
    !
    route-map EIGRP2OSPF permit 10
    set tag 200
    !
    route-map OSPF2EIGRP deny 10
    match tag 200
    !
    route-map OSPF2EIGRP permit 20
    set tag 110
    !
    route-map OSPF2RIP deny 5
    match tag 120
    !
    route-map OSPF2RIP permit 10
    set tag 110
    !
    route-map RIP2OSPF deny 10
    match tag 110
    !
    route-map RIP2OSPF permit 20
    set tag 120
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    password CCNP
    logging synchronous
    login
    !
    !
    end

    R3(config-router)#


    I have been searching around to see if what I am doing is beyond the limitation of IOS software, please let me know if there is a mis-configuration or if it's just not possible, as I don't want to spin my tires on something that is not fixable - Any more info requested please let me know.

    Thanks for any input!!
    Attached Images Attached Images
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member keenon's Avatar
    Join Date
    Jun 2004
    Location
    TN
    Posts
    1,914

    Certifications
    CCIE R/S
    #2
    no its not seen this in an IE level practice lab once. not really that hard just making sure that device doesn't create routing loops and also making sure it picks the correct path for destinations
    Reply With Quote Quote  

  4. /threadkiller ande0255's Avatar
    Join Date
    Sep 2013
    Location
    Around
    Posts
    1,160

    Certifications
    CCNA R&S, Voice, Security
    #3
    Ahh, found it, on route-map RIP2EIGRP both clauses were "set" instead of match / set to deny tagged traffic and allow / set tag on all other traffic.

    I set sequence 10 to deny match tag 200 and sequence 20 to set tag 120 and R3 immediately saw the RIP route in its table, hooray
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks