+ Reply to Thread
Results 1 to 5 of 5
  1. /threadkiller ande0255's Avatar
    Join Date
    Sep 2013
    Location
    Around
    Posts
    1,160

    Certifications
    CCNA R&S, Voice, Security
    #1

    Default OSPv3 over NBMA - R1 show nbrs in state "ATTEMPT/DOWN" - Include topology and configs

    OSPFv3_MultiArea_Topology.jpg

    From the attached Topology (Click to enlarge), I've gotten everything except the NBMA to form, and I had kind of some derp moments like forgetting to no shut interfaces - However I think I finally got all the configs correct but it JUST WON'T FORM AN ADJACENCY TO ITS SPOKEY ROUTERS!

    I also did a "debug ipv6 ospf pack" and literally got no output at all, which to me was very odd, given the config confirms it is up and active below.

    Would a more knowledgeable individual on the matter look at the hub and two spoke router running configs, and see what I did wrong?

    It will be in S0/0 on R1 and R2, and S0/2 on R3 in the NBMA (And I did double check the link-local addy's):



    R1

    R1#sh run
    Building configuration...

    *Mar 1 21:50:26.320: %SYS-5-CONFIG_I: Configured from console by console
    Current configuration : 1198 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R1
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$hFVy$8y19EZ2x/uk.bCGWnWZrB/
    !
    no aaa new-model
    !
    resource policy
    !
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    ipv6 unicast-routing
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    ipv6 address 2001::1/64
    ipv6 enable
    ipv6 ospf neighbor FE80::20F:23FF:FE09:B180
    ipv6 ospf neighbor FE80::20E:D7FF:FE10:6C60
    ipv6 ospf 1 area 123
    no frame-relay inverse-arp
    frame-relay lmi-type cisco
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/1
    no ip address
    shutdown
    !
    !
    !
    ip http server
    no ip http secure-server
    !
    ipv6 router ospf 1
    router-id 1.1.1.1
    log-adjacency-changes
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    password CCNP
    logging synchronous
    login
    !
    !
    end
    R1#



    R2

    R2#sh run
    Building configuration...

    Current configuration : 1274 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R2
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$zkNU$E1C2GXoGTu9942xIPNrro/
    !
    no aaa new-model
    !
    resource policy
    !
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    ipv6 unicast-routing
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback2
    no ip address
    ipv6 address 2022::1/128
    ipv6 enable
    ipv6 ospf 1 area 2
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    ipv6 address 2023::2/64
    ipv6 enable
    ipv6 ospf 1 area 0
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    ipv6 address 2001::2/64
    ipv6 enable
    ipv6 ospf priority 0
    ipv6 ospf 1 area 123
    no frame-relay inverse-arp
    frame-relay lmi-type cisco
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    interface Serial0/1
    no ip address
    shutdown
    !
    !
    !
    ip http server
    --More--
    no ip http secure-server
    !
    ipv6 router ospf 1
    router-id 2.2.2.2
    log-adjacency-changes
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    password CCNP
    logging synchronous
    login
    !
    !
    end

    R2#


    R3


    R3#sh run
    Building configuration...

    Current configuration : 1374 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R3
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$QFdX$9tC33yHOlq4pSVjJcmMnd0
    !
    no aaa new-model
    !
    resource policy
    !
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    ipv6 unicast-routing
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    controller T1 0/0
    framing sf
    linecode ami
    !
    controller T1 0/1
    framing sf
    linecode ami
    !
    !
    !
    !
    !
    !
    interface Loopback3
    no ip address
    ipv6 address 2033::1/128
    ipv6 ospf 1 area 3
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    ipv6 address 2023::3/64
    ipv6 enable
    ipv6 ospf 1 area 0
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    ipv6 address 2034::3/64
    ipv6 enable
    ipv6 ospf 1 area 34
    !
    interface Serial0/2
    no ip address
    encapsulation frame-relay
    ipv6 address 2001::3/64
    ipv6 enable
    ipv6 ospf priority 0
    ipv6 ospf 1 area 123
    no frame-relay inverse-arp
    !
    interface Serial0/3
    no ip address
    shutdown
    !
    !
    !
    ip http server
    no ip http secure-server
    !
    ipv6 router ospf 1
    router-id 3.3.3.3
    log-adjacency-changes
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    password CCNP
    logging synchronous
    login
    !
    !
    end

    R3#

    And to show my work, I have everything addressed and working aside from this NBMA:

    My route table on R4:

    R4#sh ipv6 route ospf
    IPv6 Routing Table - default - 8 entries
    Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
    B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
    I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
    D - EIGRP, EX - EIGRP external, NM - NEMO, ND - Neighbor Discovery
    l - LISP
    O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
    ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
    OI 2001::/64 [110/65]
    via FE80::20F:23FF:FE09:B181, FastEthernet0/1
    OI 2022::1/128 [110/2]
    via FE80::20F:23FF:FE09:B181, FastEthernet0/1
    OI 2023::/64 [110/2]
    via FE80::20F:23FF:FE09:B181, FastEthernet0/1
    OI 2033::1/128 [110/1]
    via FE80::20F:23FF:FE09:B181, FastEthernet0/1

    A ping over to R2's loopback:

    R4#ping 2022::1
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 2022::1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 0/2/4 ms
    R4#



    I can ping everything except those two serial interfaces in the NBMA network on R1 and R2 2001::1 and 2001::2, though R3's 2001::3 works without an issue. I've tried adding the encap from / no frame inverse arp, I've tried shutting down all other OSPFv3 interfaces and clearing the ipv6 OSPF proc several times, it will not change from ATTEMPT/DOWN:

    Neighbor ID Pri State Dead Time Interface ID Interface
    N/A 0 ATTEMPT/DROTHER 00:00:20 0 Serial0/0
    N/A 0 ATTEMPT/DROTHER 00:00:20 0 Serial0/0
    R1#

    The odd thing is, it will show they fail to form adjacencies twice, then it stops trying and the Time field actually goes blank.

    Any Idears?
    Reply With Quote Quote  

  2. SS -->
  3. Junior Member
    Join Date
    May 2016
    Posts
    28
    #2
    I hate frame relay. Don't you need all the frame mappings?
    Reply With Quote Quote  

  4. /threadkiller ande0255's Avatar
    Join Date
    Sep 2013
    Location
    Around
    Posts
    1,160

    Certifications
    CCNA R&S, Voice, Security
    #3
    Yeah I dislike it as well, I'm not going to spend more time than doing a wr er one my 3 NBMA routers once more and configuring just their serial interfaces for Area 0 instead of 123.

    With the NBMA switch, you configure a routing to do the frame mappings, and you use serial cables to plug into the frame switch to setup a sort of frame-switched cloud. So I am able to ping from R2 to R1 (Hub), and R2 to R3 without any layer 3 routes or protocol with frame running.

    I have dug through forums, I just cannot find an answer to this, and if this is the one thing I cannot figure out by debugs and research, so be it
    Reply With Quote Quote  

  5. /threadkiller ande0255's Avatar
    Join Date
    Sep 2013
    Location
    Around
    Posts
    1,160

    Certifications
    CCNA R&S, Voice, Security
    #4
    Quote Originally Posted by daveyb View Post
    I hate frame relay. Don't you need all the frame mappings?
    That is brilliant! I completely forgot about them because they use the broadcast statement for one of them on the spokes and this is a non-broadcast sort of network, I will play around with that right after work here - 5 karma for your help!
    Reply With Quote Quote  

  6. /threadkiller ande0255's Avatar
    Join Date
    Sep 2013
    Location
    Around
    Posts
    1,160

    Certifications
    CCNA R&S, Voice, Security
    #5
    So to finish this, my frame switch is an older model (got my equipment before the 15.x revision), so I went to type ipv6 unicast-routing on it and it asked me wtf ipv6 is.

    So that mystery is now officially solved, and the nice thing is I have the running config I've been working with saved to copy and paste all that ipv6 config for quick lab builds to test something
    Last edited by ande0255; 03-10-2017 at 11:57 PM.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks