+ Reply to Thread
Results 1 to 5 of 5
  1. Senior Member bugzy3188's Avatar
    Join Date
    Nov 2011
    Location
    Twin Cities
    Posts
    211

    Certifications
    CCNA R&S, Security+, A+, MCITP Desktop Support Technician, CIW: WFA
    #1

    Default Need Help Redistributing OSPF in to BGP

    Capture.jpg

    I am having a bit of trouble in one of my labs trying to pass OSPF traffic in to BGP. In this scenario I have a simple OSPF Instance above and a few loopback interfaces with different subnets on the Hosts router. At the bottom I have a simple instance of BGP set up, all routers belong to the same AS, the clouds, which represent ISPs, each have a different AS. As far as I can tell both OSPF and BGP are configured correctly, I am distributing connected routes in BGP and can ping any router or ISP.

    On the Edina router, I am redistributing connected in to BGP, I am also redistributing OSPF 1, which from what I understand should distribute inter and intra area routes from OSPF. I am also redistributing BGP in to OSPF so the Hosts router knows about the other subnets.

    Looking at the top ISP (it's called L3, not sure why I edited that out) I can see that the OSPF routes are being passed to it, and are recognized as being BGP routes at that point, however, they do not make it any further than that, none of the routers or ISP below know about the routes that are being pushed in to BGP from OSPF. What am I missing here? Below are the configs from the routers and ISP involved.

    Edina

    Edina#sho run | b router
    router ospf 1
    log-adjacency-changes
    redistribute bgp 100 metric-type 1 subnets
    network 100.10.1.4 0.0.0.3 area 0
    network 172.16.254.0 0.0.0.3 area 0
    !
    router bgp 100
    no synchronization
    bgp log-neighbor-changes
    redistribute connected
    redistribute ospf 1
    neighbor 100.10.1.5 remote-as 200
    no auto-summary


    L3

    L3#sho run | b router
    router bgp 200
    no synchronization
    bgp log-neighbor-changes
    redistribute connected
    neighbor 100.10.1.6 remote-as 100
    neighbor 100.10.1.18 remote-as 100
    neighbor 100.10.1.42 remote-as 100
    no auto-summary

    Chennai

    Chennai#sho run | b router
    router bgp 100
    no synchronization
    bgp log-neighbor-changes
    redistribute connected
    neighbor 100.0.0.1 remote-as 300
    neighbor 100.10.1.41 remote-as 200
    no auto-summary



    Bangalore

    Bangalore#sho run | b router
    router bgp 100
    no synchronization
    bgp log-neighbor-changes
    redistribute connected
    neighbor 100.0.0.5 remote-as 300
    neighbor 100.10.1.17 remote-as 200
    no auto-summary
    Attached Images Attached Images
    Reply With Quote Quote  

  2. SS -->
  3. Lost a treasure CodeBlox's Avatar
    Join Date
    Jun 2010
    Posts
    1,334

    Certifications
    A+, Security+, CCNA
    #2
    I'm gonna take a stab at it based on the info given and say it is due to the AS's you're using. Edina is using AS 100 and sends to AS 200 (L3). From there, it would be expected that Chennai and Bangalor would learn these routes. The issue I believe you are experiences are loop prevention mechanisms in BGP since Chennai and Bangalor are also using AS 100. BGP will not add routes to the BGP table if the AS-Path from eBGP contains it's own AS. I would say you'd need to pick another AS for either Edina or both Chennai and Bangalor. Only 1 of them should be using AS 100.
    Currently reading: Network Warrior, Unix Network Programming by Richard Stevens
    Reply With Quote Quote  

  4. Senior Member Danielh22185's Avatar
    Join Date
    Apr 2012
    Location
    DFW Area
    Posts
    1,156

    Certifications
    CCNP R&S, CCNA, CCENT
    #3
    Quote Originally Posted by CodeBlox View Post
    I'm gonna take a stab at it based on the info given and say it is due to the AS's you're using. Edina is using AS 100 and sends to AS 200 (L3). From there, it would be expected that Chennai and Bangalor would learn these routes. The issue I believe you are experiences are loop prevention mechanisms in BGP since Chennai and Bangalor are also using AS 100. BGP will not add routes to the BGP table if the AS-Path from eBGP contains it's own AS. I would say you'd need to pick another AS for either Edina or both Chennai and Bangalor. Only 1 of them should be using AS 100.
    Correct the Lvl3 Router has no idea what to do with sending the traffic because it learned the routes from AS 100 and you currently have Chennai and Bangalore in the same AS as which the routes were initially learned from.

    I went ahead and annotated it so you can see what we are talking about.
    Capture.JPG
    Last edited by Danielh22185; 07-27-2017 at 08:58 PM.
    Currently Studying: IE Stuff...kinda...for now...
    My ultimate career goal: To climb to the top of the computer network industry food chain.
    "Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi
    Reply With Quote Quote  

  5. Senior Member bugzy3188's Avatar
    Join Date
    Nov 2011
    Location
    Twin Cities
    Posts
    211

    Certifications
    CCNA R&S, Security+, A+, MCITP Desktop Support Technician, CIW: WFA
    #4
    That was it, I have been scratching my head over that for a few days, thanks!
    Reply With Quote Quote  

  6. Senior Member Danielh22185's Avatar
    Join Date
    Apr 2012
    Location
    DFW Area
    Posts
    1,156

    Certifications
    CCNP R&S, CCNA, CCENT
    #5
    Quote Originally Posted by bugzy3188 View Post
    That was it, I have been scratching my head over that for a few days, thanks!
    Easy mistake. Happens to us all when we are grinding out the labs! Always best to take a step back and get a second opinion if you are stuck.
    Currently Studying: IE Stuff...kinda...for now...
    My ultimate career goal: To climb to the top of the computer network industry food chain.
    "Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks