+ Reply to Thread
Results 1 to 2 of 2
  1. Junior Member
    Join Date
    Feb 2008
    Posts
    1
    #1

    Default IOS upgrade on a 2900XL switch

    Hi Guys,

    I have a 3550 and 2 X 2900XL switches with me. I am planning to prepare for the CCNP switching exam and was happy to go on with the switches in my home lab. But lately when configuring STP i realized that many a commands in the syllabus aren't supported in these 2900XL series. Is there any IOS version that would support these commands on 2900XL. The sh version is as given below

    Cisco Internetwork Operating System Software
    IOS (tm) C2900XL Software (C2900XL-C3H2S-M), Version 12.0(5)XU, RELEASE SOFTWARE
    (fc1)
    Copyright (c) 1986-2000 by cisco Systems, Inc.
    Compiled Mon 03-Apr-00 16:37 by swati
    Image text-base: 0x00003000, data-base: 0x00301398

    ROM: Bootstrap program is C2900XL boot loader

    Switch uptime is 36 weeks, 10 hours, 33 minutes
    System returned to ROM by power-on
    System image file is "flash:c2900XL-c3h2s-mz-120.5-XU.bin"


    cisco WS-C2924-XL (PowerPC403GA) processor (revision 0x11) with 8192K/1024K byte
    s of memory.
    Processor board ID 0x0E, with hardware revision 0x01
    Last reset from power-on

    Processor is running Enterprise Edition Software
    Cluster command switch capable
    Cluster member switch capable
    24 FastEthernet/IEEE 802.3 interface(s)

    Is there any way that i cam upgrade to a better IOS verion that supports STP RSTP (whole set of commands on the CCNP switching exam on these 2900XL switches?




    Though foolish will i be able to load these with the 2950 IOS?


    Please sent in your comments.

    Thanks
    blaup
    Reply With Quote Quote  

  2. Cisco Moderator mikej412's Avatar
    Join Date
    May 2005
    Location
    Chicago
    Posts
    10,192

    Certifications
    CCNP CCIP CCSP CCVP CCDP CCDA CCNA CS-CIPSS CS-CIPTDS CS-CIPTOS CS-CIPCSS CS-CFWS CS-CVPNS CS-CISecS ISSP 4013 4011
    #2
    You can't run the 2950 IOS on a 2900 series switch.

    Go get the latest/greatest biggest/baddest IOS available for your switch model and see what happens. You may not get all the commands you want as features are usually added to the newer switches and you're stuck with whatever the older switches were supporting when they hit end of sale.

    A 2924-XL with 8 megs may let you run the last updated enterprise version that was available.

    Quote Originally Posted by mgeorge27
    heres the link to the switch ios's on cisco's website, you need just a guest TCO account.

    http://tools.cisco.com/support/downl...utype=switches
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks