+ Reply to Thread
Results 1 to 7 of 7

Thread: Issue with BGP

  1. Skilled Hamburglar Monkerz's Avatar
    Join Date
    Apr 2010
    Location
    State of Dementia
    Posts
    832

    Certifications
    A+, Net+, CCENT, CCNA:R&S, CCNA:W, CCNP:R&S
    #1

    Default Issue with BGP

    Ok guys, tell me I am not crazy.

    I have setup a simple BGP lab, yet for some reason the transit router will not route traffic. I have attached my topology and configs as well as a few show commands. I am wondering if this IOS is buggy or if GNS3 is just messing with me.

    I am not able to ping 172.16.0.1, 172.16.0.2 or 172.16.1.1 from R1, nor am I able to ping 10.0.0.1, 10.0.0.2 or 10.1.1.1 from R3. I can ping from R2 to everything sucessfully, but when I attempt to ping 172.16.1.1 from R2's 10.0.0.2 interface, the ping fails.

    R1
    Code:
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname ISP1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    memory-size iomem 5
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 10.1.1.1 255.255.255.0
    !
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface Serial0/0
     bandwidth 128
     ip address 10.0.0.1 255.255.255.252
     clockrate 128000
    !
    interface FastEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    router bgp 200
     no synchronization
     bgp log-neighbor-changes
     network 10.1.1.0 mask 255.255.255.0
     neighbor 10.0.0.2 remote-as 100
     no auto-summary
    !
    ip classless
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
    line aux 0
    line vty 0 4
     login
    !
    !
    end
    R2
    Code:
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname ITA
    !
    boot-start-marker
    boot-end-marker
    !
    !
    memory-size iomem 5
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 192.168.0.1 255.255.255.0
    !
    interface Loopback1
     ip address 192.168.1.1 255.255.255.0
    !
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface Serial0/0
     bandwidth 128
     ip address 10.0.0.2 255.255.255.252
     clockrate 128000
    !
    interface FastEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface Serial0/1
     bandwidth 128000
     ip address 172.16.0.2 255.255.255.252
     clockrate 128000
    !
    router bgp 100
     no synchronization
     bgp log-neighbor-changes
     network 192.168.0.0
     network 192.168.1.0
     neighbor 10.0.0.1 remote-as 200
     neighbor 172.16.0.1 remote-as 300
     no auto-summary
    !
    ip classless
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
    line aux 0
    line vty 0 4
     login
    !
    !
    end
    R3
    Code:
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname ISP2
    !
    boot-start-marker
    boot-end-marker
    !
    !
    memory-size iomem 5
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 172.16.1.1 255.255.255.0
    !
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface Serial0/0
     bandwidth 128
     ip address 172.16.0.1 255.255.255.252
     clockrate 128000
    !
    interface FastEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    router bgp 300
     no synchronization
     bgp log-neighbor-changes
     network 172.16.1.0 mask 255.255.255.0
     neighbor 172.16.0.2 remote-as 100
     no auto-summary
    !
    ip classless
    !
    !
    no ip http server
    no ip http secure-server
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
     exec-timeout 0 0
     logging synchronous
    line aux 0
    line vty 0 4
     login
    !
    !
    end
    R1 "sh ip route"
    Code:
    Gateway of last resort is not set
    
         172.16.0.0/24 is subnetted, 1 subnets
    B       172.16.1.0 [20/0] via 10.0.0.2, 00:17:06
         10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C       10.1.1.0/24 is directly connected, Loopback0
    C       10.0.0.0/30 is directly connected, Serial0/0
    B    192.168.0.0/24 [20/0] via 10.0.0.2, 00:17:06
    B    192.168.1.0/24 [20/0] via 10.0.0.2, 00:17:06
    R1 "sh ip bgp"
    Code:
       Network          Next Hop            Metric LocPrf Weight Path
    *> 10.1.1.0/24      0.0.0.0                  0         32768 i
    *> 172.16.1.0/24    10.0.0.2                               0 100 300 i
    *> 192.168.0.0      10.0.0.2                 0             0 100 i
    *> 192.168.1.0      10.0.0.2                 0             0 100 i
    R2 "sh ip route"
    Code:
         172.16.0.0/24 is subnetted, 2 subnets
    C       172.16.0.0 is directly connected, Serial0/1
    B       172.16.1.0 [20/0] via 172.16.0.1, 00:19:54
         10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    B       10.1.1.0/24 [20/0] via 10.0.0.1, 00:19:54
    C       10.0.0.0/30 is directly connected, Serial0/0
    C    192.168.0.0/24 is directly connected, Loopback0
    C    192.168.1.0/24 is directly connected, Loopback1
    R2 "sh ip bgp"

    Code:
       Network          Next Hop            Metric LocPrf Weight Path
    *> 10.1.1.0/24      10.0.0.1                 0             0 200 i
    *> 172.16.1.0/24    172.16.0.1               0             0 300 i
    *> 192.168.0.0      0.0.0.0                  0         32768 i
    *> 192.168.1.0      0.0.0.0                  0         32768 i
    R3 "sh ip route"
    Code:
         172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
    C       172.16.0.0/30 is directly connected, Serial0/0
    C       172.16.1.0/24 is directly connected, Loopback0
         10.0.0.0/24 is subnetted, 1 subnets
    B       10.1.1.0 [20/0] via 172.16.0.2, 00:20:59
    B    192.168.0.0/24 [20/0] via 172.16.0.2, 00:20:59
    B    192.168.1.0/24 [20/0] via 172.16.0.2, 00:20:59
    R3 "sh ip bgp"
    Code:
    *> 10.1.1.0/24      172.16.0.2                             0 100 200 i
    *> 172.16.1.0/24    0.0.0.0                  0         32768 i
    *> 192.168.0.0      172.16.0.2               0             0 100 i
    *> 192.168.1.0      172.16.0.2               0             0 100 i
    Attached Images Attached Images
    Last edited by Monkerz; 05-31-2011 at 03:34 PM.
    Reply With Quote Quote  

  2. SS -->
  3. Went to the dark side.... Moderator networker050184's Avatar
    Join Date
    Jul 2007
    Posts
    11,649

    Certifications
    CCNA, CCNP, CCIP, JNCIA-JUNOS, JNCIS-SP, JNCIP-SP, MCA200
    #2
    The issue is the source of your pings. For example when R1 pings 172.16.0.1 its going to use a source of 10.0.0.1. R3 has no route back to this address and therefore drops the packet. Same thing with the other way. You can either advertise your blocks for your links, source the ping from one of the loopbacks or have a default to R2 to get it to succeed.
    An expert is a man who has made all the mistakes which can be made.
    Reply With Quote Quote  

  4. Skilled Hamburglar Monkerz's Avatar
    Join Date
    Apr 2010
    Location
    State of Dementia
    Posts
    832

    Certifications
    A+, Net+, CCENT, CCNA:R&S, CCNA:W, CCNP:R&S
    #3
    Quote Originally Posted by networker050184 View Post
    The issue is the source of your pings. For example when R1 pings 172.16.0.1 its going to use a source of 10.0.0.1. R3 has no route back to this address and therefore drops the packet. Same thing with the other way. You can either advertise your blocks for your links, source the ping from one of the loopbacks or have a default to R2 to get it to succeed.
    Yeah, I didn't expect the WAN interfaces to be pingable, but I thought the loopback interfaces on R1 and R3 would be.
    Reply With Quote Quote  

  5. Went to the dark side.... Moderator networker050184's Avatar
    Join Date
    Jul 2007
    Posts
    11,649

    Certifications
    CCNA, CCNP, CCIP, JNCIA-JUNOS, JNCIS-SP, JNCIP-SP, MCA200
    #4
    Well they will be pingable if you use a source address that the router has a route for, routing is a two way operation. Remember when you ping without specifying a source the router uses the outgoing interface address by default. Try "ping 172.16.0.1 source 10.1.1.1" or you might have to use the extended commands depending on your IOS.
    An expert is a man who has made all the mistakes which can be made.
    Reply With Quote Quote  

  6. Skilled Hamburglar Monkerz's Avatar
    Join Date
    Apr 2010
    Location
    State of Dementia
    Posts
    832

    Certifications
    A+, Net+, CCENT, CCNA:R&S, CCNA:W, CCNP:R&S
    #5
    Quote Originally Posted by networker050184 View Post
    Well they will be pingable if you use a source address that the router has a route for, routing is a two way operation. Remember when you ping without specifying a source the router uses the outgoing interface address by default. Try "ping 172.16.0.1 source 10.1.1.1" or you might have to use the extended commands depending on your IOS.
    Pinging from loopback to loopback is working. I need to keep studying

    Code:
    Sending 5, 100-byte ICMP Echos to 172.16.0.1, timeout is 2 seconds:
    Packet sent with a source address of 10.1.1.1
    .....
    Success rate is 0 percent (0/5)
    
    Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
    Packet sent with a source address of 10.1.1.1
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 32/107/208 ms
    Reply With Quote Quote  

  7. Went to the dark side.... Moderator networker050184's Avatar
    Join Date
    Jul 2007
    Posts
    11,649

    Certifications
    CCNA, CCNP, CCIP, JNCIA-JUNOS, JNCIS-SP, JNCIP-SP, MCA200
    #6
    You just have to remember the basics. People get caught up with protocols and this and that when it really comes down to fundamental routing and router operations.
    An expert is a man who has made all the mistakes which can be made.
    Reply With Quote Quote  

  8. Skilled Hamburglar Monkerz's Avatar
    Join Date
    Apr 2010
    Location
    State of Dementia
    Posts
    832

    Certifications
    A+, Net+, CCENT, CCNA:R&S, CCNA:W, CCNP:R&S
    #7
    This is actually a lab out of the Route Lab Manual. I print out the labs and do them myself without following their directions to ensure I can complete the task. I believe the lab is wrong, it wants you to advertise the loopbacks on all three routers, the use a tcl script to ping all loopback interfaces. It says they should all ping successfully.

    After I had failed to get it to work, I followed the lab word for word and came out with the same exact issue. I guess they didn't test their lab.


    Thanks for the help.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks