+ Reply to Thread
Results 1 to 4 of 4
  1. Junior Member
    Join Date
    Dec 2005
    Posts
    14

    Certifications
    A+, Net+, CCNA
    #1

    Question 2821 and 3550 with DHCP

    For some reason I am unable to get o fut to the internet with my laptop. From the 2821 I can ping out just fine. I enabled DHCP on the 3550 and am able to pull a proper ip address. I also can ping the default gateway and router from my laptop but not any further. Currently I am trying implement intervlan routing on the 3550 but am stumped and have no clue what to do from here. Any help would be greatly appreciated. Below are the running configs for the switch and router.

    ----------------------------
    WS-C3550-48-EMI

    Building configuration...

    Current configuration : 4341 bytes
    !
    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname SWITCH
    !
    !
    username pepsi privilege 15 password 7 095F5B130C0E1E445E
    no aaa new-model
    ip subnet-zero
    ip routing
    ip dhcp excluded-address 10.0.2.1 10.0.2.99
    !
    ip dhcp pool VLAN100
    network 10.0.2.0 255.255.255.0
    default-router 10.0.2.1
    dns-server 8.8.8.8
    !
    vtp mode transparent
    !
    !
    !
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    !
    vlan internal allocation policy ascending
    !
    vlan 99
    name VLAN99
    !
    vlan 100
    name VLAN100
    !
    interface FastEthernet0/47
    switchport access vlan 100
    switchport mode access
    spanning-tree portfast
    !
    interface FastEthernet0/48
    no switchport
    ip address 10.0.1.2 255.255.255.0
    !
    !
    interface Vlan1
    no ip address
    shutdown
    !
    interface Vlan100
    ip address 10.0.2.2 255.255.255.0
    no ip redirects
    standby 1 ip 10.0.2.1
    standby 1 preempt
    !
    ip default-gateway 10.0.1.1
    ip classless
    ip http server
    ip http secure-server

    ----

    SWITCH#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is not set

    10.0.0.0/24 is subnetted, 2 subnets
    C 10.0.2.0 is directly connected, Vlan100
    C 10.0.1.0 is directly connected, FastEthernet0/48



    ----------------------------------------
    CISCO2821

    Building configuration...


    Current configuration : 1471 bytes
    !
    ! Last configuration change at 07:01:26 UTC Thu Aug 29 2013 by nohara
    !
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname ROUTER
    !
    boot-start-marker
    boot-end-marker
    !
    no aaa new-model
    !
    !
    dot11 syslog
    ip source-route
    !
    ip cef
    !
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    voice-card 0
    !
    crypto pki token default removal timeout 0
    !
    license udi pid CISCO2821 sn FTX1112A4EE
    username pepsi privilege 15 password 7 105D1C03101C1B5D59
    !
    redundancy
    !
    interface GigabitEthernet0/0
    description <==WAN==>
    ip address dhcp
    ip nat outside
    ip virtual-reassembly in
    duplex auto
    speed auto
    no cdp enable
    !
    interface GigabitEthernet0/1
    description <==LAN==>
    ip address 10.0.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    !
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    !
    !
    ip nat inside source list 1 interface GigabitEthernet0/1 overload
    ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0
    ip route 10.0.2.0 255.255.255.0 GigabitEthernet0/1
    !
    logging esm config
    access-list 1 permit 10.0.1.0 0.0.0.255
    access-list 1 permit 10.0.2.0 0.0.0.255

    -----

    Router#show ip route
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
    + - replicated route, % - next hop override

    Gateway of last resort is 0.0.0.0 to network 0.0.0.0

    S* 0.0.0.0/0 is directly connected, GigabitEthernet0/0
    10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
    C 10.0.1.0/24 is directly connected, GigabitEthernet0/1
    L 10.0.1.1/32 is directly connected, GigabitEthernet0/1
    S 10.0.2.0/24 is directly connected, GigabitEthernet0/1
    S 10.100.0.1/32 [254/0] via 99.91.24.1, GigabitEthernet0/0
    99.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 99.91.24.0/21 is directly connected, GigabitEthernet0/0
    L 99.91.29.77/32 is directly connected, GigabitEthernet0/0
    Last edited by shimabuku; 08-31-2013 at 09:31 AM.
    Reply With Quote Quote  

  2. SS -->
  3. Network Engineer Dieg0M's Avatar
    Join Date
    Jun 2013
    Location
    Montreal
    Posts
    853

    Certifications
    CCIE #48240, CCDP
    #2
    Don't use default-gateway command on L3 switch with Ip routing enabled. Use ip route 0.0.0.0 0.0.0.0 10.0.1.1.
    Reply With Quote Quote  

  4. Junior Member
    Join Date
    Dec 2005
    Posts
    14

    Certifications
    A+, Net+, CCNA
    #3
    Thanks Dieg0m! That was part of the issue, below are the changes I made to get it working.

    Switch:
    Remove ip default-gateway 10.0.1.1 and replace with ip route 0.0.0.0 0.0.0.0 10.0.1.1

    Router:
    Remove ip route 10.0.2.0 255.255.255.0 gi0/1 and replace with ip route 10.0.2.0 255.255.255.0 10.0.1.2
    Remove ip route 0.0.0.0 0.0.0.0 gi0/0 and replace with ip route 0.0.0.0 0.0.0.0 dhcp
    Remove ip nat inside source list 1 interface GigabitEthernet0/1 overload and replace with ip nat inside source list 1 interface GigabitEthernet0/0 overload
    Reply With Quote Quote  

  5. Network Engineer Dieg0M's Avatar
    Join Date
    Jun 2013
    Location
    Montreal
    Posts
    853

    Certifications
    CCIE #48240, CCDP
    #4
    I didn't even check your router config as I was assuming you were sourcing your ping from NAT inside interface. Glad it worked out.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks