+ Reply to Thread
Results 1 to 11 of 11
  1. Senior Member
    Join Date
    Apr 2006
    Location
    Canada
    Posts
    101

    Certifications
    MCITP, MCSE, CompTIA Security+, and ITIL
    #1

    Default Unable to connect Virtual PC to internet

    Hi All,


    Unable to connect Virtual PC to internet I have 3 Virtual PC 2004 machines each with an OS of Windows 2003 Server. I would like to download the server exchange from the internet and be familiar how things are working but I could not be able to connect to the net from my vpc can you help please.....................

    Thank you
    hudda
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member BeaverC32's Avatar
    Join Date
    May 2007
    Posts
    677

    Certifications
    See Signature
    #2
    How do you have your network interface configured on your virtual machines? I typically setup with NAT to access the internet, but that's with vmware so your config may be different.
    Reply With Quote Quote  

  4. New Member royal's Avatar
    Join Date
    Jul 2006
    Location
    Chicago, IL
    Posts
    3,373
    #3
    Yep, that's the nice thing about Vmware, you can just use NAT and you're all set. With Virtual PC/Server, it's not as easy. Basically, the way you do it is as follows:

    1. Install a Microsoft loopback adapter on the host machine.

    2. On your host machine, enable Internet Connection Sharing (ICS) to share from your main adapter that receives internet access to your loopback adapter. ICS is hard coded to use the 192.168.0.x /24 network. ICS also will work as DHCP and give your loopback adapter an ip address (192.168.0.1). I always configured the loopback adapter to have a static ip address of 192.168.0.1/24. Your virtual machine's should then have a default gateway of 192.168.0.1/24.

    3. Set your virtual machine's in Virtual PC/Server to use the loopback adapter as their network adapter.

    4. Your virtual servers will by default use dhcp and will also retrieve a dhcp address from the loopback adapter. If you statically configure your virtual servers, you'll want to use the loopback's address (192.168.0.1) as your default gateway to get out to the internet.

    With this loopback method, your loopback adapter works as a router. Even if you are on a different network for your host machine, lets say 192.168.1.x /24, you can now RDP into your virtual servers from your host machine. I've used this method many times for configuring my virtual servers so they are on a different network than my host machine's environment, but still grant them access to the internet, and allow me to RDP into them from my host machine.
    Reply With Quote Quote  

  5. Senior Member
    Join Date
    Apr 2006
    Location
    Canada
    Posts
    101

    Certifications
    MCITP, MCSE, CompTIA Security+, and ITIL
    #4

    Default Thank you Royal............

    Royal, thank you so much for your time, but some other friends telling me I have to have external modem do I really need that, I will try your way, I am just wondering…..
    Reply With Quote Quote  

  6. Member
    Join Date
    Feb 2007
    Posts
    86

    Certifications
    MCSE NT4, MCSE 2003, CCNA & CCNP
    #5
    Depends how you have things set-up you could do as Royal suggests or you could just choose your physical machines network adapter providing you do not mind your virtual machines being on the same subnet as your physical machine. It is really easy to do just try the various network options under the settings of your virtual machine.

    How do you connect to the Internet with your physical machine?
    Reply With Quote Quote  

  7. Senior Member BeaverC32's Avatar
    Join Date
    May 2007
    Posts
    677

    Certifications
    See Signature
    #6
    Why not just install VMWare? It also supports a ton of other OS platforms (in particular, Linux, if you want to play around with that). It's as easy as 1-2-3!
    Reply With Quote Quote  

  8. Member
    Join Date
    Feb 2007
    Posts
    86

    Certifications
    MCSE NT4, MCSE 2003, CCNA & CCNP
    #7
    VMWare workstation is a lot better but it costs. Where as Virtual PC is free. VMWare server is free but last time I looked it did not run on Vista and I do not like it. I must admit I find Virtual PC really good for my labs sure it does not have snapshot functionality but it does a job. Would prefer VMWare Workstation but cannot justify the money
    Reply With Quote Quote  

  9. Senior Member BeaverC32's Avatar
    Join Date
    May 2007
    Posts
    677

    Certifications
    See Signature
    #8
    VMWare server works fine on Vista Ultimate...not sure if it works with other versions of Vista, though. And VMWare server is all you need, I've never used workstation.

    What don't you like about it? From my experience, it works pretty much the same as VirtualPC, but it has many more options/features.
    Reply With Quote Quote  

  10. Member
    Join Date
    Feb 2007
    Posts
    86

    Certifications
    MCSE NT4, MCSE 2003, CCNA & CCNP
    #9
    BeaverC32,

    I have never liked the fact that you have to install IIS and since I have used Workstation and Virtual PC I much prefer something that works on my Vista machine. Guess I do not like the management interface.

    I tried to get Virtual Server to work on my Vista desktop a couple of weeks ago but I could not manage it. I think it is possible but involves a lot more hassle than I would like.
    Reply With Quote Quote  

  11. Junior Member Registered Member
    Join Date
    Jul 2010
    Posts
    1
    #10

    Default Unable to connect to internet in VMWare

    Hi,

    I m using VMWare workstation 7.1.0 build 261024. For the past couple of days I m not able to connect to the internet.

    I have WS2008R2DC(Domain Controller) and WS2008R2 in my VMWare.
    For WS2008R2DC and WS2008R2, there are two network adapters, NAT and Host-only.For both of these network adapters, VMnet(Auto-bridging) is the default selection.(grayed out)

    I don't know networking stuff, so I request you guys to help me out to get internet connection working in my VMWare.Its been 2 days now.

    Thanks.
    Reply With Quote Quote  

  12. Senior Member za3bour's Avatar
    Join Date
    Mar 2010
    Location
    Santa Cruz, USA
    Posts
    991

    Certifications
    BS:Electrical Engineering,DRE, AMBCI, MCITP-EA,SA, MCP, CCNA
    #11
    I'm using VMWare with no problem with Win Server2003 and 2008 in addition to Win7 and Internet is working with no problem at all and i highly recommend it.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks