+ Reply to Thread
Results 1 to 7 of 7
  1. Senior Member joey74055's Avatar
    Join Date
    Nov 2008
    Posts
    215

    Certifications
    MCP
    #1

    Default Exchange Mail Flow

    Hello. I have a question. We have one Exchange 2003 server and two Exchange 2007 servers. Most all of our mailboxes are on 2007 but we do still have one shared mailbox, unity mailbox and a journling mailbox on 2003. Public Folders have been set to replicate to 2007. I have set up a send connector on 2007 with a cost of 1. Receive connectors have Anonymous Users checked on 2007. On 2003 there are two connectors: the Internet Email connector and the connector that connects 2003 to 2007. We have a SPAM filtering device that email goes through before it is handed off to Exchange. The SPAM filtering device is set to send email to one of our Exchange 2007 servers. Here is my question/problem: Even though the SPAM filtering device is set to forward email to Exchange 2007, somehow all of our email is still going through the Exchange 2003 server before it finally hits the users mailboxes on the Exchange 2007 server. How can I change it so that all email goes directly to Exchange 2007 and never routes through Excahnge 2003 both ways, inbound and outbound?

    Would also like to add:

    In the EMC under Org- Hub- Send Connector there are two connectors. One is the "Internet Connector" from the 2003 box and the other is the new one I created. THe address space on the 2003 one is set to a cost of 2, no smart hosts and the 2003 box is listed as the Source Server. THe other Send Connector has an address space of 1, no smart host and has the 2 excahnge 2007 servers listed as the source servers.

    In EMC under Server- Hub- my two exchange 2007 servers are listed. Each one has 2 receive connectors. Both Recieve Connectors are setup the same way. THe Default Receive Connector has Anonymous Users checked. The other Recieve Connector is labled "Client" and I am not sure what it does or why its there. Anonymous Users are not checked.

    No smart hosts configured on 2003.
    Last edited by joey74055; 01-12-2010 at 03:08 PM. Reason: Add
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member Chivalry1's Avatar
    Join Date
    Mar 2005
    Location
    127.0.0.1
    Posts
    554

    Certifications
    CISSP, CICSP, MCSE, C|EH, MCSA, MCITP: EMA 2K7/2010, MCTS:Exchange 2K7/2010, Sec+, Net+, CCA-XENAPP, ITIL-V3, MCDST, MOS
    #2
    What are the indicators that email is still flowing through the Exchange 2003 servers?

    Couple of things to check:

    1.) Ensure your Exchange 2007 list your domain "ABC.COM" as a "Authoritative Domain".

    2.) Check your SMTP Route send connector for your SPAM Appliance ensure its pointing to the Exchange 2007 Hub transport server.
    "The recipe for perpetual ignorance is: be satisfied with your opinions and
    content with your knowledge. " Elbert Hubbard (1856 - 1915)
    Reply With Quote Quote  

  4. Senior Member joey74055's Avatar
    Join Date
    Nov 2008
    Posts
    215

    Certifications
    MCP
    #3
    We know by two things: 1) for some reason the message queue on the exchange 2003 box keeps getting "stuck" and messages build up until the server is restarted several times and when this happens no one can send and receive, even internally and 2) when we view the mesasge headers on an email it shows us that the meesage wwent from the spam device straight to the exchange 2003 box.
    Reply With Quote Quote  

  5. Senior Member joey74055's Avatar
    Join Date
    Nov 2008
    Posts
    215

    Certifications
    MCP
    #4
    Would I just simply need to delete the Internet send connector on Exchange 2003 or would this cause other problems?
    Reply With Quote Quote  

  6. Senior Member joey74055's Avatar
    Join Date
    Nov 2008
    Posts
    215

    Certifications
    MCP
    #5
    Ok, this issue is now solved!

    It was a "hidden" setting in our SPAM filtering device. We just had to change it from the Exchange 2003 IP to the Exchange 2007 IP address.
    Reply With Quote Quote  

  7. Senior Member Chivalry1's Avatar
    Join Date
    Mar 2005
    Location
    127.0.0.1
    Posts
    554

    Certifications
    CISSP, CICSP, MCSE, C|EH, MCSA, MCITP: EMA 2K7/2010, MCTS:Exchange 2K7/2010, Sec+, Net+, CCA-XENAPP, ITIL-V3, MCDST, MOS
    #6
    "2.) Check your SMTP Route send connector for your SPAM Appliance ensure its pointing to the Exchange 2007 Hub transport server."

    Yeah...I figured your spam appliance still had a SMTP route to the Exchange 2003 . BTW..What spam appliance does your company use?
    "The recipe for perpetual ignorance is: be satisfied with your opinions and
    content with your knowledge. " Elbert Hubbard (1856 - 1915)
    Reply With Quote Quote  

  8. Senior Member joey74055's Avatar
    Join Date
    Nov 2008
    Posts
    215

    Certifications
    MCP
    #7
    Thank you.

    We use the Barracuda Spam Firewall.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks