+ Reply to Thread
Results 1 to 12 of 12
  1. Senior Member
    Join Date
    Apr 2009
    Location
    Sacramento, CA
    Posts
    825
    #1

    Default Cant connect client to Exchange 2010

    Im in a lab, via vmware, networking isn't an issue, I am able to logon via OWA and send mail back and forth between two users but when I try to do autodiscover (first initial setup), it asks for a username and password (trying to setup user for the first time), when I type it in (I know im doing it correctly) I get an error message:
    The action cannot be completed. The connection to Microsoft Exchange is unavailable. Outlook must be online or connect to complete this action


    note, when i try to connect to my server via putty on my port 2525 (comcast blocked 25), i get a connection refused...

    what other steps do I need to configure? I've changed send and receive connecter to port 2525 so i could send mail out... owa works just the client cannot connect

    client is on the same subnet 192.168.1 and RPC is running, autodiscovery enabled, ect
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member cyberguypr's Avatar
    Join Date
    May 2007
    Location
    Chicago, IL
    Posts
    5,768

    Certifications
    GCFE, GCED, GCIH, CISSP, CCSP, and others that should never be mentioned
    #2
    Certificate related maybe? Try Get-Exchangecertificate | fl and post the output.
    Reply With Quote Quote  

  4. Senior Member
    Join Date
    Apr 2009
    Location
    Sacramento, CA
    Posts
    825
    #3
    i should be able to connect though without a cert? this is a home lab so i haven't purchased one yet

    but tell me if i am wrong, since i am a newb, i will post output
    Reply With Quote Quote  

  5. Senior Member
    Join Date
    Apr 2009
    Location
    Sacramento, CA
    Posts
    825
    #4
    PS] C:\Windows\system32>get-exchangecertificate | fl

    AccessRules : {System.Security.AccessControl.CryptoKeyAccessRule , System.Security.AccessControl.CryptoKeyAccessR
    ule}
    CertificateDomains : {davebeiler.com, mail.davebeiler.com, autodiscover.davebeiler.com, Ser08r2Exc1.davebeiler.com}
    HasPrivateKey : True
    IsSelfSigned : True
    Issuer : C=US, S=CA, L=Sacramento, O=davebeiler, OU=it consultant, CN=davebeiler.com
    NotAfter : 7/31/2014 7:53:57 PM
    NotBefore : 7/31/2013 7:33:57 PM
    PublicKeySize : 2048
    RootCAType : None
    SerialNumber : 15D3DBF34AC2F4804B3AF22F0E86D244
    Services : None
    Status : Valid
    Subject : C=US, S=CA, L=Sacramento, O=davebeiler, OU=it consultant, CN=davebeiler.com
    Thumbprint : 59EB71B5008E42C4D08D0BDA8E2213A32E8BDB4F

    AccessRules : {System.Security.AccessControl.CryptoKeyAccessRule , System.Security.AccessControl.CryptoKeyAccessR
    ule, System.Security.AccessControl.CryptoKeyAccessRule, System.Security.AccessControl.CryptoKeyAcc
    essRule}
    CertificateDomains : {Ser08r2Exc1, Ser08r2Exc1.davebeiler.com}
    HasPrivateKey : True
    IsSelfSigned : True
    Issuer : CN=Ser08r2Exc1
    NotAfter : 7/30/2018 9:29:27 PM
    NotBefore : 7/30/2013 9:29:27 PM
    PublicKeySize : 2048
    RootCAType : None
    SerialNumber : 4E46A21E4540A8834E8A82E57706DFCE
    Services : IMAP, POP, IIS, SMTP
    Status : Valid
    Subject : CN=Ser08r2Exc1
    Thumbprint : C5A7273A400432AA2409D02A7C176327038D2790
    Reply With Quote Quote  

  6. Senior Member
    Join Date
    Apr 2009
    Location
    Sacramento, CA
    Posts
    825
    #5
    So I setup a reverse Lookup zone, I am able to connect now, but its prompts outlook that it must restart, then when I launch outlook after restart it is as if it was never setup
    Reply With Quote Quote  

  7. VMware Dude! TheProf's Avatar
    Join Date
    Jun 2010
    Location
    Canada
    Posts
    327

    Certifications
    vExpert | CCA | CCAA | MCSA | MCTS | MCITP:EMA 2010 | VCP5-DCV/DT | VTSP4/5 | VSP 5 | Network +
    #6
    If you want to test Autodiscover from Outlook, you should open your outlook client and hold down the left CTRL key, then right click on the outlook icon on the bottom right hand side and select "test email AutoConfiguration... then make sure you have just the "Use Autodiscover" selected and run the test

    In regards to certificates, those are mainly used for OWA access or S/MIME connections... I don't think they would apply here.. also keep in mind that exchange creates self signed certs that can be used temporarily... which is what you see above from your output if you look at the value called "IsSelfSigned : True".
    Reply With Quote Quote  

  8. Senior Member
    Join Date
    Apr 2009
    Location
    Sacramento, CA
    Posts
    825
    #7
    Quote Originally Posted by TheProf View Post
    If you want to test Autodiscover from Outlook, you should open your outlook client and hold down the left CTRL key, then right click on the outlook icon on the bottom right hand side and select "test email AutoConfiguration... then make sure you have just the "Use Autodiscover" selected and run the test
    that does not work, i think this only works if outlook is already open, but i can not get it to even do that
    Last edited by gbdavidx; 08-06-2013 at 12:05 AM.
    Reply With Quote Quote  

  9. Nidhoggr, the Net Serpent Claymoore's Avatar
    Join Date
    Nov 2007
    Location
    FL
    Posts
    1,622

    Certifications
    AWS Architect, MCSEx3, MCITPx6, MCTSx17
    #8
    The Remote Connectivity Analyzer has a Client testing tab that will allow you to perform the RCA tests from inside your environment and help identify the error.

    It's likely going to be the certificate on the Exchange server. You can purchase a real 3rd party SAN cert and adjust the AutoDiscoverServiceInternalUri parameter of your CAS server to eliminate the cert error that manifests as an authentication prompt. I have also seen problems when the server address is not in the Intranet Zone in the client and the workstation refuses to automatically pass credentials.

    Get-ClientAccessServer -Id <servername> | fl
    The AutoDiscoverServiceInternalUri is the value that is published as the Autodiscover Service Connection Point in AD.

    If you don't want to purchase a 3rd party cert, you could also consider building an ADCS server in your lab and get some practice with certificate services.
    How to Request a Certificate With a Custom SAN
    Reply With Quote Quote  

  10. Senior Member
    Join Date
    Apr 2009
    Location
    Sacramento, CA
    Posts
    825
    #9
    i can't even get to it externally after attempting to try to setup dns, so the connectivity analyzer tool wont work
    Reply With Quote Quote  

  11. VMware Dude! TheProf's Avatar
    Join Date
    Jun 2010
    Location
    Canada
    Posts
    327

    Certifications
    vExpert | CCA | CCAA | MCSA | MCTS | MCITP:EMA 2010 | VCP5-DCV/DT | VTSP4/5 | VSP 5 | Network +
    #10
    Check to see if the exchange services are all started... Also what version of outlook and Exchange 2010 Service pack do you have installed?
    Reply With Quote Quote  

  12. Nidhoggr, the Net Serpent Claymoore's Avatar
    Join Date
    Nov 2007
    Location
    FL
    Posts
    1,622

    Certifications
    AWS Architect, MCSEx3, MCITPx6, MCTSx17
    #11
    The RCA Client test installs software on the workstation and runs the tests from inside your network. This is to test internal connectivity in much the same way as the RCA originally tested remote connectivity.

    Based on your other posts, I'm not sure how far into the weeds you now are with this Exchange installation. Exchange relies on AD, and thus DNS, to function. If you are having internal DNS issues then you cannot guarantee Exchange is functioning. I do not know what instructions you are using for your installation, but I recommend the Exchange Deployment Assistant. That will walk you through the steps to get Exchange installed and functioning.
    Reply With Quote Quote  

  13. Senior Member
    Join Date
    Jul 2004
    Location
    Singapore
    Posts
    134

    Certifications
    MCP,MCDST and MCSA + Messaging
    #12
    Try to check if MAPI is enabled. Value should be true.

    Get-CasMailbox -identity <mailboxName>
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks