+ Reply to Thread
Results 1 to 15 of 15
  1. Senior Member
    Join Date
    Oct 2010
    Posts
    857

    Certifications
    CISSP, CEH
    #1

    Default RDP issue (not allowing two connections at once)

    Hi all,

    So recently I came across an issue that our server (2003) is not allowing two RDP sessions at once anymore. On the terminal server everything seems to be correct

    the Licensing is set to Remote Desktop and Administrators which allows two connections at once. And the group policy looks good but I'm not sure why its still not working.

    Any suggestions?
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member Devilsbane's Avatar
    Join Date
    Apr 2010
    Posts
    4,203

    Certifications
    MCSE:Security, MCDST, A+, Network+, Security+, ITIL V3 Foundations, ITIL 2011 Intermediate: Service Transition, MOS 2007 (MCAS) BAS Computer Forensics
    #2
    Quote Originally Posted by higherho View Post
    Any suggestions?
    Is someone logged in locally?
    Reply With Quote Quote  

  4. Senior Member
    Join Date
    Oct 2010
    Posts
    857

    Certifications
    CISSP, CEH
    #3
    Quote Originally Posted by Devilsbane View Post
    Is someone logged in locally?
    At the time yes but I was told that we could have 1 console connection and at least two RPD sessions. However, I guess that would suck up a license. Maybe I will try that.
    Reply With Quote Quote  

  5. Senior Member
    Join Date
    Apr 2011
    Location
    San Antonio, TX
    Posts
    1,727

    Certifications
    [Reserved]
    #4
    When you check the sessions, how many do you see logged into the server?

    How many console, and how many remote?
    Currently Working: CCIE R&S
    LinkedIn: http://www.linkedin.com/in/lewislampkin (Please connect: Just say you're from TechExams.Net!)
    Reply With Quote Quote  

  6. Senior Member
    Join Date
    Oct 2010
    Posts
    857

    Certifications
    CISSP, CEH
    #5
    Quote Originally Posted by instant000 View Post
    When you check the sessions, how many do you see logged into the server?

    How many console, and how many remote?
    1 Console, 1 remote. Then I logged off the console and I asked someone else to see if they can log in and they could not Do you think something was changed in the registry under terminal server\ licensing core?
    Reply With Quote Quote  

  7. Senior Member
    Join Date
    Apr 2011
    Location
    San Antonio, TX
    Posts
    1,727

    Certifications
    [Reserved]
    #6
    That's doubtful.

    Would you have reason to be suspicious of that?

    Any recent maintenance done on the server?

    When was your last backup?

    It is running Windows ... if you cannot verify any changes, you could reboot it and see if that clears it.
    Currently Working: CCIE R&S
    LinkedIn: http://www.linkedin.com/in/lewislampkin (Please connect: Just say you're from TechExams.Net!)
    Reply With Quote Quote  

  8. Certification Junkie Budzy's Avatar
    Join Date
    Mar 2009
    Location
    UK
    Posts
    117

    Certifications
    MCSE x1, MCSA x4, MCITP x3, MCTS x6, MCP x2
    #7
    Hi higherho,

    Perhaps have a look at this if you haven't already checked it:

    On the server's desktop:

    under admin tools -> Terminal services configuration
    Under connections, you should see RDP-tcp, open up the properties of this.
    Select the Network adapter tab and make sure the maxium connections option is set to 2.

    As long as the licencing mode is set to remote administaion then this should work unless we're dealing with a greater problem here.

    Edit: Not sure if you need to restart the terminal server service once you do this.
    Last edited by Budzy; 05-17-2011 at 10:19 PM.
    Reply With Quote Quote  

  9. Senior Member
    Join Date
    Oct 2010
    Posts
    857

    Certifications
    CISSP, CEH
    #8
    Quote Originally Posted by instant000 View Post
    That's doubtful.

    Would you have reason to be suspicious of that?

    Any recent maintenance done on the server?

    When was your last backup?

    It is running Windows ... if you cannot verify any changes, you could reboot it and see if that clears it.
    It was hardened a little bit ago by another individual and before that it did work so I was just nailing down possibilities on what he could have changed (thats why I brought up the registry before).

    Quote Originally Posted by Budzy View Post
    Hi higherho,

    Perhaps have a look at this if you haven't already checked it:

    On the server's desktop:

    under admin tools -> Terminal services configuration
    Under connections, you should see RDP-tcp, open up the properties of this.
    Select the Network adapter tab and make sure the maxium connections option is set to 2.

    As long as the licencing mode is set to remote administaion then this should work unless we're dealing with a greater problem here.

    Edit: Not sure if you need to restart the terminal server service once you do this.


    Thank you all for the help.
    Last edited by higherho; 05-19-2011 at 10:56 PM.
    Reply With Quote Quote  

  10. VCDX in 2017 Essendon's Avatar
    Join Date
    Sep 2007
    Location
    Melbourne
    Posts
    4,489

    Certifications
    VCIX-NV, VCAP5-DCD/DTA/DCA, VCP-5/DT, MCSA: 2008, MCITP: EA, MCTS x5, ITIL v3, MCSA: M, MS in Telecom Engg
    #9
    Were any Windows updates installed recently? These things can break just about anything!
    VCDX: DCV - Round 2 rescheduled (by VMware) for December 2017.

    Blog >> http://virtual10.com
    Reply With Quote Quote  

  11. Senior Member ChooseLife's Avatar
    Join Date
    Feb 2011
    Location
    runlevel 3
    Posts
    926

    Certifications
    BCSc Network Security, VCP, MCSA:Sec, CCNA:Sec, GIAC GSEC, Sec+, ITIL-f
    #10
    Quote Originally Posted by higherho View Post
    It was hardened a little bit ago by another individual and before that it did work so I was just nailing down possibilities on what he could have changed.
    That brings up a number of questions... Are you really supposed to unharden the server? Can you work with the individual to undo the change?
    Reply With Quote Quote  

  12. Senior Member
    Join Date
    Oct 2010
    Posts
    857

    Certifications
    CISSP, CEH
    #11
    Quote Originally Posted by ChooseLife View Post
    That brings up a number of questions... Are you really supposed to unharden the server? Can you work with the individual to undo the change?
    Yes this RPD change should not have happened. 2 connections is allowed as long as you limit it to Administrators.
    Reply With Quote Quote  

  13. Senior Member
    Join Date
    Oct 2010
    Posts
    857

    Certifications
    CISSP, CEH
    #12
    Quote Originally Posted by Budzy View Post
    Hi higherho,

    Perhaps have a look at this if you haven't already checked it:

    On the server's desktop:

    under admin tools -> Terminal services configuration
    Under connections, you should see RDP-tcp, open up the properties of this.
    Select the Network adapter tab and make sure the maxium connections option is set to 2.

    As long as the licencing mode is set to remote administaion then this should work unless we're dealing with a greater problem here.

    Edit: Not sure if you need to restart the terminal server service once you do this.
    I did check the network adapter settings and it has a maximum setting of 1. However, directly below that option it says

    "This server is configured in the default Romote Desktop mode for remote administration which allows a maximum of two simultaneou connections"


    I cannot change the max number either its greyed out. I did try creating a new connection and I simply named it test and selected the same settings as the other one but changed it to max 2. When I hit finished I got the following error message;

    "The new connection must have a unique connection type, transport type, or network adapter"

    is this because i alredy have a simliar connection created?
    Reply With Quote Quote  

  14. Senior Member MrAgent's Avatar
    Join Date
    Oct 2010
    Location
    Northern Virginia
    Posts
    1,283

    Certifications
    Sec+, MCP, MCSA 2003, MCTS, MCITP:VA, VCP5, MCSA 2012, MCSE Private Cloud, MCSE Server Infrastructure, C|EHv7, RHCSA, OSCP, GCIH, OSWP
    #13
    I would definitely go and check your policies again. I had the same issue once. Turned out to be a local policy.
    2016 Goals: GCIH, OSWP - DONE!
    My OSCP review http://www.jasonbernier.com/oscp-review/
    Reply With Quote Quote  

  15. Senior Member Devilsbane's Avatar
    Join Date
    Apr 2010
    Posts
    4,203

    Certifications
    MCSE:Security, MCDST, A+, Network+, Security+, ITIL V3 Foundations, ITIL 2011 Intermediate: Service Transition, MOS 2007 (MCAS) BAS Computer Forensics
    #14
    Quote Originally Posted by MrAgent View Post
    I would definitely go and check your policies again. I had the same issue once. Turned out to be a local policy.

    Run rsop.msc on the computer to get the result of all the policies applied. If you do find that the policy is set somewhere, Rsop will tell you where so that you can go change it.
    Reply With Quote Quote  

  16. Senior Member
    Join Date
    Oct 2010
    Posts
    857

    Certifications
    CISSP, CEH
    #15
    Quote Originally Posted by Devilsbane View Post
    Run rsop.msc on the computer to get the result of all the policies applied. If you do find that the policy is set somewhere, Rsop will tell you where so that you can go change it.
    I did that today and for the time I had to work on that task I did not see anything "Network" or "Remote" related that would limit the number of connections. I will take a deeper look into them again tomorrow.
    Last edited by higherho; 05-19-2011 at 10:56 PM.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks