+ Reply to Thread
Results 1 to 4 of 4
  1. Senior Member
    Join Date
    Oct 2010
    Posts
    861

    Certifications
    CISSP, CEH
    #1

    Default WSUS not working :(

    My senior SA left me with an open project which was getting WSUS back to function again. So after performing a lot of troubleshooting and also using WSUS health check I just cannot figure out how to get rid of these following event ID errors.


    Event ID: 13042 - Self-update is not working
    Event ID: 12002 - The Reporting Web Service is not working
    Event ID: 12032 - The server synchronization Web Service is not working
    Event ID: 12022 - The Client Web Service is not working
    Event ID: 12042 - The SimpleAuth Web Service is not working
    Event ID: 12052 - The DSS Authentication Web Service is not working
    Event ID: 3083 - The protocol handler Search MapiHandler 1 cannot be loaded. Error description class no registered.


    I've got documentation on each event ID but so far no luck on either of them. The documentation is basically printed out details of each event ID. Has anyone gone through this before? I've checked the following basics:

    permissions are fine.
    Ports are fine.

    I then went on IIS and did a local browse of the default website (right click and click browse) and I ge the following error:

    "HTTP 401.1 Unauthorized due to invalid credentials"

    once I saw this I thought that my local account was incorrect. So I reset the password of that (btw Enable anonymous access is enabled too).

    Just hitting a brick wall with this over and over. Any help would be greatly appreciated.

    thanks.
    Reply With Quote Quote  

  2. SS -->
  3. Virtual Member undomiel's Avatar
    Join Date
    Sep 2007
    Location
    Bellevue, WA
    Posts
    2,813

    Certifications
    MCSA:2008, VCP4/5, CCA (XS), MCITP: EA/VA, MCSE, MCSA, Linux+, Security+, Server+, A+
    #2
    Sounds like you need to enable anonymous authentication in IIS. You'll want to go over the settings in this KB article: The Microsoft Windows Server Update Services (WSUS) SelfUpdate service does not send automatic updates
    Reply With Quote Quote  

  4. Senior Member
    Join Date
    Oct 2010
    Posts
    861

    Certifications
    CISSP, CEH
    #3
    Quote Originally Posted by undomiel View Post
    Sounds like you need to enable anonymous authentication in IIS. You'll want to go over the settings in this KB article: The Microsoft Windows Server Update Services (WSUS) SelfUpdate service does not send automatic updates
    Hi UNdomiel,

    Thank you for the information. I already had the enable anonymous authentication enabled. I thought the user account password was wrong so I reset that but I still get the same error after I try to browse the website locally
    Reply With Quote Quote  

  5. Senior Member
    Join Date
    Oct 2010
    Posts
    861

    Certifications
    CISSP, CEH
    #4
    I know its been a while since i posted in this thread. I just wanted to say a few days after my last post I decided to check the permissions on the website level and that was the issue. However, I still blew the whole WSUS away and start from scratch. Why? well the person who set it up last time had everything in the systems file directory. Security standards (STIG) states that the web content / files must be on a separate partition from your system files. All and all good experience and something to keep my busy.

    Now on to the next issue :0
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks