+ Reply to Thread
Results 1 to 16 of 16
  1. Member
    Join Date
    Dec 2008
    Location
    Sydney
    Posts
    59

    Certifications
    CCNA, CEH,ECSA, MCITP EMA 07 , MCSA 03
    #1

    Default Very slow logon time...on workstations

    Hey guys,

    I have a problem with all my workstations in the domain, basically all workstations are shared by different agents (CC environment with different permissions), every single time someone tries to login onto the pc it will take approx 20 to 40 minutes to be able to see the desktop...The pcs are quite old Dell 210L 512mb of ram, but no heavy softwares are installed on the machines....I can see that it runs the start up scripts but...20 to 40 mins is crazy!!! Any ideas guys? What to check?
    Reply With Quote Quote  

  2. SS -->
  3. Virtual Member undomiel's Avatar
    Join Date
    Sep 2007
    Location
    Bellevue, WA
    Posts
    2,813

    Certifications
    MCSA:2008, VCP4/5, CCA (XS), MCITP: EA/VA, MCSE, MCSA, Linux+, Security+, Server+, A+
    #2
    I'd first check your AD health, make sure that they're not having any problems finding and contacting a DC. Next thought would be to check on whether you're using roaming profiles and how large those profiles are. If you still haven't found the problem or a clue to lead you to the problem then it is probably time to turn on group policy logging and see where all the logon time is being spent.
    Reply With Quote Quote  

  4. Junior Member
    Join Date
    Jan 2008
    Location
    Canada
    Posts
    23

    Certifications
    Network+, A+, CNA
    #3
    I highly suspect a DNS problem. Is it possible your workstations DNS are configured to your point to your ISP DNS? If so, change them to point to your DNS server (which probably is the AD server if it's a smaller environment).
    Reply With Quote Quote  

  5. Senior Member rwmidl's Avatar
    Join Date
    Dec 2009
    Location
    World-wide Availability
    Posts
    768

    Certifications
    CISSP, CISM, MCSA:2008, MCITP:SA, MCTS x 4, MCSE W2K, MCSE: Security, MCSA W2K, MCSA: Security, MCP x Alot, Security +, ACIS, ACSS
    #4
    Do you have any "newer" computers? I'm wondering if they are just so "old" they are taking extra logon times?
    CISSP | CISM | MCSA:2008 | MCITP:SA | MCSE:Security | MCSA:Security | Security + | MCTS | ACIS | ACSS
    Reply With Quote Quote  

  6. Member
    Join Date
    Dec 2008
    Location
    Sydney
    Posts
    59

    Certifications
    CCNA, CEH,ECSA, MCITP EMA 07 , MCSA 03
    #5
    Thanks guys for your reply....I also noticed...then it does not only do this when someone logs in, it also takes ages when the pc is restarted and I can see "Applying Conf Settings" before being able to type my credentials.I also forgot to mention that I can see the usual "Running Logon Scripts" for 5/10 mins...
    Reply With Quote Quote  

  7. Senior Member JeanM's Avatar
    Join Date
    Mar 2012
    Location
    California
    Posts
    1,105

    Certifications
    CCNA, MCP, S+, N+, A+
    #6
    Quote Originally Posted by Gimmyno View Post
    Thanks guys for your reply....I also noticed...then it does not only do this when someone logs in, it also takes ages when the pc is restarted and I can see "Applying Conf Settings" before being able to type my credentials.I also forgot to mention that I can see the usual "Running Logon Scripts" for 5/10 mins...

    Stand up another CLEAN install on a spare box or VM and test/compare, sounds like it could be OS/config issue not related to network (profile maybe), based on your last reply that is.
    Reply With Quote Quote  

  8. Member nycid's Avatar
    Join Date
    Oct 2011
    Location
    NC
    Posts
    71

    Certifications
    A+ Net + Sec +
    #7
    Quote Originally Posted by mctwist View Post
    I highly suspect a DNS problem. Is it possible your workstations DNS are configured to your point to your ISP DNS? If so, change them to point to your DNS server (which probably is the AD server if it's a smaller environment).
    I agree verify DNS. DNS is a ***** and about 90% of problems for this sort of thing...
    Reply With Quote Quote  

  9. Member
    Join Date
    Dec 2008
    Location
    Sydney
    Posts
    59

    Certifications
    CCNA, CEH,ECSA, MCITP EMA 07 , MCSA 03
    #8
    Thanks guys ,

    I 've found this in the logs on all Pcs:

    The system failed to update and remove host (A) resource records (RRs) for network adapter
    with settings:

    Adapter Name : {58E0997C-B8AB-410B-BA19-7EBA3456D8825}
    Host Name : MYPC
    Primary Domain Suffix : domain.domain.com
    DNS server list :
    10.x.x.x, 10.x.x.x
    Sent update to server : 10.x.x.x
    IP Address(es) :
    10.x.x.x


    And This DHCP;

    Your computer was unable to automatically configure the IP parameters for the Network Card with the network address 60EBR43F50E48. The following error occurred during configuration: The DHCP client has obtained an IP address that is already in use on the network. The local interface will be disabled until the DHCP client can obtain a new address.

    Any suggestion?
    Reply With Quote Quote  

  10. Senior Member
    Join Date
    Jun 2011
    Posts
    359
    #9
    Make sure that you have enough available ip addresses in your DHCP range and that DNS is aging and scavenging effectively; clearing old records. This should all work seamlessly without too much intervention in a small environment but if your infratructure is aging, something could be dropping the ball.
    Also, it sounds like you have a "wait for the network" gpo applied, this forces the computers to completely apply all group policy changes everytime the computer is booted up and everytime the user logs in before allowing access to the user. If something is slowing the network down and the computers are slow on top of that, it could be a problem as well. I'm configuring brand new workstations right now and when I first bring them onto the domain it takes several minutes for all of the gpos to apply; I could imagine this would be excessive in a slow network with old computers.
    Reply With Quote Quote  

  11. Virtual Member undomiel's Avatar
    Join Date
    Sep 2007
    Location
    Bellevue, WA
    Posts
    2,813

    Certifications
    MCSA:2008, VCP4/5, CCA (XS), MCITP: EA/VA, MCSE, MCSA, Linux+, Security+, Server+, A+
    #10
    Have you done any of the above mentioned troubleshooting? What did you discover during the troubleshooting? Is the client actually receiving an address from DHCP or not?
    Reply With Quote Quote  

  12. Senior Member whatthehell's Avatar
    Join Date
    Jun 2006
    Location
    Orange County, CA.
    Posts
    914

    Certifications
    Server+,A+, N+, MCDST, HDI/SCA, MCP, ITIL Foundations 2011, VCA5-DCV,VCA5-Cloud, MTA 98-364
    #11
    DCdiag /verbose?
    Perhaps try flushing DNS on one of the workstations and testing?
    Not sure if this was asked or answered, but is this a new environment? Or was it working well before?

    Are the clients all local to the DC? Or remote? Dialing in?
    Reply With Quote Quote  

  13. Junior Member
    Join Date
    Feb 2010
    Posts
    19
    #12
    Do you have roaming profiles? Check how big the user profiles are. Do a gpresult after logged in and check all applied group policies. Have a look through event viewer to see if anything is flagged up there.
    Reply With Quote Quote  

  14. Member
    Join Date
    Dec 2008
    Location
    Sydney
    Posts
    59

    Certifications
    CCNA, CEH,ECSA, MCITP EMA 07 , MCSA 03
    #13
    Hi guys,

    thanks everyone for your reply,I'm still testing.The current DC with connections was setup from another person, the DC has 3 NICs connected to the same switch, I noticed that one of the port on the switch which is connected straight to the DC is flashing amber/green, I checked it on the switch and it is set to "Half Duplex" 100 Mbps and has loads of Collisions.I believe this is affecting performance,setting it to Full Duplex makes it worse "Full Amber" light on the port.

    Any ideas?
    Reply With Quote Quote  

  15. Well ain't that shiny! TLeTourneau's Avatar
    Join Date
    Mar 2011
    Location
    MN, USA
    Posts
    582

    Certifications
    CISSP, MCITP:EA, SA, EDA7, MCTSx4, MCSA 2008, CCNA (expired), Security+(expired), Project+, CIW JavaScript Specialist, CIW Web Foundations Associate
    #14
    It would help to know how the NIC's are configured (teamed, fail-over, etc.) and if the switch supports those connections. Have you tried unpluging/disableing NIC's to see it that helps? It could be several things.
    Thanks, Tom

    B.S: IT - Network Design & Management
    M.S. - CSIA (Started 3/1/2017)Progress T1: C688, JIT2; T2: TFT2, C700, VLT2; T3: C701, C702; T4: FXT2, LQT2, C706
    Black = Not Started, Blue = In Progress, Red = Complete
    Reply With Quote Quote  

  16. Member
    Join Date
    Dec 2008
    Location
    Sydney
    Posts
    59

    Certifications
    CCNA, CEH,ECSA, MCITP EMA 07 , MCSA 03
    #15
    Yes, I tried to unplug it and plugged it back again but no better...I even rebooted the whole switch last night...
    Reply With Quote Quote  

  17. Nidhoggr, the Net Serpent Claymoore's Avatar
    Join Date
    Nov 2007
    Location
    FL
    Posts
    1,622

    Certifications
    AWS Architect, MCSEx3, MCITPx6, MCTSx17
    #16
    Quote Originally Posted by Gimmyno View Post
    Hi guys,

    thanks everyone for your reply,I'm still testing.The current DC with connections was setup from another person, the DC has 3 NICs connected to the same switch, I noticed that one of the port on the switch which is connected straight to the DC is flashing amber/green, I checked it on the switch and it is set to "Half Duplex" 100 Mbps and has loads of Collisions.I believe this is affecting performance,setting it to Full Duplex makes it worse "Full Amber" light on the port.

    Any ideas?
    Turn the port back to auto-negotiate. Both the port and the NIC have to be manually set to the same speed/duplex setting or both have to be auto. Manually setting the port speed may have been a good recommendation in 1998, but this is 2012.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks