+ Reply to Thread
Results 1 to 10 of 10
  1. Member
    Join Date
    Nov 2011
    Location
    In the 3rd world.
    Posts
    72

    Certifications
    A+, CCENT
    #1

    Default CSVDE and LDIFDE command problems.

    Hey TE,

    I've recent started studying for the 70-640 and purchased the Self-paced training kit for it. While running through the labs in the book, I've run into a problem. I've been trying to get the csvde and ldifde commands to work but they both don't seem to take. Using the dsadd command works for adding individual users.

    Currently using a trial W2K8R2 Enterprise for my studies.

    Here's what I get when I input the commands:

    C:\Users\Administrator\Documents>csvde -i -f newusers.txt -k
    Connecting to "(null)"
    Logging in as current user using SSPI
    Importing directory from file "newusers.txt"
    Loading entries.
    Add error on line 2: No Such Attribute
    The server side error is "The parameter is incorrect."
    0 entries modified successfully.
    An error has occurred in the program
    No log files were written. In order to generate a log file, please
    specify the log file path via the -j option.


    C:\Users\Administrator\Documents>ldifde -i -f newusers.ldf -k
    Connecting to "SERVER01.contoso.com"
    Logging in as current user using SSPI
    Importing directory from file "newusers.ldf"
    Loading entries.
    Add error on entry starting on line 1: No Such Attribute
    The server side error is: 0x57 The parameter is incorrect.
    The extended server error is:
    00000057: LdapErr: DSID-0C090C3E, comment: Error in attribute conversion operati
    on, data 0, v1db1
    0 entries modified successfully.
    An error has occurred in the program
    No log files were written. In order to generate a log file, please
    specify the log file path via the -j option.

    This is my "newusers.txt" file:

    DN,objectClass,sAMAccountName,sn,givenName,userPri ncipleName
    "cn=Lisa Andrews,ou=People,dc=contoso,dc=com",user,lisa.and rews,Lisa,Andrews,lisa.andrews@contoso.com
    "cn=David Jones,ou=People,dc=contoso,dc=com",user,david.jone s,David,Jones,david.jones@contoso.com


    I've looked at the book and have gone through the and checked the syntax, spelling, spacing, etc on the .txt and .ldf files and they both look like they do in the book.

    Can anybody give me some insight on what I'm doing wrong?
    Reply With Quote Quote  

  2. SS
  3. Member
    Join Date
    Apr 2011
    Posts
    83

    Certifications
    CCNA
    #2
    Did you check the errata web link in the beginning of the book? The syntax in the books might not be right. I can't remember because I haven't studied that in a while I'm reviewing other subjects right now. I remember having issues with those commands as well and I'm pretty sure I had to go online to find the correct syntax.
    Reply With Quote Quote  

  4. Member
    Join Date
    Nov 2011
    Location
    In the 3rd world.
    Posts
    72

    Certifications
    A+, CCENT
    #3
    Quote Originally Posted by method115 View Post
    Did you check the errata web link in the beginning of the book? The syntax in the books might not be right. I can't remember because I haven't studied that in a while I'm reviewing other subjects right now. I remember having issues with those commands as well and I'm pretty sure I had to go online to find the correct syntax.
    Thanks for the reply. I went to the website given in the book. But it just defaults to the learning network.

    Tried this Technet Article, but still got the same result.
    Reply With Quote Quote  

  5. Junior Member
    Join Date
    Feb 2012
    Location
    France
    Posts
    3

    Certifications
    MCITP, CCNA (expired), EMCSA
    #4
    Quote Originally Posted by KPLC View Post
    DN,objectClass,sAMAccountName,sn,givenName,userPri ncipleName
    "cn=Lisa Andrews,ou=People,dc=contoso,dc=com",user,lisa.and rews,Lisa,Andrews,lisa.andrews@contoso.com
    "cn=David Jones,ou=People,dc=contoso,dc=com",user,david.jone s,David,Jones,david.jones@contoso.com
    you had the UPN misspelled, it should be: userPrincipalName
    Reply With Quote Quote  

  6. Junior Member Registered Member
    Join Date
    Jan 2011
    Posts
    1
    #5

    Smile The answer is

    I don't know WHY all noise about this question, Simply the answer is:

    DON'T USE SPACE BEFORE OR AFTER THE COLON just like this .... DN:CN=April....

    and this is the famous example below:

    DN:CN= April Stewart,OU=People,DC=contoso,DC=com
    changeType:add
    CN:April Stewart
    objectClass:user
    sAMAccountName:april.stewart
    userPrincipalName:april.stewart@contoso.com
    givenName:April
    sn:Stewart
    displayName:Stewart,April
    mail:april.stewart@contoso.com
    description:Sales Representative in the USA
    title:Sales Representative
    department:Sales
    company:Contoso, Ltd.
    DN:CN= Tony Krijnen,OU=People,DC=contoso,DC=com
    changeType:add
    CN:Tony Krijnen
    objectClass:user
    sAMAccountName:tony.krijnen
    userPrincipalName:tony.krijnen@contoso.com
    givenName:Tony
    sn:Krijnen
    displayName:Krijnen,Tony
    mail:tony.krijnen@contoso.com
    description:Sales Representative in the NetherLands
    title:Sales Representative
    department:Sales
    company:Contoso, Ltd.


    JUST LIKE THAT.
    Reply With Quote Quote  

  7. Junior Member Registered Member
    Join Date
    Jan 2013
    Posts
    1
    #6

    Default still getting error

    i have tried it all no space after colon 1 line gap between two entries but still getting error
    unable to read the import file newusers.ldf
    no log files were written. in order to generate a log file , please specify the log file path via the -j option.
    i have tried copying and carefully watching the spaces and spelling and lines and spaces but still couldnt get the result
    help required please
    Reply With Quote Quote  

  8. Senior Member Lunchbocks's Avatar
    Join Date
    Mar 2004
    Location
    Florida
    Posts
    227

    Certifications
    VTSP, CCNA, MCP NT 4.0, MCTS 70-640
    #7
    The errata for this book is on O'Reilly's web site:

    hxxp://oreilly dot com/catalog/errata dot csp?isbn=0790145314413

    I had the same problem with these labs and some of it was typos in the book.

    Good luck with your exam!
    Reply With Quote Quote  

  9. Junior Member Registered Member
    Join Date
    Nov 2013
    Posts
    3
    #8
    I am also having this issue. Yes I checked the errata and nothing is mentioned in the confirmed or unconfirmed. I have tried everything I could think. So I am wondering what is wrong. I feel really disappointed that these books have so many issues that are not even resolved in the errata, especially when they cost so much. Any help would be appreciated.
    Reply With Quote Quote  

  10. IT Bum BGraves's Avatar
    Join Date
    Oct 2013
    Location
    ATL, GA
    Posts
    334

    Certifications
    A+, Net+, Sec+, ITILv3, CCENT, CCNA, MCSE, MCITP:EA, MCSE:Server Infrastructure, CISSP, VCA-DCV, VCP-DCV, CEHv8, CHFI,
    #9
    Quote Originally Posted by unlimitedgeek View Post
    I am also having this issue. Yes I checked the errata and nothing is mentioned in the confirmed or unconfirmed. I have tried everything I could think. So I am wondering what is wrong. I feel really disappointed that these books have so many issues that are not even resolved in the errata, especially when they cost so much. Any help would be appreciated.
    https://www.google.com/search?q=Add+...m=122&ie=UTF-8
    Reply With Quote Quote  

  11. Junior Member Registered Member
    Join Date
    Nov 2013
    Posts
    3
    #10
    Wow, thank you. It still to me 30 minutes to resolve this. There are a few keys I found,
    Check the spacing and follow it exactly
    make sure you do not have an extra space after the last line at the bottom
    everything is so sensitive this seems to be a difficult way to import users.
    Thanks for the help.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks