+ Reply to Thread
Results 1 to 4 of 4
  1. Senior Member bermovick's Avatar
    Join Date
    Apr 2010
    Location
    San Antonio, TX
    Posts
    1,122

    Certifications
    CCNP, CCNA Security, CCDA, Project+, Linux+
    #1

    Default Guest not using MAC address assigned to it in VM settings.

    I ran into a weird problem at work yesterday, and I'm wondering if anyone has any idea of the root cause.

    At work our laptops are running Redhat, with a windows VM within VMware Workstation. All addresses are statically assigned (no DHCP), so when I first started the VM, I went into network settings to assign it an address and everything. After doing so, I still wasn't able to reach anything.

    I verified the information under the NIC config and it was good, but ipconfig showed a 169 address still! I eventually noticed the MAC address reported by ipconfig /all did NOT match what Workstation had assigned for that NIC. The "hardware" settings for the NIC under windows didn't show a MAC address manually set, and removing the "device", rebooting, and letting windows re-discover it still used the incorrect one. Once I went back into the hardware settings and forced windows to use the MAC that Workstation had assigned, everything worked, but I think it would probably be better to find what was causing windows to use the wrong address in the first place. Has anyone ever seen this, or have any idea where windows is getting this other MAC address from?
    BS:IT (Security Focus) at WGU Progress:
    -={ Complete }=-

    MS:CIA at WGU Progress:
    9 of 10 done (and all non-capstone papers). Current: LQT2 - MS-CSIA Capstone
    Reply With Quote Quote  

  2. SS -->
  3. Senior Member joelsfood's Avatar
    Join Date
    Sep 2014
    Location
    Chicago, IL
    Posts
    969

    Certifications
    CCIE:DC, CCNP:DC, CCNA:DC, CCDA, VCP:DCV, VCP:NV, JNCIA-JUNOS
    #2
    have you tried manually editing the VMX to see what it shows for the MAC address in there?
    Reply With Quote Quote  

  4. Senior Member bermovick's Avatar
    Join Date
    Apr 2010
    Location
    San Antonio, TX
    Posts
    1,122

    Certifications
    CCNP, CCNA Security, CCDA, Project+, Linux+
    #3
    I haven't. I left work early today to pick up my daughter and take her out to lunch with my mom who was driving through. I'll take a look on Tuesday.
    BS:IT (Security Focus) at WGU Progress:
    -={ Complete }=-

    MS:CIA at WGU Progress:
    9 of 10 done (and all non-capstone papers). Current: LQT2 - MS-CSIA Capstone
    Reply With Quote Quote  

  5. Senior Member joelsfood's Avatar
    Join Date
    Sep 2014
    Location
    Chicago, IL
    Posts
    969

    Certifications
    CCIE:DC, CCNP:DC, CCNA:DC, CCDA, VCP:DCV, VCP:NV, JNCIA-JUNOS
    #4
    At least you have your priorities straight.

    Take a look and let us know, that's first place to look. Or rather, first place after looking in the driver settings in Windows, which you've already checked.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks