+ Reply to Thread
Results 1 to 5 of 5
  1. Senior Member
    Join Date
    Jul 2015
    Posts
    435
    #1

    Default vSwitch not routing within same subnet

    I have a lab set up, and ESXi is on the physical machine. I'm connecting with vSphere, and when I set up the VMs, the VMs are unable to talk to each other. They can all ping ESXi, but no other VMs receive a response.

    The VMs are in the same subnet, and everything that I'm seeing says that the VMs should be able to talk to each other by default since they are in the same subnet (both in the OS and on the vSwitch).

    Any ideas on what to try troubleshooting?
    Last edited by EnderWiggin; 05-14-2017 at 04:31 AM.
    Reply With Quote Quote  

  2. SS -->
  3. kj0
    kj0 is offline
    Apple and VMware kj0's Avatar
    Join Date
    Apr 2012
    Location
    Brisbane, Australia.
    Posts
    733

    Certifications
    vExpert x 4 | Apple Mac OS X Associate | Cert III - IT.
    #2
    Is this just a single host, not nested? Are they using the VM Network port group? Is Windows Firewall turned off?
    Are all machines using same vSwitch?
    2017 Goals: VCP6-DCV | VCIX
    Blog: http://readysetvirtual.wordpress.com
    Reply With Quote Quote  

  4. Senior Member
    Join Date
    Jul 2015
    Posts
    435
    #3
    It is a single host, not nested. They are in the default VM Network port group, and I've tried making a new port group as well, same result. Windows Firewall is off, and CentOS is having the same issue. All machines are on the same vSwitch.

    I think I'm going to try reinstalling ESXi today.... I really hope it's just an issue with the install (I know the image is good, as I've used this exact disc to install ESXi on other systems). It's the only thing I can think of at this point.
    Reply With Quote Quote  

  5. Self-Described Huguenot blargoe's Avatar
    Join Date
    Nov 2005
    Location
    NC
    Posts
    4,088

    Certifications
    VCAP5-DCA; VCP 3/4/5/6 (DCV); EMCSA:CLARiiON; Linux+; MCSE:M 2000/2003; MCSE:S 2000/2003; MCTS:Exch2007; Security+; A+; CCNA (expired)
    #4
    Look at the Nic Teaming settings for the portgroup in that vswitch and make sure that you have a functioning physical nic set as an active adapter.
    IT guy since 12/00

    Recent: 3/22/2017 - Passed Microsoft 70-412; 2/11/2017 - Completed VCP6-DCV (passed 2V0-621)
    Working on: MCSA 2012 upgrade from 2003 (to heck with 2008!!), more Linux, AWS Solution Architect (Associate)
    Thinking about: VCP6-CMA, MCSA 2016, Python, VCAP6-DCD (for completing VCIX)
    Reply With Quote Quote  

  6. Senior Member
    Join Date
    Jul 2015
    Posts
    435
    #5
    Thanks for the help y'all, reinstalling ESXi seems to have done the trick. Gotta love the little things.........
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks