+ Reply to Thread
Results 1 to 13 of 13
  1. Senior Member
    Join Date
    Oct 2007
    Posts
    277

    Certifications
    Check the Sig
    #1

    Default VMWare Server: cannot connect to host

    Here is my scenario:

    I have previously installed VMWare Server and created a Windows 2003 Virtual Machine located on an external hard disk attached to my local computer.

    I have previously gotten everything to work multiple times....


    One month later...I forgot how to connect to the host? Doh! It asks for the hostname, username, and password. I'm not sure what to put????!!!!

    What should I do?


    I have used this same program and Virtual machine before and everything worked including access to the internet and everything. I don't want to build a new VM. The VM is still on the external hard drive connected to my computer.

    I just need a way to connect to the host...

    Thank you,

    Goldmember
    Reply With Quote Quote  

  2. SS -->
  3. Sie
    Sie is offline
    Running on caffine
    Join Date
    Dec 2005
    Location
    England, UK
    Posts
    1,207

    Certifications
    ADITP (Advanced Diploma for IT Practitioners) & MCSA (70-270, 70-290, 70-291, 70-299) | Currently working towards C|EH
    #2
    Sounds like its just prompting you for valid credentials to log into the machine.

    Have you changed the password recently on your PC?

    Is this setup as a domain or workgroup?

    Try entering the details as follows:

    Domain/Workgroup:

    Username
    Password
    Domain

    (use domain\username or workgroup\username if domain box is not available)

    I pressume by connecting to the host you mean accessing the hosts HDD?

    ---

    However if this is the VMWare Server Console - Connect to host screen, you should just be able to select Local Host as the VM's technically run on the local machine just from a external HDD.
    Reply With Quote Quote  

  4. Senior Member
    Join Date
    Oct 2007
    Posts
    277

    Certifications
    Check the Sig
    #3
    When I ask to connect to host, am I connecting to the external HDD by name?

    Lets say my external HDD was named "ClayX"...the hostname would be ClayX correct?


    I tried connecting and it said the hostname was in the database but the data was not resolved.

    I'm guessing I need the password and username but I don't know them.

    Can I reset them somehow?
    Reply With Quote Quote  

  5. Sie
    Sie is offline
    Running on caffine
    Join Date
    Dec 2005
    Location
    England, UK
    Posts
    1,207

    Certifications
    ADITP (Advanced Diploma for IT Practitioners) & MCSA (70-270, 70-290, 70-291, 70-299) | Currently working towards C|EH
    #4
    Cant you just select Local Host rather than Remote Host?

    Its the same host just a difference storage device.

    What is the external HDD?
    Reply With Quote Quote  

  6. Senior Member
    Join Date
    Oct 2007
    Posts
    277

    Certifications
    Check the Sig
    #5
    The same host, but using an external USB HDD.

    I forgot the username and password and hostname.

    How do I recover this information?

    I am running the VMWare Server Console and Virtual Machine from the same computer, but the Virtual Machine is located on the external HDD for storage purposes(it takes up 8GB of storage).

    Thank you for help

    Goldmember
    Reply With Quote Quote  

  7. Sie
    Sie is offline
    Running on caffine
    Join Date
    Dec 2005
    Location
    England, UK
    Posts
    1,207

    Certifications
    ADITP (Advanced Diploma for IT Practitioners) & MCSA (70-270, 70-290, 70-291, 70-299) | Currently working towards C|EH
    #6
    When you open Virtual Server Console you should get the option to access Local Host and Remote Host.

    Have you attempted to access the Local Host as the External HDD is just storage attached to the Local Host (presummingly via a USB interface)

    A remote host would be another machine on a network for example.

    What make / model of external HDD are you using? Does it have its own ID / Password for security?
    Reply With Quote Quote  

  8. was here.
    Join Date
    Apr 2008
    Posts
    4,504
    #7
    Where you store VM files makes absolutely no difference to the hostname, IP address, username or password used to actually access the guest OS inside the VM. All that matters is that VMware knows where the VM is and can start it.

    What exactly are you having trouble accessing? The guest OS or the VMware Server management interface?
    Reply With Quote Quote  

  9. Senior Member
    Join Date
    Oct 2007
    Posts
    277

    Certifications
    Check the Sig
    #8
    Here is my scenario...

    I can open the VMWare Server Console and it asks me to connect to the Host.

    It then asks for the hostname, username, and password.

    I do not know any of these answers.

    I know the location of the virtual machine, and I can probably guess the username and password but so far I have had no luck.

    I didn't want to build a new Virtual machine, but I might have to.

    Thank you,

    goldmember
    Reply With Quote Quote  

  10. Sie
    Sie is offline
    Running on caffine
    Join Date
    Dec 2005
    Location
    England, UK
    Posts
    1,207

    Certifications
    ADITP (Advanced Diploma for IT Practitioners) & MCSA (70-270, 70-290, 70-291, 70-299) | Currently working towards C|EH
    #9
    VMWare Server Console allows you to connect to and Manage the VM Machines.

    There are two type of login page:

    One that prompts you if you want to connect to the local host or a remote host (I pressume this is not the one in question)

    And one titled 'Virtual Server Console - Connect to Host'
    This one prompts you for a Host name, User Name and Passsword.

    The Hostname is the name of the hosts where the VMs are installed. IE The name of your computer (not the External Hard Disk Drive)

    The username and password are valid account details for accessing that machine, I believe these may need to be administrative accounts.

    As far as im aware:
    XP requires an account with admin rights
    Vista requires THE administrator account
    Linux..... Im assuming the root account

    (yes i know there are security risks but if no others are setup then it cannot be helped unless they are created)

    What is the host OS of your machine?
    Reply With Quote Quote  

  11. SupremeNetworkOverlord Moderator Ahriakin's Avatar
    Join Date
    Oct 2005
    Location
    ::1/128
    Posts
    1,798

    Certifications
    CCIE #23276-Sec, JNCIE-Sec #105, TCSE #2343,MCSE 2003-Sec,LPIC-1
    #10
    If you're not getting the option to choose localhost then it's likely the host machine software firewall has blocked the VMWare services on that machine, open it's console and check for anything that mentions VMWarexxxxxx and set it to allow and then restart the services, or as others have mentioned you are not already logged in as a local admin (in which case as suggested use a local administrator account for the host PC). It's not anything specific to the VM or your external hard drive, just authorization to launch the VMWare console itself on the host PC.
    Reply With Quote Quote  

  12. Member
    Join Date
    Mar 2006
    Posts
    45
    #11
    As Ahriakin said, check your firewall and check the services (start, run, services.msc)...more specifically, look for the VMWARE AUTHORIZATION and REGISTRATION services. These services must be started to run virtual machines on your local machine. Otherwise, you will only get the username/password prompt.
    Reply With Quote Quote  

  13. Junior Member
    Join Date
    Aug 2008
    Posts
    1
    #12
    jbayne3's answer corrected this issue for me. I started the Authorization and Registration services, restarted VMWare Console and was provided the "Connect to Local Host / Remote Host" login screen.

    Choosing Local Host allowed me access to my local VMs.

    Thanks jbayne3 !

    martin
    Reply With Quote Quote  

  14. Junior Member
    Join Date
    Mar 2009
    Posts
    1
    #13

    Default VMware Server Issue running on Vista Home Premium 32-Bit

    Here is the problem:

    After installing VMware Server and initializing the VMware Server console I only have the option of connecting to a host by entering the host name, username and password which would suggest I am trying to access a virtual machine on a networked host.

    I do not get the option to connect to a local host which is what I want to do, the VMware Server console only gives me the one option mentioned above.

    Reading through this thread I see that the authorization and registration services need to be running to allow virtual machines on your local machine. The registration service is available but status is blank, I cannot see any authorization service. I have tried to restart the registration service and get:

    Windows could not start the VMware registration service service on local computer.

    ERROR 1075: The dependency service does not exist or has been marked for deletion

    I had a look in the dependencies tab and it and it states that the VMware registration service depends on the following system components:

    Remote Procedure Call (RPC)

    1) Why no authorization service?
    2) ERROR 1075.. is this due to something that may have been deleted from the registry.

    I was having problems removing VMworkstation 6.5 through programs and features and eventually disabled UAC to allow me to completely remove from my system. Before that however I tried removing VMworkstation by removing some registry files.

    If anyone can help it would be much appreciated

    Cheers

    James.
    Reply With Quote Quote  

+ Reply to Thread

Social Networking & Bookmarks